Subject: [rohc] IP-ID2 in Profile 1

From: "Yang Chang" <[email-masked]>
Date: Wed, 4 Sep 2002 21:04:02 +0800

Dear All,

I am now implementing ROHC and I have a question as following:

In profile 1, if bits(IP-ID2) is not zero, does it mean Extension 3 must be used? Unlike Profile 2 or 3, there is Extension 2 to hold WLSB encoded IP-ID2; In profile 1, there is only field for IP-ID in base headers and extension header 0, 1 and 2.

Thank you very much for your help!

Yang Chang
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Kausik Sinnaswamy <[email-masked]>
Date: Wed, 04 Sep 2002 18:13:32 -0700

Yang,
    Your understanding is correct. However, in profile 1, if the IP-ID 
field of the innermost IP header is random, then the base headers may be 
used to communicate the additional bits for IP-ID2.

Cheers
Kausik