Subject: RE: [rohc] What is p value for TS?

From: Anton Mårtensson (EAB)<[email-masked]>
Date: Wed, 25 Sep 2002 09:02:45 +0200

Hi Micke and all,
I agree with Yang and L-E that this is confusing. What I don't 
understand is how the decomressor could be aware of timer-based
compression is used or not. Of course the decompressor signals if
it is ready for timer-based compression but MUST the compressor always
use timer-based compression after that (with corresponding interpretation 
intervals)
If yes the OK but if not how should the decompressor know which 
interpretation interval to use, i.e. should it use p=2^(k-1)-1 or
p=2^(k-2)-1.

Regards 
 - Anton

> -----Original Message-----
> From: Mikael Degermark [mailto:[email-masked]]
> Sent: den 25 september 2002 01:22
> To: Lars-Erik Jonsson (EAB); 'Yang Chang'; [email-masked]
> Subject: Re: [rohc] What is p value for TS?
> 
> 
> Hi all,
> 
> The way it was intended and the way we've implemented it and 
> successfully
> interoperated is:
> 
> The p-value definition in section 5.7 is for W-LSB encoded TS.
> 
> The p-value definition in section 4.5.4 is for Timer-based 
> compression of
> TS.
> 
> So: yes, the p-values are different in for Timer-based and 
> W-LSB encoding of
> TS.
> 
> Cheers,
> 
> Mikael Degermark
> 
> ----- Original Message -----
> From: "Lars-Erik Jonsson (EAB)" <[email-masked]>
> To: "'Yang Chang'" <[email-masked]>; <[email-masked]>
> Sent: Tuesday, September 24, 2002 1:16 AM
> Subject: RE: [rohc] What is p value for TS?
> 
> 
> > Yang and 3095 co-authors,
> >
> > I totally agree with you that this is confusing. Unfortunately, I
> > was not involved in nailing down the details of these parts and
> > have some problems giving a clear answer to your question.
> >
> > I hope (expect) that any of those who wrote these parts can speak
> > up and explain these issues (Zhigang, Micke, others??).
> >
> > Rgds,
> > /L-E
> >
> >
> >
> > > -----Original Message-----
> > > From: Yang Chang [mailto:[email-masked]]
> > > Sent: den 9 september 2002 04:35
> > > To: [email-masked]
> > > Subject: [rohc] What is p value for TS?
> > >
> > >
> > > Dear All,
> > >
> > > I have doubt about ROHC document as following:
> > >
> > > In Section 4.5.4, on page 33, it is said that "p = 2 ^ (k-1)
> > > - 1"; However, in Section 5.7, on page 75, the interpretation
> > > intervals is said to be
> > > "p = 2 ^ (bits(TS)-2) -1". Which one is correct? or W-LSB
> > > encoded TS use different p than Timer-based compression TS.
> > >
> > > Best regards,
> > >
> > > Yang Chang
> > > _______________________________________________
> > > Rohc mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/rohc
> > >
> > _______________________________________________
> > Rohc mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/rohc
> >
> 
> _______________________________________________
> Rohc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/rohc
> 
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Mikael Degermark" <[email-masked]>
Date: Tue, 24 Sep 2002 17:31:48 -0700

This is indeed underspecified. I have a couple of diagrams that show the
various
possibilities on how switching from WLSB to Timer-based could be done, but
I'll have to dig a bit to find them again. We have discussed this issue on
bakeoffs.

Two things needs to happen during the switch: Decompressor needs to send its
clock granularity to compressor, and compressor needs to send the
time-stride to
the decompressor. The former can be per-channel, the latter is per-context.

The compressor must send a non-zero time-stride in order to enable TB
decoding
at decompressor: the decompressor does not have enough information to
decode otherwise.

The main problem here is that one can (will) run into a situation where the
compressor
cannot know if the decompressor is using Timer-based or WLSB. Therefore it
must
during this time send enough bits to ensure a correct result no matter which
TS decoding
method the decompressor is using.

I need to sleep now, so can't answer better right now. I'll try to explain
this better tomorrow.

G'nite,

Micke

----- Original Message -----
From: "Anton Mårtensson (EAB)" <[email-masked]>
To: "'Mikael Degermark'" <[email-masked]>; "Lars-Erik Jonsson (EAB)"
<[email-masked]>; "'Yang Chang'" <[email-masked]>;
<[email-masked]>
Sent: Wednesday, September 25, 2002 12:02 AM
Subject: RE: [rohc] What is p value for TS?