Subject: RE: [rohc] What is p value for TS?

From: "Lars-Erik Jonsson (EAB)" <[email-masked]>
Date: Tue, 24 Sep 2002 10:16:36 +0200

Yang and 3095 co-authors,

I totally agree with you that this is confusing. Unfortunately, I
was not involved in nailing down the details of these parts and
have some problems giving a clear answer to your question. 

I hope (expect) that any of those who wrote these parts can speak
up and explain these issues (Zhigang, Micke, others??).

Rgds,
/L-E

> -----Original Message-----
> From: Yang Chang [mailto:[email-masked]]
> Sent: den 9 september 2002 04:35
> To: [email-masked]
> Subject: [rohc] What is p value for TS?
> 
> 
> Dear All,
> 
> I have doubt about ROHC document as following:
> 
> In Section 4.5.4, on page 33, it is said that "p = 2 ^ (k-1) 
> - 1"; However, in Section 5.7, on page 75, the interpretation 
> intervals is said to be 
> "p = 2 ^ (bits(TS)-2) -1". Which one is correct? or W-LSB 
> encoded TS use different p than Timer-based compression TS.
> 
> Best regards,
> 
> Yang Chang
> _______________________________________________
> Rohc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/rohc
> 
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Mikael Degermark" <[email-masked]>
Date: Tue, 24 Sep 2002 16:22:12 -0700

Hi all,

The way it was intended and the way we've implemented it and successfully
interoperated is:

The p-value definition in section 5.7 is for W-LSB encoded TS.

The p-value definition in section 4.5.4 is for Timer-based compression of
TS.

So: yes, the p-values are different in for Timer-based and W-LSB encoding of
TS.

Cheers,

Mikael Degermark

---

From: "Yang Chang" <[email-masked]>
Date: Wed, 25 Sep 2002 14:40:57 +0800

Dear Mikael, Lars-Erik and all,

Thank you very much for your help!

Best regards,

Yang Chang