Subject: RE: [rohc] Question about the relationship between packets and st ates

From: "Sarkar, Rajib" <[email-masked]>
Date: Mon, 21 Oct 2002 17:38:42 -0700

Hi,
	That clears the things a lot. So the basic idea is 
IR -> IR + IR-DYN
FO -> Type 1 and Type 2 packets, + IR-DYN
SO -> Type 0 packets
Thanks
Rajib

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Sunday, October 20, 2002 11:39 PM
To: Sarkar, Rajib
Cc: 'Kausik Sinnaswamy'; [email-masked]
Subject: Re: [rohc] Question about the relationship between packets and
st ates

Hi! Rajib,

> 	That clarifies my first doubt. But lets say you have different
> traffic characteristics in the SO state, then should we fall back to the
FO
> state and send an IR-DYN packet (lets say we need to send an IR-DYN
packet).
> Or we can send an IR-DYN packet from SO state. 

Hmm... if the compressor is in SO state and the packet is such that you need
to send IR-DYN then that would be a ("update") and according to the RFC
3095 state transition diagrams you should move to FO, if there is an update
in the stream.

> Another example could be if
> we need to synchronize the static fields, then should we fall back to the
FO
> state and send IR packets, or fall back to the IR state and send IR
packets,
> or we can send IR packets from the SO state. These questions eventually
the
> same question I asked in my original question, that is 
> What kinds of packet we can send in IR state? (only IR packet)
> What kinds of packet we can send in FO state?  (IR-DYN and UOR-2 packets,
IR
> packet only for refreshes)
> What kinds of packet we can send in SO state? (All, but IR & IR-DYN
packets
> only for refreshes)

IR -> IR + IR-DYN
FO -> Type 1 and Type 2 packets, + IR-DYN
SO -> Type 0 packets

Regards,
Sukanta

-- 
--------------------------------------------------------------------
Sukanta Kumar Hazra <[email-masked]>      
Institute for Communications Research
PGP-KEY: http://www.icr.a-star.edu.sg/~sukanta/skhkey.asc
PGP-ID: 0x8E084AD5 
Key-Fingerprint: 9C0D B00C C62A 7059 5314  99FC CE90 478A 8E08 4AD5
--------------------------------------------------------------------
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Sarkar, Rajib" <[email-masked]>
Date: Fri, 25 Oct 2002 11:31:37 -0700

Hi,
	Now I have a question about state transition in Unidirectional Mode.

	In the Unidirectional Mode, when do not have any feedback,
compressor starts with IR state, it receives k packets. Now, if the
compressor sees there is no change in the static field and the traffic is
following a smooth pattern, so the only information it needs to send to
decompressor for successful decompression is SN number (lets say only type 2
packets), so compressor moves to SO state. However, if compressor feels
based on last k packets that it needs to send type 1,2 or IR-DYN packets to
synchronize decompressor then it will transit to FO state. Now unless the
compressor receives k consecutive packets with same static field pattern, it
will not move from IR state to any higher state.
	Is my understanding correct?
Thanks
Rajib

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Sunday, October 20, 2002 11:39 PM
To: Sarkar, Rajib
Cc: 'Kausik Sinnaswamy'; [email-masked]
Subject: Re: [rohc] Question about the relationship between packets and
st ates

Hi! Rajib,

FO
packet).

FO
packets,
the
IR
packets

IR -> IR + IR-DYN

Regards,
Sukanta