Subject: RE: [rohc] Insufficient bits to send Unscaled TS in UO-1-ID + ext 3

From: "Lars-Erik Jonsson (EAB)" <[email-masked]>
Date: Mon, 14 Oct 2002 11:12:44 +0200

> UO-1-TS cannot carry an extension header.

You're right, I had forgotten that.

> Thus it seems that it is not possible to send TS (Unscaled) in ext3
> without updating context(TTL etc).

Well, it is possible to send TS unscaled in ext3 in a UO-1-ID packet,
but only with 29 bits. However, 29 bits should be more than enough for
most cases, right? 

BR
/L-E

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Jim Fleming" <[email-masked]>
Date: Mon, 14 Oct 2002 04:25:44 -0500

----- Original Message ----- 
From: "Lars-Erik Jonsson (EAB)" <[email-masked]>
> but only with 29 bits. However, 29 bits should be more than enough for

That may depend on the Year or Day....today is 2A14 where A=October for the Hex Challenged...

128-bit DNS AAAA Record Flag Day Formats
2002:[IPv4]:[SDLL.OFFF.FFFF.TTTT]:[64-bit IPv8 or IPv16 Persistent Address]
[YMDD]:[IPv4]:[SDLL.OFFF.FFFF.TTTT]:[64-bit IPv8 or IPv16 Persistent Address]
1-bit to set the Reserved/Spare ("SNOOPY") bit in Fragment Offset [S]
1-bit to set the Don't Fragment (DF) bit [D]
2-bits to select 1 of 4 common TTL values (255, 128, 32, 8) [LL]
1-bit for Options Control [O]
7-bits to set the Identification Field(dst) [FFFFFFF]
4-bits to set the TOS(dst) Field [TTTT]
Default SDLL.OFFF.FFFF.TTTT = 0000.0000.0000.0000
FFF.FFFF.TTTT = GGG.SSSS.SSSS
http://www.ntia.doc.gov/ntiahome/domainname/130dftmail/unir.txt
IPv8
0QQQQGGGSSSSSSSS[32-bits][Port]
IPv16
0QQQQGGGSSSSSSSS[32-bits][Port]
1WWWWWWWSSSSSSSS[32-bits][Port]

Jim Fleming
2002:[IPv4]:000X:03DB:...IPv8 is closer than you think...IPv16 is even closer...
http://www.ietf.com
http://www.iana.org/assignments/ipv4-address-space
http://www.ntia.doc.gov/ntiahome/domainname/130dftmail/unir.txt
http://ipv8.dyndns.tv
http://ipv8.dyns.cx
http://ipv8.no-ip.com
http://ipv8.no-ip.biz
http://ipv8.no-ip.info
http://ipv8.myip.us
http://ipv8.dyn.ee
http://ipv8.community.net.au

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 14 Oct 2002 11:44:10 +0200

> 2002:[IPv4]:[SDLL.OFFF.FFFF.TTTT]:[64-bit IPv8 or IPv16 Persistent 

For those who have not yet encountered Jim Fleming, e.g. on the IETF 
list:

He is a troll that takes up any issues that might elicit knee-jerk 
responses, in an attempt to generate meaningless controversy (as trolls 
do).
He usually combines this with substance-free technobabble about his 
daydreams such as IPv8 or IPv16.

There is very rarely a need to reply to his messages.

I apologize in advance for being so explicit, but we have work to do 
here and don't need trolls diverting our energy.

Gruesse, Carsten