Subject: RE: [rohc] Question about the relationship between packets and st ates

From: "Sarkar, Rajib" <[email-masked]>
Date: Fri, 18 Oct 2002 13:26:39 -0700

Hi,
	Does that mean that after sending the IR packet in the IR state,
wait for some packets to be compressed and if the compressed packets
conforms to previously established patters then transit to SO state? 
Regards
Rajib

 -----Original Message-----
From: 	Kausik Sinnaswamy [mailto:[email-masked]] 
Sent:	Friday, October 18, 2002 1:20 PM
To:	Sarkar, Rajib
Cc:	[email-masked]
Subject:	Re: [rohc] Question about the relationship between packets
and states

Hi
    The FO state is essentially used to communicate any irregularities 
in the stream. After sending IR(both static and dynamic),
a direct transition to SO is appropriate, as long as the stream conforms 
to the previously established pattern.

Cheers
Kausik

Sarkar, Rajib wrote:

>Hi,
>	I have a basic question about what packets are sent in what states.
>>From the RFC 3095 it seems that one can only send the following packets in
>following states
>	IR State - only IR packets
>	FO State - IR, IR-DYN, and UOR-2 packets
>	SO State - All packets
>	Please correct me if I am wrong. If my conclusion is correct above
>then from the IR state should we send the dynamic information and jump to
SO
>state, or send only static information and jump to FO state?
>	Thanks in advance.
>Regards
>Rajib
>_______________________________________________
>Rohc mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/rohc
>  
>

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Kausik Sinnaswamy <[email-masked]>
Date: Fri, 18 Oct 2002 13:37:11 -0700

Hi
    The compressor starts off in the IR state and sends out IR packets. 
Once it is confident
that the decompressor has received all the information, it transits to 
higher compression states.
This confidence is obtained either by repeating the IR packets several 
times or through ACKs
from the decompressor. Once the compressor is confident, it transits
to SO state if there are no more deviations from the established pattern.

Cheers
Kausik

---

From: [email-masked] (Sukanta Kumar Hazra)
Date: Sat, 19 Oct 2002 14:02:15 +0800

Hi!

> conforms to previously established patters then transit to SO state? 

"Wait for some packets to be compressed"? Do you mean buffer the
incoming packets at the compressor and analyze them?

"compressed packets conforms to previously established pattern"? Do you
mean the IP packets conform to the established pattern?

The approach would require that you buffer packets. And may change the
traffic characteristics. There is a delay introduced since you would
need to collect n number of packets before you send out the first
compressed packet. I am not in favor of changing the traffic
characteristics and thus would follow follow the approach, whereby after
sending k IR packets(corresponding to k IP packets), the compressor moves 
to the SO state. When the k+1 packet arrives at the compressor. It
determines if it can be compressed in the SO state else, it falls back
to the FO state.

Regards,
Sukanta

-- 
--------------------------------------------------------------------
Sukanta Kumar Hazra <[email-masked]>      
Institute for Communications Research
PGP-KEY: http://www.icr.a-star.edu.sg/~sukanta/skhkey.asc
PGP-ID: 0x8E084AD5 
Key-Fingerprint: 9C0D B00C C62A 7059 5314  99FC CE90 478A 8E08 4AD5
--------------------------------------------------------------------
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc