Subject: [rohc] TS_OFFSET

From: [email-masked]
Date: Wed, 2 Oct 2002 11:53:57 +0100

Hi all,

I am currently looking at RFC 3095 and I have a query about the Timestamp
encoding

I understand that TS = TS_SCALEDxTS_STRIDE + TS_OFFSET and I understand how
the decompressor is initialised

I am slightly confused with part 2 where TS_SCALED = TS/TS_STRIDE, surely
this is TS_SCALED = (TS - TS_OFFSET)/TS_STRIDE

Any help would be much appreciated,

Thank you

Matthew

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: [email-masked] (Sukanta Kumar Hazra)
Date: Thu, 3 Oct 2002 19:07:42 +0800

Hi!

Here is the explanation along with an example.

(all integer calculations)

TS = TS_SCALED * TS_STRIDE + TS_OFFSET

TS_SCALED = TS/TS_STRIDE

The part to note is

TS_OFFSET = TS % TS_STRIDE

Example:

TS_i = 1200
TS_j = 1380
TS_k = 1560

where i and j and k are RTP seq no and equal to i, i+1, i+2

TS_STRIDE = (1380 - 1200)/1 = 180

TS_OFFSET = 1380 % 180 = 120

TS_SCALED_k = 1560/180 = 8 (integer calculations)

At the decompressor.

TS = 180(TS_STRIDE) * 8(TS_SCALED) + 120(TS_OFFSET) = 1560

Hope that makes it clear.

Regards,
Sukanta

----- Original Message -----
From: "[email-masked]"
Date: Wed, 02 Oct, 2002 18:53 SGT
Subject: [rohc] TS_OFFSET

-- 
--------------------------------------------------------------------
Sukanta Kumar Hazra <[email-masked]>      
Institute for Communications Research
PGP-KEY: http://www.icr.a-star.edu.sg/~sukanta/skhkey.asc
PGP-ID: 0x8E084AD5 
Key-Fingerprint: 9C0D B00C C62A 7059 5314  99FC CE90 478A 8E08 4AD5
--------------------------------------------------------------------
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc