Subject: RE: [rohc] Question about ROHC padding

From: "Sarkar, Rajib" <[email-masked]>
Date: Wed, 30 Oct 2002 07:49:39 -0800

Hi,
	Thanks for your answer. Then it means that in most of the scenarios
padding is not used right? Is there any ROHC case where padding is used?
Thanks
Rajib

-----Original Message-----
From: Carsten Bormann [mailto:[email-masked]]
Sent: Tuesday, October 29, 2002 10:36 PM
To: Sarkar, Rajib
Cc: Carsten Bormann; [email-masked]
Subject: Re: [rohc] Question about ROHC padding

> 	I have a question about ROHC padding. What I understand if only if
> you do segmentation then you need to do padding is there any other 
> scenario
> when you need to put the padding octet. Thanks in advance for help.

One scenario that comes to mind is ROHC over Ethernet.
As Ethernet has a minimum packet size, you need to have some way of 
adding padding if your packet is smaller than that.
(You might still want to compress, as the uncompressed packet may be 
significantly larger than the minimum packet size.)

Oh, and segmentation does not necessarily *imply* padding.  (If you 
want to use segmentation in a fixed-size cell environment, e.g. as an 
AAL5 replacement, you do need it, of course.)

Gruesse, Carsten
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lalit Kumar Bhasin" <[email-masked]>
Date: Wed, 30 Oct 2002 21:41:29 +0530

Refer the section, 6.3.1, parameter PACKET_SIZES_ALLOWED.
According to this, is possible for the external entity  to define the set of
allowable packet sizes. So if the ROHC packet created by the compressor
doesnot adhers to any of those allowable sizes, the padding is required to
make it equal to any one of the allowable sizes. In case if the ROHC packet
size is more than all the allowable packet sizes, the segmentation is done
first and then probably last packet may requires padding.

----- Original Message -----
From: "Sarkar, Rajib" <[email-masked]>
To: "'Carsten Bormann'" <[email-masked]>; "Sarkar, Rajib"
<[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, October 30, 2002 9:19 PM
Subject: RE: [rohc] Question about ROHC padding