Subject: Re: [rohc] MIB Doctor review of draft-ietf-rohc-mib-rtp-06.txt

From: Juergen Quittek <[email-masked]>
Date: Sat, 15 Nov 2003 15:43:37 +0100

Mike,

While committing the changes I read again my replies on your comments
and there is one point where I am not that sure anymore that it is
wrong in the last version. Please see below.

--On 09.11.2003 19:17 h +0100 Juergen Quittek wrote:

 [...]
Mike> Another point that I noticed is that the OID assignments for the
Mike> columnar objects are not contiguous, doubtless as a result of
Mike> removing columns from the tables.  Here is the result of a quick
Mike> grep:
Mike>        ::= { rohcChannelEntry 2 }
Mike>        ::= { rohcChannelEntry 3 }
Mike>        ::= { rohcChannelEntry 4 }
Mike>        ::= { rohcChannelEntry 5 }
Mike>        ::= { rohcChannelEntry 13 }
Juergen>
Juergen> Yes, this needs to be fixed.
Juergen>
Mike>        ::= { rohcInstanceEntry 2 }
Mike>        ::= { rohcInstanceEntry 4 }
Juergen>
Juergen> And this also.

Wait ... isn't this correct?

Considering the indexing this looks at least not completely
wrong to me because object rohcChannelID is already defined
as element of the rohcChannelTable:

  |  |  +--rohcInstanceTable(2)
  |  |  |  |
  |  |  |  +--rohcInstanceEntry(1) [ifIndex,rohcInstanceType,rohcChannelID]
  |  |  |     |
  |  |  |     +-- --- Enumeration           rohcInstanceType(2)
  |  |  |     +-- r-n RohcChannelIdentifier rohcInstanceFBChannelID(4)
  |  |  |     +-- r-n ObjectIdentifier      rohcInstanceVendor(5)
  |  |  |     +-- r-n SnmpAdminString       rohcInstanceVersion(6)
  |  |  |     +--  . . .

Mike, can we leave this as it is?
If not, what is the correct number assignment?

Thanks,

    Juergen

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "C. M. Heard" <[email-masked]>
Date: Sat, 15 Nov 2003 12:19:09 -0800 (PST)

> Mike> removing columns from the tables.  Here is the result of a quick
....
> Mike>        ::= { rohcInstanceEntry 4 }
...
>   |  |  |     +-- r-n SnmpAdminString       rohcInstanceVersion(6)

Normally we don't leave gaps in the OID assignments for columnar
objects even if the row object has index components in other tables.
However, that is really just a question of style;  it is not an
error to have gaps in OID assignments.  So if you feel strongly
about this case I won't object if you choose to leave it as is.
Bert may feel differently and I will let him speak for himself.

Regards,

Mike