Subject: [rohc] IP Address Compression for Context Replication

From: [email-masked]
Date: Wed, 19 Nov 2003 13:23:33 -0600

Hello,
The current Context Replication mechanism suggests to send either whole IP address  or no IP address (replication). We have submitted a draft on the idea of sending compressed IP address using base IP address. This improves header compression efficiency when packet flows carry similar (e.g. same prefix) but not exactly same IP addresses. In particular, the gain can be significant for IPv6 header compression due to the large size (16 bytes) of IPv6 addresses.
    
http://www.ietf.org/internet-drafts/draft-saifullah-rohc-ip-addr-comp-context-replication-00.txt

This draft has impacts on section 6.5.5.1 of draft-ietf-rohc-tcp-05.txt, where the format of src/dest IP addresses are defined for IR-CR.

Your comments and questions on this draft are more than welcome.

Regards,
Yousuf

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "West, Mark" <[email-masked]>
Date: Thu, 20 Nov 2003 16:07:56 +0000 (GMT)

Hi Yousuf,

I'm not sure how often you would set up a temporally close sequence of
short-lived connections to different machines on the same subnet
(web-server load balancing, perhaps?  but I thought that this was often
hidden from the user...)  Do you have any views on this..?

However, more seriously, I note that the draft has an IPR statement :-(

We are trying to make the TCP compression solution as generally useful as
possible and so the inclusion of an encumbered concept is something that
I, personally, would object to.  Can you clarify this position?

As a final comment, I'm not sure how helpful the appendix is, since
classless routing has been used since (at least) RFCs 1517/18/19...
(... and site-local addresses in IPv6 are now deprecated ;-)

Cheers,

Mark.

--
Mark A. West, Senior Consultant Engineer
Roke Manor Research Ltd., Romsey, Hants.  SO51 0ZN
Phone +44 (0)1794 833311   Fax  +44 (0)1794 833433

On Wed, 19 Nov 2003 [email-masked] wrote:

> Date: Wed, 19 Nov 2003 13:23:33 -0600
> From: [email-masked]
> To: [email-masked]
> Subject: [rohc] IP Address Compression for Context Replication
>
> Hello,