Subject: RE: [rohc] IP Address Compression for Context Replication

From: [email-masked]
Date: Mon, 24 Nov 2003 13:41:25 -0600

Hi Mark,
Thanks for the comments. Please see my reply below. What is your opinion on this draft as a technical solution for enhancing compression efficiency? 

BR,
Yousuf

> -----Original Message-----
> From: ext West, Mark [mailto:[email-masked]]
> Sent: Thursday, November 20, 2003 10:08 AM
> To: Saifullah Yousuf (NRC/Dallas)
> Cc: [email-masked]
> Subject: Re: [rohc] IP Address Compression for Context Replication
> 
> 
> 
> Hi Yousuf,
> 
> I'm not sure how often you would set up a temporally close sequence of
> short-lived connections to different machines on the same subnet
> (web-server load balancing, perhaps?  but I thought that this 
> was often
> hidden from the user...)  Do you have any views on this..?

I think it would be quite frequent to consider:
- One case is mobile router, e.g. a train connected through a mobile router to an external network. In this case the IP addresses can be temporally close.
- Another case is Personal Area Network, e.g. a person carrying a group of bluetooth devices which are connected via a mobile phone to an external network. In this case also the IP addresses will be temporally close. 
- Some networks, e.g. cellular, have IP terminals with same prefix indicating their gateways for their external networks.

> 
> However, more seriously, I note that the draft has an IPR 
> statement :-(
> 
> We are trying to make the TCP compression solution as 
> generally useful as
> possible and so the inclusion of an encumbered concept is 
> something that
> I, personally, would object to.  Can you clarify this position?
>
Our IPR folks are sending an IPR disclosure related to this draft with more information on the following web-page:
http://www.ietf.org/ipr. 

Once that information is available, the WG can look into the information and can see that it satisfy the needs for generally useful.

I would like to say that the proposed IP address compression could be an additional optional feature on top of basic context replication. As an optional feature, it should not have concern as an encumber concept.

> As a final comment, I'm not sure how helpful the appendix is, since
> classless routing has been used since (at least) RFCs 1517/18/19...
> (... and site-local addresses in IPv6 are now deprecated ;-)
> 
Thanks. I'll update the appendix.

> Cheers,
> 
> Mark.
> 
> --
> Mark A. West, Senior Consultant Engineer
> Roke Manor Research Ltd., Romsey, Hants.  SO51 0ZN
> Phone +44 (0)1794 833311   Fax  +44 (0)1794 833433
> 
> 
> 
> On Wed, 19 Nov 2003 [email-masked] wrote:
> 
> > Date: Wed, 19 Nov 2003 13:23:33 -0600
> > From: [email-masked]
> > To: [email-masked]
> > Subject: [rohc] IP Address Compression for Context Replication
> >
> > Hello,
> > The current Context Replication mechanism suggests to send 
> either whole IP address  or no IP address (replication). We 
> have submitted a draft on the idea of sending compressed IP 
> address using base IP address. This improves header 
> compression efficiency when packet flows carry similar (e.g. 
> same prefix) but not exactly same IP addresses. In 
> particular, the gain can be significant for IPv6 header 
> compression due to the large size (16 bytes) of IPv6 addresses.
> >
> > 
> http://www.ietf.org/internet-drafts/draft-saifullah-rohc-ip-ad
dr-comp-context-replication-00.txt
>
> This draft has impacts on section 6.5.5.1 of draft-ietf-rohc-tcp-05.txt, where the format of src/dest IP addresses are defined for IR-CR.
>
> Your comments and questions on this draft are more than welcome.
>
> Regards,
> Yousuf
>
>
> _______________________________________________
> Rohc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/rohc
>

--
Registered Office: Roke Manor Research Ltd, Siemens House, Oldbury, Bracknell,
Berkshire. RG12 8FZ

The information contained in this e-mail and any attachments is confidential to
Roke Manor Research Ltd and must not be passed to any third party without
permission. This communication is for information only and shall not create or
change any contractual relationship.

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Tue, 25 Nov 2003 11:33:04 +0100

One observation on the non-technical issue...

> > generally useful as possible and so the inclusion of an
> > encumbered concept is something that I, personally, would
> > object to.  Can you clarify this position?
> >
> Our IPR folks are sending an IPR disclosure related to this 
> draft with more information on the following web-page:
> http://www.ietf.org/ipr. 
> 
> Once that information is available, the WG can look into the 
> information and can see that it satisfy the needs for 
> generally useful.
> 
> I would like to say that the proposed IP address compression 
> could be an additional optional feature on top of basic 
> context replication. As an optional feature, it should not 
> have concern as an encumber concept.

The only way we can have optional features that would not
have to be implemented would be by having multiple profiles,
as that is our way of providing negotiation of supported 
functionality. 

As a general technical comment, I think there are many small
optimizations we could do with context replication, but that
does not mean it is a good idea to do it.

/L-E