Subject: [rohc] Consensus on Annotations, underscores and the remaining TCP/FN st uff?

From: "Finking, Robert" <[email-masked]>
Date: Fri, 1 Oct 2004 16:13:50 +0100

OK then y'all let's just check that we have consensus on this. I'd hate for
us to move forward here, only to find that we have a later disagreement
about whether there was a consensus or not. Therefore I have put the names
of the key players below each of Ghyslain points. Please indicate you
agreement or not, but DO NOT include any reasoning. If this is going to
work, we need just yes/no answers. If we don't have a consensus then we can
continue the debate afterwards, but please not in this thread!

Parties concerned (please just indicate here if you have responded or not)

Ghyslain   :
Kristofer :
Lars-Eric  :
Carsten    :
Raffles    : yes
Any other interested parties please add you name here

]ROHCers,
]
]Ok, I give up [more cheers!] : )
]
]Let me summarize what comes out of the mess I seem to have 
]created on the list since yesterday:
]
]1) We'll leave the underscore, we can leave the annotations in.

Ghyslain   :
Kristofer :
Lars-Eric  :
Carsten    :
Raffles    : yes
Any other interested parties please add you name here

]
]In addition, I will make the following changes to the FN:
]
]2) modify section 4.8.7 as follow:
]
]4.8.7. Profile-specific Encoding Methods
]
]   The library of encoding methods provides a basic and
]   generic set of coding methods. Some additional encodings 
]   specific to a particular protocol may however be needed, 
]   such as for methods that infer the value of a field from 
]   other values. These methods are defined based on the 
]   properties of the protocol being compressed.
]
]   Profiles may define additional encoding methods; the 
]   scope of these methods is then local to the profile 
]   definition itself, and they can be used as part of the 
]   formal definition of the profile as any other methods 
]   from the library (see section xxxx).
]
]   Profile-specific encoding methods must be rigorously
]   defined using either the ROHC-FN syntax or in plain
]   text, as long as its definition provides enough
]   information to unambiguously implement the encoding
]   method in the compressor and the decompressor. These
]   methods should be no less complete than the methods
]   provided herein.
]
]   [will add the underscore notation text here]

Ghyslain   :
Kristofer :
Lars-Eric  :
Carsten    :
Raffles    : yes
Any other interested parties please add you name here

]3) Annotations will be clarified as to:
]   - cannot be extended to mean else than number of bits for field 
]   - if in conflict with other part of the specs, they are not to
]     prevail over the spec
]   - will look like this:
]     > uncompressed_format  =   discriminator     [  8 ],

Ghyslain   :
Kristofer :
Lars-Eric  :
Carsten    :
Raffles    : yes
Any other interested parties please add you name here
   
]4) CRC encoding method a la -03 will be reinstated and will
]   now have the following signature:
]
]field   ::=   crc (num_bits, bit_pattern, initial_value, 
]                   block_data_value, block_data_length)
]

Ghyslain   :
Kristofer :
Lars-Eric  :
Carsten    :
Raffles    : yes
Any other interested parties please add you name here

]5) Since I have the token, I will make a round of edits to
]   clean up the document so that I make sure it looks like
]   a specification.
]

Ghyslain   :
Kristofer :
Lars-Eric  :
Carsten    :
Raffles    : yes (and apologies if my edits made it look not like a spec!)
Any other interested parties please add you name here

Thanks for all your inputs - it's been a breath of fresh air for me =)

Raffles

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lars-Erik Jonsson" <[email-masked]>
Date: Sat, 2 Oct 2004 21:18:43 +0200

> Lars-Erik  :yes
> Lars-Erik  : no to the underscore thing, I'm ok with the annotations
> Carsten    :
> Raffles    : yes
> Lars-Erik  : I'm fine with this, except for the fu**ing underscores
> Carsten    :
> Raffles    : yes
> Lars-Erik  : yes
> Lars-Erik  : yes
> Lars-Erik  : yes, please do
> Carsten    :

Yes, I've really appreciated the last days discussions.

/L-E

---

From: Kristofer Sandlund <[email-masked]>
Date: Mon, 04 Oct 2004 08:20:05 +0200

Lars-Erik Jonsson wrote:
>>Kristofer : yes
>>Kristofer : yes
>>Kristofer : yes
>>Kristofer : yes
>>Kristofer : yes
>>Kristofer : yes

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 4 Oct 2004 15:07:14 +0200

> Parties concerned (please just indicate here if you have responded or 
yes
> ]1) We'll leave the underscore, we can leave the annotations in.
yes, except that we now have proposals that seem to have an even larger 
consensus.
> ]   [will add the underscore notation text here]
I can live with the text above.  I don't care about underscores vs. 
declarations of non-formal definitions -- the information should be 
there.
> ]     > uncompressed_format  =   discriminator     [  8 ],
yes, again, we have another proposal.
> ]                   block_data_value, block_data_length)
yes, please.
> ]   clean up the document so that I make sure it looks like
Yes, please