Subject: RE: [rohc] RE: Annotoations - was (RE: ROHC-FN Snapshot - Wednesd ay's update )

From: "Finking, Robert" <[email-masked]>
Date: Mon, 4 Oct 2004 09:41:11 +0100

OK, well I guess this is a moot point now, but seeing as you're interested...

The way tool writing tools work, you can easily specify comment characters. These are then completely ignored. If you want to include annotations in a comment, what you are doing is effectively getting rid of any notion of comments from the tools point of view. It can no longer throw them all away regardless, it now has to treat them all individually and check if there is any special syntax. This can quickly complete nightmare as you have to deal with any arbitrary freeform English text that you come across. What you want is a special comment, which is different from an ordinary comment, that the tool *won't* treat as a comment, but will treat as part of the main syntax, so that it can process it (and here's the important bit) just like any other syntactical element of the language.

I hope this helps!

Regards

Raffles

PS It's probably worth adding that I haven't seen or used Carsten/Eilert's tool, don't even know what language it's written in or what platform it runs on. The above are just general issues to do with parsing.

-----Original Message-----
From: Lars-Erik Jonsson (LU/EAB) [mailto:[email-masked]] 
Sent: Monday, October 04, 2004 9:28 AM
To: Ghyslain Pelletier (LU/EAB); 'Carsten Bormann'; Kristofer Sandlund
Cc: Finking, Robert; [email-masked]'
Subject: RE: [rohc] RE: Annotoations - was (RE: ROHC-FN Snapshot - Wednesd ay's update )

> > >        uncompressed_format  =   discriminator,    %[  8 ]
> > 
> > fine (but won't be checked by tool)
> 
> Why can't it be checked by a tool?
> Doesn't the [ 8 ] only apply to the right-hand side of the statement?

I have the same question. Maybe it can't be checked by your tool
because of the way you have written it, but I fail to understand
why it should not be possible to write a tool that would check it.

/L-E 

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Kristofer Sandlund <[email-masked]>
Date: Mon, 04 Oct 2004 10:51:05 +0200

To me, this is a non-valid argument. I've writen a few parsers in my life, and I 
cannot see why any parser cannot have one treatment (use this) for a comment 
starting with %[ and another one (throw this away) for a comment that starts 
with % followed by anything other than [ .

Not that it matters to me what signs we use for comments/annotations, but I 
cannot for the life of me understand why this would be "[a] complete nightmare". 
We've said that we would not allow extensions to the annotation syntax, so you 
will never have to check against "arbitrary freeform English text". Right?

/Kristofer Sandlund, Effnet AB

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 4 Oct 2004 23:32:35 +0200

On Oct 04 2004, at 10:51 Uhr, Kristofer Sandlund wrote:

> To me, this is a non-valid argument. I've writen a few parsers in my 
> life, and I cannot see why any parser cannot have one treatment (use 
> this) for a comment starting with %[ and another one (throw this away) 
> for a comment that starts with % followed by anything other than [ .

That is the easy part.
I just implemented the unsavory part: relating back information from an 
annotation that is written *after* some construct-terminating 
delimiter.

	uncompressed_format = protocol; %[16]

	format_ether_v4 = discriminator, %[ 1 ]
	                  next_protocol, %[ 0 ]
...

Yech.  I need some kimchi to get the bad taste out of my mouth...

Gppd night,

Carsten