Subject: RE: [rohc] RE: External Encoding Methods

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Fri, 1 Oct 2004 10:00:46 +0200

> > What I have thought all the time was that:
> >
> > An encoding method is
> > -- either defined in English (in the FN draft or in the
> >    draft giving the FN spec)
> > -- or defined in FN, i.e. by giving an FN structure that
> >    defines the encoding method in terms of other encoding
> >    methods, field lists, and let-expressions (in the FN
> >    draft or in the draft giving the FN spec)
> 
> This is exactly my view.
> (So far, the FN draft does not define any methods in FN, IIRC, but it 
> certainly can.)

This I do not understand, in what way would you say the FN draft
defines methods, if not in FN-form?

> > I have not heard anyone saying that an FN spec can not
> > define its own methods formally.
> 
> Actually, the *only* thing an FN spec can do is define 
> encoding methods formally.

I meant in FN-form, while the opposite is plain English.

Anyway, which of these would you call "external", or whatever
term we are now using?

/L-E

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 1 Oct 2004 11:58:59 +0200

> defines methods, if not in FN-form?

Most are defined using English language.

> I meant in FN-form, while the opposite is plain English.

Yes, this is what I mean when I say "formally".
"defined formally" and "defined in FN" are synonymous here.

> Anyway, which of these would you call "external", or whatever

I would like to get rid of the term "external".

It would be nice to have a word for "encoding method defined in english 
language within the text of a spec using FN", such as inferred methods 
defined based on properties of the protocol being compressed.  This 
*may* be what some of us called "external", but I'm not even sure about 
that.

Gruesse, Carsten