Subject: RE: [rohc] TCP packet formats (help me!)

From: "Finking, Robert" <[email-masked]>
Date: Thu, 7 Oct 2004 11:41:43 +0100

]>   list_tcp_options(list_length_in_bytes) ===
]>   {
]>     end_of_list_sentinel ::= uncompressed_value(8, 0);
]>     end_of_list_pad      ::= uncompressed_value(8, 1);
]>        :                        :
]>     timestamp            ::= tcp_timestamp_list_item();
]>        :                        :
]>        :                        :
]>     etc.
]>   };
]
]Can't parse this.

Go on, then, give us a clue! What line is causing you a problem ? Is it a
silly, or is there a more fundamental flaw here?

Cheers

Raffles

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 7 Oct 2004 12:44:53 +0200

> silly, or is there a more fundamental flaw here?

I don't see uncompressed_formats and compressed_formats.  These are 
required in a structure.
I.e., you can only have ::= in a compressed_format (or the 
default_methods, which fills in the compressed_formats).

Gruesse, Carsten