Subject: [rohc] Re: ROHC WGLC (NiTs): draft-ietf-rohc-tcp-field-behavior-03.txt

From: "West, Mark" <[email-masked]>
Date: Mon, 25 Oct 2004 21:15:06 +0100 (GMT Daylight Time)

Hi Gorry,

Nothing *too* controversial here (I hope!)...

I've incorporated updates into the -04 draft and I think that I've
captured all of these.  A couple of points, inline.

Cheers,

Mark.

>
> Nit: Page 4: Intro, para 3:
> "A less stable but more detailed analysis is done in section 5..."
> - Perhaps a poor choice of words: if the section is not stable, we should
> not publish as an RFC :-)?
> - Please could you suggest some clearer words to describes the constraints
> in section 5.

I have no idea why it says 'less stable', so I took that out :-)

>
> Nit: Page 7: Source and Destination addresses
> - Are we considering possible Tunnel encapsulations at this point?
> - If so, is this referring to the inner-most IP header (directly preceding
> the TCP header)?
>

Yes, we are considering tunnel encapsulations -- I've updated the text to
allow for this (the issue of flow separation is something that is, in
part, at the discretion of the compressor).

<
> Nit: Page 22: Section 5.2.1 para 7.
> "It would also be desirable to.."
> -> Is the WG confident enough to say:
> "It is desirable to"
>

Yes!

>
> NiT: Page 33: Section 6.3: para 1
> (i) "not that onerous"
> - This text is unclear, in terms of what?
> - Do you mean there are fewer bytes?
> i.e. overhead is less significant (i.e. than 10% of capacity for an MSS of
> 536B and less than  3% for 1460B)?
>

Yes, I mean that the percentage of header bytes in the entire packet is
lower for a large packet.  I've tried to clarify that...

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: gorry fairhurst <[email-masked]>
Date: Tue, 26 Oct 2004 09:02:52 +0100

ACK: These changes seem to be good to me.

Gorry Fairhurst