Subject: RE: [rohc] FN let statements and TCP packet formats (was: Updated FN Draft - Appendix A)

From: "Finking, Robert" <[email-masked]>
Date: Thu, 7 Apr 2005 13:16:25 +0100

Hi Carsten, All,

> From: Carsten Bormann [mailto:[email-masked]] 
> Sent: Wednesday, April 06, 2005 7:03 PM
> 
> On Apr 06 2005, at 17:19 Uhr, Finking, Robert wrote:
> 
> >           ip_inner_ecn:uncomp_value = ip_ecn_flags:uncomp_value;
> 
> Why not
> 
> ip_ecn_flags:uncomp_value = ip_inner_ecn:uncomp_value;
> 
> >                 pad_len:uncomp_value = nbits - 8;
> 
> Why not
>                  nbits = pad_len:uncomp_value + 8;
> 

Because we're trying to make it into an assignment statement with LHS and RHS, NOT an equivalence relation.

> I still don't understand what we are trying to achieve here.

We're trying to either make it easier for non mathematicians to understand or else to prove that doing so breaks the packet formats.

> 
> I have no problem leaving out the "when" (the parentheses did help 
> syntax analysis; I don't think really bad things happen if you leave 
> them out).

I think we want to see an explicitly "if" or "when" or something to make the non-binding conditionals obvious.

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 7 Apr 2005 14:22:31 +0200

On Apr 07 2005, at 14:16 Uhr, Finking, Robert wrote:

> Because we're trying to make it into an assignment statement with LHS 
> and RHS

I understand that.  I just don't know what qualifies something to be an 
LHS.
(It seems to me that if there is nothing that qualifies as an LHS, the 
"when" notation is being used.)

Gruesse, Carsten

---

From: [email-masked]
Date: Thu, 7 Apr 2005 22:23:01 +0200

> We're trying to either make it easier for non mathematicians to understand or
> else to prove that doing so breaks the packet formats.

I don't understand either what we're trying to solve... I think that the let 
statement works well as it is, and if there is a risk that "non-mathematicians" 
won't understand it then it's simply to make sure that's it's properly defined 
in FN. This is becoming to close to become a matter of personal taste I feel.  
 
> non-binding conditionals obvious.

Now, this is where I might be shooting myself in the foot (laf laf) - I thought 
that these conditionals where binding, if not simply because they need to be 
reversible for the statement to be both valid for compression and 
decompression? It seems to me that there would be something missing if using 
a "if" the "intuitive" way - we'd have to redefine it to become equivalent to 
today's "let". What's the point?

Please, let's have the "let" rest in peace (or fix its definition so that 
anyone can understand it) and let us focus on reviewing the packet formats and 
actual compression...

/Ghyslain