Subject: RE: [rohc] FN let statements and TCP packet formats (was: Updated FN Draft - Appendix A)

From: "Finking, Robert" <[email-masked]>
Date: Thu, 7 Apr 2005 14:54:23 +0100

> From: Carsten Bormann [mailto:[email-masked]] 
> Sent: Thursday, April 07, 2005 1:23 PM
>
> I just don't know what qualifies 
> something to be an 
> LHS.

If it is not defined elsewhere. On the other hand, all components of an RHS must be defined
(at least if I've understood L-E correctly).

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lars-Erik Jonsson \(LU/EAB\)" <[email-masked]>
Date: Fri, 8 Apr 2005 09:07:52 +0200

Folks,

Personally, I liked the new proposal from Robert, that made
much more sense to me than the let. Further, I do not understand
the concern Ghyslain expressed about the new proposal, i.e. I
do not see what would be wrong with it.

Anyway, it seems like I am the only one disagreeing with the
let statement, and I will not continue to argue if there is
consensus among the others that I am just a disturber in this
matter (as seems to be Ghyslain's opinion). I now leave it up
to you to decide whether to address my concern or not, in any
case I will at least be happy with 95% of the FN.

/L-E

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: den 7 april 2005 22:23
> To: Finking, Robert
> Cc: 'Carsten Bormann'; [email-masked]; Kristofer Sandlund; Lars-Erik
> Jonsson (LU/EAB)
> Subject: RE: [rohc] FN let statements and TCP packet formats (was:
> Updated FN Draft - Appendix A)
> 
> 
> > > I still don't understand what we are trying to achieve here.
> > 
> > We're trying to either make it easier for non 
> mathematicians to understand or
> > else to prove that doing so breaks the packet formats.
> 
> I don't understand either what we're trying to solve... I 
> think that the let 
> statement works well as it is, and if there is a risk that 
> "non-mathematicians" 
> won't understand it then it's simply to make sure that's it's 
> properly defined 
> in FN. This is becoming to close to become a matter of 
> personal taste I feel.  
>  
> > > 
> > > I have no problem leaving out the "when" (the parentheses 
> did help 
> > > syntax analysis; I don't think really bad things happen 
> if you leave 
> > > them out).
> > 
> > I think we want to see an explicitly "if" or "when" or 
> something to make the
> > non-binding conditionals obvious.
> 
> Now, this is where I might be shooting myself in the foot 
> (laf laf) - I thought 
> that these conditionals where binding, if not simply because 
> they need to be 
> reversible for the statement to be both valid for compression and 
> decompression? It seems to me that there would be something 
> missing if using 
> a "if" the "intuitive" way - we'd have to redefine it to 
> become equivalent to 
> today's "let". What's the point?
> 
> Please, let's have the "let" rest in peace (or fix its 
> definition so that 
> anyone can understand it) and let us focus on reviewing the 
> packet formats and 
> actual compression...
> 
> /Ghyslain
>

---

From: "Finking, Robert" <[email-masked]>
Date: Fri, 8 Apr 2005 09:42:40 +0100

OK, great. Thanks L-E. In that case the only issue is the lack of clarity in the description. I'll update the draft to try and clarify the let statement section as requested previously.

Regards

Raffles

> From: Lars-Erik Jonsson (LU/EAB) 
> [mailto:[email-masked]] 
> Sent: Friday, April 08, 2005 8:08 AM
> To: [email-masked]; Finking, Robert
> Cc: Carsten Bormann; [email-masked]; Kristofer Sandlund
> Subject: RE: [rohc] FN let statements and TCP packet formats 
> (was: Updated FN Draft - Appendix A)
> 
> 
> Folks,
> 
> > Sent: den 7 April 2005 22:23
> > To: Finking, Robert

---

From: "Finking, Robert" <[email-masked]>
Date: Fri, 8 Apr 2005 13:32:10 +0100

Hi L-E, All,

OK - expect an update next week some time =)

Thanks for getting involved everybody - useful discussion.

Regards

Raffles

> Sent: Friday, April 08, 2005 12:32 PM
> To: Finking, Robert
> OK, as a guidelines for rewriting the let description, I hope 
> you will use the ideas you've developed during our 
> discussions, i.e. to explain conceptually the relation 
> between binding, assignment, assertion, and how let covers 
> all these aspects. I also expect additional examples for 
> appendix B that shows when/how let is needed, with different 
> purposes. Assignment is already there, an example of the 
> assertion usage (like for IP-ID, with parameter?) should be 
> added, and probably also an example when you have both types 
> of usages.
> 
> /L-E
> 
>