Subject: RE: [rohc] Proposed changes to rohc-tcp-09

From: "Ghyslain Pelletier \(LU/EAB\)" <[email-masked]>
Date: Thu, 28 Apr 2005 16:46:23 +0200

The point is not about now chosing to switch to box notation, the point is that we decided to use FN for TCP.

So, since what is in a draft is ultimately what should consist into the specification in the end, I cannot understand why we would have BOTH box notation AND FN to describe the TCP packet formats. For sure, both CANNOT be normative (or?).

The TCP profile is a specification, not an explanatory document whose purpose is to explain FN in yet another manner than the FN draft does. Furthermore, we then need to MAINTAIN two packet format descriptions, which I think is insane and can lead to discrepencies.

If YOU want to have the TCP profile represented using the box notation, than submit this as an informational draft and synch it with releases of the TCP profile, with the mention "informational". Then if the group wants to have this document live further and be informational RFC than that will be fine with me.

Anywho, this is my opinion.

/Ghyslain  

> -----Original Message-----
> From: Lars-Erik Jonsson (LU/EAB) 
> Sent: den 28 april 2005 15:10
> To: Ghyslain Pelletier (LU/EAB); Kristofer Sandlund; [email-masked]
> Subject: RE: [rohc] Proposed changes to rohc-tcp-09
> 
> 
> > > > - Next time the tcp-pf.txt is copied into the draft, DO NOT 
> > > > remove the box notation (for all the people I have made
> > > > read the document, I've had to give them the tcp-pf document
> > > > so that they could get easy reference to how things work),
> > > > and DO NOT remove the initial part of the file with 
> > > > the references to profile-specific encodings.
> > > 
> > > Agree, we should have the formats also in box notation, so
> > > that also ordinary humans can read this specification and get
> > > something out of it.
> > 
> > I disagree, for the simple reason that this means that we've 
> > failed with the aspect of having a formal notation that is 
> > readable and understandable. Having both augments the risks 
> > of discrepency between both notations and the risk of errors. 
> > When one would review, I am afraid that only one notation 
> > would be looked at, and not the other. If there are 
> > discrepencies, we might miss errors somewhere in the process. 
> > So, I "vote" for not having both notations in there at the 
> > same time. If you want to push the case for the "other" 
> > notation, then that is a different topic.
> 
> I just cite Kristofer:
> "for all the people I have made read the document, I've had
> to give them the tcp-pf document so that they could get easy
> reference to how things work"
> 
> Many of us can much easier build an understanding from
> pictures, FN descriptions are not easy to "see how it
> works" from. Yes, we have failed with many of our intensions
> with the FN, but I do not think we will remove it, so the
> question is not about one or the other. 
> 
> But of course, we should draw the box notation from the FN,
> then it will help with reviewing the formats rather than the
> opposite.
> 
> /L-E
> 

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Kristofer Sandlund <[email-masked]>
Date: Thu, 28 Apr 2005 16:57:50 +0200

While I understand your concern about having to have two things to verify, I 
think that is mitigated by the fact that the box notation in this case are FN 
comments, and therefore not in any way normative.

I think we will be helping the reader out a lot by keeping the box in the 
document, and it should be clear for anyone who has read the FN draft which part 
is normative and which is just comments, but it's not a dealbreaker for me if we 
don't have them there either.

BR,
	Kristofer