Subject: [rohc] MULTILOAD operands

From: Pekka Pessi <[email-masked]>
Date: Thu, 26 May 2005 18:05:33 +0300

Hello all,

There is language about decoding and executing the MULTILOAD
instruction:

   Decompression failure occurs if the set of 2-byte words set by the
   instruction would overlap the memory locations held by the
   instruction (including its operands) itself, i.e., if the instruction
   would be self-modifying.  

Now, if we have a MULTILOAD instruction like this: 

at (64) 
 
:byte_copy_left                 pad (2) 
:byte_copy_right                pad (2) 
:input_bit_order                pad (2)
set (f_bit, 4)
set (h_bit, 2)
set (p_bit, 1)
:decompressed_pointer           pad (2) 
 
align (64)
 
:initialize_memory 
 
MULTILOAD (byte_copy_left, , 
	circular_buffer, udvm_memory_size, (f_bit|p_bit), $byte_copy_left)
      
Is it supposed to fail, or not? If not, what is the expected value
of $decompressed_pointer, circular_buffer or 0?

--Pekka

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Cristian CONSTANTIN <[email-masked]>
Date: Mon, 30 May 2005 12:56:51 +0200

> of $decompressed_pointer, circular_buffer or 0?

cristian: now, your MULTILOAD instruction is located at byte 0x80 
and it's writing 4 shorts (8 bytes) starting at 0x40 up to 0x48;
there is a "gap" of 56 bytes btw. the last address MULTILOAD is writing
to and the location where MULTILOAD is loaded; so MULTILOAD is not
overwriting itself. (it is NOT self-modifying)

since the sigcomp rfc also specifies about MULTILOAD (9.2.2 MULTILOAD):

"[...] whilst the operands value_0 through to value_n-1
specify the values to load into these words (in the same order as
they appear in the instruction)."

I suppose that the value is must to be circular_buffer.
(this is at least how I understand/interpret the whole stuff).

hope it helps.
cristian
-- 
 _          | There are many people who use UNIX or Linux  
(_'_        | who IMHO do not understand UNIX.
  (_'rist   |              --David Korn  
GPG public key at wwwkeys.de.pgp.net
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc