Subject: RE: [rohc] WG last-call for SigComp User Guide and Torture Tests

From: "Surtees, Abigail" <[email-masked]>
Date: Fri, 19 Aug 2005 13:41:02 +0100

Hi Cristian,

Yes, you're right, the minimum values needed should be stated.  I
believe they all run in 16cpb and there is no state storage so 0 SMS is
ok.
For DMS, I believe they all run in 2K apart from LZW and LZJH which both
need 8K DMS.  Is that the same as your understanding?

If so, I'll add the relevant statement at the beginning of section 4.

Best regards,

Abbie

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Cristian CONSTANTIN
> Sent: Friday, August 19, 2005 1:21 PM
> To: Lars-Erik Jonsson (LU/EAB)
> Cc: [email-masked]
> Subject: Re: [rohc] WG last-call for SigComp User Guide and 
> Torture Tests
> 
> 
> On Thu, Aug 04, 2005 at 03:33:46PM +0200, Lars-Erik Jonsson 
> (LU/EAB) wrote:
> > ROHCers,
> > 
> > We have been working on several informational documents to help
> > implementers of SigComp. Since some of these have now been stable
> > for a long time, and both authors and chairs believe these are
> > ready, we are now last-calling the following documents:
> > 
> >             draft-ietf-rohc-sigcomp-torture-tests-01.txt
> >                  (for publication as Informational)
> > 
> >             draft-ietf-rohc-sigcomp-user-guide-02.txt
> >                  (for publication as Informational)
> 
> cristian: one single comment related to this draft; namely, 
> shouldn't a
> minimum acceptable value of the cpb, dms, sms parameters be 
> recommended for 
> the udvm code specified in "4.  Compression algorithms" ?
> 
> bye now!
> cristian
> -- 
>  _          | There are many people who use UNIX or Linux  
> (_'_        | who IMHO do not understand UNIX.
>   (_'rist   |              --David Korn  
> GPG public key at wwwkeys.de.pgp.net
> 

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Cristian CONSTANTIN <[email-masked]>
Date: Fri, 19 Aug 2005 16:13:46 +0200

> believe they all run in 16cpb and there is no state storage so 0 SMS is

cristian: what exactly do you mean by "state storage"? I have seen that all 
these decompressors make state create requests in their END-MESSAGE; an example 
from "4.1.1  Simplified LZ77":

END-MESSAGE (requested_feedback_location,
   returned_parameters_location, state_length, 64,
   decompress_sigcomp_message, 6, 0)

---

From: Pekka Pessi <[email-masked]>
Date: Mon, 22 Aug 2005 13:22:02 +0300

>   decompress_sigcomp_message, 6, 0)

To me it looks like all the basic algorithms in section 4 require
TCP (no feedback), 16K of DMS (because udvm memory size is 8192)
and 8K of SMS (as the size of state item created is 8192 - 64).

--Pekka