Subject: RE: [rohc] SigComp interoperability testing?

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Fri, 19 Aug 2005 12:46:58 +0200

> I think that one important thing that it would useful to understand is
> what 'SigComp interoperability testing' actually means!
> 
> First of all, there seem to be two, separate issues:
> (i) interoperability of SigComp; and
> (ii) interoperability of SIP/SigComp

Pure SigComp testing was what I was considering.

> Now, Lars-Erik's original mail said that, "not all features 
> were tested." 
> My question (and it's not a trick question -- I'm not sure
> about the answer either!) is: what are the features?  And
> how should they be tested?

Yes, this is an excellent question, and a question that probably
has to be answered before it is possible to do complete testing.

> Actually, so far as a protocol goes, SigComp is pretty 
> simple.  I don't believe that any interop test can guarantee
> to exercise all UDVM instructions (in 'real world' usage),
> and I'm unconvinced what that would mean in practice, anyway!
> So what's left?

Yes, SigComp is (protocol-wise) pretty simple. However, I *think*
I would consider testing all defined instructions as necessary
to be able to claim interoperability of the specification has
been tested. Or?

So, do you think there are useless instructions that should be
removed then?

> The lack of an interoperability statement from the previous
> test was definitely a serious oversight.  We, at least, have
> an (internal) report written at the time, so could refresh
> people's memory on what we tested, if that would be helpful!

Yes, please do. And most important, what was not tested, and
do we think it would be feasible to test "all the stuff"?

BR
/L-E

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Cristian CONSTANTIN <[email-masked]>
Date: Sat, 20 Aug 2005 01:30:11 +0200

> Pure SigComp testing was what I was considering.

cristian: now, trying to be very practical and realistic, the only real
world environment (I know of) where sigcomp is (or is going to be)
deployed is ims. and in this environment sigcomp is used for compressing
sip messages; so, in my oppinion, testing SIP/SigComp does make a lot of 
sense. but what kind of interoperability to test when it is not very clear 
(or better said standardized) how the two protocols should interact with 
each other. 

bye now!
cristian
-- 
 _          | There are many people who use UNIX or Linux  
(_'_        | who IMHO do not understand UNIX.
  (_'rist   |              --David Korn  
GPG public key at wwwkeys.de.pgp.net
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc