Subject: [rohc] SigComp user guide, a plea for feedback

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Tue, 2 Aug 2005 15:33:01 +0200

SigComp'ers,

As Mark pointed out at the meeting yesterday, the user guide has
been rather stable for a long time and should be ready to ship.
However, as he also said, there have been minor changes lately
that would be good to get feedback on (hopefully positive) before
we send the document to WGLC. More specifically, as expressed by
the slides from yesterday:

Most recent changes:
+ Added a "readonly" directive in the mnemoniccode
  - Allows a coder to specify a read-only / read-write block
  - Useful for constraining choices in translation to bytecode
  - Not signalled to, nor binding on the UDVM
  - Possibly still some questions surrounding this?
  - There's been no feedback on the proposed solution
+ Drastically simplified the "shared-mode" example
  - The previous code had never been run
  - We've done shared-mode, but not like it was shown in
    the users' guide

So, we encourage feedback on these, as we would like to
issue WGLC on both this document and the torture tests.

BR
/L-E

--------------------------------------
Lars-Erik Jonsson
IETF ROHC WG Chair
E-mail: [email-masked]
Phone: +46 8 404 29 61

My opinions are my personal opinions and should not be considered
as the opinions of my employer, if not explicitly stated.  

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Cristian CONSTANTIN <[email-masked]>
Date: Thu, 4 Aug 2005 14:39:25 +0200

>   - There's been no feedback on the proposed solution

cristian: hi! I have had a look in the draft just before paris. as I
said before, the read-only / read-write block solution (as proposed by
carsten) for the problem related mainly to the ! operator seems to me
an elegant one. the addition in the draft of this directive
reflects correctly the solution proposed by carsten on the mailing list.

using this directive, one can generate 100% correct bytecode from
assembly when using the ! operator.

>   - We've done shared-mode, but not like it was shown in

cristian: as far as the torture tests are concerned, I haven't been able
to run all of them yet. hopefully I will have some time for it next
week; until then I cannot really say more...

bye now!
cristian
-- 
 _          | There are many people who use UNIX or Linux  
(_'_        | who IMHO do not understand UNIX.
  (_'rist   |              --David Korn  
GPG public key at wwwkeys.de.pgp.net
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc