Subject: RE: [rohc] WG last-call for SigComp User Guide and Torture Tests

From: "Surtees, Abigail" <[email-masked]>
Date: Thu, 18 Aug 2005 15:41:46 +0100

Hi Cristian,

Thanks for pointing this out.  It is, in fact, meant to be there.
Between state_start and state_end is a seemingly random stream of bytes.
They are in fact the bytes generated when translating the mnemonic code
that is commented out (and which are subsequently run).  I thought it
would be useful to show where the bytes come from but obviously didn't
do it very clearly ;-)

I can add a comment along the lines of
"; The bytes between state_start and state_end come from the 
 ; translation of the following mnemonic code".

What do you think?

Best regards,

Abbie 
> 
> cristian: from my point of view everything's fine with this 
> one, except
>  1 (minor) thing. the following code snippet from page 29 
> contains some
> commented out code:
> 
>    at (12)
> 
>    END-MESSAGE (0, 0, state_length, state_start, 0, 20, 0)
> 
>    ;at (512)
>    ;OUTPUT (data, 4)
>    ;END-MESSAGE (0,0,0,0,0,0,0)
>    ;:data
>    ;byte (116, 101, 115, 116)
> 
>    :state_start
>    byte (34, 162, 12,4, 35, 0, 0, 0, 0, 0, 0, 0, 116, 101, 115, 116)
>    :state_end
> 
>    set (state_length, (state_end - state_start))
> 
> does it have any meaning at all or it was forgotten there? is it 
> supposed to appear like this in the rfc as well?
> (I assume that Abbie will modify it anyway for adding the 
> cpb, dms and sms 
> required for the tests)
> 
> bye now!
> cristian
> -- 
>  _          | There are many people who use UNIX or Linux  
> (_'_        | who IMHO do not understand UNIX.
>   (_'rist   |              --David Korn  
> GPG public key at wwwkeys.de.pgp.net
> 

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Cristian CONSTANTIN <[email-masked]>
Date: Thu, 18 Aug 2005 20:37:09 +0200

>  ; translation of the following mnemonic code".

cristian: o.k. I got it. I guess it should be mentioned that the
commented out code is the disassembled version of the state code.

bye now!
cristian