Subject: [rohc] states and package types

From: "Zhenhua \(Max\) Xiao" <[email-masked]>
Date: Tue, 16 Aug 2005 11:30:18 -0700

Hi ROHCers:

I am implementing ROHC protocol and I couldn't find in RFC how to relate the states in compressor (ir, fo, so) with packat types. In specific:

1. Does one packet type only exist in one state?
2. Does type 2 exist in fo?, type 1, 0 only in so?
3. Does every packet extension types play with either of type 0,1,2 packet types?
or these are implementation details?

Also, does any one have a good way to download the tar ball for all previous email trails? I couldn't find it how to do that through the web interface, I am sure there is a way.

thanks,

Max

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Wed, 17 Aug 2005 09:09:37 +0200

Max,

> I am implementing ROHC protocol and I couldn't find in RFC 
> how to relate the states in compressor (ir, fo, so) with 
> packat types. In specific:

I am not surprised this has confused you. Actually, the state
descriptions for the compressor is indeed just an artificial
artifact, they have no formal meaning and confuses more than
they helps. You should think of the compressor state desciption
only as a conceptual overview. Yes, RFC 3095 unfortunately
refers to the states in a rather formal way. This is something
we will have to live with, but implementer's are recommended
to think about what is technically needed for the compressor
operation, and not simply rely on the 3095 HC state desciptions.

> Also, does any one have a good way to download the tar ball 
> for all previous email trails? I couldn't find it how to do 
> that through the web interface, I am sure there is a way.

Not that I am aware of!

BR
/L-E

---

From: "Ghyslain Pelletier (LU/EAB)" <[email-masked]>
Date: Wed, 17 Aug 2005 09:37:08 +0200

Hi Max,

My understanding is that the concepts of compressor states and compressor state transitions in RFC3095 have been introduced to provide examples and guidelines on how the different packet types and feedback types can be used. I think that implementations are in no way mandated nor constrained to implement states and state transition logic in the manner suggested by RFC3095.

Further I think that it is quite possible for a compliant compressor implementation to not make use of the concept of states and state transitions, in which case the "parameters" listed above have no meaning. The only related normative constraint is that properties of different packet types must be followed - which also means that some packets can actually be sent at any time (e.g. IR), unrelated to a specific state or event. In other words, the actual mantra is "the compressor must send enough information for the decompressor to be capable of decompressing the packet"; this is both related to the input of the compressor (uncompressed packet to be compressed, and feedback from decompressor) and what the compressor has sent earlier and its confidence that the information has reached the decompressor.

Best regards,

/Ghyslain

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Zhenhua (Max) Xiao
> Sent: den 16 augusti 2005 20:30
> To: [email-masked]
> Subject: [rohc] states and package types
> 
> 
> Hi ROHCers:
>

---

From: "Zhenhua \(Max\) Xiao" <[email-masked]>
Date: Wed, 17 Aug 2005 13:10:14 -0700

Hi Lars-Eric and Ghyslain,

Thanks for the reply and that cleared things out.

Cheers,

Max

-----Original Message-----
From: Lars-Erik Jonsson (LU/EAB) [mailto:[email-masked]]
Sent: Wednesday, August 17, 2005 12:10 AM
To: Zhenhua (Max) Xiao; [email-masked]
Subject: RE: [rohc] states and package types

Max,

Not that I am aware of!

BR
/L-E