Subject: [rohc] scaled time stamp encoding

From: "Zhenhua \(Max\) Xiao" <[email-masked]>
Date: Wed, 17 Aug 2005 22:51:09 -0700

Hi ROHCers,

I am checking out 4.5.3 Scaled RTP Timestamp Encoding, my understanding is that since each rtp packet will have a different rtp timestamp value, using w-lsb to encode the scaled TS_SCALED will always result in one or more bits to be transmited - which also means that in rtp profile the packet type 0 can't be used alone (without attaching extention types), is this right? I somehow had the impression that in some (normal) cases the header could be compressed down to 1 byte, if the above was the case then "1 byte" wouldn't be possible for rtp packets (when using scaled rtp timestamp encoding), isn't it?

thanks,

Max

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Thu, 18 Aug 2005 08:13:38 +0200

Max,

If the scaled timestamp has changed linearly with the SN
(with slope 1), it can be omitted in compressed packets.

Please read the implementer's guide* for more discussions
on timestamp encoding, and other implementation details.

BR
/L-E

*) http://www.ietf.org/internet-drafts/draft-ietf-rohc-rtp-impl-guide-14.txt

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Zhenhua (Max) Xiao
> Sent: den 18 augusti 2005 07:51
> To: [email-masked]
> Subject: [rohc] scaled time stamp encoding
> 
> 
> Hi ROHCers,
> 
> I am checking out 4.5.3 Scaled RTP Timestamp Encoding, my 
> understanding is that since each rtp packet will have a 
> different rtp timestamp value, using w-lsb to encode the 
> scaled TS_SCALED will always result in one or more bits to be 
> transmited - which also means that in rtp profile the packet 
> type 0 can't be used alone (without attaching extention 
> types), is this right? I somehow had the impression that in 
> some (normal) cases the header could be compressed down to 1 
> byte, if the above was the case then "1 byte" wouldn't be 
> possible for rtp packets (when using scaled rtp timestamp 
> encoding), isn't it?
> 
> thanks,
> 
> Max
> 
>

---

From: "Zhenhua \(Max\) Xiao" <[email-masked]>
Date: Thu, 18 Aug 2005 09:14:18 -0700

Got it, thanks L-E,

Max

-----Original Message-----
From: Lars-Erik Jonsson (LU/EAB) [mailto:[email-masked]]
Sent: Wednesday, August 17, 2005 11:14 PM
To: Zhenhua (Max) Xiao; [email-masked]
Subject: RE: [rohc] scaled time stamp encoding

Max,

BR
/L-E