Subject: [rohc] Question about Encoding methods

From: "Simon" <[email-masked]>
Date: Sat, 6 Aug 2005 15:20:34 +0800

Dear ROHCers,

I am newbie in compression method; I would like have a better understand
about encoding methods.

According to RFC 3095, there are many different types of encoding methods,
do we need every encoding 

method for different field in the header? 

I will look forward to your help/reply and I would appreciate any help you
could give me in this matter. Thanks

Best Regards

Simon Teh

Univerisiti Sains Malaysia

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "West, Mark" <[email-masked]>
Date: Mon, 8 Aug 2005 10:57:07 +0100

Simon,

I'm not sure that I completely understand your question.  To try and
answer around it, then:

* do we need every encoding method in RFC 3095?

Yes!

Between them, they cover all the ways in which fields behave and can be
efficiently encoded/decoded.

* is every encoding method needed/used for every field?

No.

A field that changes rarely but unpredictably (e.g. TTL) would be 'static'
[don't send it at all] or 'irregular' [send all of it].  But fields that
are counter-like (e.g. RTP SN) would use a range of 'lsb' encodings to
cover the possibility of discontinuities and robustness requirements.
(RTP SN cannot be 'static'; TTL does not use 'lsb' encodings.)

However, all fields do need an 'irregular' encoding to be able to
initialise the field value, at least.

Does that help?

Mark.

--
Mark A. West, Senior Consultant Engineer
Roke Manor Research Ltd., Romsey, Hants.  SO51 0ZN
Phone +44 (0)1794 833311   Fax  +44 (0)1794 833433

On Sat, 6 Aug 2005, Simon wrote:

> Date: Sat, 6 Aug 2005 08:20:34 +0100
> From: Simon <[email-masked]>
> To: ROHC Mailing List <[email-masked]>
> Subject: [rohc] Question about Encoding methods
>
> Dear ROHCers,
>
>
>
> According to RFC 3095, there are many different types of encoding
> methods, do we need every encoding
>
> I will look forward to your help/reply and I would appreciate any help
> you could give me in this matter. Thanks
>
>
>
> Best Regards
>
> Simon Teh
>