Subject: [rohc] How to make bytecode using sip static dictionary?

From: "Wook Park" <[email-masked]>
Date: Thu, 24 Nov 2005 15:20:03 +0900

Hello Everybody.

I have some trouble in making sip static dictionary in sigcomp.
I want to apply deflate & static dictionary at the same time.
As you know, there is deflate bytecode in draft-ietf-rohc-sigcomp-user-guide-02.txt.

In RFC3485 and sigcomp user guide, there is some bytecode to access state like STATE-ACCESS.
But I can't find any bytecode deflate & static dictionary.

Should I make the deflate & static dictionary bytecode in my own algorithm?
And then should I make compress algorithm(deflate & static dictionary) also?

Or is there some test bytecode (deflate & static dictionary)?

Please help me. Thank you.

Wook Park
Assistant Research Engineer / ELESIGN
TEL : +82-2-866-6190(EXT. 116)
FAX : +82-2-6332-6013
Mobile : +82-017-227-8256
E-mail : [email-masked]
http://www.elesign.com
VoIP Leader (IP Phone and Gateway)

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Wook Park" <[email-masked]>
Date: Fri, 25 Nov 2005 14:14:29 +0900

I figure out as follows :
In order to use sip static dictionary, udvm could get sip static dictionary running the instruction, state-access
followed by ":initialize_memory" label: 

I want to know how I could get the string from the dictionary.
After deflating, I may get some ascii-code byte and (static dictionary pointer/length) byte. I should replace static dictionary pointer/length byte to string. How can I do?

1. How can I distinguish between   ascii-code byte  and (static dictionary pointer/length) byte?
2. How can I replace (static dictionary pointer/length) byte to stirng?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Wook Park
Sent: Thursday, November 24, 2005 3:20 PM
To: [email-masked]
Subject: [rohc] How to make bytecode using sip static dictionary?

Hello Everybody.

Wook Park

---

From: "Wook Park" <[email-masked]>
Date: Mon, 28 Nov 2005 09:48:16 +0900

Finally, I got a solution by myself.
I found out the my question was stupid.
Static dictionary is used in infate(encoding with deflate algorithm) and deflate.
So it is not necessary to use extra algoritm to use sip static dictionary.

I modify bytecode in draft-ietf-rohc-sigcomp-user-guide-02.txt a little to use sip static dictionary.
1. add STATE-ACCESS bytecode after ":initialize_memory" label: 
2. add state identifier after end-of-message
3. modify byte-copy left 1024(starting point at dictionary)
4. modify circular buffer 3468(static dictionary table size)+1024

Thank you. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Wook Park
Sent: Friday, November 25, 2005 2:14 PM
To: Wook Park; [email-masked]
Subject: RE: [rohc] How to make bytecode using sip static dictionary?

-----Original Message-----

Hello Everybody.

Wook Park