Subject: [rohc] Minor change request to 3095 Implementer's guide

From: "Ghyslain Pelletier (LU/EAB)" <[email-masked]>
Date: Fri, 11 Nov 2005 13:10:13 +0100

I'd like to suggest a rewrite of section 6.1. I think I know what the current text is trying to say, but I still fail to parse it with that respect. The text right now can actually be interpreted as that it imply that R-0 or UO-0 don't necessarily have SN bits at all time, that RTP timestamp is always updated implicitly (i.e. even for profile other than profile 0x0001!). I know it's silly, but this is actually what the current text do say ...

Point is that this text should make it to the updated profile definitions, so then I just want to know if my rewrite is ok, and then if so that it'd replace 6.1 next time the IG is updated.

6.1. Implicit updates

If an updating packet (e.g. R-0-CRC or UO-0) contains information 
^
about a specific field X (compressed RTP sequence number, typically),
then X is updated according to the content of that packet. But this
packet implicitly updates all other inferred fields (i.e. RTP 
--------------------------------------------------------^
timestamp) according to the current mode and the appropriate mapping
function of the updated and the inferred fields.

6.1. Implicit updates

A context updating packet that contains compressed sequence number
information may also carry information about other fields; in such
case, these fields are updated according to the content of the packet.
The updating packet also implicitly update inferred fields (e.g.
RTP timestamp) according to the current mode and the appropriate
mapping function of the updated and the inferred fields.

--
 Ghyslain Pelletier, Dipl. Ing.
 Wireless IP Optimizations
 Ericsson Research, Corporate Unit

 Ericsson AB, Laboratoriegränd 11
 Box 920, S-97128 Luleå, SWEDEN
 Phone : +46 (0)  8 404 29 43
 Mobile: +46 (0) 70 264 83 14
 Ghyslain.Pelletier at ericsson.com
 http://www.ericsson.com

-----------------------------------
 The opinions expressed in this
 message are my personal opinions.
 These opinions are not
 necessarily those of my employer,
 unless stated otherwise.
-----------------------------------

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lars-Erik Jonsson" <[email-masked]>
Date: Fri, 11 Nov 2005 13:26:29 +0100

This looks good as well, I'll change it in the next update!

/L-E

----- Original Message ----- 
From: "Ghyslain Pelletier (LU/EAB)" <[email-masked]>
To: <[email-masked]>
Sent: Friday, November 11, 2005 1:10 PM
Subject: [rohc] Minor change request to 3095 Implementer's guide

I'd like to suggest a rewrite of section 6.1. I think I know what the 
current text is trying to say, but I still fail to parse it with that 
respect. The text right now can actually be interpreted as that it imply 
that R-0 or UO-0 don't necessarily have SN bits at all time, that RTP 
timestamp is always updated implicitly (i.e. even for profile other than 
profile 0x0001!). I know it's silly, but this is actually what the current 
text do say ...

Point is that this text should make it to the updated profile definitions, 
so then I just want to know if my rewrite is ok, and then if so that it'd 
replace 6.1 next time the IG is updated.

6.1. Implicit updates

6.1. Implicit updates