Subject: [rohc] why R-1 packet format doesn`t have crc field?

From: "wanxiujin" <[email-masked]>
Date: Thu, 10 Nov 2005 19:32:21 +0800 (CST)

why R-1 packet format doesn`t have crc field?

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Sarkar, Biplab" <[email-masked]>
Date: Thu, 10 Nov 2005 17:50:42 +0530

I the reliable mode, when there is no need to update any context, CRC-less packets are sent. Its just to optimize the header size.

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of wanxiujin
Sent: Thursday, November 10, 2005 5:02 PM
To: [email-masked]
Subject: [rohc] why R-1 packet format doesn`t have crc field?

想 要 一 个 快 n 倍 的 免 费 邮 箱 吗 ？ 
126 专 业 电 子 邮 局 ―― 全 球 领 先 的 中 文 邮 箱 带 你 进 入 极 速 之 旅 <http://www.126.com/help/126fab.htm> 

"This email message and any attachments are confidential information of Starent Networks, Corp. The information transmitted may not be used to create or change any contractual obligations of Starent Networks, Corp.  Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon this e-mail and its attachments by persons or entities other than the intended recipient is prohibited. If you are not the intended recipient, please notify the sender immediately -- by replying to this message or by sending an email to [email-masked] -- and destroy all copies of this message and any attachments without reading or disclosing their contents. Thank you."
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Ghyslain Pelletier (LU/EAB)" <[email-masked]>
Date: Thu, 10 Nov 2005 16:18:37 +0100

Just some more thoughts on this. As Biplad pointed out, this is to allow the compressor to convey:

1) changes for the current packet using extensions,
   without updating the context
2) save one octet between the sending of a number of context
   updating UOR-2 packets and the reception of an ACK from the
   decompressor for one of these UOR-2
   (i.e. until the compressor can resume with R-0* packets)

See for example the exemple text on page 67:

     * In the FO state, m2 UOR-2 headers are sent when there is a
       pattern change, after which the compressor sends (pRTT - m2)
       R-1-* headers.  m2 is an implementation parameter, which can be
       as large as pRTT.  At that time, if the compressor has not
       received enough ACKs to the previously sent UOR-2 packets in
       order to transit to SO state, it can repeat the cycle with the
       same m2, or repeat the cycle with a larger m2, or send UOR-2
       headers continuously (m2 = pRTT).  The operation stops when the
       compressor has received enough ACKs to make the transition. 

Of course both 1) and 2) may be done by the compressor, but ... In my opinion for 1) the compressor must have some logic (potentially omniscient to a fair level) in order to figure out that the change conveyed is only for the current packet, and not for subsequent ones ... And for 2), it seems quite an awful lot of complexity in order to save one octet, with respect to sending UOR-2 until an ACK is received instead; unfortunately, the decompressor must implement this complexity in order to be interoperable -- I fail somewhat to understand the rationale being this "header size optimization". It is not either to minimize feedback usage in R-mode, since the logic already strongly suggest to use sparse feedback mechanisms.

But hey, it's in 3095 so the decompressor must handle receiving R-1, along its non updating properties : (

/Ghyslain

[email-masked] wrote:
> I the reliable mode, when there is no need to update any
> context, CRC-less packets are sent. Its just to optimize the header
> size. 
> 
> ________________________________
> 
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of wanxiujin Sent: Thursday, November 10, 2005 5:02 PM
> To: [email-masked]

--
 Ghyslain Pelletier, Dipl. Ing.
 Wireless IP Optimizations
 Ericsson Research, Corporate Unit

 Ericsson AB, Laboratoriegränd 11
 Box 920, S-97128 Luleå, SWEDEN
 Phone : +46 (0)  8 404 29 43
 Mobile: +46 (0) 70 264 83 14
 Ghyslain.Pelletier at ericsson.com
 http://www.ericsson.com

-----------------------------------
 The opinions expressed in this
 message are my personal opinions.
 These opinions are not
 necessarily those of my employer,
 unless stated otherwise.
-----------------------------------