Subject: [rohc] about re-using a CID with a different profile

From: "LI_JING" <[email-masked]>
Date: Thu, 3 Nov 2005 15:32:47 +0800

hi, ROHCers,

            As 7.2.2 in <The RFC 3095 Implementer's Guide> state,

  "    When a CID is re-used for a new context based on a different profile
   than the old context, This operation with that context MUST start in the
   initial mode of the profile (if it is a multi-mode profile).
   applies both to IR-initiated new contexts and profile downgrades with
   IR-DYN .
       A CID for an R-mode operating context SHOULD NOT be re-used for a new
   context based on a different profile than the old context, because of
   the R-0/R-1 misinterpretation risk (these packets have no CRC)."
　　　　　　　　　　　　　
　      I  feel puzzled , if CID is re-used for a new context based on a different profile
   than the old context, so the profile has to begin with initial mode and state, is it relative
 with whether current mode is R mode or not?
          So why here emphasize the CID in R mode now could not be re-used ? In my mind,
 without this paragraph would make no loss to original meaning.
          
         Thanks in advance for your contributions

　　　　　　　　　　　　　　　
BR
LI JING   
TEL: (+86)029-87916666-6075
Mail: [email-masked]
****************************************************************
This e-mail and its attachments contain confidential information 
from DATANG MOBILE, which is intended only for the person or entity
whose address is listed above. Any use of the information contained 
herein in any way (including, but not limited to, total or partial
 disclosure, reproduction, or dissemination) by persons other than 
the intended recipient(s) is prohibited. If you receive this e-mail 
in error, please notify the sender by phone or email immediately 
and delete it!  Thank you.
*****************************************************************
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Ghyslain Pelletier (LU/EAB)" <[email-masked]>
Date: Thu, 3 Nov 2005 13:36:13 +0100

Hi,

My understanding is that this paragraph mainly brings a warning that -- would the new initialization to the new profile fail at the decompressor (e.g. IR packets all get lost), then packets that correspond to packet types not carrying a CRC for verification could be misinterpreted.

This is especially true for context reuse for the same flow, between e.g. Profile 0x0001 and 0x0002 (also sometimes referred to a profile downgrade), because in such case the mode is not inherited but the flow being compressed may be the same. In other words and to exemplify, the compressor first handled a flow as being RTP/UDP/IP, but the heuristic guess was not correct, and the compressor now reverts to UDP/IP compression instead over the same flow -- but doing so it reinitializes the context with a new profile using IR-DYN. If there was a transition to R-mode before the reinitialization, then the compressor must ensure that the reinitialization is successful before sending PT-1 and PT-0 types.

/Ghyslain

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of LI_JING
> Sent: den 3 november 2005 08:33
> To: rohc
> Subject: [rohc] about re-using a CID with a different profile
> 
> hi, ROHCers,
>  
> This e-mail and its attachments contain confidential 
> information from DATANG MOBILE, which is intended only for 
> the person or entity whose address is listed above. Any use 
> of the information contained herein in any way (including, 
> but not limited to, total or partial  disclosure, 
> reproduction, or dissemination) by persons other than the 
> intended recipient(s) is prohibited. If you receive this 
> e-mail in error, please notify the sender by phone or email 
> immediately and delete it!  Thank you.