Subject: [rohc] testing sigcomp code.

From: "Sarvamangala" <[email-masked]>
Date: Wed, 29 Mar 2006 15:14:17 +0530

Hi
i am facing a unique problem. my code works if the sip message is small and fails for bigger sip messages. 

could someone please check if ur udvm is decompressing this sigcomp code correctly.

f8 14 74 1f a2 81 6 0 0 a4 0 0 f 86 7a a4 0 b6 e4 5 a4 0 0 3 0 4 0 5 0 6 0 7 0 8 0 9 0 a 1 b 1 d 1 f 1 11 2 13 2 17 2 1b 2 1f 3 23 3 2b 3 33 3 3b 4 a0 43 4 a0 53 4 a0 63 4 a0 73 5 a0 83 5 a0 a3 5 a0 c3 5 a0 e3 0 a1 2 0 1 0 2 0 3 0 4 1 5 1 7 2 9 2 d 3 11 3 19 4 21 4 31 5 a0 41 5 a0 61 6 a0 81 6 a0 c1 7 a1 1 7 a1 81 8 a2 1 8 a3 1 9 a4 1 9 a6 1 a a8 1 a ac 1 b b0 1 b b8 1 c 80 20 1 c 80 30 1 d 80 40 1 d 80 60 1 1d 3 22 9f b4 1e 20 a0 65 4 7 0 17 80 40 11 1 30 a0 bf 0 0 a0 c0 a0 c7 80 40 29 1 a1 90 a1 ff a0 90 17 50 80 40 11 9 a0 46 13 22 21 1 13 21 1 23 16 9f d1 8 10 4 12 50 4 22 1d 51 22 9f d7 6 12 51 1e 20 9f cf 1 5 0 1f 2f 8 10 4 12 50 4 26 1d 53 26 f6 6 14 53 e 20 63 14 54 52 23 22 50 52 16 9f 9e e a1 36 bb 1 1c 1 a1 35 a2 5a 1c c1 34 a1 38 a2 5a e 2a a4 86 f 38 4 bf c0 86 a1 40 6 d 38 bf c8 2c 23 2a a1 35 b6 a4 86 a1 40 6 0 fb e5 7 df e5 e6 78 f9 6c a 95 fa 65 d8 c1 a 83 30 c 6 e0 3d 4a 9e 40 16 9b b5 15 46 71 7b 93 c4 d 26 c8 3a d0 c3 1e 7f a9 4e b1 f5 d6 43 68 e8 e5 ff 92 fe 53 39 69 20 51 5a e9 87 f8 ed 2b 8d f9 35 ff e1 80 c1 a7 33 a6 e2 49 57 84 89 53 65 81 c0 9b c7 d7 63 f4 19 19 90 bb e0 54 6a d f6 7b 14 b8 1e 3b 7 58 14 b8 d e9 cf 62 2e e0 74 6c 77 3d c3 8c 2 36 b5 37 67 74 8e 60 43 85 3d 9 75 ce 3e ad 75 ba b0 2d 90 18 24 bc 34 2b 41 9b 3a bb bb cb 47 5 c8 c7 98 62 6a 85 12 4e a4 fa f4 3 a 4e 6b c4 

Regards
Sarvamangala

This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely for the use of the addressee(s). If you are not the intended recipient, please notify the sender by e-mail and delete the original message.Global Edge Software Ltd has taken every reasonable precaution to minimize this risk, but is not liable for any damage you may sustain as a result of any virus in this e-mail. You should carry out your own virus checks before opening the e-mail or attachment. Global Edge Software Ltd reserves the right to monitor and review the content of all messages sent to or from this e-mail address
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "West, Mark" <[email-masked]>
Date: Wed, 29 Mar 2006 11:58:32 +0100

Well, a few more hints would be nice :-)

(e.g. what is the expected output...)

The bytecode appears to be 'deflate' with a couple of modifications (a state-access of the state-dictionary to pre-load the buffer) and some stuff after the message has decompressed to read in a length/value and do a SHA-1 hash.  Only the state-access affects compression though?

A couple of suggestions, though:

- Have you tried running without the static dictionary?

- When you say 'large', how large is large?!  I mean, could this be a buffer-wrap problem?

- Have you verified that the compressor is producing correct output?

Good luck!

Mark.

-----Original Message-----
From: Sarvamangala [mailto:[email-masked]]
Sent: Wed 3/29/2006 10:44 AM
To: [email-masked]
Subject: [rohc] testing sigcomp code.
 
Hi

Regards
Sarvamangala

---

From: "Vishal Sudan" <[email-masked]>
Date: Thu, 30 Mar 2006 12:46:51 +0530

I ran the bytecode in my UDVM . After the INPUT-BITS  is executed the Program counter gets to a 
invalid opcode. Since the bytecode around that is 
\x1d\x3\x22\x1f\xb4\                  ; where \x1d is the input bits opcode. 
 
Assuming that \x1f mentioned above is INPUT-HUFFMAN, the INPUT-BIT is one argumnet short.
 
Thanks and Cheers,
Vishal Sudan
 
PS By mistake I did'nt send my first reply to the ROHC forum, rectifying it this time around

-----Original Message-----
From: Sarvamangala [mailto:[email-masked]]
Sent: Wednesday, March 29, 2006 6:59 PM
To: Vishal Sudan
Subject: Re: [rohc] testing sigcomp code.

Hi Vishal
 
could u tell me the exact meaning of !
 
regards
Sarvamangala

----- Original Message ----- 
From: Vishal  <mailto:[email-masked]> Sudan 
To: Sarvamangala <mailto:[email-masked]>  
Sent: Wednesday, March 29, 2006 4:59 PM
Subject: RE: [rohc] testing sigcomp code.

Hi Sarvamangala,
 
It seems to me that you have not compiled the third argument of the INPUT-BITS( 3, , ) which 
comes after the first MULTILOAD.  Because of that an invalid opcode gets hit.
 
Thanks and Cheers,
Vishal Sudan

-----Original Message-----
From: Sarvamangala [mailto:[email-masked]]
Sent: Wednesday, March 29, 2006 3:14 PM
To: [email-masked]
Subject: [rohc] testing sigcomp code.

Hi

 
Regards
Sarvamangala

---

From: "West, Mark" <[email-masked]>
Date: Thu, 30 Mar 2006 10:18:48 +0100

Hi Vishal,

I haven't run the code yet (I will do so later), but your answer still confused me!

In the quoted bytecode I can only see the sequence of bytes: 0x1d 0x03 0x22 0x9f 0xb4 ...
... which is INPUT-BITS with 3 parameters.  This is followed by INPUT-HUFFMAN (opcode 0x1e; 0x1f is STATE-CREATE).

Cheers,

Mark.

-----Original Message-----
From: Vishal Sudan [mailto:[email-masked]]
Sent: Thu 3/30/2006 8:16 AM
To: Sarvamangala; [email-masked]
Subject: RE: [rohc] testing sigcomp code.

 
Thanks and Cheers,
Vishal Sudan

 

-----Original Message-----
From: Sarvamangala [mailto:[email-masked]]
Sent: Wednesday, March 29, 2006 6:59 PM
To: Vishal Sudan
Subject: Re: [rohc] testing sigcomp code.

Hi Vishal

regards
Sarvamangala

----- Original Message ----- 
From: Vishal  <mailto:[email-masked]> Sudan 
To: Sarvamangala <mailto:[email-masked]>  
Sent: Wednesday, March 29, 2006 4:59 PM
Subject: RE: [rohc] testing sigcomp code.

Hi Sarvamangala,

Thanks and Cheers,
Vishal Sudan

-----Original Message-----
From: Sarvamangala [mailto:[email-masked]]
Sent: Wednesday, March 29, 2006 3:14 PM
To: [email-masked]
Subject: [rohc] testing sigcomp code.

Hi

 
Regards
Sarvamangala

---

From: "West, Mark" <[email-masked]>
Date: Thu, 30 Mar 2006 18:25:14 +0100

Ok, I found 5 minutes to stick the bytecode through a VM that I had lying around...

(...so no guarantees as to the accuracy of this result!)

It ran to completion and produced something, but I'm guessing that the decompressed message is not the same as the original (uncompressed input) message ;-)  For instance, the first 3 outputs I get are of literals, but non-printable characters (0xe9, 0xe6, 0x94 for the record) and then a 71 octet chunk of what looks like the static dictionary).

So I guess I stand by my original suggestions, most obviously: have you verified by some other means that your compressor is working correctly?

Cheers,

Mark.

-----Original Message-----
From: West, Mark [mailto:[email-masked]]
Sent: Thu 3/30/2006 10:18 AM
To: Vishal Sudan; Sarvamangala; [email-masked]
Subject: RE: [rohc] testing sigcomp code.

Hi Vishal,

Cheers,

Mark.

-----Original Message-----
From: Vishal Sudan [mailto:[email-masked]]
Sent: Thu 3/30/2006 8:16 AM
To: Sarvamangala; [email-masked]
Subject: RE: [rohc] testing sigcomp code.

 
Thanks and Cheers,
Vishal Sudan

 

-----Original Message-----
From: Sarvamangala [mailto:[email-masked]]
Sent: Wednesday, March 29, 2006 6:59 PM
To: Vishal Sudan
Subject: Re: [rohc] testing sigcomp code.

Hi Vishal

regards
Sarvamangala

----- Original Message ----- 
From: Vishal  <mailto:[email-masked]> Sudan 
To: Sarvamangala <mailto:[email-masked]>  
Sent: Wednesday, March 29, 2006 4:59 PM
Subject: RE: [rohc] testing sigcomp code.

Hi Sarvamangala,

Thanks and Cheers,
Vishal Sudan

-----Original Message-----
From: Sarvamangala [mailto:[email-masked]]
Sent: Wednesday, March 29, 2006 3:14 PM
To: [email-masked]
Subject: [rohc] testing sigcomp code.

Hi

 
Regards
Sarvamangala

---

From: "Vishal Sudan" <[email-masked]>
Date: Fri, 31 Mar 2006 11:32:00 +0530

My mistake. I wrote a small program to convert the bytecode given by Sarvamangala to C string 
to test. I see now that you are right and my small program is behaving badly.
 
Please neglect my wrong "analysis" retrospectively.
 
Thanks,
Vishal Sudan

[Vishal Sudan]  -----Original Message-----
From: West, Mark [mailto:[email-masked]]
Sent: Thursday, March 30, 2006 2:49 PM
To: Vishal Sudan; Sarvamangala; [email-masked]
Subject: RE: [rohc] testing sigcomp code.

Hi Vishal,

Cheers,

Mark.

-----Original Message-----
From: Vishal Sudan [ mailto:[email-masked]]
Sent: Thu 3/30/2006 8:16 AM
To: Sarvamangala; [email-masked]
Subject: RE: [rohc] testing sigcomp code.

Thanks and Cheers,
Vishal Sudan

-----Original Message-----
From: Sarvamangala [ mailto:[email-masked]]
Sent: Wednesday, March 29, 2006 6:59 PM
To: Vishal Sudan
Subject: Re: [rohc] testing sigcomp code.

Hi Vishal

regards
Sarvamangala

----- Original Message -----
From: Vishal  < mailto:[email-masked]> Sudan
To: Sarvamangala < mailto:[email-masked]> 
Sent: Wednesday, March 29, 2006 4:59 PM
Subject: RE: [rohc] testing sigcomp code.

Hi Sarvamangala,

Thanks and Cheers,
Vishal Sudan

-----Original Message-----
From: Sarvamangala [ mailto:[email-masked]]
Sent: Wednesday, March 29, 2006 3:14 PM
To: [email-masked]
Subject: [rohc] testing sigcomp code.

Hi

Regards
Sarvamangala