Subject: RE: [rohc] rfc3485 state id as part of returned Sigcomp parameters?

From: "John Barber" <[email-masked]>
Date: Thu, 9 Mar 2006 16:44:57 -0000

Hi Vishal,

Good point. I don't think this is made clear in any of the relevant
specifications.

Since all SIGCOMP implications for use with SIP *must* provide the
Sip/Sdp dictionary as an item of locally-available state, it would not
seem to be necessary to advertise it - the other end is entitled to
assume that it is present in all cases.

My own implementation plan is:
1) Don't advertise it
2) If remote advertises it, ignore the advertisement
3) Assume that the bytecode I send can use the dictionary state item at
all times.

Does anyone out there have a contrary interpretation?

Regards, John 

> -----Original Message-----
> From: Vishal Sudan [mailto:[email-masked]] 
> Sent: 09 March 2006 16:36
> To: [email-masked]
> Subject: [rohc] rfc3485 state id as part of returned Sigcomp 
> parameters?
> 
> Hi all,
> 
> I have a question regarding Sigcomp parameters.
> 
> rfc3320 says regarding Sigcomp Parameters in section 3.3
> 
> <quote from rfc3320 sec 3.3>
> ...the following parameters are
>    provided to modify SigComp behavior when receiving SigComp 
> messages:
> 
>    decompression_memory_size
>    state_memory_size
>    cycles_per_bit
>    SigComp_version
>    locally available state (a set containing 0 or more state items)
> 
>    Each parameter has a minimum value that MUST be offered by all
>    receiving SigComp endpoints.  Moreover, endpoints MAY offer
>    additional resources if available; these resources can be 
> advertised
>    to remote endpoints using the SigComp feedback mechanism.
> </quote>
> 
> My question/doubt is whether a endpoint supporting the 
> mandatory 3485 dictionary has to advertize it ( 3485 ) using 
> the parameter mechanism?
> 
> The document is very clear on what has to be advertized using 
> parameter mechanism - anything over and above the minimum 
> capabilities. But is rfc3485 within minimum capabilities for 
> a SIP endpoint?
> 
> Thanks,
> Vishal Sudan
> 
> 
> 
> 
> _______________________________________________
> Rohc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/rohc
> 
> 

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Cristian CONSTANTIN <[email-masked]>
Date: Fri, 10 Mar 2006 16:31:17 +0100

> 3) Assume that the bytecode I send can use the dictionary state item at

cristian: I make the same assumption.
(slightly off topic: I wonder if anyone has or works on having a sigcomp
stack for something else than SIP...)

bye now!
cristian
-- 
 _          | There are many people who use UNIX or Linux  
(_'_        | who IMHO do not understand UNIX.
  (_'rist   |              --David Korn  
GPG public key at wwwkeys.de.pgp.net
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc