Subject: [rohc] NACK and sip non-symmetric signalling

From: Cristian CONSTANTIN <[email-masked]>
Date: Thu, 2 Mar 2006 13:30:59 +0100

hi!

just to make sure: NACK will never function if sip signalling is not
symmetric, right?

bye now!
cristian
-- 
 _          | There are many people who use UNIX or Linux  
(_'_        | who IMHO do not understand UNIX.
  (_'rist   |              --David Korn  
GPG public key at wwwkeys.de.pgp.net
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Surtees, Abigail" <[email-masked]>
Date: Mon, 6 Mar 2006 13:51:21 -0000

Hi Cristian,

Thanks for the further explanation.

The NACK protocol adds a requirement to the use of SigComp with SIP,
that when sending a message, the endpoint must listen on the port from
which the message is sent and that a NACK must be sent back to that
port.  The SIP/SigComp stack receiving the message that causes a NACK,
has no other information about where to send the NACK (because
decompression failed):

"For a connectionless transport, such as UDP, the NACK message is sent
   back to the originator of the failed message at the port and IP
   address from which the message was sent.  Note that this may or may
   not be the same port on which the application would typically receive
   messages.  ..."

"The behavior specified above is strictly necessary for any generally
   useful form of a NACK mechanism.  In the most general case, when an
   implementation receives a message that it cannot decompress, it has
   exactly three useful pieces of information: (1) the contents of the
   message, (2) an indication of why the message cannot be decoded, and
   (3) the IP address and port from which the message originated.  Note
   that none of these contains any indication of where the remote
   application is listening for messages, if it differs from the sending
   port."

On the assumption that a NAT that has a mapping between a host and an
external IP address and port number and that it will symmetrically pass
messages received on that address and port number back to the host, a
NAT (in this instance) does not add complication.

The requirement is there for all SIP stacks that wish to use NACK.

Best regards,

Abbie

> -----Original Message-----
> From: Cristian CONSTANTIN [mailto:[email-masked]] 
> Sent: Thursday, March 02, 2006 3:29 PM
> To: Surtees, Abigail
> Cc: [email-masked]
> Subject: Re: [rohc] NACK and sip non-symmetric signalling
> 
> On Thu, Mar 02, 2006 at 01:48:08PM -0000, Surtees, Abigail wrote:
> > Hi Cristian,
> > 
> > Do you mean 'does the NACK message have to wait for a SIP 
> message to be
> > sent by the SIP stack'?
> > 
> > If that's what you mean, then the answer's no.  The whole 
> point of NACK
> > is that the SigComp layer can send a message saying "it's all going
> > wrong" without a SIP message being sent.
> > 
> > If that's not what you mean, please can you elaborate further as I'm
> > afraid I don't understand the question.
> 
> cristian: hi. first of all I'm assuming udp and by not 
> symmetric, I mean 
> that the client, for example, does not expect the response at 
> the (random) 
> port from which the request was made but at the one specified 
> in the Via header.
> (people who tried to make SIP work through NAT will recognize this
> kind of problem).
> what I'm trying to say here is that maybe NACK does not know 
> the dest port 
> where to send the error message...
> 
> bye now!
> cristian
> --