Subject: [rohc] code_len==0 in a sigcomp message's header

From: Cristian CONSTANTIN <[email-masked]>
Date: Wed, 15 Mar 2006 11:05:31 +0100

hi!

besides NACK does such a message (code_len==0 and no udvm bytecode) 
make sense? what exactly does it mean?

thanks!
bye now!
cristian
-- 
 _          | There are many people who use UNIX or Linux  
(_'_        | who IMHO do not understand UNIX.
  (_'rist   |              --David Korn  
GPG public key at wwwkeys.de.pgp.net
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Surtees, Abigail" <[email-masked]>
Date: Mon, 20 Mar 2006 16:09:12 -0000

Hi Cristian,

There is nothing to stop a non-NACK 3320 implementation dropping such a
packet when it receives it and not setting up the UDVM at all.

However, this is an implementation optimisation and, as such, does not
need to be documented.

Best regards,

Abbie 

> cristian: hi! 
> o.k. thanks. 
> so, the packets len==0 && code_len==0 packets are legal but 
> not really useful.
> anyway, what I do not understand here why not drop from the 
> begining such packets 
> under the assumptions of an rfc3320 only impl. (i.e.  NACK is 
> not supported for 
> one reason or another)
> 
> bye now!
> cristian
> --