Subject: [rohc] Incorrect cycle count in Sigcomp torture test document

From: "Vishal Sudan" <[email-masked]>
Date: Fri, 24 Mar 2006 13:10:41 +0530

Hi,

For the torture test given in Section 2.16 ( STATE-ACCESS ) in 
http://www.ietf.org/internet-drafts/draft-ietf-rohc-sigcomp-torture-tests-03.txt I see results
different than stated.

It has 5 sub-tests, each identified with a different input - 0x00,0x01,0x02,0x03 and 0x04 resp.

A possible erroneous test is for input 0x00.

The test document states 

*   If the compressed message is 0x00 then the output of the code is
*   0x7465 7374 and a total of 21 UDVM cycles are be used.

The cycle count comes out to 26

opcode	           cycles

INPUT-BYTES      1 + 1     =      2  
COMPARE	     1         =      1
STATE-ACCESS     1 + 16	   =	    17 	
OUTPUT   	     1 + 4     =      5
END-MESSAGE      1 + 0     =      1 

Total					   26

Here the length of state accessed is taken to be 16 - which seems to be the case cause
the state is created by the code 

*   END-MESSAGE (0, 0, state_length, state_start, 0, 20, 0)
*   :state_start
*   byte (34, 162, 12,4, 35, 0, 0, 0, 0, 0, 0, 0, 116, 101, 115, 116)
*   :state_end 

which has 16 bytes.

(The output is as it should  be - 0x7465 7374.)

If I am incorrect on any count I'd be glad to know of that.

As a side note I was going to report two possible errors but then saw an error on 
my part while composing this post and testing concurrently.

Cheers,
Vishal Sudan

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Surtees, Abigail" <[email-masked]>
Date: Fri, 24 Mar 2006 09:05:05 -0000

Hi Vishal,

You are correct - it should say 26.  It is correct in the appendix, but
the text missed the update.  

I guess this can also be corrected in AUTH48 (see
<http://www1.ietf.org/mail-archive/web/rohc/current/msg04090.html>)?

Thank you for pointing it out.

Best regards,

Abbie

> -----Original Message-----
> From: Vishal Sudan [mailto:[email-masked]] 
> Sent: Friday, March 24, 2006 7:41 AM
> To: [email-masked]
> Subject: [rohc] Incorrect cycle count in Sigcomp torture test document
> 
> Hi,
>