Subject: RE: [rohc] NACK and sip non-symmetric signalling

From: "Surtees, Abigail" <[email-masked]>
Date: Thu, 2 Mar 2006 13:48:08 -0000

Hi Cristian,

Do you mean 'does the NACK message have to wait for a SIP message to be
sent by the SIP stack'?

If that's what you mean, then the answer's no.  The whole point of NACK
is that the SigComp layer can send a message saying "it's all going
wrong" without a SIP message being sent.

If that's not what you mean, please can you elaborate further as I'm
afraid I don't understand the question.

Best regards,

Abbie

> -----Original Message-----
> From: Cristian CONSTANTIN [mailto:[email-masked]] 
> Sent: Thursday, March 02, 2006 12:31 PM
> To: [email-masked]
> Subject: [rohc] NACK and sip non-symmetric signalling
> 
> hi!
> 
> just to make sure: NACK will never function if sip signalling is not
> symmetric, right?
> 
> bye now!
> cristian
> -- 
>  _          | There are many people who use UNIX or Linux  
> (_'_        | who IMHO do not understand UNIX.
>   (_'rist   |              --David Korn  
> GPG public key at wwwkeys.de.pgp.net
> 

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Cristian CONSTANTIN <[email-masked]>
Date: Thu, 2 Mar 2006 16:29:04 +0100

> afraid I don't understand the question.

cristian: hi. first of all I'm assuming udp and by not symmetric, I mean 
that the client, for example, does not expect the response at the (random) 
port from which the request was made but at the one specified in the Via header.
(people who tried to make SIP work through NAT will recognize this
kind of problem).
what I'm trying to say here is that maybe NACK does not know the dest port 
where to send the error message...

bye now!
cristian