Subject: RE: [rohc] code_len==0 in a sigcomp message's header

From: "Surtees, Abigail" <[email-masked]>
Date: Mon, 20 Mar 2006 09:56:01 -0000

Hi Cristian,

Such a message would just cause decompression failure.  If a non-NACK
message has len=0 (i.e. bytecode) and code_len=0 (i.e. no bytes of
bytecode) then it will load zero bytes of bytecode into the UDVM, start
running and immediately get decompression failure because the UDVM is
pre-loaded with zeros.

Best regards,

Abbie

> -----Original Message-----
> From: Cristian CONSTANTIN [mailto:[email-masked]] 
> Sent: Wednesday, March 15, 2006 10:06 AM
> To: [email-masked]
> Subject: [rohc] code_len==0 in a sigcomp message's header
> 
> hi!
> 
> besides NACK does such a message (code_len==0 and no udvm bytecode) 
> make sense? what exactly does it mean?
> 
> thanks!
> bye now!
> cristian
> -- 
>  _          | There are many people who use UNIX or Linux  
> (_'_        | who IMHO do not understand UNIX.
>   (_'rist   |              --David Korn  
> GPG public key at wwwkeys.de.pgp.net
> 

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Cristian CONSTANTIN <[email-masked]>
Date: Mon, 20 Mar 2006 13:02:57 +0100

> running and immediately get decompression failure because the UDVM is

cristian: hi! 

...and how can you tell a NACK from a non-NACK?... if not by using
code_len?

bye now!
cristian