Subject: [rohc] testing sigcomp code

From: "Raghavendra D P" <[email-masked]>
Date: Thu, 31 Aug 2006 17:47:25 +0530

hi

i am using deflate algorithm (zlib 1.2..3) for compressing the sip message  and implementing the UDVM algorithm

Sip input message given to deflate algorithm is  

"INVITE sip:bob at biloxi.com SIP/2.0\r\n Via: SIP/2.0/UDP pc33.atlanta.com;branch=z9hG4bKnashds8;comp=sigcomp\r\n Max-Forwards: 70\r\n To: Bob <sip:bob at biloxi.com>\r\n From: Alice <sip:alice at atlanta.com>;tag=1928301774 Call-ID: a84b4c76e66710 CSeq: 314159 INVITE Contact: <sip:alice at pc33.atlanta.com> Content-Type: application/sdp Content-Length: 142"

Then the sigcomp message is
78f98412156d8fdb4e84301086bd36f11de65381490431112655d435ccd268b7b3f9469ab06d8526ae3ebd653dc46cbc9a99fc5fbe99

a99ff77573fb3d0b4552da081568cea285ca6eb0abb75ee0fa5797b017487f46ef65b55cdc2d04533a234b8b0793ba16443f191df5

1fb28711eba39cd6da28b59f44bb59a273c3a6b35bde1d4cd1492c5dc28a7776f3cdbf279496584fea40e176148c7f51786a2df76

77f991becb92569e8932489a0c27174ea1554ca3366249cce338213e543bfe4a212411b9cee0fbfb4a59b33f44c7ffe63792b9344ef3aeb9356b6d513442496feef46fbae

1b23735125179f2fe26f74b2fe26f7495abaa9d24367959f4ea5df5277ab32fecd31d8364f8c2214080

if any one has implemented the UDVM , please run code with above sigcomp message , whether output is correct or not.

thanks in advance

Regards

Raghavendra 

This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely for the use of the addressee(s). If you are not the intended recipient, please notify the sender by e-mail and delete the original message.Global Edge Software Ltd has taken every reasonable precaution to minimize this risk, but is not liable for any damage you may sustain as a result of any virus in this e-mail. You should carry out your own virus checks before opening the e-mail or attachment. Global Edge Software Ltd reserves the right to monitor and review the content of all messages sent to or from this e-mail address
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Surtees, Abigail" <[email-masked]>
Date: Thu, 31 Aug 2006 15:31:06 +0100

Hi Raghavendra,
 
It is not possible to run the message because it is not a SigComp
message.  I assume that this is the output from compressing the SIP
message.  You need to provide a full SigComp message (probably beginning
0xF8, certainly beginning 0b11111xxx) including bytecode for anyone to
be able to decompress a message with their UDVM.  See section 7 of RFC
3320 for the message format.
 
Best regards,
 
Abbie

________________________________

	From: Raghavendra D P [mailto:[email-masked]]

	Sent: 31 August 2006 13:17
	To: [email-masked]
	Subject: [rohc] testing sigcomp code

	hi

	i am using deflate algorithm (zlib 1.2..3) for compressing the
sip message  and implementing the UDVM algorithm

	"INVITE sip:bob at biloxi.com SIP/2.0\r\n Via: SIP/2.0/UDP
pc33.atlanta.com;branch=z9hG4bKnashds8;comp=sigcomp\r\n Max-Forwards:
70\r\n To: Bob <sip:bob at biloxi.com>\r\n From: Alice <sip:alice at
atlanta.com>;tag=1928301774 Call-ID: a84b4c76e66710 CSeq: 314159 INVITE
Contact: <sip:alice at pc33.atlanta.com> Content-Type: application/sdp
Content-Length: 142"

78f98412156d8fdb4e84301086bd36f11de65381490431112655d435ccd268b7b3f9469a
b06d8526ae3ebd653dc46cbc9a99fc5fbe99

a99ff77573fb3d0b4552da081568cea285ca6eb0abb75ee0fa5797b017487f46ef65b55c
dc2d04533a234b8b0793ba16443f191df5

1fb28711eba39cd6da28b59f44bb59a273c3a6b35bde1d4cd1492c5dc28a7776f3cdbf27
9496584fea40e176148c7f51786a2df76

77f991becb92569e8932489a0c27174ea1554ca3366249cce338213e543bfe4a212411b9
cee0fbfb4a59b33f44c7ffe63792b9344ef3aeb9356b6d513442496feef46fbae

1b23735125179f2fe26f74b2fe26f7495abaa9d24367959f4ea5df5277ab32fecd31d836
4f8c2214080

	if any one has implemented the UDVM , please run code with above
sigcomp message , whether output is correct or not.

	thanks in advance

	Regards

	Raghavendra