Subject: [rohc] regarding UDVM

From: "Raghavendra D P" <[email-masked]>
Date: Wed, 9 Aug 2006 10:58:07 +0530

hi

i have doubt that is there any relationship between UDVM bytecode and state values in state item comprsing of static dictionaries.

what information is stored in state , is it whole snapshot of UDVM memory up to 64k.

For the first time UDVM bytecode is uploaded along with Sig Comp message, and next time onwards  only state identifier is sent, my question is where this bytecode is stored on the other end, is it nothing but information in state value.

next question how to create UDVM bytecode
using  36 UDVM instuctions, 

 one more question is  feedback item like decompression memory sz and state memory size and cycles per bit also stored in state 

please help me in this regard

thanks in advance

Regards
Raghavendra

This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely for the use of the addressee(s). If you are not the intended recipient, please notify the sender by e-mail and delete the original message.Global Edge Software Ltd has taken every reasonable precaution to minimize this risk, but is not liable for any damage you may sustain as a result of any virus in this e-mail. You should carry out your own virus checks before opening the e-mail or attachment. Global Edge Software Ltd reserves the right to monitor and review the content of all messages sent to or from this e-mail address
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Gangadharan G - NPD, Chennai" <[email-masked]>
Date: Wed, 9 Aug 2006 14:55:53 +0530

Hi Raghu,
 
Let me try to answer ur question.
Please correct me, If I had mention anything wrong.
 
Q1. is there any relationship between UDVM bytecode and state values in
state item ?
Through UDVM instruction, you can access the state value. The state value
are identified by the State-ID. 
For Static States like dictionaries, State ID is known earlier. 
    Example, the state ID of SIP dictionary is 0xfbe507dfe5e6.
The UDVM instruction for accessing the State Value is STATE-ACCESS. 
 
Q2. what information is stored in state , is it whole snapshot of UDVM
memory up to 64k.
The State value necessarily need not be the snapshot of UDVM memory. It can
be either of the following also 
Decompressed message, Message to be sent or Dictionary.
 
Q3. where this bytecode is stored on the other end, is it nothing but
information in state value?
You can save the UDVM memory snapshot of the first message through the UDVM
instruction END-MESSAGE. 
The UDVM memory contains UDVM bytecode. While creating the state (UDVM
memory), you also need to mention the start of UDVM bytecode through the
option state_instruction.
For the next messages, you can mention the STATE-ID of the UDVM snapshot in
the Sicomp header field, Partial-State-Identifier.
 
Q4. feedback item like decompression memory sz and state memory size and
cycles per bit also stored in state 
These items are Return feedback parameters. They are stored in the
State-Handler but not as a state.
The remote end advertises these parameters in the sent message. The UDVM
passes these parameters to the corresponding compressor through
State-Handler.

-----Original Message-----
From: Raghavendra D P [mailto:[email-masked]]
Sent: Wednesday, August 09, 2006 10:58 AM
To: [email-masked]
Subject: [rohc] regarding UDVM 

hi
 
i have doubt that is there any relationship between UDVM bytecode and state
values in state item comprsing of static dictionaries.
 
what information is stored in state , is it whole snapshot of UDVM memory up
to 64k.
 
For the first time UDVM bytecode is uploaded along with Sig Comp message,
and next time onwards only state identifier is sent, my question is where
this bytecode is stored on the other end, is it nothing but information in
state value.

 one more question is feedback item like decompression memory sz and state
memory size and cycles per bit also stored in state 

thanks in advance
 
Regards
Raghavendra

Disclaimer:

This message and any attachment(s) contained here are information that is confidential, proprietary to HCL Technologies and its customers, privileged or otherwise protected by law. The information is solely intended for the individual or the entity it is addressed to. If you are not the intended recipient of this message, you are not authorized to read, forward, print, retain, copy or disseminate this message or any part of it. If you have received this e-mail in error, please notify the sender immediately by return e-mail and delete it from your computer.
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc