Subject: RE: [rohc] SigComp UDVM

From: "Gangadharan G - NPD, Chennai" <[email-masked]>
Date: Mon, 7 Aug 2006 20:53:10 +0530

Hi Cristian,
              
The UDVM bytecode is send in the first message. 
The bytecode has UDVM instruction to load the Shared States. 
The list of shared state ids are appended with compressed payload in the
message.

In the case of second choice, 
whether the state length of the Shared state are also need to be appended
with 
compressed payload in the message.

Thanks,
Gangadharan.

-----Original Message-----
From: cco [mailto:[email-masked]]
Sent: Sunday, August 06, 2006 12:53 AM
To: Gangadharan G - NPD, Chennai
Cc: [email-masked]
Subject: Re: [rohc] SigComp UDVM

On Sat, Aug 05, 2006 at 04:46:17AM +0530, Gangadharan G - NPD, Chennai
wrote:
> Hi All,
>  
> I am having doubt regarding UDVM.
>  
>                ***********************************************************
>                * Register  *  Bytecode  *        Circular Buffer        *
>                ***********************************************************
>  
> When the state value is loaded in the Circular buffer using the UDVM
> instruction STATE-ACCESS,
> how to get the no. of bytes written in the circular buffer by the
> STATE-ACCESS i.e., length of the state value. 
> This is required to update the decompressor_pointer.

cristian: with a STATE-ACCESS you have 2 choices.

1. you spec. the state length. in this case you update the decompressor
pointer with the state length.

2. you spec. a 0 state length and the state length saved at the state
creation is used. I guess this is the case you are dealing with.
in this case your compressor has to know what are the sizes of the
states (windows) it is working with and the bytecode has to update the
decompressor pointer accordingly.

bye now!
cristian

Disclaimer:

This message and any attachment(s) contained here are information that is confidential, proprietary to HCL Technologies and its customers, privileged or otherwise protected by law. The information is solely intended for the individual or the entity it is addressed to. If you are not the intended recipient of this message, you are not authorized to read, forward, print, retain, copy or disseminate this message or any part of it. If you have received this e-mail in error, please notify the sender immediately by return e-mail and delete it from your computer.

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: cco <[email-masked]>
Date: Mon, 7 Aug 2006 18:57:24 +0000

> compressed payload in the message.

cristian: if the state size changes at each every compressed packet,
then yes. you could also have a compressor that uses a fixed length
window.

bye now!
cristian