Subject: [rohc] please clarify it

From: Raghavendra <[email-masked]>
Date: 12 Sep 2006 14:47:04 +0530

hi

UDVM bytecode for the DEFLATE compression is taken from SigComp user
guide, which includes following instruction 

MULTILOAD (64, 122, circular_buffer, udvm_memory_size, 5,
circular_buffer,

0,       3,       0,       4,       0,       5,
0,       6,       0,       7,       0,       8,
0,       9,       0,       10,      1,       11,
1,       13,      1,       15,      1,       17,  
2,       19,      2,       23,      2,       27,what indicates 10 lines 
2,       31,      3,       35,      3,       43,
3,       51,      3,       59,      4,       67,  
4,       83,      4,       99,      4,       115,
5,       131,     5,       163,     5,       195,
5,       227,     0,       258,

0,       1,       0,       2,       0,       3,
0,       4,       1,       5,       1,       7,
2,       9,       2,       13,      3,       17,
3,       25,      4,       33,      4,       49,
5,       65,      5,       97,      6,       129,
6,       193,     7,       257,     7,       385,what indicates 10 lines
8,       513,     8,       769,     9,       1025,
9,       1537,    10,      2049,    10,      3073,
11,      4097,    11,      6145,    12,      8193,
12,      12289,   13,      16385,   13,      24577)

i am decoding its corresponding bytecode given in SigComp guide 

3,       51,      3,       59,      4,       67,  these are the inputs
to multiload  instruction and its corresponding bytecode is 

03 3303 3b04 a043

but 67 it has give 43 but it bytecode contains a043  - how a0

clarify my doubt
thanks in advance

Regards
Raghavendra DP

This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely for the use of the addressee(s). If you are not the intended recipient, please notify the sender by e-mail and delete the original message.Global Edge Software Ltd has taken every reasonable precaution to minimize this risk, but is not liable for any damage you may sustain as a result of any virus in this e-mail. You should carry out your own virus checks before opening the e-mail or attachment. Global Edge Software Ltd reserves the right to monitor and review the content of all messages sent to or from this e-mail address
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Vishal Sudan" <[email-masked]>
Date: Tue, 12 Sep 2006 15:35:47 +0530

Raghavendra,

As mentioned in rfc3320 section 8.5

   To reduce the size of typical UDVM bytecode, each operand for a UDVM
   instruction is compressed using variable-length encoding.  The aim is
   to store more common operand values using fewer bytes than rarely
   occurring values.

So the given number decimal 67 gets converted into 0xa043 going by   
Figure 10 in rfc3320 ( which is the one for multitypes, as the given operand 
of MULTILOAD is )

The actual applicable row of that being 
     101nnnnn nnnnnnnn               N                   0 - 8191

Thanks and Regards,
Vishal Sudan

-----Original Message-----
From: Raghavendra [mailto:[email-masked]]
Sent: Tuesday, September 12, 2006 2:47 PM
To: [email-masked]
Subject: [rohc] please clarify it

hi

0,       3,       0,       4,       0,       5,
0,       6,       0,       7,       0,       8,
0,       9,       0,       10,      1,       11,
1,       13,      1,       15,      1,       17,  

0,       1,       0,       2,       0,       3,
0,       4,       1,       5,       1,       7,
2,       9,       2,       13,      3,       17,
3,       25,      4,       33,      4,       49,
5,       65,      5,       97,      6,       129,

03 3303 3b04 a043

clarify my doubt
thanks in advance

Regards
Raghavendra DP