Subject: [rohc] please do clarify

From: Raghavendra <[email-masked]>
Date: 11 Sep 2006 18:08:28 +0530

hi
 
i am decoding the UDVM bytecode for the DEFLATE compression algorithm
given in RFC 4464 -sigComp guide

i am not geeting 2nd byte of staring word 0X0f86
0f - indicates the multiload instruction 

and first operand is 64 see below multiload instruction, but bytecode 
is showing 86 how

MULTILOAD (64, 122, circular_buffer, udvm_memory_size, 5,
circular_buffer ,......)

Thanks
regards

This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely for the use of the addressee(s). If you are not the intended recipient, please notify the sender by e-mail and delete the original message.Global Edge Software Ltd has taken every reasonable precaution to minimize this risk, but is not liable for any damage you may sustain as a result of any virus in this e-mail. You should carry out your own virus checks before opening the e-mail or attachment. Global Edge Software Ltd reserves the right to monitor and review the content of all messages sent to or from this e-mail address
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "John Barber" <[email-masked]>
Date: Mon, 11 Sep 2006 14:00:56 +0100

Hi,

0x86 is the correct encoding of the value 64 for a multitype operand.

See figure 10 in the SIGCOMP RFC. 0x86 is 0b10000110 so the operand
format is 1000011n with n == 0 and the equivalent value is 2 ^ (n + 6)
which is 64.

Regards, John 

> -----Original Message-----
> From: Raghavendra [mailto:[email-masked]] 
> Sent: 11 September 2006 13:38
> To: [email-masked]
> Subject: [rohc] please do clarify
> 
> 
> hi
>  
> i am decoding the UDVM bytecode for the DEFLATE compression 
> algorithm given in RFC 4464 -sigComp guide
> 
> i am not geeting 2nd byte of staring word 0X0f86 0f - 
> indicates the multiload instruction 
> 
> and first operand is 64 see below multiload instruction, but 
> bytecode is showing 86 how
> 
>