Subject: RE: [rohc] RoHCv2 and Timer-based compression of RTP Timestamp

From: "Kapoor, Rohit" <[email-masked]>
Date: Fri, 22 Sep 2006 15:58:11 -0700

Ghyslain, RoHCers,

Over the last few weeks, we have been doing simulations and analysis to
evaluate the impact of not having timer-based compression on VoIP
capacity of 3GPP2 systems.

Our results show that for current 3GPP2 systems, VoIP capacity loss can
be as much as 5%, while for future 3GPP2 systems (currently being
standardized), the capacity loss is as much as 10% or higher. The main
reason for such VoIP capacity loss comes from the fact that physical
layer payloads are discrete, meaning sometimes even a single byte
increment in size of compressed header can lead to a significant
increase in the size of the physical layer payload used (with the spare
octets being padded).

On another note, RoHC v2 profiles do have advantages over RoHC v1
profiles for future 3GPP2 systems. Graceful handling of multiple IP
headers is one example which can make v2 profiles very useful for future
3GPP2 systems. Given this, it seems like not having timer-based
compression is just reducing the "usefulness" of v2 profiles.

It is likely that for 3GPP2 to migrate to RoHC v2 profiles in the
future, timer-based compression would be a big factor, since VoIP
capacity loss of 10% is considered extremely significant. Thus, we
strongly support the inclusion of timer-based compression in RoHC v2
profiles.

Thanks,
Rohit

> -----Original Message-----
> From: Ghyslain Pelletier (LU/EAB)
[mailto:[email-masked]]
> Sent: Friday, September 15, 2006 5:22 AM
> To: [email-masked]; [email-masked]
> Subject: RE: [rohc] RoHCv2 and Timer-based compression of RTP
Timestamp
> 
> Teemu,
> 
> The technical merits of timer-based compression, and whether to
include
> it or not in RoHCv2, have already been discussed on the list and at
the
> Montreal meeting.
> 
> As you know, everything sent to the list gets archived!
> 
> The last mail on this thread is found at the following link:
> http://www1.ietf.org/mail-archive/web/rohc/current/msg04408.html
> You can start from there and make your way back through the
discussion.
> 
> I have also summarized pros and cons of having timer-based compression
> in RoHCv2 in my presentation at the MTL meeting:
> http://www3.ietf.org/proceedings/06jul/slides/rohc-2/sld41.htm
> 
> My understanding is that so far the consensus leans towards not to
> support tbc in RoHCv2. Personnally, based on the technical discussion,
I
> am happy with this consensus. In our original individual submission,
> which later got accepted as a wg document, we consciously made the
> proposal wihtout supporting tbc so it is not something that was
> "forgotten".
> 
> Regards,
> 
> ///Ghyslain
> 
> [email-masked] wrote:
> > Hi,
> >
> > I looked at draft-ietf-rohc-rfc3095bis-rohcv2-profiles-00.txt
> > and I couldn't find any mention about "Timer-based
> > compression of RTP Timestamp" (as in chapter 4.5.4 in RFC3095).
> >
> > I wonder why it is not there?
> >
> > Thanks,
> >
> > 	Teemu
> >
> > _______________________________________________
> > Rohc mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/rohc
> 
> 
> _______________________________________________
> Rohc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/rohc

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lars-Erik Jonsson \(LU/EAB\)" <[email-masked]>
Date: Mon, 25 Sep 2006 08:41:54 +0200

Rohit,

> Ghyslain, RoHCers,
> 
> Over the last few weeks, we have been doing simulations and
> analysis to evaluate the impact of not having timer-based
> compression on VoIP capacity of 3GPP2 systems. 

Thanks for doing these studies, it is indeed good to get
some concrete arguments in favor of TBC, up until now I
think all arguments pro-TBC have been without backing.
Your input is thus of great value.

> Our results show that for current 3GPP2 systems, VoIP
> capacity loss can be as much as 5%, while for future 3GPP2
> systems (currently being standardized), the capacity loss
> is as much as 10% or higher. The main reason for such VoIP
> capacity loss comes from the fact that physical layer
> payloads are discrete, meaning sometimes even a single
> byte increment in size of compressed header can lead to a
> significant increase in the size of the physical layer
> payload used (with the spare octets being padded).

I will not question your results, just conclude that this
is rather depressing news. It means systems are still not
built for true IP networking, but with a circuit-based
approach, optimizing for voice. I really thought that way
of building network links was becoming history.

Anyway, let's hear what others have to say about TBC for v2.

Cheers,
/L-E

---

From: "Ghyslain Pelletier \(LU/EAB\)" <[email-masked]>
Date: Mon, 25 Sep 2006 09:13:46 +0200

Rohit,

Thanks for the input, much appreciated! As said before, I am not against
adding support for TBC, it needed a motivation and you seem to have
provided it. Assuming that no one is against adding support for TBC to
RoHCv2, we will then include it in the next update of the draft, as in
my understanding many have raised this question and there seems to be a
consensus shifting that way.

Best regards,

///Ghyslain

Kapoor, Rohit wrote:
> systems (currently being standardized), the capacity loss is
> as much as 10% or higher. The main reason for such VoIP
> payloads are discrete, meaning sometimes even a single byte
> increment in size of compressed header can lead to a
> On another note, RoHC v2 profiles do have advantages over
> RoHC v1 profiles for future 3GPP2 systems. Graceful handling
> of multiple IP headers is one example which can make v2
> profiles very useful for future
> 3GPP2 systems. Given this, it seems like not having
> timer-based compression is just reducing the "usefulness" of v2
> profiles. 
> 
> It is likely that for 3GPP2 to migrate to RoHC v2 profiles in
> the future, timer-based compression would be a big factor,
> since VoIP capacity loss of 10% is considered extremely
> significant. Thus, we strongly support the inclusion of
> timer-based compression in RoHC v2 profiles.
> 
> Thanks,
> Rohit
> 
>> include it or not in RoHCv2, have already been discussed on the list
>> and at the Montreal meeting. 
>> 
>> I have also summarized pros and cons of having timer-based
>> compression in RoHCv2 in my presentation at the MTL meeting:
>>> and I couldn't find any mention about "Timer-based compression of
>>> RTP Timestamp" (as in chapter 4.5.4 in RFC3095).
>>>

---

From: "Kapoor, Rohit" <[email-masked]>
Date: Tue, 26 Sep 2006 12:46:43 -0700

Lars-Erik,

> Anyway, let's hear what others have to say about TBC for v2.

Your point is definitely valid that systems are still being built such
that they are optimized for voice. The reality is that voice capacity is
still a very important factor in the design of cellular systems, and
hence optimizing systems for VoIP capacity is key.

Thanks,
Rohit