Subject: Re: [rohc] Hi

From: satyanarayanam <[email-masked]>
Date: Thu, 10 Apr 2008 22:32:24 -0700 (PDT)

Carsten Bormann wrote:
> 
> On Mar 25 2008, at 10:06, Ang Way Chuang wrote:
>>> 	I do want to know the Ethernet type filed(802.3)/ length of the  
>>> ethernet
>>> frame value when ROHC is enabled.
>>> plz do let me know if anybody worked on this.Its urgent.
>>
>> Was it ever defined at all?
> 
> There is currently no "ROHC over Ethernet" specification.
> 
>  From my (expired) draft on ROHC over 802:
> http://tools.ietf.org/html/draft-bormann-rohc-over-802-01
> 
> ...
>> Previous proposals generally suffered from a lack of systems  
>> perspective on 802 networks. The present document attempts to supply  
>> some systems perspective and provides a rough outline for a solution.
> In particular, see section 3.1.
> 
> Now, of course, I'd like to know what your application is -- lack of  
> requirements input was the main impediment to making this draft happen  
> as an RFC.
> 
> Gruesse, Carsten
> 
> _______________________________________________
> Rohc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rohc
> 
> 

Hi,

  Did you implemented rohc on ethernet?
we are trying to implement rohc before to ip layer that is it can know that
what is type of prifile that rohc supports,then why not i can send directly
to ipv4/v6 if that profile is not supported that means bypassing ROHC, BUt
still we are using uncpmpressed packet for this.

Thank you all

-- 
View this message in context: http://www.nabble.com/Hi-tp16271641p16625249.html
Sent from the IETF - Rohc mailing list archive at Nabble.com.

_______________________________________________
Rohc mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rohc

---

From: Biplab Sarkar <[email-masked]>
Date: Fri, 11 Apr 2008 12:02:18 +0530

Hi Satya,

I am not sure if I got your doubt.
The current ROHC channels which don't have any separate ROHC Protocol-ID
field have to use IP Protocol-ID in the under lying packets protocol
field. So, there can't be any mixup between ROHC and vanilla IP packets.
One has to use some out-of-band signalling to decide what has to be sent
(ROHC pkts, or IP pkts) but not both. 

Thanks & Regards
Biplab