Subject: [rohc] [rfc 5225] question on reordering ratio

From: Suneeta Rao <[email-masked]>
Date: Sun, 20 Jul 2008 01:37:08 -0700 (PDT)

Dear ROHCers,
The ROHC reordering ratio introduced in RFC 5225 is a bit puzzling to me. It is not really clear from the text if it handles the reodering before the compressor, or reordering between the compressor and decompressor.
It also isn't a part of negotiated parameter list like we have in RFC 3095. Can someone indicate what is the mechanism to determing the value of this parameter? Does it come from channel characteristics?
Regards,
Suneeta.

_______________________________________________
Rohc mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rohc

---

From: Biplab Sarkar <[email-masked]>
Date: Mon, 21 Jul 2008 12:10:28 +0530

Hi Suneeta,

The reordering ratio will address the reordering between the compressor
and decompressor. Its more closely related to over-the-air ARQ
algorithms.

The parameter "reordering ratio" is dictated by the compressor to give
some indication about its perception about the reordering channel as
seen by the decompressor. So you can see that its located in a number of
context control packets (co_common). 

Thanks & Regards
Biplab

On Sun, 2008-07-20 at 01:37 -0700, Suneeta Rao wrote:
>  
> Dear ROHCers,
>  
> The ROHC reordering ratio introduced in RFC 5225 is a bit puzzling to
> me. It is not really clear from the text if it handles the reodering
> before the compressor, or reordering between the compressor and
> decompressor.
>  
> It also isn't a part of negotiated parameter list like we have in RFC
> 3095. Can someone indicate what is the mechanism to determing the
> value of this parameter? Does it come from channel characteristics?
>  
> Regards,
> Suneeta.
>  
> 
> 
>