Subject: [rohc] incompatible feedback type 2 causes problems in reusing the context for profile change

From: Suneeta Rao <[email-masked]>
Date: Mon, 8 Sep 2008 04:16:52 -0700 (PDT)

Hello ROHCers,

I have a question on changing profile from ROHCv2 to RFC3095 and vice versa. Please note that I only have a basic simulation environment.

When I change from ROHCv2 to RFC3095 in compressor, I am getting some stale feedback from the peer decompressor which was for ROHCv2. However, because of incompatible formats between ROHCv2 and RFC3095, compressor is interpreting parts of Ack no as "mode bits" of RFC 3095. This is being treated as a mode transition.

I'm pointing this out as this looks like a ROHC specification issue. In general, what is the expected behaviour if profile change is done from ROHCv2 to ROHCv1? How are stale packets to be handled? I haven't looked at other profiles, but I guess the issue might be there for TCP profile also.

Regards,
Suneeta.

_______________________________________________
Rohc mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rohc

---

From: Sarkar Biplab <[email-masked]>
Date: Mon, 08 Sep 2008 17:49:32 +0530

Hi Suneeta,

I believe you can't have direct backward compatibility between ROHCv1
and ROHCv2. Only one should exists. This problem will not exist between
feedbacks from different protocols in the same version of the ROHC
specification.

Thanks & Regards,
Biplab 

On Mon, 2008-09-08 at 04:16 -0700, Suneeta Rao wrote:
>  
> Hello ROHCers,
>  
> I have a question on changing profile from ROHCv2 to RFC3095 and vice
> versa. Please note that I only have a basic simulation environment.
>  
> When I change from ROHCv2 to RFC3095 in compressor, I am getting some
> stale feedback from the peer decompressor which was for ROHCv2.
> However, because of incompatible formats between ROHCv2 and RFC3095,
> compressor is interpreting parts of Ack no as "mode bits" of RFC 3095.
> This is being treated as a mode transition.
>  
> I'm pointing this out as this looks like a ROHC specification issue.
> In general, what is the expected behaviour if profile change is done
> from ROHCv2 to ROHCv1? How are stale packets to be handled? I haven't
> looked at other profiles, but I guess the issue might be there for TCP
> profile also.
>  
> Regards,
> Suneeta.
>  
> 
> 
>