Subject: [rohc] state machine at compressor side

From: "Vamsikrishna" <[email-masked]>
Date: Wed, 10 Sep 2008 14:33:20 +0530

Hi,
	i am a bit confused about the statment given in RFC 5225 and staement is
           "Header compression can be conceptually characterized as the
      interaction of a compressor with a decompressor state machine, one
      per context."
		Does it mean that there is no state machine at the compressor side?????

	Regarding modes, 5225 mentioned about unidirectional and bidirectional
modes only.
                        Does it mean that we don't have three modes like
		1. unidirectional.
		2. Bidirectional optimistic mode.
		3. Bidirectional reliable mode.

Thanks&Regards
Vamsi

The information contained in this electronic message and any attachments to this message are intended for the exclusive use of the addressee(s) and may contain proprietary, confidential or privileged information. If you are not the intended recipient, you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately and destroy all copies of this message and any attachments contained in it.
_______________________________________________
Rohc mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rohc

---

From: "Ghyslain Pelletier" <[email-masked]>
Date: Wed, 10 Sep 2008 13:39:55 +0200

> Does it mean that there is no state machine at 

Correct.

> Does it mean that we don't have three 

Correct.

Cheers,

///Ghyslain

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Vamsikrishna
> Sent: den 10 september 2008 11:03
> To: [email-masked]
> Subject: [rohc] state machine at compressor side
> 
> 
>    Hi,
> 	Regarding modes, 5225 mentioned about unidirectional 
> and bidirectional modes only.
> The information contained in this electronic message and any 
> attachments to this message are intended for the exclusive 
> use of the addressee(s) and may contain proprietary, 
> confidential or privileged information. If you are not the 
> intended recipient, you should not disseminate, distribute or 
> copy this e-mail. Please notify the sender immediately and 
> destroy all copies of this message and any attachments 
> contained in it.