Subject: [rohc] Doubt regarding the Static chain termination for Profile 0x004

From: Ganesh <[email-masked]>
Date: Fri, 12 Feb 2010 15:05:36 +0900

Hi All,
I have one doubt regarding the Static chain termination part for Profile No
0x004,
as per the RFC 3843

*3.1. Static Chain Termination RFC 3843*
*
compressor can choose to end the static chain at any IP header, and indicate
this by setting the MSB of the IP version field to 1 (0xC for IPv4 or 0xE
for IPv6).

as per my Understanding
1. For IPV4,
+---+---+---+---+---+---+---+---+
 LSB             | MSB
+---+---+---+---+---+---+---+---+
| Version = 4 | 0          |
+---+---+---+---+---+---+---+---+

the MSB 0 has to be replaced By 1, so it will be as below (0xC for IPv4)
+---+---+---+---+---+---+---+---+
 LSB             | MSB
+---+---+---+---+---+---+---+---+
| Version = 4 | 1          |
+---+---+---+---+---+---+---+---+

2. For IPV6.  ( 0xE for IPv6)
+---+---+---+---+---+---+---+---+
 LSB             | MSB
+---+---+---+---+---+---+---+---+
| Version = 6 | Flow Label(msb)  |
+---+---+---+---+---+---+---+---+

RFC 3843 Mentions that MSB has to be replaced by 1, how can the 4 bits of
the flow Label MSB can be changed to 1??
is my understanding correct??
can anyone clarify my doubt??

*Thanks & Regards,
Ganesh Babu Kamma

---

From: Simon Laurenz <[email-masked]>
Date: Fri, 12 Feb 2010 07:33:04 +0100

Hi Ganesh

I think you got to things wrong.  First thing is that every change  is 
made only in the Version field. This means only in the first 4 bits of 
the first byte. There the first  bit is the MSB (Most significance bit).
Thus results in the following replacement:

1. For IPv4:

*
 Version        |  IHL
**
 **MSB     **LSB |
|     0x4         |     0x5         |
|     0100       |  0101           |

becomes
*
*
 Version        |  IHL
**
 **MSB     **LSB |
|     0xC         |     0x5         |
|     1100       |  0101           |
2. For IPv6:

*
 Version        |  Flowlabel
**
 **MSB     **LSB |
|     0x6        |     0xXX        |
|     0110       |    xxxx         |
becomes
 Version        |  Flowlabel
**
 **MSB     **LSB |
|     0xE         |     0xXX       |
|     1110       |     xxxx       |
Best regards

Simon Laurenz

Ganesh wrote:
> Hi All,
> I have one doubt regarding the Static chain termination part for 
> Profile No 0x004,
> as per the RFC 3843 
>
> compressor can choose to end the static chain at any IP header, and 
> indicate this by setting the MSB of the IP version field to 1 (0xC for 
> IPv4 or 0xE for IPv6).
>
> as per my Understanding 
> 1. For IPV4,
> RFC 3843 Mentions that MSB has to be replaced by 1, how can the 4 bits 
> of the flow Label MSB can be changed to 1??
> ------------------------------------------------------------------------
>
> _______________________________________________
> Rohc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rohc
>