Subject: Re: [rohc] Doubt regarding the Static chain termination for Profile 0x004

From: "Gurushant" <[email-masked]>
Date: Thu, 4 Mar 2010 17:26:16 +0530

Hello Simon,
I have doubt related to static chain termination. The RFC 3843 ,sec 3.1
mentions that "The decompressor must store this indication in the context
for correct decompression of subsequent headers. Note that the IP version
field in decompressed headers must be restored to its original value"

May I request to elaborate more on this reference, i.e. how the subsequent
header version is restored to original value?

Thanks & Best Regards
Gurushant

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Simon Laurenz
Sent: Friday, February 12, 2010 12:03 PM
To: Ganesh; [email-masked]
Subject: Re: [rohc] Doubt regarding the Static chain termination for
Profile 0x004

Hi Ganesh

I think you got to things wrong.  First thing is that every change  is
made only in the Version field. This means only in the first 4 bits of
the first byte. There the first  bit is the MSB (Most significance bit).
Thus results in the following replacement:

1. For IPv4:

*
+---+---+---+---+---+---+---+---+
 Version        |  IHL
+---+---+---+---+---+---+---+---+
**
 **MSB     **LSB |
+---+---+---+---+---+---+---+---+
|     0x4         |     0x5         |
+---+---+---+---+---+---+---+---+
*
|     0100       |  0101           |
+---+---+---+---+---+---+---+---+
*

becomes
*
*
+---+---+---+---+---+---+---+---+
 Version        |  IHL
+---+---+---+---+---+---+---+---+
**
 **MSB     **LSB |
+---+---+---+---+---+---+---+---+
|     0xC         |     0x5         |
+---+---+---+---+---+---+---+---+
*
|     1100       |  0101           |
+---+---+---+---+---+---+---+---+
*
*
2. For IPv6:

*
+---+---+---+---+---+---+---+---+
 Version        |  Flowlabel
+---+---+---+---+---+---+---+---+
**
 **MSB     **LSB |
+---+---+---+---+---+---+---+---+
|     0x6        |     0xXX        |
+---+---+---+---+---+---+---+---+
*
|     0110       |    xxxx         |
+---+---+---+---+---+---+---+---+
*
*
*
becomes
*
*
+---+---+---+---+---+---+---+---+
 Version        |  Flowlabel
+---+---+---+---+---+---+---+---+
**
 **MSB     **LSB |
+---+---+---+---+---+---+---+---+
|     0xE         |     0xXX       |
+---+---+---+---+---+---+---+---+
*
|     1110       |     xxxx       |
+---+---+---+---+---+---+---+---+
*
*
Best regards

Simon Laurenz

Ganesh wrote:
> Hi All,
> I have one doubt regarding the Static chain termination part for
> Profile No 0x004,
> as per the RFC 3843
>
> *3.1. Static Chain Termination RFC 3843*
> *
> compressor can choose to end the static chain at any IP header, and
> indicate this by setting the MSB of the IP version field to 1 (0xC for
> IPv4 or 0xE for IPv6).
>
> as per my Understanding
> 1. For IPV4,
> +---+---+---+---+---+---+---+---+
>  LSB             | MSB
> +---+---+---+---+---+---+---+---+
> | Version = 4 | 0          |
> +---+---+---+---+---+---+---+---+
>
> the MSB 0 has to be replaced By 1, so it will be as below (0xC for IPv4)
> +---+---+---+---+---+---+---+---+
>  LSB             | MSB
> +---+---+---+---+---+---+---+---+
> | Version = 4 | 1          |
> +---+---+---+---+---+---+---+---+
>
> 2. For IPV6.  ( 0xE for IPv6)
> +---+---+---+---+---+---+---+---+
>  LSB             | MSB
> +---+---+---+---+---+---+---+---+
> | Version = 6 | Flow Label(msb)  |
> +---+---+---+---+---+---+---+---+
>
> RFC 3843 Mentions that MSB has to be replaced by 1, how can the 4 bits
> of the flow Label MSB can be changed to 1??
> is my understanding correct??
> can anyone clarify my doubt??
>
>
>
>
>
> *Thanks & Regards,
> Ganesh Babu Kamma
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> Rohc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rohc
>

_______________________________________________
Rohc mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rohc

---

From: "Gurushant" <[email-masked]>
Date: Wed, 10 Mar 2010 15:23:03 +0530

Dear All, 

Can one help on the below issue?

Thanks & Best Regards
Gurushant

Hello Simon,

Thanks & Best Regards
Gurushant

-----Original Message-----

Hi Ganesh

1. For IPv4:

*

becomes
*
*

*

Simon Laurenz

---

From: Klaus Warnke <[email-masked]>
Date: Wed, 10 Mar 2010 11:37:55 +0100

Hello Gurushant,

At Wed, 10 Mar 2010 15:23:03 +0530,
Gurushant wrote:
>> I have doubt related to static chain termination. The RFC 3843 ,sec
>> 3.1 mentions that "The decompressor must store this indication in
>> the context for correct decompression of subsequent headers. Note
>> that the IP version field in decompressed headers must be restored
>> to its original value"
>> 
>> May I request to elaborate more on this reference, i.e. how the
>> subsequent header version is restored to original value?

If you don't remenber in the decompressor context, how many IP headers
are in the chain, you could not restore the original chain. In all
other profiles it is clear, because there are at most two IP
headers. It was sufficient to remember tunnel or not. If you are
using, for example, the RTP profile, after the one/two IP headers the
RTP header must follow. So there you need no extra information in the
decompressor context. But in this profile, the count of the IP headers
is not fixed, therefore you have to remember its termination to know
where the UDP/RTP headers are following (in RTP profile).

To restore the original version value, you have to clear the MSB:

* 0xC for IPv4 back to 0x4
* 0xE for IPv6 back to 0x6

That means, you should not put the 0xC/0xE value in the version field
of the reconstructed IP header in case of decompression the last IP
header in the chain.

Was this your question?

> Gurushant

Gruss, Klaus

---

From: "Gurushant" <[email-masked]>
Date: Wed, 10 Mar 2010 16:29:41 +0530

Hello Klaus, 

Thanks, that confirms my understanding.

Thanks & Best Regards
Gurushant.

-----Original Message-----
From: Klaus Warnke [mailto:[email-masked]]
Sent: Wednesday, March 10, 2010 4:08 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [rohc] Doubt regarding the Static chain termination for
Profile0x004

Hello Gurushant,

Was this your question?

Gruss, Klaus