Subject: Re: [rohc] Errata against ROHC RFCs

From: "Koruga, Sasha M CTR SPAWARSYSCEN-PACIFIC, 58110" <[email-masked]>
Date: Wed, 2 Feb 2011 09:44:10 -0700

Hi Lars,

Is it possible to include an errata as Calle proposed here: http://www.ietf.org/mail-archive/web/rohc/current/msg05960.html
Specifically, "I would like to change the text in 6.6.11 to say 'for each IPv4 header' instead of 'for each IP header'."
That issue has been a great source of confusion for my team, and the suggested change would quell our concerns.
Thank you.

Regards,
Sasha

On Mon, Jan 31, 2011 at 4:21 AM, Lars Eggert <[email-masked]> wrote:
> Hi,
>
> several errata have been submitted against ROHC RFCs: http://www.rfc-editor.org/errata_search.php?rec_status=2&area_acronym=tsv&wg_acronym=rohc&presentation=table
>
> The TSV ADs would like to enlist the help of the RFC authors and the broader ROHC community in order to determine how to process these, i.e., which should be "verified", "held" or "rejected".
>
> Please discuss these errata on this list.
>
> Lars
>
> PS: IESG guidelines on errata handling:
>
>   In order to help you determine the correct handling for the errata
>   in step (4), the IESG has come up with a few guidelines:
>
>  1. Only errors that could cause implementation or deployment
>    problems or significant confusion should be Approved.
>
>  2. Things that are clearly wrong but could not cause an
>    implementation or deployment problem should be Hold for Document
>    Update.
>
>  3. Errata on obsolete RFCs should be treated the same as errata on
>    RFCs that are not obsolete where there is strong evidence that
>    some people are still making use of the related technology.
>
>  4. Trivial grammar corrections should be Hold for Document Update.
>
>  5. Typographical errors which would not cause any confusions to
>    implementation or deployments should be Hold for Document Update.
>
>  6. Changes which are simply stylistic issues or simply make things
>    read better should be Hold for Document Update.
>
>  7. Changes that modify the working of a protocol to something that
>    might be different from the intended consensus when the document
>    was approved should be either Hold for Document Update or
>    Rejected. Deciding between these two depends on judgment.
>    Changes that are clearly modifications to the intended consensus,
>    or involve large textual changes, should be Rejected. In unclear
>    situations, small changes can be Hold for Document Update.
>
>  8. Changes that modify the working of a process, such as changing an
>    IANA registration procedure, to something that might be different
>    from the intended consensus when the document was approved should
>    be Rejected.
>
> _______________________________________________
> Rohc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rohc
>
>

---

From: Lars Eggert <[email-masked]>
Date: Wed, 2 Feb 2011 20:11:56 +0200

Hi,

> Is it possible to include an errata as Calle proposed here: http://www.ietf.org/mail-archive/web/rohc/current/msg05960.html

yes, but not by email. See http://www.rfc-editor.org/errata.php and report it using the web form. It'll then undergo the review process.

Lars

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 3 Feb 2011 09:44:04 +0100

> yes, but not by email. See http://www.rfc-editor.org/errata.php and report it using the web form. It'll then undergo the review process.

Yeah, in the referenced mail from September 2010, Carl Knutsson said he was going to do that based on Sasha's input -- nudge, nudge.

Gruesse, Carsten

---

From: Carl Knutsson <[email-masked]>
Date: Thu, 03 Feb 2011 12:19:25 +0100

Sorry about the delay Sasha. I should have done this months ago. I will
do as soon as I pressed the send button.

cheers,

/Calle