Subject: [rohc] [Technical Errata Reported] RFC5225 (2703)

From: RFC Errata System <[email-masked]>
Date: Thu, 3 Feb 2011 04:22:00 -0800 (PST)

The following errata report has been submitted for RFC5225,
"RObust Header Compression Version 2 (ROHCv2): Profiles for RTP, UDP, IP, ESP and UDP-Lite".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5225&eid=2703

--------------------------------------
Type: Technical
Reported by: Carl Knutsson <[email-masked]>

Section: 6.6.11

Original Text
-------------
o  ip_id_behavior, one octet for each IP header in the compressible
   header chain starting from the outermost header.  Each octet
   consists of 2 bits padded with 6 MSBs of zeroes.

Corrected Text
--------------
o  ip_id_behavior_outer, one octet for each IPv4 header except the
   innermost in the compressible header chain starting from the outermost 
   header. Each octet consists of 2 bits padded with 6 MSBs of zeroes.

o  ip_id_behavior_innermost, one octet if the innermost header is an 
   IPv4 header. The octet consists of 2 bits padded with 6 MSBs of zeroes.

Notes
-----
There is no control field called ip_ip_behavior in the document. There are two control fields related to IP-ID behavior, ip_id_behavior_innermost and ip_id_behavior_outer. For IPv6, only the ip_id_behavior_innermost field exists and its value is always IP_ID_BEHAVIOR_RANDOM according to the FN. This makes it impossible to include ip_id_behavior_outer when calculating the crc for IPv6 headers. Furthermore, since the ip_id_behavior_innermost is constant it makes no sense to include it in the crc calculation.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5225 (draft-ietf-rohc-rfc3095bis-rohcv2-profiles-06)
--------------------------------------
Title               : RObust Header Compression Version 2 (ROHCv2): Profiles for RTP, UDP, IP, ESP and UDP-Lite
Publication Date    : April 2008
Author(s)           : G. Pelletier, K. Sandlund
Category            : PROPOSED STANDARD
Source              : Robust Header Compression
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

---

From: Lars Eggert <[email-masked]>
Date: Thu, 3 Feb 2011 14:52:11 +0200

Based on the ongoing discussion, I assume the community consensus is to approve this?

---

From: Carl Knutsson <[email-masked]>
Date: Thu, 03 Feb 2011 14:35:53 +0100

Lars, others,

I have had an on-list discussion with Sasha and an off-list with
Kristofer and I have come up with the suggested correction. The actual
details of the suggestion in the errata haven't been discussed. So I
would like people to review the errata. Comments from the authors would
also be appreciated.

There are three things that I'd like to point out here:

1) There is no ip_id_behavior control field in the FN of RFC 5225. Only
ip_id_behavior_innermost and ip_id_behavior_outer.

2) Not to include the control field for outer IPv6 headers is the actual
bug fix. There does not exist any ip_id_behavior_outer control field in
the FN for ipv6 (it does for ipv4).

3) Excluding the control field for the innermost IPv6 header may be
considered a change and not a correction, but since the whole business
with the ip_id_behavior is not crystal clear...

So especially number 3) is up for discussion and also my suggestion for
the Corrected Text.

cheers,

/Calle

---

From: Kristofer Sandlund <[email-masked]>
Date: Thu, 3 Feb 2011 14:26:39 +0100

Ongoing discussion? I'm no longer subscribed to the rohc list (and I'm quite sure my co-author doesn't read it either), so I don't know of anything that has been discussed there.

But I have previously discussed the below issue with Calle and I agree with his suggested update.

/Kristofer

at den 3 februari 2011 13:52, Lars Eggert wrote :
> > The following errata report has been submitted for
> > RFC5225, "RObust Header Compression Version 2 (ROHCv2):
> > Profiles for 
> RTP, UDP, IP, ESP and UDP-Lite".
> > 
> >   innermost in the compressible header chain starting
> > from 
> the outermost
> > 
> >   header. Each octet consists of 2 bits padded with 6
> > MSBs 
> of zeroes.
> > 
> > 
> > 
> >   IPv4 header. The octet consists of 2 bits padded with
> > 6 
> MSBs of zeroes.
> > 
> > Notes
> > -----
> > There is no control field called ip_ip_behavior in the
> document. There are two control fields related to IP-ID
> behavior, ip_id_behavior_innermost and
> ip_id_behavior_outer. For IPv6, only the
> ip_id_behavior_innermost field exists and its value is
> always IP_ID_BEHAVIOR_RANDOM according to the FN. This
> makes it impossible to include ip_id_behavior_outer when
> calculating the crc for IPv6 headers. Furthermore, since
> the ip_id_behavior_innermost is constant it makes no
> sense to include it in the crc calculation. 
> > 
> > Instructions:
> > -------------
> > This errata is currently posted as "Reported". If
> > necessary, please use "Reply All" to discuss whether it
> > should be verified or rejected. When a decision is
> > reached, the verifying party (IESG) can log in to
> > change the status and edit the report, if necessary. 
> > 
> > Title               : RObust Header Compression Version
> > 2 
> (ROHCv2): Profiles for RTP, UDP, IP, ESP and UDP-Lite

---

From: "Ghyslain Pelletier" <[email-masked]>
Date: Thu, 3 Feb 2011 08:58:32 -0500

Similar to Kristofer, I am also no longer subscribed to the ROHC list and no 
longer follow discussions in that forum. I also agree with the proposed 
update.

///Ghyslain

--------------------------------------------------
From: "Kristofer Sandlund" <[email-masked]>
Sent: Thursday, February 03, 2011 8:26 AM
To: "Lars Eggert" <[email-masked]>; <[email-masked]>
Cc: "David Harrington" <[email-masked]>; <[email-masked]>
Subject: RE: [Technical Errata Reported] RFC5225 (2703)

> Ongoing discussion? I'm no longer subscribed to the rohc list (and I'm 
> quite sure my co-author doesn't read it either), so I don't know of 
> anything that has been discussed there.
>