Subject: Re: [rohc] [Technical Errata Reported] RFC5225 (2703)

From: "Koruga, Sasha M CTR SPAWARSYSCEN-PACIFIC, 58110" <[email-masked]>
Date: Thu, 3 Feb 2011 09:18:46 -0700

Calle's correction looks good to me. Thank you, Calle.

-Sasha

On Thu, Feb 3, 2011 at 5:35 AM, Carl Knutsson <[email-masked]> wrote:
> Lars, others,
>
> I have had an on-list discussion with Sasha and an off-list with
> Kristofer and I have come up with the suggested correction. The actual
> details of the suggestion in the errata haven't been discussed. So I
> would like people to review the errata. Comments from the authors would
> also be appreciated.
>
> There are three things that I'd like to point out here:
>
> 1) There is no ip_id_behavior control field in the FN of RFC 5225. Only
> ip_id_behavior_innermost and ip_id_behavior_outer.
>
> 2) Not to include the control field for outer IPv6 headers is the actual
> bug fix. There does not exist any ip_id_behavior_outer control field in
> the FN for ipv6 (it does for ipv4).
>
> 3) Excluding the control field for the innermost IPv6 header may be
> considered a change and not a correction, but since the whole business
> with the ip_id_behavior is not crystal clear...
>
> So especially number 3) is up for discussion and also my suggestion for
> the Corrected Text.
>
> cheers,
>
> /Calle
>
> On 02/03/2011 01:52 PM, Lars Eggert wrote:
>> Based on the ongoing discussion, I assume the community consensus is to approve this?
>>
>> On 2011-2-3, at 14:22, RFC Errata System wrote:
>>
>>>
>>> The following errata report has been submitted for RFC5225,
>>> "RObust Header Compression Version 2 (ROHCv2): Profiles for RTP, UDP, IP, ESP and UDP-Lite".
>>>
>>> --------------------------------------
>>> You may review the report below and at:
>>> http://www.rfc-editor.org/errata_search.php?rfc=5225&eid=2703
>>>
>>> --------------------------------------
>>> Type: Technical
>>> Reported by: Carl Knutsson <[email-masked]>
>>>
>>> Section: 6.6.11
>>>
>>> Original Text
>>> -------------
>>> o  ip_id_behavior, one octet for each IP header in the compressible
>>>
>>>   header chain starting from the outermost header.  Each octet
>>>
>>>   consists of 2 bits padded with 6 MSBs of zeroes.
>>>
>>> Corrected Text
>>> --------------
>>> o  ip_id_behavior_outer, one octet for each IPv4 header except the
>>>
>>>   innermost in the compressible header chain starting from the outermost
>>>
>>>   header. Each octet consists of 2 bits padded with 6 MSBs of zeroes.
>>>
>>>
>>>
>>> o  ip_id_behavior_innermost, one octet if the innermost header is an
>>>
>>>   IPv4 header. The octet consists of 2 bits padded with 6 MSBs of zeroes.
>>>
>>> Notes
>>> -----
>>> There is no control field called ip_ip_behavior in the document. There are two control fields related to IP-ID behavior, ip_id_behavior_innermost and ip_id_behavior_outer. For IPv6, only the ip_id_behavior_innermost field exists and its value is always IP_ID_BEHAVIOR_RANDOM according to the FN. This makes it impossible to include ip_id_behavior_outer when calculating the crc for IPv6 headers. Furthermore, since the ip_id_behavior_innermost is constant it makes no sense to include it in the crc calculation.
>>>
>>> Instructions:
>>> -------------
>>> This errata is currently posted as "Reported". If necessary, please
>>> use "Reply All" to discuss whether it should be verified or
>>> rejected. When a decision is reached, the verifying party (IESG)
>>> can log in to change the status and edit the report, if necessary.
>>>
>>> --------------------------------------
>>> RFC5225 (draft-ietf-rohc-rfc3095bis-rohcv2-profiles-06)
>>> --------------------------------------
>>> Title               : RObust Header Compression Version 2 (ROHCv2): Profiles for RTP, UDP, IP, ESP and UDP-Lite
>>> Publication Date    : April 2008
>>> Author(s)           : G. Pelletier, K. Sandlund
>>> Category            : PROPOSED STANDARD
>>> Source              : Robust Header Compression
>>> Area                : Transport
>>> Stream              : IETF
>>> Verifying Party     : IESG
>>
>
> _______________________________________________
> Rohc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rohc
>

---

From: rstangarone-ietf <[email-masked]>
Date: Thu, 03 Feb 2011 20:59:08 -0800

I've also discussed this with Sasha offline, I'll take a look at the
errata again and give you some input shortly.

Bob

On 02/03/2011 08:18 AM, Koruga, Sasha M CTR SPAWARSYSCEN-PACIFIC, 58110