Subject: [rohc] MPTCP and ROHC

From: "Border, John" <[email-masked]>
Date: Sun, 8 Sep 2019 14:25:49 +0000

Does ROHC work with MPTCP?

John

---

From: Yoshifumi Nishida <[email-masked]>
Date: Thu, 12 Sep 2019 00:46:16 -0700

Hi John,
Do you mean whether we can compress MPTCP options with ROHC or just MPTCP
won't break ROHC?
--
Yoshi

On Sun, Sep 8, 2019 at 7:26 AM Border, John <[email-masked]> wrote:

> _______________________________________________
> multipathtcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multipathtcp
>

---

From: "Border, John" <[email-masked]>
Date: Thu, 12 Sep 2019 20:11:23 +0000

The latter.

From: Yoshifumi Nishida <[email-masked]>
Sent: Thursday, September 12, 2019 3:46 AM
To: Border, John <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [multipathtcp] MPTCP and ROHC

CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you recognize the sender and know the content is safe.
Hi John,
Do you mean whether we can compress MPTCP options with ROHC or just MPTCP won't break ROHC?
--
Yoshi

On Sun, Sep 8, 2019 at 7:26 AM Border, John <[email-masked]<mailto:[email-masked]>> wrote:

John

_______________________________________________
multipathtcp mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/multipathtcp<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_multipathtcp&d=DwMFaQ&c=dIKa1mMv92xhhFzVXv5A3Q&r=9F44ji63_2hvW5HufmlpP-DFKXuFy4jDtL5PXwKlTqg&m=r8FoosS9r5k8j4FLwQ_iuAeeuWLM7tRjWDDnCADTVGM&s=YO-lkzCO6o1DwCPEXY54s5u8wQcJwhe2aWqzIdiU5PQ&e=>

---

From: "West, Mark" <[email-masked]>
Date: Thu, 12 Sep 2019 20:43:57 +0000

It’s been a long time, but… ROHC-TCP should work with MPTCP (although I’ve never tested it). ROHC can handle ‘generic’ TCP options (i.e. those for which there’s no optimised  compressor  behaviour; that would include all MPTCP options) and in other respects should be transparent: if a header field changes in an unexpected way, the compressor will end up sending a less efficient (or even uncompressed) representation. So I haven’t thought about the implications for the compression ratio – but it shouldn’t break.

Mark.

From: Rohc [mailto:[email-masked]] On Behalf Of Border, John
Sent: 12 September 2019 21:11
To: Yoshifumi Nishida
Cc: [email-masked]; [email-masked]
Subject: Re: [rohc] [multipathtcp] MPTCP and ROHC

The latter.

Hi John,

John

---

From: Yoshifumi Nishida <[email-masked]>
Date: Fri, 13 Sep 2019 00:35:52 -0700

+1.
I think the only difference between MPTCP packets and non-MPTCP TCP packets
is MPTCP option.
Also, MPTCP option should be no less than another kind of TCP option.
if there's any concerns on this, it'll be an interesting point for
discussions.
--
Yoshi

On Thu, Sep 12, 2019 at 1:44 PM West, Mark <[email-masked]> wrote:

>
>
> It’s been a long time, but… ROHC-TCP should work with MPTCP (although I’ve
> never tested it). ROHC can handle ‘generic’ TCP options (i.e. those for
> which there’s no optimised  compressor  behaviour; that would include all
> MPTCP options) and in other respects should be transparent: if a header
> field changes in an unexpected way, the compressor will end up sending a
> less efficient (or even uncompressed) representation. So I haven’t thought
> about the implications for the compression ratio – but it shouldn’t break.
>
>
>
> Mark.
>
>
>
>
>
> <https://www.dsei.co.uk/welcome>
>
> Follow Us: LinkedIn <http://www.linkedin.com/company/roke-manor-research>
> | Twitter <https://twitter.com/rokemanor> | Facebook
> <https://www.facebook.com/rokemanor>
>
> Roke Manor Research Limited, Romsey, Hampshire, SO51 0ZN, United Kingdom.
> Part of the Chemring Group. Registered in England & Wales. Registered No:
> 00267550. The information contained in this e-mail and any attachments is
> proprietary to Roke Manor Research Limited and must not be passed to any
> third party without permission. This communication is for information only
> and shall not create or change any contractual relationship.
> www.roke.co.uk
> <http://www.roke.co.uk/?utm_source=Roke&utm_medium=Email&utm_content=Company%20Signature&utm_campaign=Roke>
> ------------------------------
>
> *From:* Rohc [mailto:[email-masked]] *On Behalf Of *Border, John
> *Sent:* 12 September 2019 21:11
> *To:* Yoshifumi Nishida
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: [rohc] [multipathtcp] MPTCP and ROHC
>
>
>
> The latter.
>
>
>
> *From:* Yoshifumi Nishida <[email-masked]>
> *Sent:* Thursday, September 12, 2019 3:46 AM
> *To:* Border, John <[email-masked]>
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: [multipathtcp] MPTCP and ROHC
>
>
>
> *CAUTION:* This email originated from outside of the organization. Do not
> click links or open attachments unless you recognize the sender and know
> the content is safe.
>
> Hi John,
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_multipathtcp&d=DwMFaQ&c=dIKa1mMv92xhhFzVXv5A3Q&r=9F44ji63_2hvW5HufmlpP-DFKXuFy4jDtL5PXwKlTqg&m=r8FoosS9r5k8j4FLwQ_iuAeeuWLM7tRjWDDnCADTVGM&s=YO-lkzCO6o1DwCPEXY54s5u8wQcJwhe2aWqzIdiU5PQ&e=>
>
>