Subject: [Roll-bier-dt] Fwd: Bier interim in January

From: Peter van der Stok <[email-masked]>
Date: Thu, 08 Nov 2018 14:14:34 +0700

Hi all, 
This is to remind you that an interim was proposed in Nice (with support
from Pascal) in the month of January.
Please have a look at your agenda to see when this is feasible.
In the limit we might organize a wild weekend (with partners welcome).

Peter 
-- 
Peter van der Stok
vanderstok consultancy
mailto: [email-masked], [email-masked]
www: www.vanderstok.org [1]
tel NL: +31(0)492474673     F: +33(0)966015248 

Links:
------
[1] http://www.vanderstok.org

---

From: Tony Przygienda <[email-masked]>
Date: Thu, 8 Nov 2018 14:15:19 +0700

I can really only make it after 2nd, best last Jan week ...

On Thu, Nov 8, 2018 at 2:14 PM Peter van der Stok <[email-masked]>
wrote:

> www: www.vanderstok.org
> _______________________________________________
> Roll-bier-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll-bier-dt
>

---

From: Greg Shepherd <[email-masked]>
Date: Mon, 12 Nov 2018 10:52:22 -0800

Jan works for me.

On Wed, Nov 7, 2018 at 11:16 PM Tony Przygienda <[email-masked]> wrote:

> I can really only make it after 2nd, best last Jan week ....
>

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 13 Nov 2018 04:52:32 +0100

January in europe would in general work well for me to, i just need to figure out
the exact timing of one other event in januar before i know my exact availability.

Whats a good tool to inquire - doodle is at hour level... Maybe just use it
but only owrry about the days ?

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Alvaro Retana <[email-masked]>
Date: Tue, 13 Nov 2018 01:36:57 -0500

Hi!

Process/terminology question:  we’re talking about a DT meeting, not a WG
Interim (maybe focused on roll-bier), right?

I’m ok with either.

If we’re talking about a physical WG interim, then there are time frames we
need to keep an eye on.  Specifically, we need to make a formal
announcement at least 4 weeks in advance.

> In the limit we might organize a wild weekend (with partners welcome).

Thanks!

Alvaro.

---

From: Peter van der Stok <[email-masked]>
Date: Tue, 13 Nov 2018 09:50:42 +0100

HI Alvaro,

It is originally a DT meeting.
What is the subtle difference between interim and dt meeting, both in
the context of IETF ROLL/ BIER

Peter
Alvaro Retana schreef op 2018-11-13 07:36:

> Hi! 
> 
> Process/terminology question:  we're talking about a DT meeting, not a WG Interim (maybe focused on roll-bier), right? 
> 
> I'm ok with either.   
> 
> If we're talking about a physical WG interim, then there are time frames we need to keep an eye on.  Specifically, we need to make a formal announcement at least 4 weeks in advance.
> On November 8, 2018 at 3:14:34 PM, Peter van der Stok ([email-masked]) wrote:
> 
>> Hi all, 
>> This is to remind you that an interim was proposed in Nice (with support from Pascal) in the month of January.
>> tel NL: +31(0)492474673     F: +33(0)966015248 _______________________________________________ 

Links:
------

---

From: Alvaro Retana <[email-masked]>
Date: Tue, 13 Nov 2018 04:14:16 -0500

> It is originally a DT meeting.
Ok, that’s what I thought.

> What is the subtle difference between interim and dt meeting, both in the
> context of IETF ROLL/ BIER
>
The difference is simply who is expected to be there and whether it needs
to be advertised beyond this mailing list or not.

The DT is free to meet whenever you want — just coordinate among yourselves
and that’s it.

A WG Interim is just like a meeting at the IETF, where the whole WG is
expected to know  about the details and participate.  The only difference
with respect to a meeting at the IETF is that it is somewhere else, either
virtual (WebEx, Zoom, etc.) or in-person.  This one we have to advertise to
the whole WG, provide remote access, etc..

Alvaro.

> Process/terminology question:  we're talking about a DT meeting, not a WG
> If we're talking about a physical WG interim, then there are time frames
> we need to keep an eye on.  Specifically, we need to make a formal

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 13 Nov 2018 10:30:18 +0100

I think we shuold be fine to organize it as a meeting of the BIER DT
indicating that WG members not interested in this set of work items
should not have to be present.

We should still announce it to the WG and make sure attendence is open,
we set up the IETF ROLL webex during the interim to enable remote
access and share slides on it during the meeting. Also the rooms
handsfree we have work quite well for remote participants.

I only attended on in-person interim, which was a BIER interim
in hmm... end of 2016 in San Jose, and it was a WG interrim, but
i think all the technical aspects where as described above.

Aka: no big different except the official scope and maybe any other
official WG interim procedural aspects alvaro would remind us of as
necessary.

Cheers
    Toerless

On Tue, Nov 13, 2018 at 04:14:16AM -0500, Alvaro Retana wrote:
> Ok, that???s what I thought.
> 
> The DT is free to meet whenever you want ??? just coordinate among yourselves
> and that???s it.
> 

-- 
---
[email-masked]

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 14 Nov 2018 00:49:25 +0000

I created a doodle, 

please indicate any day you could be there: https://doodle.com/poll/a4qc62fvyw82sk4u 
I can have a room with roughly 15 people, maybe a few more. But I need to get the date early to reserve the room while it is available.
Then we'll decide how many days ina row we need, and whether we wish to be contiguous to a week end so you guys can enjoy the sea of the ski.
Take care,

Pascal

> -----Original Message-----
> From: Roll-bier-dt <[email-masked]> On Behalf Of Toerless
> Eckert
> Sent: mardi 13 novembre 2018 16:30
> To: Alvaro Retana <[email-masked]>
> Cc: Peter van der Stok <[email-masked]>; [email-masked];
> [email-masked]
> Subject: Re: [Roll-bier-dt] Fwd: Bier interim in January
> 
> I think we shuold be fine to organize it as a meeting of the BIER DT indicating
> that WG members not interested in this set of work items should not have to
> be present.
> 
> We should still announce it to the WG and make sure attendence is open, we
> set up the IETF ROLL webex during the interim to enable remote access and
> share slides on it during the meeting. Also the rooms handsfree we have work
> quite well for remote participants.
> 
> I only attended on in-person interim, which was a BIER interim in hmm... end
> of 2016 in San Jose, and it was a WG interrim, but i think all the technical
> aspects where as described above.
> 
> Aka: no big different except the official scope and maybe any other official WG
> interim procedural aspects alvaro would remind us of as necessary.
> 
> Cheers
>     Toerless
> 
> > > What is the subtle difference between interim and dt meeting, both
> > > in the context of IETF ROLL/ BIER
> > >
> > The difference is simply who is expected to be there and whether it
> > needs to be advertised beyond this mailing list or not.
> >
> > The DT is free to meet whenever you want ??? just coordinate among
> > yourselves and that???s it.
> >
> > expected to know  about the details and participate.  The only
> > difference with respect to a meeting at the IETF is that it is
> > somewhere else, either virtual (WebEx, Zoom, etc.) or in-person.  This
> > one we have to advertise to the whole WG, provide remote access, etc..
> >
> > Alvaro.
> >
> > >
> > >
> > > Peter
> > >
> > > Process/terminology question:  we're talking about a DT meeting, not
> > > a WG Interim (maybe focused on roll-bier), right?
> > >
> > > I'm ok with either.
> > >
> > > If we're talking about a physical WG interim, then there are time
> > > frames we need to keep an eye on.  Specifically, we need to make a
> > > formal announcement at least 4 weeks in advance.
> > >
> > >> This is to remind you that an interim was proposed in Nice (with
> > >> support from Pascal) in the month of January.

---

From: IJsbrand Wijnands <[email-masked]>
Date: Wed, 14 Nov 2018 09:14:43 +0100

Hi Folks,

Is there already an agenda of topics and/or goals set for the interim? 

Thx,

Ice. 

> On 14 Nov 2018, at 01:49, Pascal Thubert (pthubert) <[email-masked]> wrote:
> 
> I created a doodle, 
>

---

From: Peter van der Stok <[email-masked]>
Date: Wed, 21 Nov 2018 17:12:14 +0100

Hi BIER addicts,

Could you please response to the doodle proposed by Pascal,
He needs to reserve the room in time.
So, a response before the end of this week will be really appreciated.

Can you indicate whether you want to make use of the weekend before or
after the meeting?

Many thanks,

peter

Pascal Thubert (pthubert) schreef op 2018-11-14 01:49:

> On Tue, Nov 13, 2018 at 04:14:16AM -0500, Alvaro Retana wrote: On November 13, 2018 at 4:50:42 PM, Peter van der Stok
> ([email-masked])
> wrote:
> 
> HI Alvaro,
> 

--
---
[email-masked]

Links:
------

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 21 Nov 2018 17:40:17 +0100

On Nov 21, 2018, at 17:12, Peter van der Stok <[email-masked]> wrote:
> 
> Can you indicate whether you want to make use of the weekend before or after the meeting?

“Make use” = “vacation with spouse” or “use the meeting room”?

Grüße, Carsten

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 21 Nov 2018 17:00:07 +0000

The meeting room is at the office so I do not plan to access it over the week end.
So I think Peter means enjoying the week end with whomever you want in the French Riviera : )

Pascal

> From: Roll-bier-dt <[email-masked]> On Behalf Of Carsten
> Bormann
> Sent: mercredi 21 novembre 2018 17:40
> To: peter van der Stok <[email-masked]>
> Cc: Pascal Thubert (pthubert) <[email-masked]>; Toerless Eckert
> <[email-masked]>; [email-masked]; Alvaro Retana
> <[email-masked]>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 21 Nov 2018 23:38:08 +0100

> So I think Peter means enjoying the week end with whomever you want in the French Riviera : )

Well, I wouldn’t mind.
Spouse opted out, though (last few weeks of term leave little time even on the weekends), so it will be just me.

Grüße, Carsten

---

From: Tony Przygienda <[email-masked]>
Date: Mon, 26 Nov 2018 08:28:45 -0800

looked @ my ageand, I won't be able to be there, will probably dial in

--- tony

On Wed, Nov 21, 2018 at 8:12 AM Peter van der Stok <[email-masked]>
wrote:

> I can have a room with roughly 15 people, maybe a few more. But I need to
> get the date early to reserve the room while it is available.
> Then we'll decide how many days ina row we need, and whether we wish to be
> contiguous to a week end so you guys can enjoy the sea of the ski.
> Take care,
>
> Pascal
>
> indicating
> official WG

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 28 Nov 2018 17:25:15 +0100

Ice

Excellent question. I think the answer right now is no, but maybe here
is how we could proceed:

a) Lets first determine what the next step is in the documents for
   roll-bier that we want to achieve by IETF104.

   Ines was suggesting that we should consider a high-level overview
   draft, for example reformatting into draft form what we had worked
   out in slides and the etherpad in the design team. Primarily goal
   would be to set the stage for the set of required followup documents
   specifying the solution.

   I could take a stab at that, but maybe good parts of this should come
   fro pascals document, e.g.: splitting up the informational parts from
   the normative parts and extending on the informational ones .. ?

   And then fesible next steps for the drafts specifying the solution.
   Right now the primary documents existing are the one from pascal
   and carsten, so i would like their input for how they could see 
   those documents evolve until 104.

   Please chime in if this is the right goal, and if so, what it should
   entail.

b) Any form of meetings - webex or in-person until IETF104 to achieve a)
   would be fine. If the authors of the docs in a) for example think
   they can get the work done better meeting in person, then let's do
   that. From the doodle we also know who has time when.

c) Ines was suggesting to consider taking the friday @IETF104 to
   continue this work in case the friday will be handled again as it was
   @IETF103 - but we both did not know if that is the plan. Does anyone
   know ?

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Alvaro Retana <[email-masked]>
Date: Wed, 28 Nov 2018 11:53:50 -0800

On November 28, 2018 at 11:25:19 AM, Toerless Eckert ([email-masked]) wrote:

c) Ines was suggesting to consider taking the friday
<http://airmail.calendar/2018-11-30 12:00:00 EST> @IETF104 to
continue this work in case the friday <http://airmail.calendar/2018-11-30
12:00:00 EST> will be handled again as it was
@IETF103 - but we both did not know if that is the plan. Does anyone
know ?

I do. ;-)

No, we won’t do the same thing.  We will have a "full day" of sessions on
Friday — probably ending between 1-4pm.

The IESG is considering experimenting with unstructured time on a different
day of the week.

Alvaro.

---

From: Alvaro Retana <[email-masked]>
Date: Wed, 28 Nov 2018 12:00:10 -0800

Just a high-level comment/question…. Off topic...

I’m hoping that "to set the stage for the set of required followup
documents specifying the solution” means that the informational document(s)
will most likely serve their purpose as inspiration for the solution
only…and not be published as RFCs.  Is that the intent?  Or is the intent
to publish that as requirements, framework, or whatever-else RFCs…and
*later* work on solutions?

I realize that without knowing the specific content of those document it
may be hard to provide a definite answer…so I’m just looking for intent at
this point.

Thanks!

Alvaro.

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 28 Nov 2018 21:02:26 +0100

Thanks Alvaro

So we can tentatively consider to have additional time beyond the WG
for work on roll-bier-dt during IETF week, just not on the friday. Makes
sense.

Cheers
    Toerless

On Wed, Nov 28, 2018 at 11:53:50AM -0800, Alvaro Retana wrote:
> No, we won???t do the same thing.  We will have a "full day" of sessions on
> Friday ??? probably ending between 1-4pm.
> 

-- 
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 28 Nov 2018 22:39:27 +0100

sorry i this is a rant, but your email reads a bit
like pushing one of my buttons where i am somewhat sensitive.

In anima i had to live through the ADs asking just to have specs
to implement, only that later on in WG and IESG review more
and more questiosn where asked for the sepcs to become more
explanational by reviewers because they didn't understand thre
functionality just from the specification part and so we ended
up with humunguous spec drafts because we where asked not to
publish arch documents.

I don't think we need to sequentialize explaining the framework
and working on the specification of its components. Ideally,
we can start with just enough of an outline of a framework so
that we can agree on the resulting component specifications and
start those quickly.Wwe continue to add explanations to the component
framework doc while we are working on the specs, therefore allowing
to keep the specs crisp but also have a vehicle to deliver better
explanations.

To also give my  classic reference: I would have never understood
RFC2362 and its revisions of the followind decades if there wouldn't
have been draft-ietf-idmr-pim-arch, and i think its a big failure of
the IETF to not have published that as an RFC. But then again, i
was back then not in the role of the three author/implementers of
the PIM-SM spec, but in the role of an operator of PIM-SM.

Cheers
    Toerless

On Wed, Nov 28, 2018 at 12:00:10PM -0800, Alvaro Retana wrote:
> Just a high-level comment/question???. Off topic...
> 
> I???m hoping that "to set the stage for the set of required followup
> documents specifying the solution??? means that the informational document(s)
> only???and not be published as RFCs.  Is that the intent?  Or is the intent
> to publish that as requirements, framework, or whatever-else RFCs???and
> may be hard to provide a definite answer???so I???m just looking for intent at
> this point.
> 
> Thanks!
> 
> Alvaro.
> 
> 

-- 
---
[email-masked]

---

From: Alvaro Retana <[email-masked]>
Date: Wed, 28 Nov 2018 13:49:48 -0800

Toerless:

I am not a fan of publishing stand-alone framework/requirements/use cases.
But as I said before, without knowing the specific contents of the
documents it is not easy to provide a one-size-fits-all answer.

I’m asking early so we don’t end up in the situation you mention below and
we are in sync.  There are many ways to go about documenting the support
material…not all of them end up as RFCs…but also we don’t need to end up in
not publishing something that is needed/important/valuable.

Let’s just keep that in mind going forward…

Thanks!

Alvaro.

On November 28, 2018 at 4:39:30 PM, Toerless Eckert ([email-masked]) wrote:

Cheers
Toerless

-- 
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 28 Nov 2018 22:54:54 +0100

> I am not a fan of publishing stand-alone framework/requirements/use cases.

I hope my explanation made it clear that this should not be the goal.
If you think that how i outlined it makes sense, let me know, or how
you think it should be changed. Overall i just think there is limited
interest to work on things not getting published as RFCs.

> documents it is not easy to provide a one-size-fits-all answer.

I think what we need should be similar to what we have in some of the
explanations in Pascals document and the IETF103 slides i did.

> I???m asking early so we don???t end up in the situation you mention below and
> material???not all of them end up as RFCs???but also we don???t need to end up in

See above. I would like not do do throwaway work, and you let me know
if you think if drafts not becoming RFC are throwaway. If you don't
think they are, then please tell me who still knows
draft-ietf-idmr-pim-arch

> Let???s just keep that in mind going forward???

Sure
 
Cheers
    Toerless

-- 
---
[email-masked]

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 29 Nov 2018 07:28:00 +0000

I’m with Toerless here

I think the IETF benefits a lot from architecture documents. We are publishing the DetNet one and last calling the 6TiSCH one at this very moment while going through the pains of missing one at LPWAN. Note that both will be published as std track.

The value of publishing those is many fold:

- provides a std track reference for the WG std documents allowing them to concentrate on their protocol as opposed to spending efforts on the bigger picture.

- provides an entry point to the WG context for new comets and external bodies. E.g., IEC needs to refer DetNet in general before digging in specific methods to be inherited from RFC blah

- position the RFCs from this WG vs other WGs and possibly SDOs such as IEEE. In this efforts some major bugs, overlap or gaps can be isolated and solved.

Note the this discussion does not concern problem statement and requirements drafts. For those there can be other ways. In RFC 8505 I just inserted the rewards draft text in appendix.

All the best,

Pascal

> Le 28 nov. 2018 à 22:55, Toerless Eckert <[email-masked]> a écrit :
>

---

From: Peter van der Stok <[email-masked]>
Date: Thu, 29 Nov 2018 10:19:45 +0100

Hi all,

My very practical 2 cents.

Reading the solutions and the requirements space as outlined by Pascal,
Carsten and Toerless, I don't think
that just giving a spec of the final chosen solution will suffice.

Having written that , I have no clue about the size of the needed
explanations.

So, I would consider that an architecture document is necessary at this
stage as a WG document.
How this document ends up in appendices or merits a STD RFC will become
clear during the evolution of the design (size of the text).

Peter
Pascal Thubert (pthubert) schreef op 2018-11-29 08:28:

> I'm with Toerless here
> documents specifying the solution??? means that the informational document(s) will most likely serve their purpose as inspiration for the solution
> may be hard to provide a definite answer???so I???m just looking for intent at this point.
> 
> Thanks!
> 
> Alvaro.
> 

-- 
---
[email-masked]