Subject: [Roll] DIO option for compression context

From: "Turner, Randy" <[email-masked]>
Date: Wed, 23 Sep 2015 13:57:34 +0000

Hello All,

At the Prague plenary, during the 6lo session, a number of ROLL participants suggested that a multicast DIO option might be better suited for dissemination of RFC 6282 compression context information as an alternative to RFC 6775 - rather than use DHCPv6 for values that are not "node-specific" but apply to all nodes on the network.

The attached document re-states the option in the form of a DIO option and references RFC 6775 section 7.2 for context lifecycle management.

This document would be categorized as experimental.

I was looking for comments from the ROLL group on this preliminary text (as this is a DIO option proposal) prior to finalizing the text and submitting as a draft.

Thanks!
Randy

P PLEASE CONSIDER OUR ENVIRONMENT BEFORE PRINTING THIS EMAIL.

This e-mail (including any attachments) is confidential and may be legally privileged. If you are not an intended recipient or an authorized representative of an intended recipient, you are prohibited from using, copying or distributing the information in this e-mail or its attachments. If you have received this e-mail in error, please notify the sender immediately by return e-mail and delete all copies of this message and any attachments. Thank you.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 23 Sep 2015 16:18:52 +0000

Hello Randy:

This is good work and I think it needs to be pursued

I see that you omitted the lifetime in the option (comparing to RFC 6775). Why is this so?

Section 5 should mention that the option is propagated as is. If it is not needed in all DIOs then you could indicate when to send it. This could be for instance trickled upon a change and placed in responses to DIS messages.

Cheers,

Pascal

From: Roll [mailto:[email-masked]] On Behalf Of Turner, Randy
Sent: mercredi 23 septembre 2015 15:58
To: [email-masked]
Subject: [Roll] DIO option for compression context

Hello All,

Thanks!
Randy