Subject: AW: AW: Differentiated Routing, not only plain rambo-SPF

From: Hummel Heinrich <[email-masked]>
Date: Wed, 14 Aug 2002 14:47:24 +0200

Let's assume there are two Smallest Size Tree road systems X1 and X2. X2 detours/avoids the kernel links of X1.
For some source/destination node pair the total pathes may be different. Or only the section in the middle is different.
Or only a section close to the source (or close to the dest.) is different. Whatever applies:
From the point of congestion on road system X1 the packet my crankback (hereby source and dest. address are swapped)
to that first node which is also part of X2.
There  source and dest. address are swapped again,  DSCP-X1 is replaced by DSCP-X2 and the packet is  moved forward 
via X2.

Heinrich

-----Ursprüngliche Nachricht-----
Von: shen jing [mailto:[email-masked]]
Gesendet: Mittwoch, 14. August 2002 14:21
An: [email-masked]
Cc: 'Hummel Heinrich'; [email-masked]'
Betreff: Re: AW: Differentiated Routing, not only plain rambo-SPF

The discussion you mentioned is that of congestion removement by e2e
mechanism  or by routing. Professor Crowcroft proposed a method
named ECN++ which trigger a new path that acts when ECN bit is set 
in packet header.

> 
> Heinrich,
> 
> -> yes,it is similar;
> -> but here it is about state-less IP forwarding, i.e. about
> -> forwarding the individual IP packets, without any
> -> RSVP path and without any MPLS path.
> 
>   Oh! Ok...you would like to do Crankback in
>   connection less IP environments?!?
> 
>   In such a case, you might find below paper interesting:
> http://www.ecse.rpi.edu/Homepages/shivkuma/research/papers/te-latest.pdf
> 
>   There was some discussion in E2E list regarding
>   pros & cons of this approach. I couldn't find the URL
>   but I vaguely remember that the subject of the discussion
>   is "EC++N" or something like that...
> 
> --
> Venkata
> 
> _______________________________________________
> routing-discussion mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/routing-discussion

-- 
Jing Shen

State Key Lab of CAD&CG
ZheJiang University(YuQuan)
HangZhou, Z.J. 310027
P.R.China

Tel: +86-571-87932423
Mobile: (0)13516813753
Email: [email-masked]

**********************************************************************
* The SunShine of life is made up of very little beams which is      *
*  bright all the time                                               *
**********************************************************************

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: shen jing <[email-masked]>
Date: Wed, 14 Aug 2002 22:03:17 +0800

Hummel,

the crankback could be assumed, but the difficulty exists with when it
is triggered.

No matter how the two trees are estabilished, the network traffic is
shown to be 
self-similar, and with the increase of bandwidth*delay burst traffic
occurs frequently.

If a router react to transient overload, there may be a huge burden on
dealing with such 
operations. So, I think this mechanism may be adpoted for broken links
but not for congestion.

-- 
Jing Shen

State Key Lab of CAD&CG

Tel: +86-571-87932423
Mobile: (0)13516813753

---

From: shen jing <[email-masked]>
Date: Wed, 14 Aug 2002 22:03:17 +0800

Hummel,

-- 
Jing Shen

State Key Lab of CAD&CG

Tel: +86-571-87932423
Mobile: (0)13516813753