Subject: AW: Differentiated Routing, not only plain rambo-SPF

From: Hummel Heinrich <[email-masked]>
Date: Mon, 5 Aug 2002 11:05:51 +0200

From  [MPLS-OPS]: MPLS Debacle back to [routing-discussion]:Differentiated Routing, not only plain rambo-SPF

Senthil,
This email of yours as well as your previous one only confirms my statement, that
the entire Internet community  (or at least you and some others) is the prisoner of this rambo-SPF routing algorithm.
All the protocols you have enlisted (...,BW inversion SP,...PNNI,..) and let me also add
the reverse SPF in some multicast models, share this egocentric  SPF view.

I am    N O T     talking just another brand of rambo-SPF.

Also, it wouldn't be helpful to follow your advice (come up with requirements, application statements,...)
because if I did you would read all of it with your SPF-centric view in mind. You even do so now, after
I have explained how each router may aquire the identical view of some road system.

Another analogy: 
When you fly to some meeting place, you may get a flyer-map at the hotel concierge. The flyer-maps may be the same
no matter at which hotel you stay. But, eventually, they have a different "You are Here" markation depending on
the specific hotel. I am looking at the propagated road systems by a commonly shared view first, then I respect the
different "you are here" markation. Rambo-SPF however means:"I am here.I see the world only from my point of view."
Taking into consideration any kind of constraints and whichever weights doesn't change anything of this egocentric
view + behavior with all its disadvantages.

Heinrich

-----Ursprüngliche Nachricht-----
Von: senthil ayyasamy [mailto:[email-masked]]
Gesendet: Samstag, 3. August 2002 09:40
An: venumadhav josyula; Hummel Heinrich;
[email-masked]'; [email-masked]
Cc: Andrew Walding; [email-masked]; [email-masked]
Betreff: Re: AW: [MPLS-OPS]: MPLS Debacle

> See how many
> QoS
> > routing schemes were proposed, researched and not
> > deployed. See what is the problem with those
> routing
> > Variants and then suggest differential routing
> > Scheme.
> >
> Ok tell me why would not such a scheme work?
Where I mentioned  *differential routing* wont
work. Proposing new ideas are always easy. Let me 
illustrate with an example.

SPF+ variants of SP algo (widest SP, shortest widest
bandwidth path, bw inversion SP, ...)+ optimal
multipath+source routing+ loose source routing+
explicit paths (MPLS)+ k-shortest path and its
variants+QoS routing( load sensitive,delay sensitive,
single metric based,multi-metric based) +OSPF
extensions+ all dynamic routing schemes as mentioned 
in Ash book+PNNI + all frame relay and other type of
routing+ MPLS based (constrianed or whatever)+ overlay
based routing+ onion routing+hot potato+ cold potato
routing+...

I have listed a *few* unicast routing schemes. I can
list more routing Schemes taking multicast, any cast
into picture... leave alone ad-hoc, host mobility,
network mobility, topology independent ...so on..

Most of the above routing schemes are subsets of some
of the listed schemes. So suggesting a new routing
scheme is not a big work. Using a simple combination
and taking  some new technologies into picture, one
can come up with a new routing scheme. But frankly
that's not a correct approach for any protocol
developed in IETF.

You should exactly come up with:
- Requirements
- Applicability statement
- What problems the current schemes did not solve
which lead you to suggest the present routing scheme.
- What is the over-head when compared to the other
existing technologies??? Usegood simulation to prove
them.
- A theoretical model to prove its use by means of
routing problem formulations
- Some case studies.
- Study their properties (scalability, flexibility and
extendibility.)
- What all places it is most useful or waste
(inter-domain or intra-domain)
- Does it conform with the architectural principle
(this is important: e.g.. Scalability alone is not the
reason for intserv non-usage. It did not work within
boundaries (AS.) alone.It can transcend an autonomous
system boundary and so policy cannot be maintained.
Hence, it did not support the business models well.) 

Now come to IETF. Give an engineering perspective to
your routing scheme. Convince vendors to implement
your routing scheme.

It is sometimes unfortunate that people just come up
with some X routing scheme and try to convince
engineering folks. Some of the IETF works was just
proposals and hence did not succeed or gave problems
at the later stage. So do all the above work for your
new scheme and then everyone will accept your
proposal.

Read the below book on how well the author approach
such new schemes. 
 *G. R. Ash. Dynamic Routing in Telecommunications
Networks. McGraw Hill, New York, 1998*
This is the book, which introduced dynamic routing
schemes. It is not just bunch of ideas but has a
in-depth analysis of requirements and theory.

> CSPF (Constraint based shortest path) which is a
> kind
> of differential routing. I have some discussion in
> this thread itself on that respect. 
> Constraint based routing is modification of shortest
> path alo to account for contraints such as (BW ,
> QOS,
> policy). 

I accept this scheme. There are simulation and
mathematical work to see its behavior. But what it
lacks is *deployment* which we cannot help.
There might be lot of operational and business policy
factors associated.

> CSPF solution is quite popular many are implementing
> it , but I am not sure deployment and
> interoperatablity concerns......... CSPF answers QOS
> routing concerns (correct if i am wrong). It is not
> the all of the mechanims proposed are failure.......

Note: I could not resist and hence replied. But if
your care to respond to this mail, reply to general
routing discussion than MPLS list.

__________________________________________________
Do You Yahoo!?
Yahoo! Health - Feel better, live better
http://health.yahoo.com

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: Jon Crowcroft <[email-masked]>
Date: Mon, 05 Aug 2002 10:42:03 +0100

In message <EF8E39AA846CD411BB9C00508B951F510514B977@MCHH267E>, Hum
mel Heinrich typed:

 >>the entire Internet community  (or at least you and some others) 
 >>is the prisoner of this rambo-SPF routing algorithm.

there is no Internet community except in the perception of
individuals, which is quite amusing, as the "egocentric"
model of SPF you (nicely) outline is the chief
characteristic of the viewpoint that perceives the existence
of the mythical Internet community....

in the meantime, i happen to agree - i think that some form
of cooperative path computation strategy 
( e.g.  diffusive computational nash game, or
epidemic/gossip tabu search, or whathave you) might yield
more novel solutions than incremental techniques rooted in
the 35 year old stuff we've (oops, s/we/me) tended to get
stuck on....

one thing we need to do is think global - looking at
mean to peak traffic measurements now widely available, 
it behoves us to consider flipping traffic either way around 
the planet based on diurnal variations in load...as well
as looking at the tier 1 and tier 2 queueing delays, it
looks like we could consider starting to approximate a
large part of pathset computation using
geographic based schemes to seperate out capacity and
propagation-contribs to latency, from availability and load

s/d-ijk-stra/d-xyz-stra/

cheers
jon

---

From: Jon Crowcroft <[email-masked]>
Date: Mon, 05 Aug 2002 10:42:03 +0100

s/d-ijk-stra/d-xyz-stra/

cheers
jon