Subject: AW: Differentiated Routing, not only plain rambo-SPF

From: Hummel Heinrich <[email-masked]>
Date: Mon, 12 Aug 2002 17:02:57 +0200

Jing,
Let me recapture and use the following DSCPs: 
DSCP-Gold-1st, DSCP-Gold-2nd, DSCP-Silver-1st,DSCP-Silver-2nd,DSCP-Bronze-1st,DSCP-Bronze-2nd. 

DSCP-Gold-1st and DSCP-Gold-2nd shall trigger DiffServ Gold-SLA handling.
DSCP-Silver-1st and DSCP-Silver-2nd shall trigger DiffServ Silver-SLA handling.
DSCP-Bronze-1st and DSCP-Bronze-2nd shall trigger DiffServ Bronze-SLA handling. 

They shall as well identify road systems: 
DSCP-Gold-1st, DSCP-Gold-2nd, DSCP-Silver-1st,DSCP-Silver-2nd,DSCP-Bronze-1st,DSCP-Bronze-2nd - built in this
sequence. Hereby each road system is based on what has been left over by the previously built road systems (in terms of
bandwidth).

Gold:  A smallest size tree of toll roads, highways, state roads, country roads.
Silver:A smallest size tree of highways, state roads, country roads.
Bronze:A smallest size tree of state roads, country roads, and highways only if no path otherwise.
 
QoS parameters (speed, packet loss rate, MTU size,..) may define the type of road.

1st and 2nd road system may be different at least  w.r.t. their kernel parts. (The kernel part be that 
center of the smallest size tree, which is used by at least m ingress/egress combinations).
Either traffic starts out with a) proper DSCP-Y-1st, resp. DSCP-Y-2nd, or b) is  changed from DSCP-Y-1st to
DSCP-Y-2nd at the rim of the kernel if some current traffic load information advises so. I prefer a) and if possible such
that any microflow will entirely take one single route.

Jing, you are mentioning two aspects, namely stability and extensibility.
Stability: 
We may toss a dice at the ingress,i.e. determine a random number Y between 0.0 and 1.0. If  
0.0<= Y < a, then we use DSCP-Y-1st, if a<= Y < 1, then we use DSCP-Y-2nd. The real number a should be such
that we avoid/dissolve some congestion and do not relocate it. At low-traffic times a is equal 1. But for the busy hour
determining value a  will be a very interesting topic. 
If any  University folks were interested in doing simulations as to determine value a for all ingress/egress combinations
and for all three SLAs, I would be happy to exchange more thoughts and details on it (so far I have always deferred it).
Especially, it would be interesting to get comparable results between what I called "Orchestrally Conducted Traffic" and
OMP.
However we would be leaving  the DiffRout-track of thoughts. Therefore we should say: this is out of scope of this thread. 
It may only be addressed by some other thread.

Extensibility:
So far I have no solution, on how to determine a smallest size tree made out of OSPF-links and EBGP/IBGP-hops.
BTW:
It seems to be appropriate to focus on  smallest size tree road systems, at least for some time, although ring and
somehow meshy road systems might also be considered. 

Can anybody contribute some  solution ? I think, it must be an identical tree of BGP-hops. Only all edge routers of the
same OSPF network must aquire the completely identical tree. Somehow:-)

Heinrich 

-----Ursprüngliche Nachricht-----
Von: shen jing [mailto:[email-masked]]
Gesendet: Dienstag, 6. August 2002 15:04
An: Hummel Heinrich
Cc: [email-masked]; [email-masked]
Betreff: Re: Differentiated Routing, not only plain rambo-SPF

Hi Hummel,

As DSCP is used for packet queueing in routers,  there may be many types of  queueing mechanism for scheduling of
different classes.

As mentioned in previous message that when overflow/congestion happens along some path, the flow of the same  DSCP
could be overflowed onto other path (?) or it could be dispersed onto multiple paths computed.
This means, if we want to adapt to time-varying network status  LSA must be triggered by overflow of any queue on its
outgoing interface. Because internet traffic's self-similarity characteristics and "heavy-tailed" flow sized distribution,
  we
could not expect the network status maintains a stable status. That is,  routing behavior have to be adjusted frequently.
Right ?  CBQ or the like may adjust the resource allocated dynamically according to load on routers, how could that be
reflected ?   I think, all these factors will do harm to routing stability and extensibility, esp. when we consider
inter-AS routing.

Well, I think some time to read those paper suggested.

>
>
> Hummel, was your original proposal same like Diffserv-aware-TE. I thought
> it was different.
>
> My answer:
> DiffRout is definitively different.
>
> My motivation and my key thoughts to open this discussions have been:
> - combine the best of Intserv/MPLS and Diffserv and as a result do stateless IP forwarding but get
>      what  Intserv/MPLS are providing: Qos/BW/Policy/Traffic balancing/rerouting.
>
> - therefore construct road systems and do IP forwarding/routing also based on DSCP.
>
> - the road systems may have assigned bandwidth. This is reasonable/feasable because some traffic can really
>   be locked into some slim road system (smallest size tree, smallest ring) just like MPLS traffic can be locked into
>   some LSP. Whereas with rambo-SPF bandwidth assignment makes no sense as the sum of all
>   shortest path trees computed by all the nodes would span the entire network, i.e. spread traffic all over it.
>   The price for staying within some road system should be acceptable: Eventually, make a few hops more.
>   Based on my computations, the smallest size tree may be smaller than the avarage shortest path tree by 15-20 %.
>   So I think the detour for the packets will not be very big either.
>
> - be guided by what you can observe on daily road traffic: Especially in the U.S. there are so many ramp-based
>   road junctions, which are more impressive than any traffic light controlled junction, so that motor-cyclists may
>   jump the queue of waiting cars (=DiffServ) if the traffic light is red.
>   There are so many observations that can be made watching how the traffic is managed for cars,
>   trains, airplanes, pedestrians, etc. We all are used to it and don't discern extra smartness in it. However there is.
>
> - and I realized what is the big obstacle: Yes it is this rambo-SPF routing paradigma. It does not represent the
>   surveillant view, only the egomanic view, combined with the hope that in total you get best results because
>   "the streets are emptiest when each car takes the shortest route":-).
>
> Heinrich
>
>
>
>
>
> _______________________________________________
> routing-discussion mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/routing-discussion

--
Jing Shen

State Key Lab of CAD&CG
ZheJiang University(YuQuan)
HangZhou, Z.J. 310027
P.R.China

Tel: +86-571-87932423

Email: [email-masked]

**********************************************************************
* The SunShine of life is made up of very little beams which is      *
*  bright all the time                                               *
**********************************************************************

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: shen jing <[email-masked]>
Date: Tue, 13 Aug 2002 20:20:18 +0800

Hummel,

> QoS parameters (speed, packet loss rate, MTU size,..) may define the type of road.

Do you means to restrict DSCP to be 3bits? 

> that any microflow will entirely take one single route.

So, that means to use alternative path for overflowed traffic?  In fact,
someone has proposed similar

method. Perhaps you are interested in the following paper:

http://www.cs.virginia.edu/~rv3s/pubs/compnet_paper.pdf 

> 
>
> Stability:
> We may toss a dice at the ingress,i.e. determine a random number Y between 0.0 and 1.0. 

I think this determines when a second path is adopted for traffic
routing, in fact we do not
need to use a random number if MPLS is used. At this situation, I think
what we need is to 
monitor load on a LSP, if the load is more than 70% of the effective
bandwidth another LSP is
adpoted. If distributed routing is used ( as that of current IP
network), traffic dispersion 
have to be triggerred by heuristic method mentioned by you.

> So far I have no solution, on how to determine a smallest size tree made out of OSPF-links and EBGP/IBGP-hops.

As I think, a routing system built on time-varying network status will
do harm to both
stability and extensibility, because it could not be expected to all
routers converge to the same 
point within a short time period. 

Some others have been working on resource management in DiffServ
networks, the page located 
at:

http://standards.ericsson.net/rmd/

In deed, I'm very interested in this idea but I think it need more
clarification.

Hope to hear from others.

-- 
Jing Shen

State Key Lab of CAD&CG

Tel: +86-571-87932423

---

From: shen jing <[email-masked]>
Date: Tue, 13 Aug 2002 20:20:18 +0800

Hummel,

-- 
Jing Shen

State Key Lab of CAD&CG

Tel: +86-571-87932423