Subject: Re: Differentiated Routing, not only plain rambo-SPF

From: shen jing <[email-masked]>
Date: Fri, 02 Aug 2002 15:48:15 +0800

Hi Hummel,

Do you means,

1) if we want to route with DSCP it should be desired that  logical views of network based on each possible
DSCP is computed ?

2.)  Each router builds up a seperate routing table for each possible DSCP , and there exist a default routing table
       for packets whose DSCP are not set  ?

3.)   When a new packet arrives, the dispatching logic may look like :

      Procedure  DSCP_BASED_DISPATCH ( incoming_packet )
            if   DSCP   then
                 if  (  DSCP-related-table-exist )
                     running-table =  DSCP-related-table;

           if  running-table==NULL
                  running-table = default-table;

           out_port= find_routing_item( incoming_packet);
           enqueue(out_port, incoming_packet);

        END PROCEDURE

But, How could the logical view be computed?  DSCP is just for queueing mechanism, should that be included in LSA?

And, I think there may other problem as extensiblility and stability.

And,the last , I'm not so clear about the method computing shortest size tree, and I'm very interested in your work of
minimal partial mesh between n sites of a VPN. Would you please give a little more word or some reference sites ?

Thank  you .

Regards

> Let's be concentrated again. And let me get to the heart of the matter.
>
> Obviously I am not the only one who thought about using the DSCP also for doing Differentiated Routing.
> Will say: not the only one who thought about indexing different Routing Tables by different DSCPs.
>
> IMO, these routing tables should represent different and very distinct and differentiated road systems.
> This is only possible, if they are genuine partial structures of the total network. In addition to them we still need
> that "default"-road system which is identical to the entire network (e.g. in order to ping any node), i.e. today's routing tables.
>

[snip]

--
Jing Shen

State Key Lab of CAD&CG
ZheJiang University(YuQuan)
HangZhou, Z.J. 310027
P.R.China

Tel: +86-571-87932423

Email: [email-masked]

**********************************************************************
* The SunShine of life is made up of very little beams which is      *
*  bright all the time                                               *
**********************************************************************

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: shen jing <[email-masked]>
Date: Fri, 02 Aug 2002 15:48:15 +0800

Hi Hummel,

Do you means,

           if  running-table==NULL

        END PROCEDURE

Thank  you .

Regards

[snip]

--
Jing Shen

State Key Lab of CAD&CG

Tel: +86-571-87932423