Subject: GR/NSF Terminology

From: Danny McPherson <[email-masked]>
Date: Wed, 29 Jan 2003 13:40:29 -0700

[Folks, notice the cross-post...  Perhaps [email-masked]
should be the only one to receive replies, please try to respect this].
 
I think it'd be a good thing for all of the GR/NSF protocol extensions 
to employ a common set of terminology, instead of each using your own.
I believe the OSPF *WG* document currently does the best job with defining
terms, etc.., although I'm not sure it's sufficient or accommodates 
everything.  

I'd be willing to work on a "generic document" if need be, or would 
be happy if the current protocol-specific documents (i.e., BGP, IS-IS, 
OSPF, LDP, RSVP (dead?), VPN stuff, other?) would make some attempt to 
use the same terms.

Any comments?

-danny

> This is the start of a Working Group last call for
> draft-ietf-ospf-hitless-restart-05.txt, OSPF Hitless Restart.
> All comments must be sent to the OSPF list by Friday,
> February 8th, 2003.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-ospf-hitless-restart-05.txt
> 
> My previous list posting on this WG last call was lost or
> filtering. My apologies if this is a duplicate.
> 
> Thanks,
> Acee & Rohit
> --
> Acee

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: Danny McPherson <[email-masked]>
Date: Wed, 29 Jan 2003 22:05:51 -0700

> What are the terms/definitions that need to be common across the various
> protocol documents? Minimally, I'd include:
> :
>     - hitless restart (aka, graceful restart :^)
>     - planned restart
>     - unplanned restart

I was thinking these, for starters, then including the 
general concepts in addition to the terms..

Some things that immediately come to mind:  hitless restart, graceful restart, non-stop 
forwarding, helper mode, rx-only mode, helper neighbor, Grace periods, Restart reasons, 
Restart Support, intervals, etc..  All the intervals could be aligned to make things more 
intuitive.

Clearly, the bits stuff needs to remain the protocol-specific documents but
aligning terminology, deployment extensions, security considerations (e.g., 
seq numbers with MD5 signatures), caveats (e.g., potential problems with 
supporting unplanned restarts), etc.. would seem to me to be useful.

-danny

---

From: Danny McPherson <[email-masked]>
Date: Wed, 29 Jan 2003 22:05:51 -0700

-danny

---

From: Jeff Parker <[email-masked]>
Date: Thu, 30 Jan 2003 10:26:44 -0500

Danny
	How far back will you go?  Will you clear up the spelling of
Routeing as well?   

- jeff parker

---

From: Jeff Parker <[email-masked]>
Date: Thu, 30 Jan 2003 10:26:44 -0500

Danny

- jeff parker

---

From: Danny McPherson <[email-masked]>
Date: Thu, 30 Jan 2003 08:33:58 -0700

> The OSPF document you cite defines various terms, but in an 
> OSPF-specific fashion.  Furthermore, the definitions are not 
> collected anywhere in the document but are peppered throughout it... 
> which is fine in context but doesn't lend itself to generic use of 
> the terms.

Agreed.

> Seems like there are two things we could do:
> 
> First, leave the documents as they are.  This is my preferred 
> alternative.  The docs are relatively well advanced in terms of 
> specification and even deployment, and doing what would be a 
> non-trivial update solely for the purpose of aligning terminology 
> strikes me a being work for work's sake.  This is doubly true because 
> a major terminology change creates the risk of introducing subtle 
> errors to the spec if one isn't careful.  Apart from aesthetics, what 
> need do you think is fulfilled by aligning the specs?
> 
> Alternately, if we do want to go ahead and change the specs, then a 
> (generic) definitions document such as you have volunteered to write 
> seems a necessity.  I'm not a fan of "framework" documents and I hope 
> we could keep the scope of the proposed definitions document focused.

OK, so folks don't seem to be to keen on the idea at this point.
Given that I'm not attached to the idea of more work "for the
sake of work" then I'll drop it.  I believe there is room for 
commonality but look where that's got me in PWE3 *8^/

> By the way, I think "graceful restart" has historic precedence over 
> "hitless restart" if you want to align terms :-). 

Agreed. 

-danny

---

From: Danny McPherson <[email-masked]>
Date: Thu, 30 Jan 2003 08:33:58 -0700

Agreed.

Agreed. 

-danny