Subject: Doubt in OSPF v3 -SPF calculation

From: Karthikeyan <[email-masked]>
Date: Fri, 28 Feb 2003 11:02:23 +0000 (GMT)

Hello to all,

I have some doubt in OSPF v3 SPF calculation.

In section 3.8.1 while processing multiple router LSA associated with the router
The RFC says that
"The Options field and the router type bits (bits W, V, E and B) should always
be taken from "fragment" with the smallest Link State ID"
This process is done in step 2 of "calculating shortest path tree for that area"
Can anybody explain me why the options field and the router type bits should
always be taken from fragment with smallest Link state ID?

Thanks in advance.
S.Karthikeyan

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: Acee Lindem <[email-masked]>
Date: Fri, 28 Feb 2003 10:09:39 -0500

> always be taken from fragment with smallest Link state ID?

Hello Karthikeyan,

This allows the originating router to only re-originate a single
LSA "fragment" when one of these bits change. Without this rule,
the originating router would have to re-originate all the router
LSA "fragments" for that area.

Thanks,
Acee

> 
> Thanks in advance.
> S.Karthikeyan
> 
> _______________________________________________ routing-discussion 
> mailing list [email-masked] 

-- 
Acee

---

From: Acee Lindem <[email-masked]>
Date: Fri, 28 Feb 2003 10:09:39 -0500

Hello Karthikeyan,

Thanks,
Acee

-- 
Acee