Subject: Re: RE: Reliability in LAN

From: "Karthikeyan Subramaniam" <[email-masked]>
Date: 11 Apr 2003 03:18:16 -0000

My requirements are reliability mechanism based on UDP/IP. I 
have to optimise the packet transaction in the LAN using SACK and 
NACK effectively. One more thing as I have to build reliability on 
LAN, I need not follow hierarchial approach of data recovery 
(Method used to avoid overloading the sender). Is there any RFC or 
draft avaiable for reliable multicast mechanism based on these 
requirements?

Thanks
karthik
On Thu, 10 Apr 2003 Michael Luby wrote :
>One could also look at RFCs 3450, 3451, 3452 and 3453.  These 
>provide a
>direct solution to adding reliability to multicast without losing 
>any
>scalability.
>
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of 
>Manfredi, Albert
> > E
> > Sent: Thursday, April 10, 2003 10:39 AM
> > To: Karthikeyan Subramaniam; [email-masked]
> > Subject: RE: Reliability in LAN
> >
> >
> > Yes. See RFCs 2357, 2887, and 3048. In short, you have to 
>build
> > the reliability mechanisms on top of UPD/IP. These sometimes
> > mimick what had been done in XTP multicast years ago.
> >
> > Bert
> >
> >
> > > -----Original Message-----
> > > From: Karthikeyan Subramaniam 
>[mailto:[email-masked]]
> > > Sent: Thursday, April 10, 2003 3:51 AM
> > > To: [email-masked]
> > > Subject: Reliability in LAN
> > >
> > >
> > > Hello,
> > >
> > >    Is there any draft or RFC available for multicast 
>reliability
> > > in LAN?
> > > I have an multicast application which needs an reliable 
>mechanism
> > > to send packets, so that other member in the group receive 
>the
> > > packet without any packet loss.
> > >
> > > thanks,
> > > -karthik.
> > _______________________________________________
> > routing-discussion mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/routing-discussion
> >
>

_______________________________________________________________________
Odomos - the only  mosquito protection outside 4 walls -
Click here to know more!
http://r.rediff.com/r?http://clients.rediff.com/odomos/Odomos.htm&&odomos&&wn

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: Jing Shen <[email-masked]>
Date: Fri, 11 Apr 2003 18:07:16 +0800 (CST)

I don't understand what's the difference between them, because your condition could be considered as a simplified model of reliable multicast with only one hop ( or maybe that covers a VLAN ).
If focusing on application layer QoS,  it could construct application layer multicast tree without consideration on underlying networks. 
 
 Karthikeyan Subramaniam <[email-masked]> wrote:

Thanks
karthik
>direct solution to adding reliability to multicast without losing 

Jing Shen

State Key Lab of CAD&CG
ZheJiang University(YuQuan)
HangZhou, ZheJiang Province 310027
P.R.China

---------------------------------
Do You Yahoo!?
"雅虎通网络KTV, 随时随地免费卡拉OK~~"

---

From: Jing Shen <[email-masked]>
Date: Fri, 11 Apr 2003 18:07:16 +0800 (CST)

Thanks
karthik

Jing Shen

State Key Lab of CAD&CG