Subject: decison process in routing protocols

From: "Alok Dube" <[email-masked]>
Date: Mon, 7 Jul 2003 19:39:43 +0530

Hi,

I have a basic question on routing.

Is it possible to develop an accurate "cost based" decision process in a
routing protocol if the information passed to a routing node is based on the
"decision process" run by another node?

Isn't "decision process" supposed to be local to each peer?

-thanks
Alok

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: "Tony Li" <[email-masked]>
Date: Mon, 7 Jul 2003 10:45:43 -0700

A decision process can be run anywhere that has complete
and accurate information.  Conversely, anyplace (including
locally) that does not have complete and accurate information
cannot successfully run a decision process.

Thus, locality is only an implementation issue.  From that
perspective, however, having a failure that makes it impossible
for data to make it to or from the decision process would make
the forwarding engine effectively useless.  Protecting against
such failures requires more redundancy and more system complexity.
Therefore, remote decision processes are not very common.

Tony

|    -----Original Message-----
|    From: Alok Dube [mailto:[email-masked]] 
|    Sent: Monday, July 07, 2003 7:10 AM
|    To: [email-masked]
|    Subject: decison process in routing protocols
|    
|    
|    Hi,
|    
|    I have a basic question on routing.
|    
|    Is it possible to develop an accurate "cost based" 
|    decision process in a
|    routing protocol if the information passed to a routing 
|    node is based on the
|    "decision process" run by another node?
|    
|    Isn't "decision process" supposed to be local to each peer?
|    
|    -thanks
|    Alok
|    
|    
|    _______________________________________________
|    routing-discussion mailing list
|    [email-masked]
|    https://www1.ietf.org/mailman/listinfo/routing-discussion
|

---

From: Shehzad Merchant <[email-masked]>
Date: Mon, 7 Jul 2003 11:36:32 -0700

The decision process is both a policy and implementation issue. If the
remote node has the policy information to execute the decision process on
behalf of other nodes, and has "accurate and complete" topology information
as the other nodes would see it (for example a network wide view of the
topology as in a link state protocol), conceivably it could execute the
decision process on behalf of other nodes if one chooses to implement things
that way.

-S

-----Original Message-----
From: Lloyd Wood [mailto:[email-masked]]
Sent: Monday, July 07, 2003 11:24 AM
To: Tony Li
Cc: Alok Dube; [email-masked]
Subject: RE: decison process in routing protocols

On Mon, 7 Jul 2003, Tony Li wrote:

> Thus, locality is only an implementation issue.

But locality determines what information is _known_ to be complete and
accurate.

Hence split horizon and poison reverse, no?
(Okay, Alok asked about cost and I'm considering cost as distance.)

L.

>  From that

<http://www.ee.surrey.ac.uk/Personal/L.Wood/><[email-masked]>

---

From: "Naidu, Venkata" <[email-masked]>
Date: Mon, 7 Jul 2003 14:34:33 -0400

-> A decision process can be run anywhere that has complete
-> and accurate information.  Conversely, anyplace (including
-> locally) that does not have complete and accurate information
-> cannot successfully run a decision process.
-> 
-> Thus, locality is only an implementation issue.  From that
-> perspective, however, having a failure that makes it impossible
-> for data to make it to or from the decision process would make
-> the forwarding engine effectively useless.  Protecting against
-> such failures requires more redundancy and more system complexity.
-> Therefore, remote decision processes are not very common.

  That said, remote decision processes are inevitable in
  certain situations. For example, inter-area/AS source 
  routing requires some kind of distributed routing information
  (mostly from borders routers) to make an apt decision.
  Distributed routing decisions (with partial information)
  is common in mobile ad-hoc networks. 

  Theoretical foundation do exists for distributed routing
  algorithms. Recently, MPLS is started using such algos.

  In the past there is some work in IP distributed routing
  called "open router". Where multiple forwarding planes are
  controlled by one are many control plane decision processes.
  SS7 also does a kind of distributed out-of-band decisions.

Venkata.
 
-> Tony
-> 
-> 
-> |    -----Original Message-----
-> |    From: Alok Dube [mailto:[email-masked]] 
-> |    Sent: Monday, July 07, 2003 7:10 AM
-> |    To: [email-masked]
-> |    Subject: decison process in routing protocols
-> |    
-> |    
-> |    Hi,
-> |    
-> |    I have a basic question on routing.
-> |    
-> |    Is it possible to develop an accurate "cost based" 
-> |    decision process in a
-> |    routing protocol if the information passed to a routing 
-> |    node is based on the
-> |    "decision process" run by another node?
-> |    
-> |    Isn't "decision process" supposed to be local to each peer?
-> |    
-> |    -thanks
-> |    Alok
-> |    
-> |    
-> |    _______________________________________________
-> |    routing-discussion mailing list
-> |    [email-masked]
-> |    https://www1.ietf.org/mailman/listinfo/routing-discussion
-> |    
-> 
-> _______________________________________________
-> routing-discussion mailing list
-> [email-masked]
-> https://www1.ietf.org/mailman/listinfo/routing-discussion
->

---

From: Shehzad Merchant <[email-masked]>
Date: Mon, 7 Jul 2003 11:36:32 -0700

-S

-----Original Message-----
From: Lloyd Wood [mailto:[email-masked]]
Sent: Monday, July 07, 2003 11:24 AM
To: Tony Li
Cc: Alok Dube; [email-masked]
Subject: RE: decison process in routing protocols

L.

---

From: "Tony Li" <[email-masked]>
Date: Mon, 7 Jul 2003 13:43:07 -0700

They have to make the exact SAME decisions that the process would
make if it was running locally.

Tony

|    -----Original Message-----
|    From: Alok Dube [mailto:[email-masked]] 
|    Sent: Monday, July 07, 2003 11:51 AM
|    To: [email-masked]
|    Subject: Re: decison process in routing protocols
|    
|    
|    >   In the past there is some work in IP distributed routing
|    >   called "open router". Where multiple forwarding planes are
|    >   controlled by one are many control plane decision processes.
|    >   SS7 also does a kind of distributed out-of-band decisions.
|    
|    Hi,
|    
|    do these compute the "decison process for the best route" from the
|    "forwarding plane's" perspective?
|    
|    -thanks
|    Alok
|    
|    
|    _______________________________________________
|    routing-discussion mailing list
|    [email-masked]
|    https://www1.ietf.org/mailman/listinfo/routing-discussion
|

---

From: "Tony Li" <[email-masked]>
Date: Mon, 7 Jul 2003 13:43:07 -0700

Tony