Subject: RE: BOF Agenda - Multicast Last-Mile Solutions

From: "Manfredi, Albert E" <[email-masked]>
Date: Mon, 7 Jul 2003 15:25:08 -0400

> At 07:54 PM 7/7/2003 +0100, Lloyd Wood wrote:
> >(multicast makes a lot of sense in a satellite broadcast environment,
> >  where link utilisation matters. If you can resell your
> >  constrained capacity, multicast increases, not decreases, your
> >  revenue.)
> 
> Exactly right.  I ran into an example of that recently.

Sorry, but I had exactly the opposite reaction.

Over a broadcast channel, such as satellite, it seems to me, any sort of encapsulation is just fine. At the receiving end*s*, the receivers can easily reformat the packet to be unicast or multicast, to enable the appropriate routing where routing matters.

The broadcast channel's individual streams can be differentiated in any number of ways, including the use of Class D addresses certainly. But that makes a weak argument for IP Multicast, I think. For instance, what's wrong with using PIDs in MPEG-2 Transport Stream? Or what about differentiating based only on a LLC/SNAP header ID?

Bert

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: Lloyd Wood <[email-masked]>
Date: Mon, 7 Jul 2003 20:33:07 +0100 (BST)

On Mon, 7 Jul 2003, Manfredi, Albert E wrote:

> Over a broadcast channel, such as satellite, it seems to me, any
> sort of encapsulation is just fine. At the receiving end*s*, the
> receivers can easily reformat the packet to be unicast or multicast,
> to enable the appropriate routing where routing matters.

what do you mean by 'reformat the packet'?

> The broadcast channel's individual streams can be differentiated in
> any number of ways, including the use of Class D addresses
> certainly. But that makes a weak argument for IP Multicast, I think.
> For instance, what's wrong with using PIDs in MPEG-2 Transport
> Stream? Or what about differentiating based only on a LLC/SNAP
> header ID?

You'd have to indicate that the multicast packet was a multicast
packet via PID or LLC/SNAP _as well_ - tightly coupling semantics down
the layers.

L.

<http://www.ee.surrey.ac.uk/Personal/L.Wood/><[email-masked]>

---

From: Lloyd Wood <[email-masked]>
Date: Mon, 7 Jul 2003 20:33:07 +0100 (BST)

L.