Subject: RE: BOF Agenda - Multicast Last-Mile Solutions

From: "Manfredi, Albert E" <[email-masked]>
Date: Mon, 7 Jul 2003 16:20:52 -0400

Lloyd Wood wrote:

> Manfredi, Albert E wrote:
>
> > My fundamental disagreement with bringing up a broadcast channel is
> > that the broadcast channel per se couldn't care less.
> 
> the terminals receiving from that channel, however, do care when
> discriminating. Channels are fundamentally physical, they don't care.
> A shared link medium is, however, a different beast.

Okay, maybe we need examples to stay on the same page. Greg Shepherd mentioned high bit rate streams as a good reason to use IP multicast vs unicast. So let's take satellite DTV distribution as an example.

The head end uplinks DTV program streams to the satellite. They come back as MPEG streams, identified by a physical channel and a PID within that channel. So far, NO indication of multicast anything. Just unique IDs for each bitstream, so they can be differentiated at the receiving ends.

Now this signal can be immediately decoded and used by a satellite receiver, or it can be encapsulated in IP Multicast packet, then in an Ethernet frame, for distribution over a wired internet of some kind. The broadcast link does not make for an interesting "must have" for IP multicast, in this TV example.

Okay, forget TV. If the satellite link is a more intrinsic part of this internet, i.e. a leg in an otherwise routed IP network, then use of IP multicast in this particular leg of the network is not really any more or less compelling than transmitting IP multicast packets over a wired link. Could be Ethernet, could be a wave-divided optical link, could be a SONET STS frame, could be a T3 or T1 phone link.

I think that to make IP multicast compelling, ISPs have to be convinced that it's to their advantage. One important piece MIGHT be to come up with a scheme that can accurately count group membership. IGMP does NOT provide such a technique as of now.

Bert

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: Lloyd Wood <[email-masked]>
Date: Mon, 7 Jul 2003 21:53:37 +0100 (BST)

On Mon, 7 Jul 2003, Manfredi, Albert E wrote:

> I think that to make IP multicast compelling, ISPs have to be
> convinced that it's to their advantage. One important piece MIGHT be
> to come up with a scheme that can accurately count group membership.
> IGMP does NOT provide such a technique as of now.

This is why I like core-based trees; I had core-based trees counting
group members in my PhD thesis. (Since a core has upstream state, I
don't view it as IGMP snooping; more proxying/aggregation).

L.

<http://www.ee.surrey.ac.uk/Personal/L.Wood/><[email-masked]>

---

From: Lloyd Wood <[email-masked]>
Date: Mon, 7 Jul 2003 21:53:37 +0100 (BST)

L.