Subject: What is this all about? [was Re: Open Routing Area meeting in Vienna]

From: David Meyer <[email-masked]>
Date: Wed, 30 Jul 2003 14:26:17 -0700

I was reading all of the traffic on this list this AM and
	decided to go off to the gym, experience a little of the
	relationship between mass and gravity, and think about
	all of this a bit. So, it seems to me that there are 
	(at least) five general areas that we've been discussing:  

	(i).	The control theoretic properties of the BGP
		control plane. As Randy points out, this is a
		topic of great interest to most everyone, and has
		been (and continues to be) the object of a great
		deal of study. 

	(ii).	Possibly not unrelated to (i). above is the
		potential impact on the behavior of the BGP
		control plane (i.e., operational stability). More
		specifically, we seem to be discussing the impact
		of various transporting features and their
		associated signaling using the BGP control plane
		(no one seems to have voiced an explicit problem
		with the BGP data plane, as far as I can tell).  

	(iii).	Another point that has been discussed in this
		thread (as well as in Vienna) relates to the
		software engineering aspects of transporting
		features and signaling using the BGP
		infrastructure that is deployed on the Internet
		today. In particular, some have concern about the
		effect of this practice on the stability of the
		Internet (i.e., (i)-(ii) above). Others see it
		(explicitly) differently. 

	(iv).	Again, possibly related to (i)-(iii) are a set of
		loosely defined/described concerns relating to
		the possible increase in system complexity
		deriving from extensions to BGP (the term
		extensions here is itself loosely defined; one
		might argue that the extension was to MP-BGP, and
		the rest fits within that framework, and hence
		are not extensions). 
		
		One thing that I think we as a community have
		learned over the past few years is that a
		quantitative understanding of the complexity of a
		system like the Internet is currently beyond our
		grasp. See http://www.maoz.com/~dmm/complexity_and_the_internet 
		for an overview of some of the early work in this
		area (the point here is that the field is in a
		very early stage in its development).  

	(v).	Market forces and their associated economics. It
		is interesting to note that, in addition to the
		discussion of AFs we're having here, current BGP
		deployment practices are clearly not independent
		of these same forces.

	(vi).	Others that I missed.

	These are complex issues in that they involve a system
	(the Internet) who's behavior we can not precisely
	characterize (in many cases, we just don't have the
	tools). These include, but not limited to, the quantative
	behavior of the current BGP control plane, market forces
	involved in fielding features (and signaling) in BGP, and
	in general, the stability and scaling properties of the
	BGP as deployed in the Internet.

	All of that considered, one approach which might be
	constructive here is to understand which of (i)-(v)
	above, if any, are in scope for this discussion (and in
	scope for the IETF in general), and to fill out (vi), as 
	there must be other issues not captured by
	(i)-(iv). Then, to Danny's point, we can finish up the
	straw-person document, post it here (or wherever is
	appropriate), and discuss that. That would seem to be
	consistent with the IETF process, as I understand it.  

>> My point: each person's arguments should carry weight based on the
>> content, not on the author's employer...

	Agree, and to put a (slightly) finer point on it (quoting
	the great Sly Stone now): 

Sometimes I'm right, but I can be wrong
My own beliefs are in my song
The butcher, the banker, the drummer and then
Makes no difference what group I'm in

	Dave

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: David Meyer <[email-masked]>
Date: Wed, 30 Jul 2003 16:45:44 -0700

>> 		with the BGP data plane, as far as I can tell).  

	I kinda mangled what I was trying to say here (sorry
	about that). Basically, this item was supposed to capture
	the discussion about the impact of carrying new AF/SAFIs
	and their associated signaling data in BGP. The
	parenthetical comment about the data plane was meant to
	reflect that I hadn't seen any discussion about the
	encoding or format of the data being carried (someone
	correct me if I'm wrong there). 

	Dave

---

From: David Meyer <[email-masked]>
Date: Wed, 30 Jul 2003 16:45:44 -0700

Dave