Subject: RE: decison process in routing protocols

From: "Tony Li" <[email-masked]>
Date: Mon, 7 Jul 2003 10:45:43 -0700

A decision process can be run anywhere that has complete
and accurate information.  Conversely, anyplace (including
locally) that does not have complete and accurate information
cannot successfully run a decision process.

Thus, locality is only an implementation issue.  From that
perspective, however, having a failure that makes it impossible
for data to make it to or from the decision process would make
the forwarding engine effectively useless.  Protecting against
such failures requires more redundancy and more system complexity.
Therefore, remote decision processes are not very common.

Tony

|    -----Original Message-----
|    From: Alok Dube [mailto:[email-masked]] 
|    Sent: Monday, July 07, 2003 7:10 AM
|    To: [email-masked]
|    Subject: decison process in routing protocols
|    
|    
|    Hi,
|    
|    I have a basic question on routing.
|    
|    Is it possible to develop an accurate "cost based" 
|    decision process in a
|    routing protocol if the information passed to a routing 
|    node is based on the
|    "decision process" run by another node?
|    
|    Isn't "decision process" supposed to be local to each peer?
|    
|    -thanks
|    Alok
|    
|    
|    _______________________________________________
|    routing-discussion mailing list
|    [email-masked]
|    https://www1.ietf.org/mailman/listinfo/routing-discussion
|    

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: "Alok Dube" <[email-masked]>
Date: Mon, 7 Jul 2003 23:31:49 +0530

Hi Tony,

What confuses me is this:

how would "running a decison process at any place which has complete and
accurate information" work fine at any place but the node at which needs to
compute the path to an end point from "its" perspective?

or

is each node where we "run the decision process" supposed to compute the
path from the "end node's perspective"(the place where the node is supposed
to put that information as a result of the decision process) or from "its
perspective"?

-thanks
Alok

---

From: Lloyd Wood <[email-masked]>
Date: Mon, 7 Jul 2003 19:24:01 +0100 (BST)

On Mon, 7 Jul 2003, Tony Li wrote:

> Thus, locality is only an implementation issue.

But locality determines what information is _known_ to be complete and
accurate.

Hence split horizon and poison reverse, no?
(Okay, Alok asked about cost and I'm considering cost as distance.)

L.

>  From that

<http://www.ee.surrey.ac.uk/Personal/L.Wood/><[email-masked]>

---

From: "Alok Dube" <[email-masked]>
Date: Mon, 7 Jul 2003 23:31:49 +0530

Hi Tony,

or

-thanks
Alok

---

From: Lloyd Wood <[email-masked]>
Date: Mon, 7 Jul 2003 19:24:01 +0100 (BST)

L.