Subject: RE: decison process in routing protocols

From: "Naidu, Venkata" <[email-masked]>
Date: Mon, 7 Jul 2003 14:34:33 -0400

-> A decision process can be run anywhere that has complete
-> and accurate information.  Conversely, anyplace (including
-> locally) that does not have complete and accurate information
-> cannot successfully run a decision process.
-> 
-> Thus, locality is only an implementation issue.  From that
-> perspective, however, having a failure that makes it impossible
-> for data to make it to or from the decision process would make
-> the forwarding engine effectively useless.  Protecting against
-> such failures requires more redundancy and more system complexity.
-> Therefore, remote decision processes are not very common.

  That said, remote decision processes are inevitable in
  certain situations. For example, inter-area/AS source 
  routing requires some kind of distributed routing information
  (mostly from borders routers) to make an apt decision.
  Distributed routing decisions (with partial information)
  is common in mobile ad-hoc networks. 

  Theoretical foundation do exists for distributed routing
  algorithms. Recently, MPLS is started using such algos.

  In the past there is some work in IP distributed routing
  called "open router". Where multiple forwarding planes are
  controlled by one are many control plane decision processes.
  SS7 also does a kind of distributed out-of-band decisions.

Venkata.
 
-> Tony
-> 
-> 
-> |    -----Original Message-----
-> |    From: Alok Dube [mailto:[email-masked]] 
-> |    Sent: Monday, July 07, 2003 7:10 AM
-> |    To: [email-masked]
-> |    Subject: decison process in routing protocols
-> |    
-> |    
-> |    Hi,
-> |    
-> |    I have a basic question on routing.
-> |    
-> |    Is it possible to develop an accurate "cost based" 
-> |    decision process in a
-> |    routing protocol if the information passed to a routing 
-> |    node is based on the
-> |    "decision process" run by another node?
-> |    
-> |    Isn't "decision process" supposed to be local to each peer?
-> |    
-> |    -thanks
-> |    Alok
-> |    
-> |    
-> |    _______________________________________________
-> |    routing-discussion mailing list
-> |    [email-masked]
-> |    https://www1.ietf.org/mailman/listinfo/routing-discussion
-> |    
-> 
-> _______________________________________________
-> routing-discussion mailing list
-> [email-masked]
-> https://www1.ietf.org/mailman/listinfo/routing-discussion
-> 

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: "Alok Dube" <[email-masked]>
Date: Tue, 8 Jul 2003 00:21:21 +0530

>   SS7 also does a kind of distributed out-of-band decisions.

Hi,

do these compute the "decison process for the best route" from the
"forwarding plane's" perspective?

-thanks
Alok

---

From: "Alok Dube" <[email-masked]>
Date: Tue, 8 Jul 2003 00:21:21 +0530

Hi,

-thanks
Alok