Subject: RE: Open Routing Area meeting in Vienna

From: Sanjay Wadhwa <[email-masked]>
Date: Fri, 1 Aug 2003 06:42:12 -0700 (PDT)

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Robert Raszuk
> Sent: Friday, August 01, 2003 3:55 AM
> To: Lars Erik Gullerud
> Cc: [email-masked]
> Subject: Re: Open Routing Area meeting in Vienna
> 

...snip
>
> We have first one:
> 
> 1. Separate BGP sessions for each AFI/SAFI require "trashing" IGP
with
> new addresses (IBGP) or multiple interfaces (EBGP) cases.
> 
> Thx !
> R.
> 

This requirement holds true today. However, different bgp sessions to
the same peer address for different services (AFI/SAFI) is also
possible by defining seperate well known tcp port per service.  
 
-Sanjay

__________________________________
Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo.
http://search.yahoo.com

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: Sanjay Wadhwa <[email-masked]>
Date: Fri, 1 Aug 2003 06:42:12 -0700 (PDT)

...snip
with

-Sanjay

---

From: Schrodi Karl <[email-masked]>
Date: Wed, 6 Aug 2003 19:27:59 +0200

Gentlemen,

a few weeks after Vienna I expected the waves to calm down - but instead, the discussion seems to catch fire ... (whooow!)

I think, that (as often) there are several possible positions - each one has its pros and cons and none of them is perfectly right. We all know, that ´THE right choice in the long run´ doesn´t exist - and if it would, we would not know it in advance (thank good, that nobody can foresee the future). So, I suggest to come back to a common charter which probably should be something like ´to prevent damage and facilitate improvements of the net´ (which btw. I like to read between the lines of all the contributions).

Fact is, we have BGP today - and it is a good solution, because it works (and permanently proves to do so). It serves its primary purpose of being the inter-domain routing protocol and it serves some other purposes it was found of being capable to do throughout the years. But still, I think, there is some room for improvements in its original purpose. Let me give five lines for an example:

(Re)Routing convergence times may not be an issue for email conversation or file transfer. But you probably will not like severe disturbances in the life cast of a sports event or a net meeting session ... . Routing stability and fast convergence may facilitate introduction and broad acceptance of new, higher value services on the net.

I´m not enough expert to say what ´is easy with BGP´ or what ´cannot be done with BGP´, but I see three points:
1. BGP (as is) should be the starting point for any further considerations.
2. Gradual improvements are always easier to achieve and smoother to introduce than big steps or breaks.
3. Any kind of improvements will be much easier to achieve on an ´unloaded´, pure routing protocol.

I would like to know, if somebody is already (or probably would be willing to do so) working on such or similar improvement issues.
(I guess my five lines are not sufficient to well define the problem, but a problem statement could probably be a good starting point.)

Karl

-----Ursprüngliche Nachricht-----
Von: Yakov Rekhter [mailto:[email-masked]]
Gesendet: Mittwoch, 6. August 2003 17:14
An: Alex Zinin
Cc: Robert Raszuk; [email-masked]
Betreff: Re: Open Routing Area meeting in Vienna 

Alex,

[clipped...]
 
> The point is that I agree that the MP-BGP framework is a good match
> for the required functionality, however the number of concerns we have
> heard suggest that it may not be THE right choice in the long run.

We also heard for quite some time that for the Internet inter-domain
routing BGP "may not be THE right choice in the long run". With
this in mind I would suggest for folks interested in "THE right
choice in the long run" to stop arguing against adding more stuff
to BGP, and instead join the folks working on "THE right choice in 
the long run" for the Internet inter-domain routing.

Yakov.

P.S. For those interested in the current status of the work on "THE
right choice in the long run" for the Internet inter-domain routing
I am happy to report that this work, aka as a LTSFGTC (Long Term
Solution For Generations To Come), is in progress and is expected
to be published in RFC100000.

---

From: Schrodi Karl <[email-masked]>
Date: Wed, 6 Aug 2003 19:27:59 +0200

Gentlemen,

Karl

-----Ursprüngliche Nachricht-----
Von: Yakov Rekhter [mailto:[email-masked]]
Gesendet: Mittwoch, 6. August 2003 17:14
An: Alex Zinin
Cc: Robert Raszuk; [email-masked]
Betreff: Re: Open Routing Area meeting in Vienna 

Alex,

[clipped...]

Yakov.

---

From: Yakov Rekhter <[email-masked]>
Date: Thu, 07 Aug 2003 13:01:39 -0700

Lars,

> Of course you can use multiple sessions and build separate meshes, and
> for a lot of cases, this is in fact already the common way to do it. But
> that hardly scales ad infinitum, and in fact causes even more
> administrative hassles than if each service was carried in it's own
> completely separate protocol, as you now also need N addresses set up on
> each host to support N services in individual sessions.
> 
> My point was that while you say that "that is what making each AFI/SAFI
> fully modular is all about", BGP has certain inherent properties that
> does NOT make them fully modular. 

Could you please point out to these "inherent properties", and explain
why they do not make BGP fully modular.

> If you really want BGP to be the
> generalized "stuff distribution protocol", then the protocol needs even
> more changes to generalize it to this level. 

What *specific* changes does it need ?

> Whether making a "BGP5"
> with these kinds of changes is the way to go or to create a brand new
> "stuff distribution protocol" is something I don't really have an
> opinion on - I just don't think BGP as we know it today is the answer.

What do you see missing in BGP (please be very specific) ?

> I'll just restate my earlier comment - it's about isolating each service
> so any failure will impact as small a portion of the customers as
> possible. And as the complexity increases, and the chances for failure
> with it, this becomes even more important.

I don't think there is any disagreement on the need to provide
isolation between services. It is just that some folks claim that
(a) there is no way to provide such isolation within BGP, (despite
the fact that there are products on the market that do provide such
isolation with BGP), and that (b) the new protocol is going to
provide such isolation (which at the present moment is nothing but
an unsubstantiated claim).

Yakov.

---

From: Yakov Rekhter <[email-masked]>
Date: Thu, 07 Aug 2003 13:01:39 -0700

Lars,

Yakov.