Subject: Re: bgp router id

From: "Alok Dube" <[email-masked]>
Date: Mon, 1 Dec 2003 14:09:14 +0530

> b) Since the router ID is used to resolve the opening of the connection,
>    it does NOT matter which address the router uses as long as it is
>    globally unique.  Using an RFC 1918 address would be... unfortunate.

....even if it is within an AS? (on iBGP interfaces)?

-thanks
Alok

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: "Alok Dube" <[email-masked]>
Date: Mon, 1 Dec 2003 14:09:14 +0530

-thanks
Alok

---

From: Mohacsi Janos <[email-masked]>
Date: Mon, 1 Dec 2003 13:43:20 +0100 (CET)

> ....even if it is within an AS? (on iBGP interfaces)?

For IBGP the usage of loopback is recommended, due to possible alternate
routes. Regards,
	Janos Mohacsi

---

From: Mohacsi Janos <[email-masked]>
Date: Mon, 1 Dec 2003 13:43:20 +0100 (CET)

---

From: "Alok Dube" <[email-masked]>
Date: Mon, 1 Dec 2003 18:23:14 +0530

I am not asking about the "uniqueness" of router-id.
frankly, loopback or no loopback, I dont quite understand how a node can
have multiple identifiers if one wants to prevent routing loops in case of
RRs..so i guess the router-id would be unique.

my question was specific to the address/identifier given to the iBGP
interface and/or to the router-id (even in case of RR)?

----- Original Message -----
From: "Mohacsi Janos" <[email-masked]>
To: "Alok Dube" <[email-masked]>
Cc: "Tony Li" <[email-masked]>; "Tulip Rasputin"
<[email-masked]>; <[email-masked]>
Sent: Monday, December 01, 2003 6:13 PM
Subject: Re: bgp router id

---

From: "Alok Dube" <[email-masked]>
Date: Mon, 1 Dec 2003 18:23:14 +0530

---

From: Curtis Villamizar <[email-masked]>
Date: Mon, 01 Dec 2003 08:47:05 -0500

> interface and/or to the router-id (even in case of RR)?

Unlike any other interface on the box, the loopback never goes down so
if you have a TCP connection, it will never go down as long as at
least one interface remains up and the router remains reachable.  It
is **strongly** recommended that the loopback interface be used for
all IBGP.  It was always convenient to use the same unique number (the
IPV4 address of the loopback) for the BGP Identifier.

For IPv6 we had to decouple the BGP Identifier from the TCP connection
address.  For IPv6 you should still use a loopback, but use some other
4 byte unique number for the BGP Identifier.  A good choice would be
the IPv4 address of the same loopback device seeing as IPv4 hasn't
shown any signs of going away.  In the hypothetical case where you
don't have such a thing, make up a number.

Curtis

---

From: Curtis Villamizar <[email-masked]>
Date: Mon, 01 Dec 2003 08:47:05 -0500

Curtis

---

From: "Alok Dube" <[email-masked]>
Date: Mon, 1 Dec 2003 19:24:50 +0530

Hi,

my question was why cant the IP/and or router-id be an RFC 1918 IP address
for peers which are *internal to the AS*...like RRs or iBGP speakers?

why is it  *unfortunate*??

i understand the bit about Loopback never being down, or the case where one
can have multiple IP ends for the sessions to the same peer with the same
Router-id etc.

i also understand that there is a field called Originator id in the RR RFC
(which may not have much relevance if one was to look at poison reverse or
cases where RRs would *not* send back routes learnt from RR back to the same
RR)..hence i feel that the loop may never be formed in such cases (full mesh
among RRs+all RRs are nonclients hence no route reflection among routes
learnt between RRs + poision reverse)

my question was :

why is using a RFC 1918 address as the address that the router uses for
setting up the BGP peering *unfortunate* if the peers are in the same AS and
do not interact with aany external entity?

-thanks
Alok

---

From: "Alok Dube" <[email-masked]>
Date: Mon, 1 Dec 2003 19:24:50 +0530

Hi,

my question was :

-thanks
Alok