Subject: Re: bgp router id

From: Tulip Rasputin <[email-masked]>
Date: Tue, 2 Dec 2003 05:43:19 -0500 (EST)

Alok,

My original question has been unanswered but I will attempt to answer yours.
 
> my question was why cant the IP/and or router-id be an RFC 1918 IP address
> for peers which are *internal to the AS*...like RRs or iBGP speakers?
> 
> why is it  *unfortunate*??

Suppose one of your IBGP peer aggregates some routes. It will put its Router ID in the Aggregator
field and will advertise this to other peers. Now, for this case, lets assume it uses an RFC 1918
IP address. There is a probability that when this path is leaked out of your own AS, and received
by some other IBGP peer (which again may use RFC 1918 addresses) of some other AS, things may not
go as expected. Its thus always better to use non RFC 1918 IP addresses for your BGP speakers.

> I also understand that there is a field called Originator id in the RR RFC
> (which may not have much relevance if one was to look at poison reverse or
> cases where RRs would *not* send back routes learnt from RR back to the same

Poison reverse only works for directly connected peers/routers. By "direct" I don't mean a
"direct" physical connection, but rather a "direct" logical connection. 

We need the concept of Originator ID in BGP because the RR can receive the path it originally
originated, from a peer, after it has traversed mulitple hops, and not necessarily from a router
to which it had advertised this before!

Simply put, Poison reverse will not help in BGP. 

The BGP experts may be able to provide a clearer picture.

Regards,
Rasputin

______________________________________________________________________ 
Post your free ad now! http://personals.yahoo.ca

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 1 Dec 2003 13:12:38 -0500

Tony and all: 

Enke Chen proposed no restrictions on router ID
in [draft-ietf-idr-bgp-identifier-03.txt].
I've attached an earlier version for anyone who wants
the reasoning.  

This Draft will be processed after the base specification.
So, it would be unfortunate to use RFC 1918.
 
Sue Hares

-----Original Message-----
From: Tony Li [mailto:[email-masked]]
Sent: Wednesday, November 26, 2003 11:31 PM
To: Tulip Rasputin; [email-masked]
Subject: RE: bgp router id

a) Since this is a BGP question, it truly belongs on the IDR list.
b) Since the router ID is used to resolve the opening of the connection,
   it does NOT matter which address the router uses as long as it is
   globally unique.  Using an RFC 1918 address would be... unfortunate.

Tony

|  -----Original Message-----
|  From: Tulip Rasputin [mailto:[email-masked]] 
|  Sent: Wednesday, November 26, 2003 5:23 PM
|  To: [email-masked]
|  Subject: bgp router id
|  
|  
|  Hi,
|  
|  I noticed a BGP behaviour and just wanted to confirm if it 
|  is indeed an anormal thing to happen. I
|  am not using a loopback IP address nor have I configured a 
|  BGP router ID. It thus picks up the
|  highest IP address available as its Router ID for all the 
|  BGP session that it establishes. Now
|  when this interface goes down it picks up the next highest 
|  IP address that is available and uses
|  it for all subsequent peerings.
|  
|  Isnt this odd? A single router using 2 different router IDs 
|  with two different peers?
|  
|  I know this is wrong. Either this router should continue 
|  with the same old router ID (even though
|  the interface it not there .. but that hardly matters!) that 
|  it had or it should select a new
|  router ID, break off connections with all the previous peers 
|  (very expensive!) and establish new
|  connections with peers using this new Router ID.
|  
|  I think it should be the former one. And when it finds that 
|  it has no more BGP speakers in FSM
|  state > OpenConfirm it can update use the new Router ID for 
|  all subsequent peerings.
|  
|  WOuld like to hear your opinion,
|  
|  Tulip
|  
|  
|  
|  _____________________________________________________________
|  _________ 
|  Post your free ad now! http://personals.yahoo.ca
|  
|  _______________________________________________
|  routing-discussion mailing list
|  [email-masked]
|  https://www1.ietf.org/mailman/listinfo/routing-discussion
|

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 1 Dec 2003 13:12:38 -0500

Tony and all: 

 
Sue Hares

-----Original Message-----
From: Tony Li [mailto:[email-masked]]
Sent: Wednesday, November 26, 2003 11:31 PM
To: Tulip Rasputin; [email-masked]
Subject: RE: bgp router id

Tony