Subject: How does router learn ASN ?

From: Abhishek Mittal <[email-masked]>
Date: Fri, 19 Dec 2003 21:51:38 -0800 (PST)

Hi All,
 
I have a small query.

How does router learn the ASN with respect to IP address while doing the trace.

route-views.oregon-ix.net>traceroute cisco.com
Translating "cisco.com"...domain server (128.223.32.35) [OK]
Type escape sequence to abort.
Tracing the route to cisco.com (198.133.219.25)
  1 net60-gw.uoregon.edu (128.223.60.1) [AS 3582] 4 msec 0 msec 0 msec
  2 0.ge-0-0-0.uonet8-gw.uoregon.edu (128.223.2.8) [AS 3582] 4 msec 0 msec 0 msec
  3 eugn-car1-gw.nero.net (207.98.66.11) [AS 3701] 0 msec 4 msec 0 msec
  4 eugn-core1-gw.nero.net (207.98.64.168) [AS 3701] 0 msec 0 msec 4 msec
  5 sl-gw26-stk-2-1.sprintlink.net (144.223.56.17) [AS 1239] 12 msec 12 msec 16 msec
  6 sl-bb20-stk-8-0.sprintlink.net (144.232.4.114) [AS 1239] 12 msec 16 msec 12 msec
  7 sl-bb20-sj-9-0.sprintlink.net (144.232.20.99) [AS 1239] 16 msec 16 msec 16 msec
  8 sl-gw11-sj-9-0.sprintlink.net (144.232.3.138) [AS 1239] 20 msec 16 msec 16 msec
  9 sl-ciscopsn2-11-0-0.sprintlink.net (144.228.44.14) [AS 1239] 16 msec 16 msec 12 msec
 10 sjck-dirty-gw1.cisco.com (128.107.239.5) [AS 109] 24 msec 24 msec 20 msec
 11 sjck-sdf-ciod-gw2.cisco.com (128.107.239.110) [AS 109] 20 msec 20 msec 20 msec
 12  *
    cisco.com (198.133.219.25) [AS 109] 20 msec 20 msec
route-views.oregon-ix.net>

Thanks & Regards,
Abhishek Mittal

---------------------------------
Do you Yahoo!?
New Yahoo! Photos - easier uploading and sharing

---

From: Jeffrey Haas <[email-masked]>
Date: Mon, 22 Dec 2003 13:36:21 -0500

> How does router learn the ASN with respect to IP address while doing the trace.

In most sane scenarios, a prefix is only originated by a single AS.
Every BGP route has an AS Path with the rightmost AS presumed to be
the originating AS.
Aggregation may break this. :-)

-- 
Jeff Haas 
NextHop Technologies

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: Jeffrey Haas <[email-masked]>
Date: Mon, 22 Dec 2003 13:36:21 -0500

-- 
Jeff Haas 
NextHop Technologies

---

From: Curtis Villamizar <[email-masked]>
Date: Mon, 29 Dec 2003 17:24:28 -0500

> In most sane scenarios, a prefix is only originated by a single AS.

Since when is BGP restricted to sane scenarios?  :-)

> Aggregation may break this. :-)

I think the question was in regard to a particular implememtation of
traceroute that listed an AS number with each hop.  Most host
traceroutes that do this refer to a routing registry for the mapping
of prefix to AS as the original prtraceroute did.  Since the
traceroute was from a U.Oregon route views server, the local BGP
information is more likely used.  Someone that administers those hosts
would know better.

Curtis

---

From: Curtis Villamizar <[email-masked]>
Date: Mon, 29 Dec 2003 17:24:28 -0500

Curtis

---

From: David Meyer <[email-masked]>
Date: Mon, 29 Dec 2003 14:29:36 -0800

>> information is more likely used.

The latter is correct. Dave

---

From: David Meyer <[email-masked]>
Date: Mon, 29 Dec 2003 14:29:36 -0800