Subject: Re: Ops and management section in RTG Area drafts

From: Pekka Savola <[email-masked]>
Date: Wed, 3 Nov 2004 08:10:48 +0200 (EET)

On Wed, 13 Oct 2004, Alex Zinin wrote:
> The idea of an ops-n-management section in RTG documents has been floating
> around for a while. This should provide considerations on this matter.
> Please review and post comments to this list.

I took a peek at the document.

This seems like potentially a good idea, but the idea is rather raw 
yet, so it's difficult to say.

However, to better grasp the severity (or not) of the situation, I'd 
like to know if someone could mention some documents which did not 
take the manageability into consideration in a sufficient manner.

I think there would need to be a bit more beef to the section 3 to 
describe what should be on the section.  It also might not hurt to 
write an example Management Considerations section for an existing RFC 
(where this was lacking) and put it in the appendix, as was done in 
RFC 3552 on security.  That ensures that at least the document authors 
go through the exercise of figuring out what needs to be in the 
section for a particular RFC :).

A couple of nits:
  - uppercase keywords probably should not be used in a process doc
  - which process would this be run through?  As a july14 experiment?
  - s/Consiederations/Considerations/
  - IANA considerations is not necessarily at the end of the body of 
the draft (depending on how you define 'body'), so I'd just say, just 
before IANA considerations.  (Actually, I'd prefer to say "just before 
security considerations.)

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 3 Nov 2004 09:05:25 -0000

Hey Pekka,

Thanks for reading!

All good points, and further discussion as well as drafting are clearly required.

> take the manageability into consideration in a sufficient manner.

I don't want to point fingers, but...
Probably a classic example is how O&M functions are being retrofitted in MPLS. LSP Ping,
traceroute, BFD etc. might be exactly the solutions we would have come up with had we
designed in from the start. OTOH we might have come up with a far clever way of doing
things. What is clear is that O&M requirements are still being finalised in MPLS some time
after the protocols went to RFC.

> section for a particular RFC :).

Yes. We certainly plan more beef in section 3.
As the draft says...
   THIS SECTION IS UNDER DEVELOPMENT.
   SUBSTANTIAL TEXT REMAINS TO BE WRITTEN.
   THE SUBSECTIONS COULD USEFULLY GIVE EXAMPLES

You're right that a comprehensive example would be useful. We also want to give in-line
examples in the context of each section.

>   - uppercase keywords probably should not be used in a process doc

Right.

>   - which process would this be run through?  As a july14 experiment?

Or April 1st?

I'd like the ADs to drive this point.

>   - s/Consiederations/Considerations/

I never could type (or run spell checkers)

> security considerations.)

Good point.

Thanks,
Adrian

PS. We'd really like some input on the list of things that the Manageability Section
should cover