Subject: Revising RFC 1264: implementation reqs for PS

From: Alex Zinin <[email-masked]>
Date: Mon, 11 Jul 2005 14:08:44 -0700

Taking this to the list for more eyes.

-- 
Alex
http://www.psg.com/~zinin

This is a forwarded message
From: Alex Zinin <[email-masked]>
To: Yakov Rekhter <[email-masked]>
Cc: [email-masked]
Date: Monday, July 11, 2005, 1:43:43 PM
Subject: draft-fenner-zinin-rtg-standard-reqts-00

===8<==============Original message text===============
Yakov,

  Thanks for reviewing the document!
  I agree with you.

-- 
Alex
http://www.psg.com/~zinin

Monday, July 11, 2005, 1:40:30 PM, Yakov Rekhter wrote:
> Alex and Bill,

> One quick comment on the draft. For PS the draft requires
> at least two implementation, but does not say anything
> about whether these two implementations should be independent.

> If the purpose of requiring two implementations is to show
> that the spec is sufficiently clear for implementation, then
> the implementations really should be required to be independent.

> Yakov.
===8<===========End of original message text===========

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: Alex Zinin <[email-masked]>
Date: Mon, 11 Jul 2005 14:15:13 -0700

// taking this one to the list too:

--
Alex

Monday, July 11, 2005, 1:58:48 PM, Yakov Rekhter wrote:
...
> Two other points:

> 1. From section 3:

>       All Routing Area submissions: In addition to the requirements
>       described in [RFC2026], a requirement that applies to all
>       documents submitted to the IESG for Internet Standards track
>       publication within the Routing Area is that a protocol or an
>       extension to it SHALL NOT be put on the Standards Track if no
>       implementation exists for it.  If it is desirable to encourage
>       implementation of a specification, publication as an Experimental
>       RFC SHOULD be considered.

> I am not sure the IETF should use RFCs as a way to encourage implementations.

> Also, turning an Internet Draft into an Experimental RFC could
> create a dis-incentive for producing a Standards Track document.

> 2. Given that the requirements for the Standards Track document
> are more strict in the Routing Area from all other areas, would
> not this create an incentive to start WGs in areas other than routing,
> and thus effectively bypass the requirements specified in your
> document ?

---

From: Bill Fenner <[email-masked]>
Date: Mon, 11 Jul 2005 17:46:49 -0400

> create a dis-incentive for producing a Standards Track document.

I agree with Yakov.  I thought I edited this out of the document
that I submitted - that's what I get for submitting from the beach.
Consider this paragraph deleted.

> and thus effectively bypass the requirements specified in your

Well, 1264 has theoretically been in force for quite some time,
and this only slightly strengthens 1264.  The Routing Area is
smaller than most other areas, but I'm pretty sure that the
IESG is smart enough to tell when someone is picking their area
just to avoid these rules.

  Bill

---

From: Alex Zinin <[email-masked]>
Date: Tue, 12 Jul 2005 16:40:08 -0700

> just to avoid these rules.

One other comments that we got unicast on this was that the process laid
out in the document should apply to routing protocols developed within the
IETF, not only routing area. This makes perfect sense to me.

--
Alex