Subject: FW: WG Review: Interface to the Routing System (i2rs)

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 16 Jan 2013 16:21:52 -0000

FYI

> -----Original Message-----
> From: [email-masked] [mailto:ietf-announce-
> [email-masked]] On Behalf Of The IESG
> Sent: 15 January 2013 16:43
> To: IETF-Announce
> Subject: WG Review: Interface to the Routing System (i2rs)
> 
> A new IETF working group has been proposed in the Routing Area. The IESG
> has not made any determination yet. The following draft charter was
> submitted, and is provided for informational purposes only. Please send
> your comments to the IESG mailing list (iesg at ietf.org) by 2013-01-22.
> 
> Interface to the Routing System (i2rs)
> ------------------------------------------------
> Current Status: Proposed Working Group
> 
> Assigned Area Director:
>   Adrian Farrel <[email-masked]>
> 
> Mailing list
>   Address: [email-masked]
>   To Subscribe: https://www.ietf.org/mailman/listinfo/i2rs
>   Archive:
> http://www.ietf.org/mail-archive/web/i2rs/current/maillist.html
> 
> Charter of Working Group:
> 
> Working Group Name:
>         Interfaces to the Routing System (I2RS)
> 
> IETF Area:
>         Routing Area
> 
> Chair(s):
>         TBD
> Routing Area Director(s):
>         Adrian Farrel
> Routing Area Advisor:
>         Adrian Farrel
> Operations Area Advisor:
>         TBD
> 
> Mailing Lists:
>         General Discussion: [email-masked]
>         To Subscribe: https://www.ietf.org/mailman/listinfo/i2rs
>         Archive:
> http://www.ietf.org/mail-archive/web/i2rs/current/maillist.html
> 
> Description of Working Group:
> 
>  In an IP routed network, the routing system:
> 
>  - Distributes topology and other state (network metadata)
>  - Uses this network metadata to determine the best path to each given
>    reachable destination attached to the network
>  - Communicates these decisions to the forwarding plane of each
>    forwarding device in the network.
> 
>  That is, the routing system is the collection of entities, protocols
>  and processes that collectively build the forwarding tables that are
>  exported into the entities that constitute the network's fowarding
>  plane.
> 
>  While processes participating in the routing system are often colocated
>  with the local forwarding elements, this isn't a necessary condition.
>  Thus, the routing system includes control plane protocols that compute
>  routes and paths for data packets, wherever the processes implementing
>  those protocols may be running.
> 
>  I2RS facilitates real-time or event driven interaction with the routing
>  system through a collection of protocol-based control or management
>  interfaces. These allow information, policies, and operational
>  parameters to be injected into and retrieved (as read or by
>  notification) from the routing system while retaining data consistency
>  and coherency across the routers and routing infrastructure, and among
>  multiple interactions with the routing system. The I2RS interfaces will
>  co-exist with existing configuration and management systems and
>  interfaces.
> 
>  It is envisioned that users of the I2RS interfaces will be management
>  applications, network controllers, and user applications that make
>  specific demands on the network.
> 
>  The I2RS working group works to develop a high-level framework and
>  architecture that describes the basic building-blocks necessary to
>  enable the specific use cases, and that will lead to an understanding
>  of the abstract informational models and requirements for
>  encodings and protocols for the I2RS interfaces. Small and well-scoped
>  use cases are critical to constrain the scope of the work and achieve
>  sufficient focus for the working group to deliver successful outcomes.
>  Initial work within the working group will be limited to a single
>  administrative domain.
> 
>  The working group is chartered to work on the following items:
> 
>  - High-level architecture and framework for I2RS including
>    considerations of policy and security.
> 
>  - Tightly scoped key use cases for operational use of I2RS as follows:
>     o Interactions with the Routing Information Base (RIB). Allowing
>       read and write access to the RIB, but no direct access to the
>       Forwarding Information Base (FIB).
>     o Control and analysis of the operation of the Border gateway
>       Protocol (BGP) including the setting and activation of policies
>       related to the protocol.
>     o Control, optimization, and choice of traffic exit points from
>       networks based on more information than provided by the dynamic
>       control plane.
>     o Distributed reaction to network-based attacks through quickly
>       modification of the control plane behavior to reroute traffic for
>       one destination while leaving a standard mechanisms (filters,
>       metrics, and policy) in place for other routes.
>     o Service layer routing to improve on existing hub-and-spoke
>       traffic.
>     o The ability to extract information about topology from the
>       network. Injection and creation of topology will not be considered
>       as an initial work item.
> 
>     Other use cases may be adopted by the working group only through
>     rechartering.
> 
>  - Abstract information models consistent with the use cases.
> 
>  - Requirements for I2RS protocols and encoding languages.
> 
>  - An analysis of existing IETF and other protocols and encoding
>    languages against the requirements.
> 
>  The working group is not currently chartered to develop protocols,
>  encoding languages, or data models. The objective of this work effort
>  is to arrive at common standards for these items, but these items are
>  dependent on the progress of the topics listed above. Work for these
>  items will be conducted in this working group only after a re-charter,
>  and/or may be carried out in another working group with specific
>  responsibility for the protocol or encoding language.
> 
> Goals and Milestones:
> 
> Jul 2013: Request publication of an Informational document defining the
>           problem statement
> Jul 2013: Request publication of an Informational document defining the
>           highlevel architecture and framework
> Aug 2013: Request publication of Informational documents describing use
>           cases
> Sep 2013: Request publication of an Informational document defining the
>           protocol  requirements
> Sep 2013: Request publication of an Informational document defining
>           encoding language requirements
> Nov 2013: Request publication of Standards Track documents specifying
>           information models
> Nov 2013: Request publication of an Informational document providing an
>           analysis of existing IETF and other protocols and encoding
>           languages against the requirements
> Dec 2013: Consider re-chartering
>

---

From: karim benhamouche <[email-masked]>
Date: Wed, 16 Jan 2013 14:04:38 -0500

Hi Adrian,

Is it related to SDN ?

------------------------------------------------------
*Karim Benhamouche, CCIE #24645
*
Sr. IP Network Specialist and CEO
Spécialiste Sénior en Réseaux IP et Président
Montreal: (514) 371-0734 / Toronto: (647) 874-5544
Email / Courriel: [email-masked]

On Wed, Jan 16, 2013 at 11:21 AM, Adrian Farrel <[email-masked]> wrote:

> _______________________________________________
> routing-discussion mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/routing-discussion
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 16 Jan 2013 20:43:52 -0000

Hi Karim,
 
What can I say? RTFM.
 
Well, read the draft charter, and read the I-Ds that exist. You can find the
I-Ds by searching for "-irs-" in the datatracker.
 
Also read the slides from the BoF in Atlanta.
 
Cheers,
Adrian
 
From: karim benhamouche [mailto:[email-masked]] 
Sent: 16 January 2013 19:05
To: [email-masked]
Cc: [email-masked]
Subject: Re: FW: WG Review: Interface to the Routing System (i2rs)
 
Hi Adrian,
 
Is it related to SDN ?

---

From: karim benhamouche <[email-masked]>
Date: Wed, 16 Jan 2013 15:55:22 -0500

I will do.
Thanks for these informations.

On Wed, Jan 16, 2013 at 3:43 PM, Adrian Farrel <[email-masked]> wrote:

> Hi Karim,****
>
> ** **
>
> What can I say? RTFM.****
>
> ** **
>
> Well, read the draft charter, and read the I-Ds that exist. You can find
> the I-Ds by searching for "-irs-" in the datatracker.****
>
> ** **
>
> Also read the slides from the BoF in Atlanta.****
>
> ** **
>
> Cheers,****
>
> Adrian****
>
> ** **
>
> *From:* karim benhamouche [mailto:[email-masked]]
> *Sent:* 16 January 2013 19:05
> *To:* [email-masked]
> *Cc:* [email-masked]
> *Subject:* Re: FW: WG Review: Interface to the Routing System (i2rs)****
>
> ** **
>
> Hi Adrian,****
>
> ** **
>
> Is it related to SDN ?****
>
> ** **
>
> On Wed, Jan 16, 2013 at 11:21 AM, Adrian Farrel <[email-masked]>
> wrote:****
>
> FYI
>
> > ------------------------------------------------****
>

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 18 Jan 2013 00:32:14 +0100

Hi Karim,

I don't think it is related only if this SDN ir related-to/includes
routing systems, but I think we will start to discuss if related or
not.

AB

On 1/16/13, karim benhamouche <[email-masked]> wrote:
> wrote: