Subject: Re: question on link state routing protocols

From: [email-masked] (Noel Chiappa)
Date: Wed, 8 May 2013 15:15:04 -0400 (EDT)

> From: Tony Li <[email-masked]>

    > Fair, but this is exactly why 802.11 has a built-in link layer
    > mechanism. No need to replicate it at a higher layer.

I guess I still don't understand why IS-IS doesn't have the most robust
possible update flooding mechanism, though - the potential consequences of
out-of-sync maps (forwarding loops) are so severe.

There must be something I'm missing (especially since they include the robust
mechanism on point-point links). And it can't be because they didn't want
to fuss with N^2, or having a DR to avoid that - IS-IS does have a DR.

I guess the right thing to do is ask the people who designed it. (Which I
guess would be Radia, Ross and Dave Oran?)

	Noel

---

From: Ross Callon <[email-masked]>
Date: Wed, 8 May 2013 20:06:14 +0000

I am hoping that Radia or Dave Oran will speak up. I *used* to know the answer to this question, but have forgotten the details. 

Ross

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Noel Chiappa
Sent: Wednesday, May 08, 2013 3:15 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: question on link state routing protocols

	Noel
_______________________________________________
routing-discussion mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/routing-discussion

---

From: Tony Li <[email-masked]>
Date: Wed, 8 May 2013 14:07:09 -0700

Noel,

> out-of-sync maps (forwarding loops) are so severe.

With all due respect, you have it backwards.  The CSNP mechanism is FAR more robust than a LSP-by-LSP acknowledgement.  It is a continuing and ongoing cross-checksum between adjacencies.  With IS-IS, if an LSP is lost in flight, then it is caught in the next CSNP cycle and retransmitted.  Further, if something happens in memory on either system and LSPs are lost, then they get retransmitted.  And there's only one mechanism to take care of both.

Tony