Subject: Improving and Restructuring the Routing Area

From: Alia Atlas <[email-masked]>
Date: Tue, 10 Jun 2014 15:57:45 -0400

To all participants in the Routing Area,

Adrian and I are working on improving the quality, speed, and
experience of getting work done in the IETF Routing Area.  There are
three initiatives that we are working: WG Draft QA, Routing Area
specific WG chair training, and reorganizing the working groups in the
area.

First, we intend to use our Routing Directorate more proactively by
introducing a Working Group Draft Quality Assurance (WG Draft QA)
process where the same selected routing directorate member will review
a draft during WG draft adoption and during WG last call.  The process
will be documented on the Routing Area wiki
(http://trac.tools.ietf.org/area/rtg/trac/wiki).  This should allow
directorate reviews to report technical issues that can actually get
fixed early in the process (equivalent of bug reports) as opposed to
just noting the concerns in the drafts (equivalent of release notes).

Second, as was discussed during the recent IESG retreat, in addition
to the IETF-wide WG chair training, we intend to have a series of
training sessions for WG Chairs in the Routing Area addressing topics
such as judging consensus, project management, motivating volunteers,
using the datatracker (via a sandbox version that can be played
with safely), and sharing experiences between WG chairs.

Third, we intend to reorganize the working groups in the Routing area.
We feel that it is important to focus on areas where there is active
interest in standardization and to be open and able to accept new work
into the area.  As you know, we have had several new working groups
(nvo3, i2rs, sfc, spring) created in the last few years and we need to
be open and able to handle more new work as it comes in.  We would
also like to improve the signal-to-noise ratio experienced by
participants in the different working groups and improve the quantity
and quality of discussion and reviews.  It is likely that not all WGs
in the Routing Area will be directly affected.

Here is the time-line for reorganizing the WGs.

   NOW: public discussion on [email-masked] about how to
   reorganize the working groups to best meet our motivations.
   Additional focused discussions are expected on the
   [email-masked] and [email-masked] mailing lists.

   In Toronto: There will be meetings with the WG chairs and the
   Routing Directorate to get the ideas described and agreed upon.

   At the Routing Area Meeting in Toronto: Discuss the set of
   reorganized WGs and general charter content in the Routing Area
   meeting.

   September 2014: Based upon the feedback, suggestions, and
   discussion, Adrian and I finalize the reorganized WG charters.  We
   start the internal IESG discussion and public reviews.

   October 2014: Formal rechartering process completes.

   In Honolulu: The new set of WGs meet.

   After Honolulu: Adrian and I deal with any issues and charter
   updates based upon a few months of experience.

Here are the motivations that Adrian and I would like to be considered
when coming up with ideas for how the WGs should be reorganized.

   1) Move towards organizing working groups on functional
   responsibilities rather than scoping them to specific protocols.

   2) Split giant working groups so relevant work is done in one place
   and there is an improved signal-to-noise ratio for participants who
   are only interested in a slice of the current working group's work.

   3) Create synergies for scattered functionality (example ideas:
   OAM, FRR, traffic-engineering)

   4) Create a DISPATCH working group for clear new idea discussion;
   rtgwg serves some of this purpose but doesn't have a clear process
   and isn't drawing in the new ideas.

   5) Focus Routing Area time on design centers rather than on far
   corner cases.

   6) Each working group should have clear, well defined, and achievable
goals.

Noting that the Routing Area has inherited some of its WG structure
from the sub-IP area, it is not a goal to force IP routing and MPLS
routing to remain separated.

The goal of this reorganization is not closing working groups.  Adrian
and Alia are perfectly capable of closing working groups without going
through restructuring.

For those of you that have read this far, thank you.  Getting this 80%
right is going to take some serious discussion and thought.  We all
work in the Routing Area together with different perspectives.  Please
think carefully and help us have a highly focused discussion.

Thanks,
Alia and Adrian

---

From: Ross Callon <[email-masked]>
Date: Tue, 10 Jun 2014 22:08:48 +0000

I think that there is quite a bit of content in this email, and that we might need to end up with several threads -- such as one for routing directorate changes, one for WG chair training, and one for WG reorganization.

Speaking for the latter – WG reorganization, and specifically on dealing with very large WGs: I think that there is a tradeoff here. Very large WGs can be cumbersome and might not be as “focused” as smaller groups. However, it is much easier or more likely for work to diverge when it is split into multiple groups.

As one example, one obviously large group is MPLS. Looking at the work going on in MPLS, one possible way to split it up would be to split off the OAM work. However, how to manage a protocol is very much tied into other aspects of the operation of the protocol. If people working on one aspect of a protocol are bored listening to OAM discussions, it might nonetheless be a good idea for them to listen to OAM discussions.

Do we want to get into discussing details pertinent to specific WGs?

Thanks, Ross

From: routing-discussion [mailto:[email-masked]] On Behalf Of Alia Atlas
Sent: Tuesday, June 10, 2014 3:58 PM
To: [email-masked]
Subject: Improving and Restructuring the Routing Area

   NOW: public discussion on [email-masked]<mailto:[email-masked]> about how to
   reorganize the working groups to best meet our motivations.
   Additional focused discussions are expected on the
   [email-masked]<mailto:[email-masked]> and [email-masked]<mailto:[email-masked]> mailing lists.

   6) Each working group should have clear, well defined, and achievable goals.

Thanks,
Alia and Adrian

---

From: Martin Vigoureux <[email-masked]>
Date: Thu, 12 Jun 2014 14:30:34 +0200

>     responsibilities rather than scoping them to specific protocols.

Alia, Adrian,

I do not know if that is crystal clear for every one, but if we plan to 
end-up with such organization may be it would be worth listing, 
defining/scoping and agreeing on the functions.

Is this what you have in mind:

routing, forwarding/encapsulation, resource control, resilience, oam, 
VPNs, mcast, ...

Also, beyond the functional areas we will end up with, I tend to think 
that there are elements which would be transversal
inter-domain (routing, resource control, path computation)
security

Your views and those of others are welcome.
Thx

-m

---

From: Loa Andersson <[email-masked]>
Date: Thu, 12 Jun 2014 14:41:56 +0200

Folks,

I think that Martin asks good questions. I'm not convinced that 
splitting working groups along "functions" even if we can agree what
functions should be the basis for the split.

I think that one aspect tht has not been at all mentioned is that
working groups should be established such the need for coordination
between them are minimized. And before yoou start yelling at me, yes
there are a need for coordiantion almost always, but I strive to
minimize

I'd also say that one protocol goes into one working group (again
as far as possible). We have had two coordination activities where we
mostly succeeded LDP for LSPs to MPLS, LDP for PWs to PWE3, and RSVP-TE
for anything but packet to CCAMP, RSVP-TE for packet to MPLS.

/Loa

On 2014-06-12 14:30, Martin Vigoureux wrote:
> _______________________________________________
> routing-discussion mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/routing-discussion

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 18 Jun 2014 11:53:51 +0100

Thanks Alia and Adrian,

Dear All,

I agree that the area should restructure and follow more clear
IETF-management-objectives for the area. I will try mt best to comment but
that does not mean my input is best, just writting thoughts which may help.
Some suggested before that WGs were not working together, they are
separate, and that it was not the way of progress.Your message did not
mention the reasons of this or did not define the problem.  I think the
main problem is the management not the participants or the organising of
concensus, if we know the reasons of our problem it is the best start to
avoid it repeat.

My comments/discuusion below:

I will start with the last paragraph:

 {For those of you that have read this far, thank you.  Getting this 80%
right is going to take some serious discussion and thought.  We all
work in the Routing Area together with different perspectives.  Please
think carefully and help us have a highly focused discussion.}

Two thinking points :

a) I see the discussion can be: 1) Area Restructure, 2) WGs Reorganising or
closing, 3) WG's Charters and Functions. Please show us the way for future
discussings.

 b) IETF Routing Area performance after change. What is the principle
reasons to make us do closing a WG or merging some WGs into one? Please
note that there are possibilities that other organisations may like to
close many IETF-WGs but is that good for the community? Will we have the
same speed after reorganising?

more below:

> specific WG chair training, and reorganizing the working groups in the

Why are they the only priority? I suggest to add Participation and
Management Quality Assurance, the problem is not the draft but is who are
working in the WG with Chair with AD. If we get reasonable participation
and more volunteering and more acknowledgemnts, then we will get better
drafts.

> with safely), and sharing experiences between WG chairs.

In my opinion, the WG chairs in this area should communicate more often on
the lists, some WGs do already and they make it work with quality but some
WG have busy Chairs therefore we get low quality in participation and
reviews. The ADs should force Editors and Chairs to volunteer more. I had a
comment to an editor in another area but still got no respond because the
chair/AD accepted that behavior, and I did not.

>    Routing Directorate to get the ideas described and agreed upon.

Please report the results and what will be done to this list, because you
may meet any time but what is the value/results of the meeting is more
important.

>    reorganized WGs and general charter content in the Routing Area

I suggest, first each WG in the area discuss and deliver a report to the
ADs of their feedback with WG consensus.

>    start the internal IESG discussion and public reviews.

I suggest that ADs receive from individuals feedback and also from WG
feedbacks (including its recharter ideas), so each WG have discussed on its
list and gave it WG report to ADs and then here in this list each
individual can put their individual opinion.

>    October 2014: Formal rechartering process completes.

Recharter is not enough, to solve the current issue you want to solve.

>    responsibilities rather than scoping them to specific protocols.

IMO, that is not enough, you need first to make sure that each one WG is
organised, then you start moving toward organising WGs.

>    are only interested in a slice of the current working group's work.

IMHO, that is very wrong decision, please why we separating while we want
to organise and volunteer together. This

>    and isn't drawing in the new ideas.

This preferable to be f2f meeting only WG.

>    6) Each working group should have clear, well defined, and achievable

This should be in the charter and ADs should follow up with the goals and
milestones.

> and Alia are perfectly capable of closing working groups without going

IMO, usually restructure is more about managment (ADs, Chairs, and
departments) than about participants work. Reorganising and closing WG is
necessary at any time if there is a need which does not affect each
work/draft/participant.

Thanks,

AB

---

From: <[email-masked]>
Date: Wed, 18 Jun 2014 12:08:44 +0000

"I suggest to add Participation and Management Quality Assurance, the problem is not the draft but is who are working in the WG with Chair with AD. If we get reasonable participation and more volunteering and more acknowledgemnts, then we will get better drafts."

I suggest reading Robert M. Pirsig's "Zen and the Art of Motorcycle Maintenance."

It's about what happens to a PhD student who is obsessed with quality.

Lloyd Wood
http://about.me/lloydwood
________________________________
From: routing-discussion <[email-masked]> on behalf of Abdussalam Baryun <[email-masked]>
Sent: Wednesday, 18 June 2014 8:53 PM
To: Alia Atlas
Cc: [email-masked]
Subject: Re: Improving and Restructuring the Routing Area

Thanks Alia and Adrian,

Dear All,

I agree that the area should restructure and follow more clear IETF-management-objectives for the area. I will try mt best to comment but that does not mean my input is best, just writting thoughts which may help. Some suggested before that WGs were not working together, they are separate, and that it was not the way of progress.Your message did not mention the reasons of this or did not define the problem.  I think the main problem is the management not the participants or the organising of concensus, if we know the reasons of our problem it is the best start to avoid it repeat.

Two thinking points :

a) I see the discussion can be: 1) Area Restructure, 2) WGs Reorganising or closing, 3) WG's Charters and Functions. Please show us the way for future discussings.

b) IETF Routing Area performance after change. What is the principle reasons to make us do closing a WG or merging some WGs into one? Please note that there are possibilities that other organisations may like to close many IETF-WGs but is that good for the community? Will we have the same speed after reorganising?

more below:

On Tue, Jun 10, 2014 at 8:57 PM, Alia Atlas <[email-masked]<mailto:[email-masked]>> wrote:
To all participants in the Routing Area,

Why are they the only priority? I suggest to add Participation and Management Quality Assurance, the problem is not the draft but is who are working in the WG with Chair with AD. If we get reasonable participation and more volunteering and more acknowledgemnts, then we will get better drafts.

In my opinion, the WG chairs in this area should communicate more often on the lists, some WGs do already and they make it work with quality but some WG have busy Chairs therefore we get low quality in participation and reviews. The ADs should force Editors and Chairs to volunteer more. I had a comment to an editor in another area but still got no respond because the chair/AD accepted that behavior, and I did not.

Please report the results and what will be done to this list, because you may meet any time but what is the value/results of the meeting is more important.

I suggest, first each WG in the area discuss and deliver a report to the ADs of their feedback with WG consensus.

I suggest that ADs receive from individuals feedback and also from WG feedbacks (including its recharter ideas), so each WG have discussed on its list and gave it WG report to ADs and then here in this list each individual can put their individual opinion.

IMO, that is not enough, you need first to make sure that each one WG is organised, then you start moving toward organising WGs.

IMHO, that is very wrong decision, please why we separating while we want to organise and volunteer together. This

This should be in the charter and ADs should follow up with the goals and milestones.

IMO, usually restructure is more about managment (ADs, Chairs, and departments) than about participants work. Reorganising and closing WG is necessary at any time if there is a need which does not affect each work/draft/participant.

Thanks,
Alia and Adrian

Thanks,

AB

---

From: Christian Hopps <[email-masked]>
Date: Thu, 19 Jun 2014 05:47:08 -0400

Hi isis-wg,

Please be aware of the ongoing discussion related to improving the Routing Area. The discussion is taking place on  [email-masked], so please subscribe and join in if interested.

Thanks,
Chris.

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 19 Jun 2014 22:06:32 +0100

Hi Ross,

Thanks. I want to discuss your point more further, my comments below,

On Tuesday, June 10, 2014, Ross Callon wrote:

>  I think that there is quite a bit of content in this email, and that we
> might need to end up with several threads -- such as one for routing
> directorate changes, one for WG chair training, and one for WG
> reorganization.
>
>
> Yes, I think it will be good to discuss here before the next meetings,
because it is a big change for this IETF large area.

>
>
> Speaking for the latter – WG reorganization, and specifically on dealing
> with very large WGs: I think that there is a tradeoff here. Very large WGs
> can be cumbersome and might not be as “focused” as smaller groups.
>
>
There are old WGs and large WGs (old in participation or large in
participation), I think large WGs are difficult to reorganise, because we
may reduce interests to participate.  The most important issue is not in
participation but in team work, if WGs are just groups with no team work
then the work or the output is with low quality. On the other hand small
WGs may not be focused because the group is not working as a team.

> However, it is much easier or more likely for work to diverge when it is
> split into multiple groups.
>
> We may split but still there should be links between the groups, otherwise
we loose the value of the main routing use cases. The ADs  and
WGs' chairs should maintain those links.

>
>
> As one example, one obviously large group is MPLS. Looking at the work
> going on in MPLS, one possible way to split it up would be to split off the
> OAM work. However, how to manage a protocol is very much tied into other
> aspects of the operation of the protocol. If people working on one aspect
> of a protocol are bored listening to OAM discussions, it might nonetheless
> be a good idea for them to listen to OAM discussions.
>
>
>
Because I don't know why we are changing, I think it is important to start
with the principles of reorganising and closing, as what make us select
some WGs to reorganise? But if the reason of the ADs to think of
reorganising is some specific WGs then we may just start with specifying
them.

Best,
AB

---

From: Ross Callon <[email-masked]>
Date: Thu, 26 Jun 2014 14:55:32 +0000

One issue that occurs to me is the split between L2VPN and L3VPN. PWE3 seems to be closely related.

I remember when PPVPN was split into L2VPN and L3VPN. At the time there was a rather active debate going on regarding L2VPN standards that was causing the L3VPN work to be sort of lost in the noise. This particular motivation for the split ended long ago.

I don’t have a strong opinion regarding whether L2VPN, L3VPN, and PWE3 should stay separate or should merge, but I think that it is a question which is worth asking.

Thanks, Ross

Thanks,
Alia and Adrian

---

From: Giles Heron <[email-masked]>
Date: Thu, 26 Jun 2014 17:12:25 +0100

Yes, worth consideration for sure.

The 3 groups are certainly a lot less active than they were once.  And while L2VPN is probably the most active, the majority of that activity is around EVPN - which uses similar mechanisms to IPVPN/RFC4364.  There are also drafts which straddle the L2/L3 divide (e.g. for integrated L2 and L3 forwarding in the data-center).  And re PWE3 we're just adopting a draft in L2VPN which was previously in PWE3 - so the boundary there can be a bit blurry too.  Though PWE's blurrier (if that's even a word) boundary may be that with MPLS.

I think there might also be value in doing VPN YANG models in one place (if we agree that we need to do YANG models now as well as/instead of MIBs) as we can ensure maximum commonality in the models that way.

speaking only for myself, and not for my co-chair, of course.

Giles

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 26 Jun 2014 13:22:44 -0400

Also, speaking for myself (and not my PWE3 co-chair), I agree with Giles
(and an earlier comment from Stewart) that the current work in PWE3 is
closer to that in the MPLS WG than the L2VPN WG. For the most part, we're
working on various extensions to LDP for PW setup and maintenance. That
said, whether MPLS & PWE3 should be merged is dependent on other factors as
well, such whether this would be putting too much into one WG (the "big" WG
syndrome).

Cheers,
Andy

On Thu, Jun 26, 2014 at 12:12 PM, Giles Heron <[email-masked]> wrote:

> The 3 groups are certainly a lot less active than they were once.  And
> while L2VPN is probably the most active, the majority of that activity is
> around EVPN - which uses similar mechanisms to IPVPN/RFC4364.  There are
> also drafts which straddle the L2/L3 divide (e.g. for integrated L2 and L3
> forwarding in the data-center).  And re PWE3 we're just adopting a draft in
> L2VPN which was previously in PWE3 - so the boundary there can be a bit
> blurry too.  Though PWE's blurrier (if that's even a word) boundary may be
> that with MPLS.
>
> I think there might also be value in doing VPN YANG models in one place
> (if we agree that we need to do YANG models now as well as/instead of MIBs)
> as we can ensure maximum commonality in the models that way.
>
> > I remember when PPVPN was split into L2VPN and L3VPN. At the time there
> was a rather active debate going on regarding L2VPN standards that was
> causing the L3VPN work to be sort of lost in the noise. This particular
> motivation for the split ended long ago.
> >
> > I don’t have a strong opinion regarding whether L2VPN, L3VPN, and PWE3
> should stay separate or should merge, but I think that it is a question
> which is worth asking.
> >
> > Thanks, Ross
> >

---

From: "Shah, Himanshu" <[email-masked]>
Date: Thu, 26 Jun 2014 16:14:07 -0400

IMHO – PWE3 is more tightly coupled to L2VPN and merge there than to MPLS.
This way, we will avoid BIG wg syndrome.

Regards,
himanshu

From: routing-discussion [mailto:[email-masked]] On Behalf Of Andrew G. Malis
Sent: Thursday, June 26, 2014 1:23 PM
To: Giles Heron
Cc: Ross Callon; [email-masked]
Subject: Re: LxVPN, RE: Improving and Restructuring the Routing Area

Also, speaking for myself (and not my PWE3 co-chair), I agree with Giles (and an earlier comment from Stewart) that the current work in PWE3 is closer to that in the MPLS WG than the L2VPN WG. For the most part, we're working on various extensions to LDP for PW setup and maintenance. That said, whether MPLS & PWE3 should be merged is dependent on other factors as well, such whether this would be putting too much into one WG (the "big" WG syndrome).

Cheers,
Andy

On Thu, Jun 26, 2014 at 12:12 PM, Giles Heron <[email-masked]<mailto:[email-masked]>> wrote:
Yes, worth consideration for sure.

Giles

On 26 Jun 2014, at 15:55, Ross Callon <[email-masked]<mailto:[email-masked]>> wrote:

> From: routing-discussion [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Alia Atlas
> To: [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
routing-discussion mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/routing-discussion