Subject: RE: OAM and restructuring the Rtg Area

From: Qin Wu <[email-masked]>
Date: Wed, 11 Jun 2014 09:55:20 +0000

Hi,
I like the suggestion made by Ross about restructure for OAM. There is OAM in some RTG working groups and it needs coordination. Also there is the management of OAM function with the control plane. It would be interesting to have single working group for OAM in routing area.
Please see that we have proposed a BoF for Toronto called the TIME BoF http://trac.tools.ietf.org/bof/trac/ We don't know if we get granted, but there is a mailing list and Internet-Drafts that discuss ideas to have common OAM approaches in the IETF.

Regards!
-Qin
From: routing-discussion [mailto:[email-masked]] On Behalf Of Ross Callon
Sent: 10 June 2014 23:09
To: Alia Atlas; [email-masked]<mailto:[email-masked]>
Subject: RE: Improving and Restructuring the Routing Area

I think that there is quite a bit of content in this email, and that we might need to end up with several threads -- such as one for routing directorate changes, one for WG chair training, and one for WG reorganization.

Speaking for the latter – WG reorganization, and specifically on dealing with very large WGs: I think that there is a tradeoff here. Very large WGs can be cumbersome and might not be as “focused” as smaller groups. However, it is much easier or more likely for work to diverge when it is split into multiple groups.

As one example, one obviously large group is MPLS. Looking at the work going on in MPLS, one possible way to split it up would be to split off the OAM work. However, how to manage a protocol is very much tied into other aspects of the operation of the protocol. If people working on one aspect of a protocol are bored listening to OAM discussions, it might nonetheless be a good idea for them to listen to OAM discussions.

Do we want to get into discussing details pertinent to specific WGs?

Thanks, Ross

From: routing-discussion [mailto:[email-masked]] On Behalf Of Alia Atlas
Sent: Tuesday, June 10, 2014 3:58 PM
To: [email-masked]<mailto:[email-masked]>
Subject: Improving and Restructuring the Routing Area

To all participants in the Routing Area,

Adrian and I are working on improving the quality, speed, and
experience of getting work done in the IETF Routing Area.  There are
three initiatives that we are working: WG Draft QA, Routing Area
specific WG chair training, and reorganizing the working groups in the
area.

First, we intend to use our Routing Directorate more proactively by
introducing a Working Group Draft Quality Assurance (WG Draft QA)
process where the same selected routing directorate member will review
a draft during WG draft adoption and during WG last call.  The process
will be documented on the Routing Area wiki
(http://trac.tools.ietf.org/area/rtg/trac/wiki).  This should allow
directorate reviews to report technical issues that can actually get
fixed early in the process (equivalent of bug reports) as opposed to
just noting the concerns in the drafts (equivalent of release notes).

Second, as was discussed during the recent IESG retreat, in addition
to the IETF-wide WG chair training, we intend to have a series of
training sessions for WG Chairs in the Routing Area addressing topics
such as judging consensus, project management, motivating volunteers,
using the datatracker (via a sandbox version that can be played
with safely), and sharing experiences between WG chairs.

Third, we intend to reorganize the working groups in the Routing area.
We feel that it is important to focus on areas where there is active
interest in standardization and to be open and able to accept new work
into the area.  As you know, we have had several new working groups
(nvo3, i2rs, sfc, spring) created in the last few years and we need to
be open and able to handle more new work as it comes in.  We would
also like to improve the signal-to-noise ratio experienced by
participants in the different working groups and improve the quantity
and quality of discussion and reviews.  It is likely that not all WGs
in the Routing Area will be directly affected.

Here is the time-line for reorganizing the WGs.

   NOW: public discussion on [email-masked]<mailto:[email-masked]> about how to
   reorganize the working groups to best meet our motivations.
   Additional focused discussions are expected on the
   [email-masked]<mailto:[email-masked]> and [email-masked]<mailto:[email-masked]> mailing lists.

   In Toronto: There will be meetings with the WG chairs and the
   Routing Directorate to get the ideas described and agreed upon.

   At the Routing Area Meeting in Toronto: Discuss the set of
   reorganized WGs and general charter content in the Routing Area
   meeting.

   September 2014: Based upon the feedback, suggestions, and
   discussion, Adrian and I finalize the reorganized WG charters.  We
   start the internal IESG discussion and public reviews.

   October 2014: Formal rechartering process completes.

   In Honolulu: The new set of WGs meet.

   After Honolulu: Adrian and I deal with any issues and charter
   updates based upon a few months of experience.

Here are the motivations that Adrian and I would like to be considered
when coming up with ideas for how the WGs should be reorganized.

   1) Move towards organizing working groups on functional
   responsibilities rather than scoping them to specific protocols.

   2) Split giant working groups so relevant work is done in one place
   and there is an improved signal-to-noise ratio for participants who
   are only interested in a slice of the current working group's work.

   3) Create synergies for scattered functionality (example ideas:
   OAM, FRR, traffic-engineering)

   4) Create a DISPATCH working group for clear new idea discussion;
   rtgwg serves some of this purpose but doesn't have a clear process
   and isn't drawing in the new ideas.

   5) Focus Routing Area time on design centers rather than on far
   corner cases.

   6) Each working group should have clear, well defined, and achievable goals.

Noting that the Routing Area has inherited some of its WG structure
from the sub-IP area, it is not a goal to force IP routing and MPLS
routing to remain separated.

The goal of this reorganization is not closing working groups.  Adrian
and Alia are perfectly capable of closing working groups without going
through restructuring.

For those of you that have read this far, thank you.  Getting this 80%
right is going to take some serious discussion and thought.  We all
work in the Routing Area together with different perspectives.  Please
think carefully and help us have a highly focused discussion.

Thanks,
Alia and Adrian

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 11 Jun 2014 09:52:36 -0400

Qin (and Ross),

On Wed, Jun 11, 2014 at 09:55:20AM +0000, Qin Wu wrote:
> I like the suggestion made by Ross about restructure for OAM. There is OAM
> in some RTG working groups and it needs coordination. Also there is the
> management of OAM function with the control plane. It would be interesting
> to have single working group for OAM in routing area.

We have an entire area (OPS) with part of this as their charter.  While I agree
there is a desire to get more involvement in OAM issues and perhaps
centralize some of the subject matter experts, how would a WG within routing
help?

I suspect an argument could even be made that MPLS OAM may belong in
transport or int. :-)

To some extent, the call from the ADs is to find a way to let work that
doesn't have strong boundaries have a home that removes those boundaries.
We should be considering this impact across IETF areas and not only within 
routing.  (meta-working groups, as I call them.)

-- Jeff

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 11 Jun 2014 16:42:25 +0100

Just a question, Jeff...

Don't we already have a WG in Routing that does OAM? 
Are you suggesting that BFD should move to INT?

We also have OAM in MPLS (LSP ping and MPLS-TP), CCAMP (where it is coordination
of OAM using the control plane), PWE3 and L2VPN (with a history of VCCV), and
NVO3 and SFC (currently floating new ideas related to OAM).

OTOH, your final para seems to suggest that bundling function (like OAM) into a
single WG and having that be cross-area in some sense would not be a bad idea.

Adrian

> -----Original Message-----
> From: routing-discussion [mailto:[email-masked]] On
Behalf
> Of Jeffrey Haas
> Sent: 11 June 2014 14:53
> To: Qin Wu
> Cc: [email-masked]; [email-masked]
> Subject: Re: OAM and restructuring the Rtg Area
> 
> Qin (and Ross),
>

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 11 Jun 2014 12:38:12 -0400

> Are you suggesting that BFD should move to INT?

I do like to ask leading questions. :-)

If we were to look at the work BFD does today, there would probably be the
same level of hand-wringing over whether it's a routing protocol used for
OAM or OAM that has routing components and thus belongs in INT.

> single WG and having that be cross-area in some sense would not be a bad idea.

Something cross-area is exactly what I have in mind, and think BFD probably
fits in the same boat.

Some of the other discussion also suggested we want more "agility" within
the IETF.

To me, these competing things suggest:
- Keep many of the trappings of a WG for specific work.  Mailing list,
  ability to have sessions, etc.
- Have related sub-WGs fit into a cross-area meta-group.  You could liken
  this to "dotted line" managerial relationships.

Thus, I don't think I'd kill BFD as a separate WG.  
We should spin-up the cross-area functionality and put BFD under such a
function.  IGP was a similar analogy for isis/ospf (and perhaps others).

But aside from "fostering communication" and "splitting work from overloaded
groups", I'm unclear what any of this does for us procedurally.  In my
experience, people already pay (at least partial) attention to related WGs.
If they don't, having something like a meta-area list that draws your
attention to classes of work is good.

BFD probably wouldn't change how often it needs to meet.  (Partially because
the chairs are aggressive about not meeting unless there is new content to
discuss in a room.)  

MPLS OAM would probably split into a separate session, but the people doing
much of that work would still need to heavily coordinate in the main MPLS WG.  

And to make a critical point: If such splits with coordination to related
WGs results in the need for the same presentation to happen more than one
place, we've *failed* in my opinion.

By comparison, if the same "the IGPs could use this feature" results in one
presentation to the IGP meta-WG, we've saved a wasted presentation slot and
discussion.  That's a win.

-- Jeff

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 11 Jun 2014 17:06:05 -0400

> function.  IGP was a similar analogy for isis/ospf (and perhaps others).

This reminds me of the sub-IP pseudo-area that we spun up in 2001, which
was jointly managed by the INT, OPS, RTG and TSV ADs. It had mpls, ccamp,
ppvpn (later to become l2vpn and l3vpn), IP over optical, and similar
groups that were dealing with sub-l3 issues. It worked very well, and could
be a case study for how to proceed here.

Cheers,
Andy

---

From: Qin Wu <[email-masked]>
Date: Thu, 12 Jun 2014 03:27:29 +0000

Hi, Jeffrey:
if my understanding is correct, joint meetings or sessions between two area is usually rare.
Collaboration is almost always through individuals participating in both OPS area and RTG area.
Therefore removing boundary between two areas seems a really good idea to me.

Regards!
-Qin
-----邮件原件-----
发件人: Jeffrey Haas [mailto:[email-masked]] 
发送时间: 2014年6月11日 21:53
收件人: Qin Wu
抄送: [email-masked]; [email-masked]
主题: Re: OAM and restructuring the Rtg Area

Qin (and Ross),

On Wed, Jun 11, 2014 at 09:55:20AM +0000, Qin Wu wrote:
> I like the suggestion made by Ross about restructure for OAM. There is 
> OAM in some RTG working groups and it needs coordination. Also there 
> is the management of OAM function with the control plane. It would be 
> interesting to have single working group for OAM in routing area.

We have an entire area (OPS) with part of this as their charter.  While I agree there is a desire to get more involvement in OAM issues and perhaps centralize some of the subject matter experts, how would a WG within routing help?

I suspect an argument could even be made that MPLS OAM may belong in transport or int. :-)

To some extent, the call from the ADs is to find a way to let work that doesn't have strong boundaries have a home that removes those boundaries.
We should be considering this impact across IETF areas and not only within routing.  (meta-working groups, as I call them.)

-- Jeff