Subject: big equal to inefficient ??

From: Loa Andersson <[email-masked]>
Date: Thu, 12 Jun 2014 07:16:02 +0200

Alia and Adrian,

you say:

    2) Split giant working groups so relevant work is done in one place
    and there is an improved signal-to-noise ratio for participants who
    are only interested in a slice of the current working group's work.

Exactly what metrics is the assertion that "giant working groups" are
in-efficient based on?

/Loa
-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 12 Jun 2014 18:16:13 +0100

> Exactly what metrics is the assertion that "giant working groups" are
Well, one concern is that some large working groups take two
sessions - the most allowed at a meeting, and still end up with so
many drafts to discuss they either get 5mins or less each, or not
discussed. This is not a productive way forward.

Now maybe the answer is to take a much firmer line on what gets
discussed at IETF, but that needs a cultural change. The problem
is that cultural changes are incredibly difficult and so far I have
seen no workable answer beyond splitting the work into smaller
slices.

- Stewart

---

From: Scott Brim <[email-masked]>
Date: Thu, 12 Jun 2014 13:20:34 -0400

IMHO it's not so much scope (what gets discussed) as serialization and
focus. You can cover a wide range of topics, eventually, as long as you set
milestones for each one and ratchet them forward at speed appropriate to
their urgency. I suspect an "agile" approach to the overall charter would
be appropriate for a large WG.

On Thu, Jun 12, 2014 at 1:16 PM, Stewart Bryant <[email-masked]> wrote:

> _______________________________________________
> routing-discussion mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/routing-discussion
>

---

From: Loa Andersson <[email-masked]>
Date: Thu, 12 Jun 2014 19:21:16 +0200

Stewart,

> seen no workable answer beyond splitting the work into smaller

So if we split the wg taking two sessions into 3 or 4 groups, taking 3
or 4 sessions, that is better?

/Loa

--

---

From: Giles Heron <[email-masked]>
Date: Thu, 12 Jun 2014 18:42:16 +0100

> or 4 sessions, that is better?

yes, if the total length of the sessions is the same :)

in general a more focussed group is better I think as there's less risk of people having to sit through tons of drafts they're not interested in - though I know in MPLS you have often split the sessions so that (for example) all the MPLS-TP drafts get grouped together.

Giles

---

From: Ross Callon <[email-masked]>
Date: Thu, 12 Jun 2014 17:58:43 +0000

Actually, the MPLS group (which is about as big as they get, I think) has not been quite as busy for the last two IETFs. Thus we have been able to have more in depth discussion (which is desirable). Before that we were pretty jammed with so many presentations that what you said did happen. 

If you split the same presentations between more WGs, it doesn't make the week less busy. If we want to have more longer discussions and a less overloaded week, it is probably necessary to push back on some presentations. To me this is a matter for WG chair training -- which I think is a very good idea even for experienced WG chairs (there is always something that we can do better, or that we have forgotten about over the years).  

To me the reason for splitting or combining WGs would be to make the work fit more logically into groups, if we can come up with a split that allows this to happen. 

I don't think that any split can be perfect. Thus there will always be drafts which are of interest to multiple WGs, and a need to coordinate work between WGs. However, it would be desirable if we can reduce the overlaps by grouping work into reasonable logical pieces. How to improve this over what we have now is not obvious to me. 

Ross

-----Original Message-----
From: routing-discussion [mailto:[email-masked]] On Behalf Of Stewart Bryant
Sent: Thursday, June 12, 2014 1:16 PM
To: Loa Andersson; [email-masked]
Subject: Re: big equal to inefficient ??

- Stewart

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 12 Jun 2014 18:14:12 +0000

Hi Giles,
I'm not so sure as, in my personal experience, I'll have to attend all three or four WG and will be asking to make their scheduling mutually exclusive.

	Regards,
		Greg

-----Original Message-----
From: routing-discussion [mailto:[email-masked]] On Behalf Of Giles Heron
Sent: Thursday, June 12, 2014 10:42 AM
To: Loa Andersson
Cc: [email-masked]; [email-masked]
Subject: Re: big equal to inefficient ??

On 12 Jun 2014, at 18:21, Loa Andersson <[email-masked]> wrote:

>>> Exactly what metrics is the assertion that "giant working groups" 
>>> are in-efficient based on?
>>> 
>>> /Loa
>> Well, one concern is that some large working groups take two sessions 
>> - the most allowed at a meeting, and still end up with so many drafts 
>> to discuss they either get 5mins or less each, or not discussed. This 
>> is not a productive way forward.
>> 
>> discussed at IETF, but that needs a cultural change. The problem is 
>> that cultural changes are incredibly difficult and so far I have seen 
>> no workable answer beyond splitting the work into smaller slices.
>> 
>> - Stewart
> 

Giles

---

From: Giles Heron <[email-masked]>
Date: Thu, 12 Jun 2014 19:22:58 +0100

right - but if their total length is no longer than that of the single WG then scheduling is no more difficult?

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 12 Jun 2014 18:35:02 +0000

Then what we gain:
Time to discuss presentations in more details - no
Increased logistical complexity - yes

	Regards,
		Greg

-----Original Message-----
From: Giles Heron [mailto:[email-masked]] 
Sent: Thursday, June 12, 2014 11:23 AM
To: Gregory Mirsky
Cc: Loa Andersson; [email-masked]; [email-masked]
Subject: Re: big equal to inefficient ??

On 12 Jun 2014, at 19:14, Gregory Mirsky <[email-masked]> wrote:

>>>>  2) Split giant working groups so relevant work is done in one 
>>>> place  and there is an improved signal-to-noise ratio for 
>>>> participants who  are only interested in a slice of the current working group's work.
>>>> 
>>> sessions
>>> - the most allowed at a meeting, and still end up with so many 
>>> drafts to discuss they either get 5mins or less each, or not 
>>> that cultural changes are incredibly difficult and so far I have 
>>> seen no workable answer beyond splitting the work into smaller slices.
>>> 
>>> - Stewart
>> 
>> So if we split the wg taking two sessions into 3 or 4 groups, taking 
>> 3 or 4 sessions, that is better?
>

---

From: Edward Crabbe <[email-masked]>
Date: Thu, 12 Jun 2014 11:40:43 -0700

I agree with Ross.

It seems to me that this proposal runs the risk of  either non-linearly
increase the communication complexity and overhead (subgroups must
coordinate with other subgroups) or result in chairs providing information
conduits for subgroups (dramatically increasing chair work load and
decreasing available time per subgroup as part of overall communication
overhead.)  It will also result in additional overload for participants as
the number of SubWGs people have to attend increasing.

On Thu, Jun 12, 2014 at 10:58 AM, Ross Callon <[email-masked]> wrote:

> Actually, the MPLS group (which is about as big as they get, I think) has
> not been quite as busy for the last two IETFs. Thus we have been able to
> have more in depth discussion (which is desirable). Before that we were
> pretty jammed with so many presentations that what you said did happen.
>
> If you split the same presentations between more WGs, it doesn't make the
> week less busy. If we want to have more longer discussions and a less
> overloaded week, it is probably necessary to push back on some
> presentations. To me this is a matter for WG chair training -- which I
> think is a very good idea even for experienced WG chairs (there is always
> something that we can do better, or that we have forgotten about over the
> years).
>
> To me the reason for splitting or combining WGs would be to make the work
> fit more logically into groups, if we can come up with a split that allows
> this to happen.
>
> I don't think that any split can be perfect. Thus there will always be
> drafts which are of interest to multiple WGs, and a need to coordinate work
> between WGs. However, it would be desirable if we can reduce the overlaps
> by grouping work into reasonable logical pieces. How to improve this over
> what we have now is not obvious to me.
>
> Ross
>

---

From: Giles Heron <[email-masked]>
Date: Thu, 12 Jun 2014 19:42:06 +0100

we gain that those of us who only care about one chunk of the work don't have to go to all the meetings :)

though as I mentioned before the MPLS WG have addressed that to some extent in the past...

---

From: Jeffrey Haas <[email-masked]>
Date: Thu, 12 Jun 2014 14:53:13 -0400

> seen no workable answer beyond splitting the work into smaller

We already dedicated some plenary time in trying to reduce unnecessary
meetings and presentations.  That session should probably be dug up and a
link posted to the video so we can try to take it more to heart.

Thought experiment (probably proving I've been poisoned by excess exposure
to management):
Metrics are usually what is needed to figure out how effective something is.
In the case of WG sessions, I think the desired metrics are probably a nice
constrained set.
- Was the overall session productive?
- On a per-presentation basis, was the material:
  + Informative
  + Necessary to present?
  + Generated good discussion at the meeting - even if not the session?

Is there anything in our organizational policies preventing individual WGs
from gathering these metrics?

-- Jeff

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 12 Jun 2014 20:03:04 +0100

There is a spectrum that runs from one single WG
for the whole of RTG, through to something much close to
one WG one draft. The former allows optimum cross interest
co-ordination, the latter focus on detailed topic of interest
to a few subject matter experts.

Clearly both are models are ridiculous.

The problem that Adrian and I grappled with for
a long time, and that Adrian and Alia are trying to
work through here, is what is the optimum structure
of the RTG Area in 2014 and forward?

Is it status quo? If not what structure gives us the right
balance between co-ordination, agility and focus and
makes optium use of the very limited resources we
have?

- Stewart

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 12 Jun 2014 12:13:47 -0700

I am a fan of good tools. I think it would be cool if there wa
a web page a few weeks before the IETF with for each WG the list of
possible drafts, and letting me click which ones i am interested in.
Would IMHO help to improve of ther current judgement method applied
by WG chairs to decide what to take on to the agenda.

---

From: Lou Berger <[email-masked]>
Date: Thu, 12 Jun 2014 18:27:11 -0400

I agree with the points made by Ed and Ross. I'm particularly concerned
with the potential for the standardization of duplicative mechanisms
that could (and have) occurred without the type of communication
mentioned by Ed.  Consider a concrete case: If rsvp-te and cr-ldp had
been in two WGs, would rfc3468 been possible? I think not, and I think
we would have a (more) fragmented market and O(2n) the load
standardizing parallel extensions.

Also a couple of additional points on the 5 minute / draft issue:

- I've often seen this problem result from a desire to let all who
request a slot get one.  While this may have once been some WG's
practice and to some degree part of the IETF culture , I think this
approach died under it's own weight and now generally some discussion on
the list and anticipated discussion in session is required -- and this
has helped provide more time for substantive discussion.

- One on going demand for WG time in some of the "big*" groups are
individual drafts that are looking for a home.  I think the "big" group
I co-chair generally sends the equivalent of 1 session on such drafts. I
think the idea mentioned in Alia's and Adrian mail of a RTG Area
Dispatch WG might help here.   Now that said, there is the very real
risk that all RTG WGs will want to deconflict with this 2nd RTG Area
wide session, and there is still an additional session for discussing
new work.  So, perhaps we should also go with Eckert's idea of polling
for session time at least for new WGs (maybe we'll try this for CCAMP in
Toronto...)

Lou

(*) I'll send some metrics on size in another message.

---

From: Lou Berger <[email-masked]>
Date: Thu, 12 Jun 2014 18:39:50 -0400

Alia and Adrian,

Can you identify which "giant working groups" you are considering splitting?

You said the objective of this item is:

    an improved signal-to-noise ratio for participants who
    are only interested in a slice of the current working group's work.

I think it's really interesting that you are focusing on improving
signal-to-noise ratio for *participants*.  In the  WG (which may be in
your giant list) I co-chair, we try to chunk topics in meeting sessions
to allow those contributing to just a part of the WGs activities can
decide which session to attend.  (If wondering why we generally have two
sessions, see my previous mail on this subject.) Of course, many
participants are interested in most topics and attend the WG's typical
two sessions.  We also avoid the potential duplication of mechanisms
mentioned in my previous mail on this topic as well as the added
communication/coordination, mentioned by Ed, that would be needed if
these two sessions were different WGs...  

Thanks,
Lou

PS For those who like metrics, here's some data from the last 25 meetings

Per wg breakdown, alphabetized:
bfd     Total Sessions:  5    Met 1x:  5
ccamp   Total Sessions: 49    Met 1x:  3    Met 2x: 20    Met 3x:  2
forces  Total Sessions: 23    Met 1x: 23
i2rs    Total Sessions:  4    Met 1x:  4
idr     Total Sessions: 26    Met 1x: 24    Met 2x:  1
irs     Total Sessions:  1    Met 1x:  1
isis    Total Sessions: 21    Met 1x: 21
karp    Total Sessions: 15    Met 1x: 15
l1vpn   Total Sessions:  4    Met 1x:  4
l2vpn   Total Sessions: 28    Met 1x: 20    Met 2x:  4
l3vpn   Total Sessions: 24    Met 1x: 20    Met 2x:  2
manet   Total Sessions: 27    Met 1x: 23    Met 2x:  2
mpls    Total Sessions: 49    Met 1x:  7    Met 2x: 12    Met 3x:  6
nsc     Total Sessions:  1    Met 1x:  1
nvo3    Total Sessions:  9    Met 1x:  5    Met 2x:  2
ospf    Total Sessions: 23    Met 1x: 19    Met 2x:  2
pce     Total Sessions: 27    Met 1x: 23    Met 2x:  2
pim     Total Sessions: 27    Met 1x: 23    Met 2x:  2
pwe3    Total Sessions: 30    Met 1x: 20    Met 2x:  5
rl2n    Total Sessions:  1    Met 1x:  1
roll    Total Sessions: 22    Met 1x: 12    Met 2x:  5
rpsec   Total Sessions:  4    Met 1x:  4
rtgarea Total Sessions: 28    Met 1x: 22    Met 2x:  3
rtgwg   Total Sessions: 23    Met 1x: 19    Met 2x:  2
sdn     Total Sessions:  1    Met 1x:  1
sfc     Total Sessions:  2    Met 1x:  2
sidr    Total Sessions: 34    Met 1x: 19    Met 2x:  3    Met 3x:  3
spring  Total Sessions:  2    Met 1x:  2
status  Total Sessions:  1    Met 1x:  1

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 13 Jun 2014 00:05:05 +0100

Replying to Lou's post at the top of my pile, but general comments on this
discussion as well.

> Can you identify which "giant working groups" you are considering splitting?

Absolutely not! :-)

Actually, we have many thoughts and ideas, but we are deliberately soliciting
opinions and winkling stuff out of all of you.

After a slow start you have all really got going and I am learning some useful
things and being reminded of others.

>     are only interested in a slice of the current working group's work.

Yes, and here i want to pounce on Loa's question.

| Exactly what metrics is the assertion that "giant working
| groups" are in-efficient based on?

It's a good question, but one that Loa has to answer because the suggestion of
inefficiency is one that he brought in (it's not in the original email from Alia
and me).

What I am interested in is whether people are sitting through meeting time
waiting for one draft to come up. Perhaps they are OK with this (it's warm,
except where the aircon is too assertive, and there is wifi). When I look out at
a meeting (I often get up to do exactly that) I sometimes see 50% of eyes raised
and sometimes less than 20%. What could be the cause?

Maybe most people attending WG meetings are tourists. They are at the IETF for
webrtc, and they just popped into PIM in case something exciting happens.

But there are splits and splits.
The GMPLS variants of CR-LDP and RSVP-TE were done in the same WG, but this work
was split out of MPLS (where it was started). 
Did that mean that RSVP-TE implementers had to go to two WGs? Yes.
Did it mean that packet heads did not need to sit through hours of discussion of
how to switch lambdas? Yes.

So for me this is about functional grouping to get the right people in the room
for the right work.  I worry that if I answer the question I will discover that,
since I have to attend as many routing area meetings as possible, we should only
have one WG :-)

> these two sessions were different WGs...

It's a good example because CCAMP meetings no longer absorb two big slots. And,
instead of asking for just one 2.5 hour slot, the two smaller slots achieve this
chunking and allow people who don't care about OTN, etc. to go for coffee.

It's hard to say where the line is drawn for "functional grouping" which we are
seeking and "forcing additional coordination and communication".

At one extreme we might decide to put IDR, L3VPN, L2VPN, SIDR... into one WG
because that way we don't need cross-communication on BGP (and there have been
some fumbles :-). On the other extreme we might say that CCAMP could split into
TE related work, packet work, and non-packet work (THESE ARE JUST EXAMPLES FOR
ILLUSTRATIVE PURPOSES AND ARE NOT EVEN STRAW MEN!)

So, continue to discuss! Come up with ideas about what could be grouped
together, regrouped, and split. And say why that would be good or bad.

This is really helping me. Please continue.

Adrian

---

From: Loa Andersson <[email-masked]>
Date: Fri, 13 Jun 2014 06:32:23 +0200

Adrian,

> and sometimes less than 20%. What could be the cause?

What you said was:

I kind of translated bad "signal-to-noise ratio" to "inefficient" and I
guess that a rather large percentage of people commenting on my mail
understood that.

So to rephrase:

Exactly what metrics is the assertion that "giant working
groups" have a bad signal-to-noise ratio based on?

Sometimes I've been sitting through wg's (small or large) where I'm
only interested in one draft. What quite ofteh happens listening to
the "noise" is that I find something interesting where I can
potentially contribute. This is a synergy that we may re-organize
away.

You also say that you keep watching how big portion of the participants
pay attention (I have to admit that I try to do that also). From what I
see I've no basis to say that the portion of participants appearing to
pay attention is bigger or smaller in large or small working groups.

Please note:

I'm not saying that we should not re-organize, but I've so far not
found THE principle according to which we can re-organize the entire
area.

/Loa

--

---

From: Loa Andersson <[email-masked]>
Date: Fri, 13 Jun 2014 06:39:36 +0200

Giles,

You are right if a 1 to 3 split, result in three 1 hour meetings
instead of one 2.5 hour meeting.

Only that I doubt i works that way. Mr Parkinson did look at this
back in the mid 1950-ies.

I think it is likely that we end up with in the order of 4.5 hours of
meeting time.

/Loa

--

---

From: Alia Atlas <[email-masked]>
Date: Fri, 13 Jun 2014 00:47:11 -0400

It sounds as if you are measuring efficiency by meeting time.
Shouldn't quality of drafts, discussion, and review come in?
The IETF's goal is good open standards, not meetings.

Alia

On Fri, Jun 13, 2014 at 12:39 AM, Loa Andersson <[email-masked]> wrote:

>>> I'm not so sure as, in my personal experience, I'll have to attend all
>>> three or four WG and will be asking to make their scheduling mutually
>>> exclusive.
>>>
>>>         Regards,
>>>                 Greg
>>>
>>> in general a more focussed group is better I think as there's less risk
>>> of people having to sit through tons of drafts they're not interested in -
>>> though I know in MPLS you have often split the sessions so that (for
>>> example) all the MPLS-TP drafts get grouped together.
>>>
>>> Giles
>>>
>>>  /Loa
>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>> --
>>>>
>>>>

---

From: Loa Andersson <[email-masked]>
Date: Fri, 13 Jun 2014 06:52:56 +0200

Alia,

In no way I'm measuring efficiency in meeting time. We have a
a discussion with many facets and it is impossible to repeat every
argument in every mail.

This was just a comment on an assertion that a group that has
been split three ways will require the same meeting time after
as before the split.

/Loa

On 2014-06-13 06:47, Alia Atlas wrote:
> On Fri, Jun 13, 2014 at 12:39 AM, Loa Andersson <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Giles,
>
>         right - but if their total length is no longer than that of the
>         single WG then scheduling is no more difficult?
>
>         On 12 Jun 2014, at 19:14, Gregory Mirsky
>         <[email-masked]
>         <mailto:[email-masked]>> wrote:
>
>             Hi Giles,
>             I'm not so sure as, in my personal experience, I'll have to
>             attend all three or four WG and will be asking to make their
>             scheduling mutually exclusive.
>
>                      Regards,
>                              Greg
>
>             From: routing-discussion
>             [mailto:[email-masked]
>             <mailto:[email-masked]>] On Behalf Of
>             Giles Heron
>             Cc: [email-masked]
>             <mailto:[email-masked]>; [email-masked]
>             <mailto:[email-masked]>
>             On 12 Jun 2014, at 18:21, Loa Andersson <[email-masked]
>             <mailto:[email-masked]>> wrote:
>
>                 Stewart,
>
>             in general a more focussed group is better I think as
>             there's less risk of people having to sit through tons of
>             drafts they're not interested in - though I know in MPLS you
>             have often split the sessions so that (for example) all the
>             MPLS-TP drafts get grouped together.
>
>             Giles
>
>                 /Loa
>
>
>
>
>
>                 --
>
>
>                 Loa Andersson                        email:
>                 [email-masked] <mailto:[email-masked]>
>                 Senior MPLS Expert [email-masked] <mailto:[email-masked]>
>                 Huawei Technologies (consultant)     phone: +46 739 81
>                 21 64 <tel:%2B46%20739%2081%2021%2064>
>
>                 _________________________________________________
>                 <mailto:[email-masked]>
>                 https://www.ietf.org/mailman/__listinfo/routing-discussion
>                 <https://www.ietf.org/mailman/listinfo/routing-discussion>
>
>
>             _________________________________________________
>             [email-masked] <mailto:[email-masked]>
>             https://www.ietf.org/mailman/__listinfo/routing-discussion
>             <https://www.ietf.org/mailman/listinfo/routing-discussion>
>
>
>
>     --
>
>
>     <mailto:[email-masked]>
>     Senior MPLS Expert [email-masked] <mailto:[email-masked]>
>     <tel:%2B46%20739%2081%2021%2064>
>
>     _________________________________________________
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/__listinfo/routing-discussion
>     <https://www.ietf.org/mailman/listinfo/routing-discussion>
>
>

--

---

From: Alia Atlas <[email-masked]>
Date: Fri, 13 Jun 2014 00:58:26 -0400

Loa,

Ok.  It seemed odd to me.  I'm more interested in reading out the
communities of interest and closely related work.  We all suffer from the
Bystander effect (i.e. someone else will take care of it) when a group gets
too large.

Alia
On Jun 13, 2014 12:53 AM, "Loa Andersson" <[email-masked]> wrote:

>>                 <https://www.ietf.org/mailman/listinfo/routing-discussion
>> >
>>
>>

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 13 Jun 2014 09:59:44 -0400

> found THE principle according to which we can re-organize the entire

I'm also wondering as we continue this discussion whether we're tailoring
our comments way too much around observations of meeting sessions rather
than the overall work.  Much (should) happen on the mailing lists.

-- Jeff

---

From: Loa Andersson <[email-masked]>
Date: Sat, 14 Jun 2014 08:04:16 +0200

Jeff,

> than the overall work.  Much (should) happen on the mailing lists.

I think you are heads on!

There are issues that are focused on the F2F meetings. It seems that
they are possible manage within the current area structure. We might
want to make sure that the re-org actions we take don't make them worse,
e.g. more working harder scheduling.

If we consider the work on the mailing, I do not see that the signal-to-
noise ratio is a real problem. Maybe sometimes the signal is to weak
(not enough discussion).

One of my co-chairs has often said "quality takes time", I agree
thinking things through one extra time improve quality and probably
save working time in the long run. This begs the question how we
measure speed and efficiency.

I'd say (maybe I'm as old-fashion as Ken) take more work to the mailing
lists, but use the tools you need. If you need a dt have one, if you
need an interim do one, etc. However we should remember that discussions
in the IETF happens on mailings lists.

Over the last few years we have tweaked the MPLS wg process, one thing
we done is to require that authors that update their documents due to
comments confirm with the people making the comments that they are
comfortable with how the comment has been addressed.

/Loa

--

---

From: "Ken Gray (kegray)" <[email-masked]>
Date: Sat, 14 Jun 2014 11:53:25 +0000

I will note that the "bar bof" motif has been good for discussion.  Maybe every WG needs to hold one - to enable the less socially skilled.  Of course, that could lead to a particularly hard Friday.  

Sent from my iPhone

> On Jun 14, 2014, at 4:04 PM, "Loa Andersson" <[email-masked]> wrote:
> 
> Jeff,
>

---

From: Lou Berger <[email-masked]>
Date: Sat, 14 Jun 2014 08:25:50 -0400

On 6/13/2014 12:58 AM, Alia Atlas wrote:
>
> We all suffer from the Bystander effect (i.e. someone else will take
> care of it) when a group gets too large.
>
> Alia
>

So "Giant" = number of attendees in the room (or active on the list)? 
Unless the split results in meeting time overlap, I don't see how
splitting groups helps. 

Are you trying to address the tourism effect? (Which by the way is one
of my pet peeves, but I've given up on getting our "leadership" to not
choose meeting destinations based on the number of IETF tourists that
will show.)

Lou

---

From: Loa Andersson <[email-masked]>
Date: Sat, 14 Jun 2014 14:51:40 +0200

Lou,

I think there is a pretty strong agreement splitting the "giants" (who
ever came up with that name) doesn't help. What we do in one or two 
slots we will have to do in 6 or 7. In stead of being subscribed to
1 or two mailing lists, there will two handfuls, and a very tricky
coordination to reach even the roughest consensus.

/Loa

PS

BTW how big is the tourist problem, lot of people milling around on
Sun and Mon, and then gradually declining towards the end of the
week.

--

---

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 14 Jun 2014 14:33:24 +0100

In the interests of stirring this particular pot to see what floats to the
surface...

If splitting existing WGs would not be of any specific benefit, why don't we
merge a few WGs? After all, most people who go to CCAMP also go to MPLS, so
surely joining them would be beneficial.

Adrian

> From: routing-discussion [mailto:[email-masked]] On
Behalf
> Of Loa Andersson
> Sent: 14 June 2014 13:52
> To: Lou Berger

---

From: Lou Berger <[email-masked]>
Date: Sat, 14 Jun 2014 10:08:27 -0400

Do I hear a new area being proposed?

:-)

---

From: Loa Andersson <[email-masked]>
Date: Sat, 14 Jun 2014 16:23:16 +0200

Adrian,

I had to go out and walk the dog for a while. no pun intended this is a
quite young puppy that really don't understand how to stay out of
underfoot. Keep my mind on something else for a while. How not to step
on the puppy.

No - I think you are making the same mistake again. The number of peopel
(unless maybe in the case that they are getting close to zero) does not
have anything to do with how we set up wg's.

I'd even say that if we were to start from scratch it is unlikely that
we come with the current distribution of wg's. But that is moot, we
have a history and I honestly think that the "giant" (your term not
mine) working group also have an almost giant experience of efficiently
run the working groups.

Anyone that reads this to say the current chairs should continue to run
the working groups, have to go back and read again.

The point is that *the working group* has that giant experience, the
individuals are not *that* important. The organizational principle I
think we should use for gradual re-org of our working groups is that we
should build on the history and improve where we can.

An example - let us say that we two working group (with what have come
to see as "overlap"), i.e. wg A are chartered to do  m, n and o and wg B
are chartered to p, q and r. And when A do anything on m, we repeatedly 
find that we have to cross-review that with the part of B that are doing
q, and vice versa. Closer investigating this might lead us to see that
some re-org would be beneficial. We could move m and q to a new working
group, but if q and r closely related and would cause the same problem
again across another interface this might not be a good idea; moving q
to A or M to B might be better.

My point here is that - with 25 years history - grand new re-org
attempts are likely to cause more problems than they solve. Scratch
the "re-org the area" scheme and work with the wg's, the wg chair and
leadership in general to solve issues where we see problem. Small scale
rather than big scale.

/Loa

--

---

From: Loa Andersson <[email-masked]>
Date: Sat, 14 Jun 2014 16:24:31 +0200

revival of sub-IP :)

/Loa

On 2014-06-14 16:08, Lou Berger wrote:
>> [mailto:[email-masked]] On
>> Behalf
>> > Of Loa Andersson
>> > Sent: 14 June 2014 13:52
>> > To: Lou Berger

--

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 18 Jun 2014 12:27:15 +0100

> choose meeting destinations based on the number of IETF tourists that
That is orthogonal to the problem that I think is being addressed.

However I agree with your concern. Minneapolis would work for
me every time.

Stewart

---

From: Lou Berger <[email-masked]>
Date: Wed, 18 Jun 2014 11:11:50 -0400

Stewart,
	
> That is orthogonal to the problem that I think is being addressed.

This is what I expected, that is, until Alia raised it...

> However I agree with your concern. Minneapolis would work for

WFM...

Lou