Subject: Routing Area YANG Coordinators Wiki

From: David Sinicrope <[email-masked]>
Date: Tue, 21 Jul 2015 14:21:32 +0000

Hi All,
http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgYangCoord
Above is a link to the Routing Area YANG Coordinators area that was established earlier this year to help track the YANG models being developed in the iETF Routing Area.
There are a number of resources on the wiki pages, but the coordinators would like to draw attention specifically to the “Summary of Routing Area YANG Drafts”
(The section with the big red text "* == YANG MODEL AUTHORS LOOK HERE == *”

These tables are intended to help summarize and track the YANG drafts in the Routing Area.    Draft authors and WG Chairs are requested to keep the wiki table updated as drafts are created and progressed through the document development process.  Instructions for completing a table row for a YANG model draft are provided.

Questions on the instructions should be directed to the Routing Area YANG Coordinators (Qin Wu​[email-masked]<mailto:[email-masked]> and David Sinicrope [email-masked]<mailto:[email-masked]> )

Thanks for your help and support keeping this information up to date.

Thanks,
Dave and Qin

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 23 Jul 2015 13:37:38 +0000

Hi David and Bill,
I’ve reviewed the table and wonder why some YANG models of OAM tagged differently. For example, MPLS-TP OAM YANG model tagged as related to LIME, BFD – as OAM related and TWAMP as Measurement related. While all three are correct references all three equally apply to these models as BFD and TWAMP are OAM protocols and are relevant for work of LIME WG. Personally, I think that reference to OAM would be the most generic and still correct.

                Regards,
                                Greg

From: routing-discussion [mailto:[email-masked]] On Behalf Of David Sinicrope
Sent: Tuesday, July 21, 2015 4:22 PM
To: [email-masked]
Subject: Routing Area YANG Coordinators Wiki

Hi All,

Thanks,
Dave and Qin

---

From: Loa Andersson <[email-masked]>
Date: Thu, 23 Jul 2015 23:22:14 +0200

David and Qin,

One more question related to the table. The column third from the right
says "Announced on the coordination list"; which list and what action?

/Loa

On 2015-07-23 15:37, Gregory Mirsky wrote:
> Hi David and Bill,
>
> I’ve reviewed the table and wonder why some YANG models of OAM tagged
> differently. For example, MPLS-TP OAM YANG model tagged as related to
> LIME, BFD – as OAM related and TWAMP as Measurement related. While all
> three are correct references all three equally apply to these models as
> BFD and TWAMP are OAM protocols and are relevant for work of LIME WG.
> Personally, I think that reference to OAM would be the most generic and
> still correct.
>
>                  Regards,
>
>                                  Greg
>
> *From:*routing-discussion [mailto:[email-masked]]
> *On Behalf Of *David Sinicrope
> *Sent:* Tuesday, July 21, 2015 4:22 PM
> *To:* [email-masked]
> *Subject:* Routing Area YANG Coordinators Wiki
>
> Hi All,
>
> Above is a link to the Routing Area YANG Coordinators area that was
> established earlier this year to help track the YANG models being
> developed in the iETF Routing Area.
>
> There are a number of resources on the wiki pages, but the coordinators
> would like to draw attention specifically to the “Summary of Routing
> Area YANG Drafts”
>
> (The section with the big red text "** == YANG MODEL AUTHORS LOOK HERE
> == ***”*
>
> These tables are intended to help summarize and track the YANG drafts in
> the Routing Area.    Draft authors and WG Chairs are requested to keep
> the wiki table updated as drafts are created and progressed through the
> document development process.  Instructions for completing a table row
> for a YANG model draft are provided.
>
> Questions on the instructions should be directed to the Routing Area
> YANG Coordinators (Qin Wu​[email-masked]
> <mailto:[email-masked]> and David Sinicrope
> [email-masked] <mailto:[email-masked]> )
>
> _______________________________________________
> routing-discussion mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/routing-discussion
>

---

From: David Sinicrope <[email-masked]>
Date: Fri, 24 Jul 2015 07:34:31 +0000

Hi Loa,

The YANG interest list noted on:  http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgYangCoord

Action is not prescriptive.  I would suggest an email with:
- the draft name if progressed that far
- the purpose of the model
- rough idea of the scope of the model
- rough list of authors or interested parties, perhaps a lead contact
- anticipated timeline
- any other info those thinking of creating a model or having created a draft model think is useful

Or any subset of this info announcing the rest as needed.

Hope this helps,
Dave

> On Jul 23, 2015, at 23:22, Loa Andersson <[email-masked]> wrote:
> 
> David and Qin,
>

---

From: Qin Wu <[email-masked]>
Date: Fri, 24 Jul 2015 08:01:55 +0000

Greg, thanks for pointing out this inconsistency issue, your suggestion looks good, we will fix it.

发件人: Gregory Mirsky [mailto:[email-masked]]
发送时间: 2015年7月23日 15:38
收件人: David Sinicrope; [email-masked]; Qin Wu
主题: RE: Routing Area YANG Coordinators Wiki

Hi David and Bill,

                Regards,
                                Greg

From: routing-discussion [mailto:[email-masked]] On Behalf Of David Sinicrope
Sent: Tuesday, July 21, 2015 4:22 PM
To: [email-masked]<mailto:[email-masked]>
Subject: Routing Area YANG Coordinators Wiki

Hi All,

Thanks,
Dave and Qin

---

From: Gregory Mirsky <[email-masked]>
Date: Fri, 24 Jul 2015 08:07:30 +0000

Hi Qin,
thank you for kind consideration of my comments. If the Relation with others column may be used to filter the table for dependencies and/or overview of functional areas, e.g. OAM, then, I think, authors may make changes given defined set of characterizations, e.g. Routing, OAM, Service, etc.

                Regards,
                                Greg

From: Qin Wu [mailto:[email-masked]]
Sent: Friday, July 24, 2015 10:02 AM
To: Gregory Mirsky; David Sinicrope; [email-masked]
Subject: RE: Routing Area YANG Coordinators Wiki

发件人: Gregory Mirsky [mailto:[email-masked]]
发送时间: 2015年7月23日 15:38
收件人: David Sinicrope; [email-masked]<mailto:[email-masked]>; Qin Wu
主题: RE: Routing Area YANG Coordinators Wiki

Hi David and Bill,

                Regards,
                                Greg

Hi All,

Thanks,
Dave and Qin

---

From: Qin Wu <[email-masked]>
Date: Fri, 24 Jul 2015 08:19:28 +0000

Sure, we have provided  instructions to help author to update YANG Model Summary table wiki page.
But what we really like to see is WG chair can pay more attention to this Summary table wiki page and use it as a channel or tool  to start conversation with  corresponding WG who is working on the relevant YANG model
and enforce YANG model authors to update the table and resolve potential overlapping. We believe I2RS and TEAS Two WGs are doing a very good job for starting such conversation, resolve a lot of overlap issue in the first place.
So please consult with your WG Chairs if you update this Summary Table.  Thanks!

-Qin
发件人: Gregory Mirsky [mailto:[email-masked]]
发送时间: 2015年7月24日 10:08
收件人: Qin Wu; David Sinicrope; [email-masked]
主题: RE: Routing Area YANG Coordinators Wiki

Hi Qin,

                Regards,
                                Greg

From: Qin Wu [mailto:[email-masked]]
Sent: Friday, July 24, 2015 10:02 AM
To: Gregory Mirsky; David Sinicrope; [email-masked]<mailto:[email-masked]>
Subject: RE: Routing Area YANG Coordinators Wiki

Hi David and Bill,

                Regards,
                                Greg

Hi All,

Thanks,
Dave and Qin