Subject: Design Team on Overlay OAM in Routing is Chartered

From: Alia Atlas <[email-masked]>
Date: Wed, 16 Dec 2015 14:33:34 -0500

Based on the presentation by Greg Mirsky and discussion in rtgwg and
elsewhere, I have decided to charter a fast-moving Routing Area design team
to work on Overlay OAM.

The charter is below:

In the Routing Area, several WGs (e.g. NVO3, BIER, and SFC) are working on
relatively new encapsulations to create overlays. These overlay or service
encapsulations are transport-independent since they may be over different
transports or at different layers in the networking stack. Each WG is
starting to discuss what OAM and tools need to be developed (see
draft-ietf-sfc-oam-framework-00, draft-ietf-bier-oam-requirements-00, and
individual drafts in NVO3). With increasing use of overlay and service
layer tunnels, extensions to traceroute to allow visibility into multiple
layers are being discussed (e.g.
draft-nordmark-nvo3-transcending-traceroute-01).

There is an opportunity to propose protocols and methods to provide Overlay
OAM in a sufficiently generic fashion that they can meet the requirements
and be applied to at least BIER, NSH, VXLAN-GPE, GENEVE, and GUE. A truly
successful result would also be applicable to other technologies.

This Design Team is chartered to first produce a brief gap analysis and
requirements document to focus its work on protocol extensions. This should
be published by March 2016. With that basis, this Design Team is chartered
to rapidly propose extensions to existing IETF OAM protocols such as those
discussed in [RFC 7276] and new ones to support the requirements for OAM
from NVO3, BIER, and SFC. The Design Team will produce an initial proposal
by IETF 95. It is expected that the initial proposal will provide guidance
to additional people who will be interested in working on the details and
gaps.

The Design Team will consider the preliminary OAM requirements from NVO3,
BIER, and SFC. The Design Team should align with the LIME WG's work on
common YANG models of OAM.

The members of the design team are:
   Greg Mirsky (DT lead)
   Ignas Bagdonas
   Erik Nordmark
   Carlos Pignataro
   Mach Chen
   Santosh Pallagatti
   Deepak Kumarde
   David Mozes
   Nagendra Kumar Nainar

The design team has a private mailing list that will be publicly archived.
The mailing list is [email-masked].

The design team will also use a wiki to track some information.  Others are
also welcome to comment and interact there.
The wiki is at:  http://wiki.tools.ietf.org/area/rtg/trac/wiki/RtgOoamDT

Regards,
Alia

---

From: Antoni Przygienda <[email-masked]>
Date: Wed, 16 Dec 2015 19:44:40 +0000

+1, laudable effort & full support …

Thanks Alia

--- tony
_____________________________________________
“Simple, clear purpose and principles give rise to complex and intelligent behavior. Complex rules and regulations give rise to simple and stupid behavior.”
--- Dee Hock

From: rtgwg [mailto:[email-masked]] On Behalf Of Alia Atlas
Sent: Wednesday, December 16, 2015 11:34 AM
To: [email-masked]
Cc: Brian Haberman; [email-masked]; joel jaeggli; [email-masked]; Benoit Claise; Terry Manderson; [email-masked]
Subject: Design Team on Overlay OAM in Routing is Chartered

Based on the presentation by Greg Mirsky and discussion in rtgwg and elsewhere, I have decided to charter a fast-moving Routing Area design team to work on Overlay OAM.

The charter is below:

In the Routing Area, several WGs (e.g. NVO3, BIER, and SFC) are working on relatively new encapsulations to create overlays. These overlay or service encapsulations are transport-independent since they may be over different transports or at different layers in the networking stack. Each WG is starting to discuss what OAM and tools need to be developed (see draft-ietf-sfc-oam-framework-00, draft-ietf-bier-oam-requirements-00, and individual drafts in NVO3). With increasing use of overlay and service layer tunnels, extensions to traceroute to allow visibility into multiple layers are being discussed (e.g. draft-nordmark-nvo3-transcending-traceroute-01).

There is an opportunity to propose protocols and methods to provide Overlay OAM in a sufficiently generic fashion that they can meet the requirements and be applied to at least BIER, NSH, VXLAN-GPE, GENEVE, and GUE. A truly successful result would also be applicable to other technologies.

This Design Team is chartered to first produce a brief gap analysis and requirements document to focus its work on protocol extensions. This should be published by March 2016. With that basis, this Design Team is chartered to rapidly propose extensions to existing IETF OAM protocols such as those discussed in [RFC 7276] and new ones to support the requirements for OAM from NVO3, BIER, and SFC. The Design Team will produce an initial proposal by IETF 95. It is expected that the initial proposal will provide guidance to additional people who will be interested in working on the details and gaps.

The Design Team will consider the preliminary OAM requirements from NVO3, BIER, and SFC. The Design Team should align with the LIME WG's work on common YANG models of OAM.
The members of the design team are:
   Greg Mirsky (DT lead)
   Ignas Bagdonas
   Erik Nordmark
   Carlos Pignataro
   Mach Chen
   Santosh Pallagatti
   Deepak Kumarde
   David Mozes
   Nagendra Kumar Nainar

The design team has a private mailing list that will be publicly archived.
The mailing list is [email-masked]<mailto:[email-masked]>.

The design team will also use a wiki to track some information.  Others are also welcome to comment and interact there.
The wiki is at:  http://wiki.tools.ietf.org/area/rtg/trac/wiki/RtgOoamDT

Regards,
Alia

---

From: Jeff Tantsura <[email-masked]>
Date: Wed, 16 Dec 2015 19:52:41 +0000

Great news!
Full support and looking forward to working with the DT team!

Regards,
Jeff

On Dec 16, 2015, at 11:33 PM, Alia Atlas <[email-masked]<mailto:[email-masked]>> wrote:

The charter is below:

Regards,
Alia

---

From: "VAN DE VELDE, Gunter (Gunter)" <[email-masked]>
Date: Thu, 17 Dec 2015 10:46:51 +0000

Great news. Looking forward to work together with the DT team.

Ciao,

G/

From: rtgwg <[email-masked]<mailto:[email-masked]>> on behalf of Alia Atlas <[email-masked]<mailto:[email-masked]>>
Date: Wednesday 16 December 2015 at 20:33
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Brian Haberman <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, joel jaeggli <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Benoit Claise <[email-masked]<mailto:[email-masked]>>, Terry Manderson <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Design Team on Overlay OAM in Routing is Chartered

The charter is below:

Regards,
Alia

---

From: Qin Wu <[email-masked]>
Date: Fri, 18 Dec 2015 02:39:49 +0000

Good to know this activity to be setup. I believe this work is complementary to what LIME WG is doing since
1. LIME is focusing modeling existing OAM technology and not tasked to develop any new OAM protocols.
2. If any new protocol can be developed through this activity, common YANG model proposed in LIME WG can really benefit from it.

-Qin
发件人: routing-discussion [mailto:[email-masked]] 代表 Alia Atlas
发送时间: 2015年12月17日 3:34
收件人: [email-masked]
抄送: Brian Haberman; [email-masked]; joel jaeggli; [email-masked]; Benoit Claise; [email-masked]
主题: Design Team on Overlay OAM in Routing is Chartered

The charter is below:

Regards,
Alia

---

From: Loa Andersson <[email-masked]>
Date: Fri, 18 Dec 2015 11:18:00 +0800

Alia,

Good initiative!

Design team,

Let me know if there is any support I can give from the bottom of my
mpls well.

/Loa

On 2015-12-17 03:33, Alia Atlas wrote:
> elsewhere, I have decided to charter a fast-moving Routing Area design
> team to work on Overlay OAM.
>
> The charter is below:
>
>     In the Routing Area, several WGs (e.g. NVO3, BIER, and SFC) are
>     working on relatively new encapsulations to create overlays. These
>     overlay or service encapsulations are transport-independent since
>     they may be over different transports or at different layers in the
>     networking stack. Each WG is starting to discuss what OAM and tools
>     need to be developed (see draft-ietf-sfc-oam-framework-00,
>     draft-ietf-bier-oam-requirements-00, and individual drafts in NVO3).
>     With increasing use of overlay and service layer tunnels, extensions
>     to traceroute to allow visibility into multiple layers are being
>     discussed (e.g. draft-nordmark-nvo3-transcending-traceroute-01).
>
>     There is an opportunity to propose protocols and methods to provide
>     Overlay OAM in a sufficiently generic fashion that they can meet the
>     requirements and be applied to at least BIER, NSH, VXLAN-GPE,
>     GENEVE, and GUE. A truly successful result would also be applicable
>     to other technologies.
>
>     This Design Team is chartered to first produce a brief gap analysis
>     and requirements document to focus its work on protocol extensions.
>     This should be published by March 2016. With that basis, this Design
>     Team is chartered to rapidly propose extensions to existing IETF OAM
>     protocols such as those discussed in [RFC 7276] and new ones to
>     support the requirements for OAM from NVO3, BIER, and SFC. The
>     Design Team will produce an initial proposal by IETF 95. It is
>     expected that the initial proposal will provide guidance to
>     additional people who will be interested in working on the details
>     and gaps.
>
>     The Design Team will consider the preliminary OAM requirements from
>     NVO3, BIER, and SFC. The Design Team should align with the LIME WG's
>     work on common YANG models of OAM.
>
> The mailing list is [email-masked] <mailto:[email-masked]>.
>
> The design team will also use a wiki to track some information.  Others
> are also welcome to comment and interact there.
> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg
>

---

From: Thomas Morin <[email-masked]>
Date: Fri, 18 Dec 2015 09:49:34 +0100

Hi everyone,

> Let me know if there is any support I can give from the bottom of my

This comment is a good opportunity to highlight the fact that MPLS/GRE 
and MPLS/UDP are part of various service layer tunnels used for overlays.

I will go as far as to suggest that these encaps should be explicitely 
called out in the DT charter (more than through "other technologies").

Best,

-Thomas

---

From: Thomas Morin <[email-masked]>
Date: Fri, 18 Dec 2015 17:44:11 +0100

For those interested in the follow-up emails:

https://mailarchive.ietf.org/arch/msg/rtg-ooam-dt/aMlUE7RNAaDSYhR-qjdXILQbo14

https://mailarchive.ietf.org/arch/msg/rtg-ooam-dt/WGA4_uC2AMeC_B-wuzm366OWo5Q

Best,

-Thomas

---

From: "Manish Kumar (manishkr)" <[email-masked]>
Date: Sun, 20 Dec 2015 22:57:18 +0000

Hi Alia,

Good to see  this integrated (rather than fragmented!); there would be  more commonalities than difference of requirements. I believe that GRE should be mandatory rather than best effort as well given its wide deployment for overlays (perhaps the most widely deployed general purpose encap, keeping MPLS in a different league!).

Thanks,
Manish

From: rtgwg <[email-masked]<mailto:[email-masked]>> on behalf of Alia Atlas <[email-masked]<mailto:[email-masked]>>
Date: Thursday, 17 December 2015 1:03 am
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Brian Haberman <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, joel jaeggli <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Benoit Claise (bclaise)" <[email-masked]<mailto:[email-masked]>>, Terry Manderson <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Design Team on Overlay OAM in Routing is Chartered

The charter is below:

Regards,
Alia

---

From: "Black, David" <[email-masked]>
Date: Mon, 21 Dec 2015 15:36:02 +0000

> I believe that GRE should be mandatory rather than best effort as well given its wide deployment for overlays

I have no opinion on that, but suggest that any OAM work on GRE should be done with GRE/UDP in mind.

Moreover, the GRE/UDP draft is likely to go to WG Last Call in TSVWG in the next month or so.  GRE/UDP is a simple encapsulation, as there is no (shim) header between the UDP and GRE headers, and none will be added (in contrast to the new encapsulations which have such headers):

https://datatracker.ietf.org/doc/draft-ietf-tsvwg-gre-in-udp-encap/

If there are any OAM concerns or recommendations that ought to be covered in the GRE/UDP draft, now would be a good time to bring them up - please sending comments to [email-masked]<mailto:[email-masked]> .

The current -08 version of the GRE/UDP draft is not really ready for comprehensive review - the text on separating operator network usage from general Internet usage is "digging in the right place," but I expect that another revision is needed to get it into good shape (to their credit, the authors have the new text in my [WG chair] Inbox for review prior to posting).  Hence I'd suggest focusing on OAM topics until the next version (-09) of the GRE/UDP draft is posted.

Thanks,
--David

From: routing-discussion [mailto:[email-masked]] On Behalf Of Manish Kumar (manishkr)
Sent: Sunday, December 20, 2015 5:57 PM
To: Alia Atlas; [email-masked]
Cc: Brian Haberman; [email-masked]; joel jaeggli; [email-masked]; Benoit Claise (bclaise); [email-masked]
Subject: Re: Design Team on Overlay OAM in Routing is Chartered

Hi Alia,

Thanks,
Manish

The charter is below:

Regards,
Alia

---

From: Gregory Mirsky <[email-masked]>
Date: Mon, 21 Dec 2015 18:13:28 +0000

+ Overlay OAM DT

From: routing-discussion [mailto:[email-masked]] On Behalf Of Black, David
Sent: Monday, December 21, 2015 7:36 AM
To: Manish Kumar (manishkr); Alia Atlas; [email-masked]
Cc: Brian Haberman; [email-masked]; [email-masked]; joel jaeggli; [email-masked]; Benoit Claise (bclaise); [email-masked]
Subject: RE: Design Team on Overlay OAM in Routing is Chartered

Thanks,
--David

From: routing-discussion [mailto:[email-masked]] On Behalf Of Manish Kumar (manishkr)
Sent: Sunday, December 20, 2015 5:57 PM
To: Alia Atlas; [email-masked]<mailto:[email-masked]>
Cc: Brian Haberman; [email-masked]<mailto:[email-masked]>; joel jaeggli; [email-masked]<mailto:[email-masked]>; Benoit Claise (bclaise); [email-masked]<mailto:[email-masked]>
Subject: Re: Design Team on Overlay OAM in Routing is Chartered

Hi Alia,

Thanks,
Manish

The charter is below:

Regards,
Alia

---

From: "Russ White" <[email-masked]>
Date: Wed, 23 Dec 2015 08:33:26 -0500

> elsewhere, I have decided to charter a fast-moving Routing Area design team

This is great news!

:-)

Russ

---

From: "Russ White" <[email-masked]>
Date: Wed, 23 Dec 2015 08:28:28 -0500

This is great news!

:-)

Russ