Subject: Request for information - Challenges in routing related to semantic addressing

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 13 Feb 2021 11:41:18 -0000

Hi,

We have just posted "Challenges for the Internet Routing Infrastructure Introduced by Changes in Address Semantics" (https://datatracker.ietf.org/doc/draft-king-irtf-challenges-in-routing/).

This IRTF draft is an attempt to survey the issues and existing research related to the impact on the routing system of the many and varied proposals to add semantics to IP (chiefly IPv6) addresses. Where we are unable to find existing research, we are trying to collect the research questions that we think need to be addressed [sic].

Obviously, this is just a -00 version of the draft and it has a long way to go both in terms of clarity and literature search.

We asked the IRTF to help us with comments and thoughts. In particular, if anyone is aware of any ongoing or published research in the area of semantic addressing or the consequences in routing, we would like to hear about it.

This document is deliberately NOT discussing:
-	Are these address semantic schemes wise or crazy?
-	Is it legal to place semantics in addresses?
-	Is it even possible to achieve overloading of addresses?
What we are doing is zooming in on any existing research of the impact on the routing system and, absent that, to list out the questions that should be answered by research.

Alvaro suggested that routing-discussion would be a good place to copy this request for help.

Response direct to the authors or on this list (until we're told it is not appropriate for this list 😉)

Best,
Adrian (for the authors)

---

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 15 Feb 2021 08:36:46 +0200

Hi Adrian,

Thanks for this informational draft, I also think it is important for this
list, however, I think I need to have some primary definitions by the
authors in this draft, to define meanings of the main objective items
(addressing, semantic routing, etc), so then it will be easier to survey
and overview.

Best Regards,
AB

On Sat, Feb 13, 2021 at 1:41 PM Adrian Farrel <[email-masked]> wrote:

> Hi,
>
> We have just posted "Challenges for the Internet Routing Infrastructure
> Introduced by Changes in Address Semantics" (
> https://datatracker.ietf.org/doc/draft-king-irtf-challenges-in-routing/).
>
> This IRTF draft is an attempt to survey the issues and existing research
> related to the impact on the routing system of the many and varied
> proposals to add semantics to IP (chiefly IPv6) addresses. Where we are
> unable to find existing research, we are trying to collect the research
> questions that we think need to be addressed [sic].
>
> Obviously, this is just a -00 version of the draft and it has a long way
> to go both in terms of clarity and literature search.
>
> We asked the IRTF to help us with comments and thoughts. In particular, if
> anyone is aware of any ongoing or published research in the area of
> semantic addressing or the consequences in routing, we would like to hear
> about it.
>
> What we are doing is zooming in on any existing research of the impact on
> the routing system and, absent that, to list out the questions that should
> be answered by research.
>
> _______________________________________________
> routing-discussion mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/routing-discussion
>

---

From: "King, Daniel" <[email-masked]>
Date: Mon, 15 Feb 2021 10:40:12 +0000

Hi AB,

Thanks for scanning and commenting.

The I-D has bubbled for a while after seeing various discussions on contextual and semantic routing I-Ds, mostly clean-slate approaches. Although the initial literature review highlighted some common objectives across proposals and implementations, I struggled to find anything that defined "semantic routing" and goals that we could use/reference. I likely missed prior research that provides a useful definition. If not, then I agree that having the IRTF research community document a description for "semantic routing" and common goals, would be beneficial.

BR, Dan.

From: Abdussalam Baryun <[email-masked]>
Sent: 15 February 2021 06:37
To: adrian <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: [External] Re: Request for information - Challenges in routing related to semantic addressing

This email originated outside the University. Check before clicking links or attachments.
Hi Adrian,

Thanks for this informational draft, I also think it is important for this list, however, I think I need to have some primary definitions by the authors in this draft, to define meanings of the main objective items (addressing, semantic routing, etc), so then it will be easier to survey and overview.

Best Regards,
AB

On Sat, Feb 13, 2021 at 1:41 PM Adrian Farrel <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

We have just posted "Challenges for the Internet Routing Infrastructure Introduced by Changes in Address Semantics" (https://datatracker.ietf.org/doc/draft-king-irtf-challenges-in-routing/<https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-king-irtf-challenges-in-routing%2F&data=04%7C01%7Cd.king%40lancaster.ac.uk%7C0789ec4da3bd49e47c8408d8d17c22c9%7C9c9bcd11977a4e9ca9a0bc734090164a%7C0%7C0%7C637489678393825383%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=zmZnEd9jRMv%2BdH%2FcFlyz7yBK09JYQFDuHTBmoQnV4w8%3D&reserved=0>).

Best,
Adrian (for the authors)

_______________________________________________
routing-discussion mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/routing-discussion<https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Frouting-discussion&data=04%7C01%7Cd.king%40lancaster.ac.uk%7C0789ec4da3bd49e47c8408d8d17c22c9%7C9c9bcd11977a4e9ca9a0bc734090164a%7C0%7C0%7C637489678393835329%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=3Hw%2B88OLxy6v9NQ5D4rAWyzS%2FAd9NC9gFKao3jGVce4%3D&reserved=0>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 15 Feb 2021 11:10:59 -0500

I can't argue with an effort to define the term "semantic routing".
However, I would be very concerned by an effort to define goals for it 
before we have such a definition.  Depending upon the definition, the 
answer may be that it is a bad idea.

Yours,
Joel

On 2/15/2021 5:40 AM, King, Daniel wrote:
> The I-D has bubbled for a while after seeing various discussions on 
> contextual and semantic routing I-Ds, mostly clean-slate approaches. 
> Although the initial literature review highlighted some common 
> objectives across proposals and implementations, I struggled to find 
> anything that defined "semantic routing" and goals that we could 
> use/reference. I likely missed prior research that provides a useful 
> definition. If not, then I agree that having the IRTF research community 
> document a description for "semantic routing" and common goals, would be 
> beneficial.
> 
> BR, Dan.
> 
> *From:*Abdussalam Baryun <[email-masked]>
> *Sent:* 15 February 2021 06:37
> *To:* adrian <[email-masked]>
> *Cc:* [email-masked]; 
> [email-masked]
> *Subject:* [External] Re: Request for information - Challenges in 
> routing related to semantic addressing
> 
> *This email originated outside the University. Check before clicking 
> links or attachments.*
> 
> Hi Adrian,
> 
> Thanks for this informational draft, I also think it is important for 
> this list, however, I think I need to have some primary definitions by 
> the authors in this draft, to define meanings of the main objective 
> items (addressing, semantic routing, etc), so then it will be easier to 
> survey and overview.
> 
> Best Regards,
> 
> AB
> 
> Introduced by Changes in Address Semantics" 
> (https://datatracker.ietf.org/doc/draft-king-irtf-challenges-in-routing/ 
> <https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-king-irtf-challenges-in-routing%2F&data=04%7C01%7Cd.king%40lancaster.ac.uk%7C0789ec4da3bd49e47c8408d8d17c22c9%7C9c9bcd11977a4e9ca9a0bc734090164a%7C0%7C0%7C637489678393825383%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=zmZnEd9jRMv%2BdH%2FcFlyz7yBK09JYQFDuHTBmoQnV4w8%3D&reserved=0>).
> 
> We asked the IRTF to help us with comments and thoughts. In particular, 
> if anyone is aware of any ongoing or published research in the area of 
> semantic addressing or the consequences in routing, we would like to 
> hear about it.
> 
> What we are doing is zooming in on any existing research of the impact 
> on the routing system and, absent that, to list out the questions that 
> should be answered by research.
> 
> [email-masked] <mailto:[email-masked]>
> <https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Frouting-discussion&data=04%7C01%7Cd.king%40lancaster.ac.uk%7C0789ec4da3bd49e47c8408d8d17c22c9%7C9c9bcd11977a4e9ca9a0bc734090164a%7C0%7C0%7C637489678393835329%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=3Hw%2B88OLxy6v9NQ5D4rAWyzS%2FAd9NC9gFKao3jGVce4%3D&reserved=0>
> 
>

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 15 Feb 2021 16:25:05 +0000

Joel

You have to start somewhere. Semantic routing is a staring point for a concept that clearly we need to research and gradually understand. If at the end of the process a better name emerges, no one will be precious about the word semantic. However for now we need to understand the mapping of the requirement to the need and then to determine the optimum name. For now, the term semantic routing seems to describe the direction even if it does not fully describe the destination.

Stewart

> On 15 Feb 2021, at 16:10, Joel M. Halpern <[email-masked]> wrote:
> 
> However, I would be very concerned by an effort to define goals for it before we have such a definition.  Depending upon the definition, the answer may be that it is a bad idea.
> 
> Yours,
> Joel
> 
>> *Cc:* [email-masked]; [email-masked]
>> *Subject:* [External] Re: Request for information - Challenges in routing related to semantic addressing
>> *This email originated outside the University. Check before clicking links or attachments.*
>> Hi Adrian,
>> On Sat, Feb 13, 2021 at 1:41 PM Adrian Farrel <[email-masked] <mailto:[email-masked]>> wrote:
>> Hi,
>> We have just posted "Challenges for the Internet Routing Infrastructure Introduced by Changes in Address Semantics" (https://datatracker.ietf.org/doc/draft-king-irtf-challenges-in-routing/ <https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-king-irtf-challenges-in-routing%2F&data=04%7C01%7Cd.king%40lancaster.ac.uk%7C0789ec4da3bd49e47c8408d8d17c22c9%7C9c9bcd11977a4e9ca9a0bc734090164a%7C0%7C0%7C637489678393825383%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=zmZnEd9jRMv%2BdH%2FcFlyz7yBK09JYQFDuHTBmoQnV4w8%3D&reserved=0>).
>> https://www.ietf.org/mailman/listinfo/routing-discussion <https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Frouting-discussion&data=04%7C01%7Cd.king%40lancaster.ac.uk%7C0789ec4da3bd49e47c8408d8d17c22c9%7C9c9bcd11977a4e9ca9a0bc734090164a%7C0%7C0%7C637489678393835329%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=3Hw%2B88OLxy6v9NQ5D4rAWyzS%2FAd9NC9gFKao3jGVce4%3D&reserved=0>

---

From: Tony Li <[email-masked]>
Date: Mon, 15 Feb 2021 09:43:41 -0800

> On Feb 15, 2021, at 8:10 AM, Joel M. Halpern <[email-masked] <mailto:[email-masked]>> wrote:
> 

I’ll go a bit farther.

In reading this draft, I’m struck by the lack of clear articulation of some of the fundamentals of the architecture. Routing and addressing are functionally tied together and 
any discussions of modifications to one requires a clear discussion of how it would affect the other function. We learned long ago that overloading functionality on packet fields is a poor design choice,
and even the early decision to overload identification onto location has had profound and deleterious effects that we have still not overcome.  In fact, you list the impacts of this architectural error
as things that you’d like to fix: multihoming, mobility, and multipath routing.

It’s also somewhat concerning when you list Scalability as one of the goals that you are proposing to fix with semantic overloading. It should be clear that any overloading of the address space
will reduce, not improve, its flexibility and thereby limit, not enhance Scalability.

If and when there is a clear definition of “semantic routing” and a clear proposal on how to move forward, there must also be a clear discussion of the affects of overloading addressing will
affect routing.

The original purpose of giving IPv6 128 bits of address space was to ensure that there was continued scalability for the routing system for the next 20 years (which have now expired ;-). In fact,
what we’ve learned is that transitioning to a new network layer takes a lot longer than what we had hoped and that the lifetime of a network layer is far more than expected. Thus, we should
be aiming to preserve IPv6 functionality in perpetuity and not simply for the next generation. To this end, we must be very careful about any unintended side-effects from overloading addressing,
especially with regards to routing scalability.

We have a fine example of this when we decided that most end sites would be granted a /64 prefix. This effectively took half of the addressing bits off of the table for global routing and since addressing is
hierarchical, this was a logarithmic decrease in overall routing scalability. Meanwhile, most of the individual sites are domestic networks that will never ever subnet.

So, please be very clear about the impacts of any proposal that suggests overloading addressing. The impact to the architecture will definitely be non-trivial and thus it bears careful consideration.

Regards,
Tony

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 15 Feb 2021 18:01:16 -0000

Thanks Tony, Joel, et al.

It is, perhaps not surprising that the discussion gravitates to “what is semantic addressing” and “what problems is it trying to solve”. And given that way of reading the draft, I suppose I am not surprised by being “accused” of suggesting that that semantic addressing is a solution for specific problems.

In fact (maybe the draft isn’t clear enough, maybe my mail to this list wasn’t clear enough), what we are trying to do is establish what research has been done on the implications for the routing system of what Tony calls “overloaded addresses”, and to set out the research questions that we think need to be looked into.

Along the way, and to give context, I think it is important to list out the proposals for adding semantics to addresses, and I think it is necessary to give a high-level accounting of what problems people think they are solving. But, as I said in my original email, 

> should be answered by research.

It seems to me that it is quite likely that many people have strong opinions about things that might go wrong. It also seems to me that a really good way to prove whether something is good or bad is to do the research. That’s what we’re looking for.

Keep discussing 😊

Adrian

From: Tony Li <[email-masked]> On Behalf Of Tony Li
Sent: 15 February 2021 17:44
To: Joel M. Halpern <[email-masked]>
Cc: King, Daniel <[email-masked]>; Adrian Farrel <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [External] Request for information - Challenges in routing related to semantic addressing

On Feb 15, 2021, at 8:10 AM, Joel M. Halpern <[email-masked] <mailto:[email-masked]> > wrote:

 

I’ll go a bit farther.

affect routing.

Regards,

Tony

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 15 Feb 2021 20:05:02 +0100

Hi Adrian,

My main comment to the draft is that the center of gravity is placed on
addressing semantics without clearly started if this draft is talking about
flat global addressing or local encapsulation. Sort of reader assumes it is
applicable to both.

Both tunnels and encapsulation words occur 3 times each in the entire
document.

It may be perhaps better to restructure it such that for global routing
system semantics of given address is different while in my network I can
use it to encapsulate and switch packets with much more freedom.

Kind regards,
Robert.

On Mon, Feb 15, 2021 at 7:01 PM Adrian Farrel <[email-masked]> wrote:

> It is, perhaps not surprising that the discussion gravitates to “what is
> semantic addressing” and “what problems is it trying to solve”. And given
> that way of reading the draft, I suppose I am not surprised by being
> “accused” of suggesting that that semantic addressing is a solution for
> specific problems.
>
>
>
> In fact (maybe the draft isn’t clear enough, maybe my mail to this list
> wasn’t clear enough), what we are trying to do is establish what research
> has been done on the implications for the routing system of what Tony calls
> “overloaded addresses”, and to set out the research questions that we think
> need to be looked into.
>
>
>
> Along the way, and to give context, I think it is important to list out
> the proposals for adding semantics to addresses, and I think it is
> necessary to give a high-level accounting of what problems people think
> they are solving. But, as I said in my original email,
>
> It seems to me that it is quite likely that many people have strong
> opinions about things that might go wrong. It also seems to me that a
> really good way to prove whether something is good or bad is to do the
> research. That’s what we’re looking for.
>
>
>
> Keep discussing 😊
>
>
>
> Adrian
>
>
>
>
>
> *From:* Tony Li <[email-masked]> *On Behalf Of *Tony Li
> *Sent:* 15 February 2021 17:44
> *To:* Joel M. Halpern <[email-masked]>
> *Cc:* King, Daniel <[email-masked]>; Adrian Farrel <
> [email-masked]>; [email-masked];
> *Subject:* Re: [External] Request for information - Challenges in routing
> related to semantic addressing
>
>
>
>
>
>
>
> On Feb 15, 2021, at 8:10 AM, Joel M. Halpern <[email-masked]> wrote:
>
>
>
> In reading this draft, I’m struck by the lack of clear articulation of
> some of the fundamentals of the architecture. Routing and addressing are
> functionally tied together and
>
> any discussions of modifications to one requires a clear discussion of how
> it would affect the other function. We learned long ago that overloading
> functionality on packet fields is a poor design choice,
>
> and even the early decision to overload identification onto location has
> had profound and deleterious effects that we have still not overcome.  In
> fact, you list the impacts of this architectural error
>
> It’s also somewhat concerning when you list Scalability as one of the
> goals that you are proposing to fix with semantic overloading. It should be
> clear that any overloading of the address space
>
> If and when there is a clear definition of “semantic routing” and a clear
> proposal on how to move forward, there must also be a clear discussion of
> the affects of overloading addressing will
>
> affect routing.
>
>
>
> The original purpose of giving IPv6 128 bits of address space was to
> ensure that there was continued scalability for the routing system for the
> next 20 years (which have now expired ;-). In fact,
>
> what we’ve learned is that transitioning to a new network layer takes a
> lot longer than what we had hoped and that the lifetime of a network layer
> is far more than expected. Thus, we should
>
> be aiming to preserve IPv6 functionality in perpetuity and not simply for
> the next generation. To this end, we must be very careful about any
> unintended side-effects from overloading addressing,
>
> We have a fine example of this when we decided that most end sites would
> be granted a /64 prefix. This effectively took half of the addressing bits
> off of the table for global routing and since addressing is
>
> hierarchical, this was a logarithmic decrease in overall routing
> scalability. Meanwhile, most of the individual sites are domestic networks
> that will never ever subnet.
>
>
>
> So, please be very clear about the impacts of any proposal that suggests
> overloading addressing. The impact to the architecture will definitely be
> non-trivial and thus it bears careful consideration.
>
>
>
> Regards,
>
> Tony
>
>