Subject: [RPSEC] RE: [manet] Dumber Question?

From: Marwaha Shivanajay <[email-masked]>
Date: Wed, 15 May 2002 21:17:54 +0800

Hi,
Assignment of IP adresses is done using "autoconfiguration" in ad hoc
networks.
The draft that deals with this can be found here
http://www.cs.ucsb.edu/~eroyer/txt/autoconf.txt

To summarize it in short:
If a mobile node wants to have an IP address it broadcasting a RREQ kind of
message destined to that IP address. If there exists a mobile device with
the same address it gets a RREP back from it and reinitiates the process by
choosing a new IP address, otherwise (if it aint get any RREP) it assumes
that IP address.

The IP address seeking node keeps a temporary address for receiving RREP
back to it.

It does deal with avoiding duplicacy of IP addresses in one disconnected set
of mobiles. But there isn't any central mechanism to allot the same. Nor
does it guarentee uniqueness in disconnected networks. 

Regards,
Shivanajay Marwaha
-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~
Research Scholar
Electrical and Computer Engg. Dept.
National University of Singapore.
10 Kent Ridge Crescent,
Singapore 119260.
Ph. +65-68742136
-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~

-----Original Message-----
From: Daniel Oldham [mailto:[email-masked]] 
Sent: Wednesday, May 15, 2002 7:20 PM
To: Mullen, John P. (Contractor)
Cc: Nast, Douglas P; [email-masked]
Subject: RE: [manet] Dumber Question?

Hello Everyone:

Good point, on the Internet IP addresses are regulated and assigned to 
provide a hierarchical structure to allow for proper routing. 

For an ad-hoc network what controls the assignment of IP addresses? 

What happens if there are duplicate IP addresses in an ad-hoc network? 

How is an ad-hoc network connected to the Internet?

How do packets from the Internet get an IP address in an ad-hoc network? 
--
Daniel R. Oldham Ph.D.
Computer Engineer
Satellite Networks and Architectures Branch
NASA Glenn Research Center
21000 Brookpark Road (MS 54-5)
Cleveland OH 44135
216.433.6307 - voice
216.433.8705 - fax
[email-masked]

>>>>>>>>>>>>>>>>>> Original Message <<<<<<<<<<<<<<<<<<

On 5/14/02, 2:16:26 PM, "Mullen, John P. (Contractor)" 
<[email-masked]> wrote regarding RE: [manet] Dumb 
Question?:

> Hi Doug,

> My concern was that the forwarding process might be called something 
> else
in
> a MANET, since it functions differently from the analogous process in
wired
> networks.  However, the consensus seems to be that the same term is 
> used.
 I
> think I've gotten my answer on that.

> The process would be the consequence of the chosen protocol.  As I 
> understand it, the process by which a node obtains link information is 
> called "routing" and the process by which a node decides which of the
three
> things to do is called either "forwarding" or "switching," depending 
> on
who
> you talk to.  The details of the processes would be limited by
operational
> and hardware constraints and defined in the protocols.

> The scheme used to assign node addresses is a key issue in military
MANETs.
> At the upper levels, one wants a scheme that reflects the hierarchical 
> military organization.  This facilitates the proper routing of orders, 
> partial orders, etc.  However, at the lower levels, one would want an 
> addressing scheme that reflects the actual network topology.  This 
> would allow clustering, which would make route determination and 
> forwarding simpler.  One solution is to do both, coordinating the 
> system via the interface.  However, the nodes are in constant motion, 
> so the interface would need to update its information on the fly.  
> Offsetting the higher efficiency of the clusterable scheme at the 
> lower levels is a more complicated interface and more difficulty 
> enforcing security.  I don't
think
> this issue has been resolved yet, so, of course, the protocols are 
> also
up
> in the air.

> I just started reading _Ad Hoc Networking_, edited by Charles Perkins.
In
> "A DoD Perspective on Mobile Ad Hoc Networks," James Freebersyser
speculates
> on p. 33 that it is unlikely a single protocol will be able to operate 
> efficiently over the full range of conditions under which a military
MANET
> must operate.  If he is correct, the issue may never be fully 
> resolved.

> But, there is always hope,

> And, graduate students.

> :-)

> John Mullen

> -----Original Message-----
> From: Nast, Douglas P [mailto:[email-masked]]
> Sent: Tuesday, May 14, 2002 11:10 AM
> To: 'Mullen, John P. (Contractor)'
> Cc: [email-masked]
> Subject: RE: [manet] Dumb Question?

> John,

> You sent a reply saying you understood that layer 3 routing was going 
> on
but
> wondered what this other process was.  Thanks for the clarification.

> Note that in your question you say that "such a thing is not possible. 
> Instead, each node that receives a packet decides to..."  and then you
give
> 3 possible behaviors, consume, re-broadcast, or discard.

> By what process do the nodes come to understand which of these 
> behaviors
is
> appropriate for them? Who/What is doing the teaching and to what 
> purpose? Are the decisions you describe being made on the basis of MAC 
> layer addresses or IP?

> The first thing that occurs to me is that this behavior was learned 
> via a route discovery process, sort of like source route bridging in 
> 802 LANs. This approach to routing in Manets was proposed a while back 
> by David B. Johnson, and is, I think, the basis of the reactive 
> approach to manet routing.  If that's the case, then you can call it 
> routing or you can
call
> it switching, but it is not worthy of a new name.

> Based on Perkins and Ram responses, I guess I am missing something,
though.
> Do you think your question has been resolved? If so how?

> Doug Nast, Boeing

> -----Original Message-----
> From: Mullen, John P. (Contractor) 
> [mailto:[email-masked]]
> Sent: Monday, May 06, 2002 2:08 PM
> To: [email-masked]
> Subject: [manet] Dumb Question?

> Hello,

> I am looking for a term, but have had no luck.

> In wired nets, a packet is routed through the network from node to 
> node,
say
> by routing tables.  However, in MANETs, in which packets are broadcast
via
> omnidirectional antennae on a shared channel, such a thing is not
possible.
> Instead, each node that receives a packet  decides to:
>      1.  Discard the packet,
>      2.  "Read" the packet, since it is addressed to the node, and/or
>      3.  Rebroadcast the packet.

> If the node is not to be an intermediary node in the end-to-end path
between
> the source and the destination, or if the node is receiving a copy of 
> a packet it had previously broadcast, it will not broadcast the packet.
This
> is necessary to avoid overutilizing the channel.

> If the node is an intermediary node on the path, then it must 
> rebroadcast the packet.

> I've got this much figured out, but what I do not know is what this
process
> is called.  It is the MANET equivalent to "routing," but is not really 
> routing, since the sending node has no way of directing the packet.

> I've tried a number of searches and read a few glossaries, but have 
> not
been
> able to find this term.

> I'd appreciate any help.

> Thanks,

> John P. Mullen

> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet

> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

_______________________________________________
RPSEC mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rpsec

---

From: Fred Baker <[email-masked]>
Date: Wed, 15 May 2002 10:31:07 -0700

>Assignment of IP adresses is done using "autoconfiguration" in ad hoc

ahem; one mechanism for address assignment is autoconfiguration. Never tell 
your customer that he's not allowed to type it in :^)