Subject: RE: [RPSEC] Agenda Items for Atlanta

From: "Michel Py" <[email-masked]>
Date: Wed, 16 Oct 2002 22:16:24 -0700

Tony / Russ,

> Tony Tauber wrote:
> It's time to get this information together so please send
> along any items you wish discussed or presented in Atlanta.

Dumb question (kinda long)

> [quoted from the charter]
> It is also a non-goal at this point to produce new or change
> the current security mechanisms in the existing routing protocols.

The way I read this is:
"Let's try not to make the same mistakes for future protocols than we
made for the existing ones".

So, part of the drafts that needs to be produced is to document what not
to do, but the idea is to make future protocols better, not the current
ones; the cornerstone of it being:

> OCT 02 Submit initial I-D (or set of I-Ds) which outlines
> security requirements for routing systems.
> MAR 03 Submit the I-D documenting security requirements to
> routing systems for publication as Informational RFC

Although it's impossible to predict future developments, I have trouble
envisioning a requirements draft that is not aware of currently being
developed protocols.

Finally, here is my question: Is there a list of currently being
developed routing protocols that this WG will look at as part of the
process of writing the requirements document?

Michel.

_______________________________________________
RPSEC mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rpsec

---

From: Russ White <[email-masked]>
Date: Thu, 17 Oct 2002 10:32:48 -0400 (EDT)

> The way I read this is: "Let's try not to make the same
> mistakes for future protocols than we made for the existing
> ones".
> 
> So, part of the drafts that needs to be produced is to
> document what not to do, but the idea is to make future
> protocols better, not the current ones; the cornerstone of it
> being:
> 
> Although it's impossible to predict future developments, I
> have trouble envisioning a requirements draft that is not
> aware of currently being developed protocols.

I don't think this is possible, either. The point was more to
prevent us from black holing on existing security mechanisms, and
just to focus on what we could to do make things more secure.

> Finally, here is my question: Is there a list of currently
> being developed routing protocols that this WG will look at
> as part of the process of writing the requirements document?

All the routing protocols.... ISIS, BGP (and variants), OSPF,
RIP, PIM, etc. There's no list because we presume such a list
will change before we finish it. 

:-)

Russ

__________________________________
[email-masked] CCIE <>< Grace Alone