Subject: Re: [RPSEC] Back to the Basics: The AS Path

From: Sandy Murphy <[email-masked]>
Date: Mon, 24 Jan 2005 14:42:36 -0500 (EST)

>> Yes, understood.  But prepending arbitrary AS's is a challenging security
>> principle to support.
>
>        where will you check to ensure an AS is properly assigned?
>        whois?

Assigned?  What do you mean?

We're currently just trying to decide what a valid path is.  We haven't
talked yet about how one would perform the verification, if that's
what you mean.

--Sandy

_______________________________________________
RPSEC mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rpsec

---

From: [email-masked]
Date: Mon, 24 Jan 2005 21:13:25 +0000

> Assigned?  What do you mean?

	much of the thread has talked about "my" vs "arbitrary" ASNs.
	how are these attributes to be determined by anyone other
	than the prefix originator?

> talked yet about how one would perform the verification, if that's

	and my question lies at the heart of "valid" path.
	by what means is a "valid" path determined?

	e.g. i originate prefix 192.168.53.0/24 from AS 4555...
	by what means does someone/someprogram deterministically
	decide that AS 4555 is "mine" and is allowed to properly
	originate a path to said prefix?

	if the answer is via the WHOIS protocol, then there are larger
	fish to fry than RPSEC... :)