Subject: Re: [RPSEC] Back to the Basics: The AS Path

From: Sandy Murphy <[email-masked]>
Date: Mon, 24 Jan 2005 14:31:45 -0500 (EST)

>> The common usage is to prepend an arbitrary number of your *own* AS to
>> the path. I wouldn't be surprised if some people depend on being able
>> to prepend an arbitrary AS other than their own.
>
>        and there are some folks who have several AS'es and 
>        they use these as well as private AS'es..

I know that there are folks who own several AS's for various reasons.
But could they not just make sure that they repeat the same one of
those AS's when they do multiple prepending?  Hope it's not just a "the
config tools don't let us".

As for private AS's, I thought the whole idea of the "private" part
was that you didn't include them in updates to external peers?  Isn't
that commonly reported as bad practice?

>> Being able to prepend your own AS is vital.
>
>        yes.

Not in question.  No one has suggested that you wouldn't be able to do so.

--Sandy

_______________________________________________
RPSEC mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rpsec

---

From: Jeffrey Haas <[email-masked]>
Date: Mon, 24 Jan 2005 15:50:22 -0500

> that commonly reported as bad practice?

Private ASes can be used for whatever purpose you want.  However, they're
not supposed to be visible in the public Internet.

In order for private ASes to be visible, you have to put them in your eBGP
sessions.

If the network looks like:

2 --- 1 --- 65000 --- 65001 10/8

And destination D shows up at AS 2 as:

10/8 <1>

Then we've met common practice.

AS 1 will likely have:

10/8 <1 65000 65001>

-- 
Jeff Haas 
NextHop Technologies