Subject: Re: [rrg] Critique of Compact Routing

From: [email-masked]
Date: Mon, 29 Dec 2008 18:37:45 EST

One additional remark:
I have been involved in PNNI.So I know a lot about state of the art  
hierarchical routing. When we did PNNI we were fancy about address  summarization (wrt 
3 address families!) as well as about topology  aggregation (which we did 
definitively in a wrong way).
Today I am pursuing a completely different topology aggregation in order to  
get rid of address summarization completely.
 
I have said several times, that I have learned to be patient. However there  
is a limit: TARA can incrementally be deployed such that the BGP table size  
would continuously shrink provided that during this phase IPv4 addresses are  
still globally unique. Thereafter they may be router-locally unique, no  
problem.
 
Heiner

In einer eMail vom 30.12.2008 00:17:21 Westeuropäische Normalzeit schreibt  
[email-masked]:

know this paper for quite a while and whenever I mentioned any word on  this 
mailinglist about "stretch", a term invented by these authors as to  
discriminate ANY hierarchical routing architecture, those that they know as  well as 
those that they don't know, I had to think of this paper.
 
Heiner

In einer eMail vom 29.12.2008 23:56:13 Westeuropäische Normalzeit  schreibt 
[email-masked]:

In an  earlier message 000565 I mentioned a paper:

On Compact  Routing for the Internet
Dmitri Krioukov, kc claffy, Kevin  Fall, Arthur Brady
ACM SIGCOMM CCR, v.37, n.3, p.41-52,  2007

This is available at:

http://arxiv.org/abs/0708.2309

-  Robin
_______________________________________________
rrg mailing  list
[email-masked]
https://www.irtf.org/mailman/listinfo/rrg

_______________________________________________
rrg  mailing  list
[email-masked]
https://www.irtf.org/mailman/listinfo/rrg

_______________________________________________
rrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/rrg

---

From: Steven Blake <[email-masked]>
Date: Mon, 29 Dec 2008 21:00:33 -0500

On Mon, 2008-12-29 at 18:37 -0500, [email-masked] wrote:
 
> I have said several times, that I have learned to be patient. However
> there is a limit: TARA can incrementally be deployed such that the BGP
> table size would continuously shrink provided that during this phase
> IPv4 addresses are still globally unique. Thereafter they may be
> router-locally unique, no problem.

Show us a draft.

Regards,

// Steve