Subject: Re: [rrg] Summary of architectural solution space

From: [email-masked]
Date: Fri, 19 Dec 2008 12:58:40 EST

A comment wrt Strategy C 's major criticism:
 
What is hereby criticized is an allegeable inability for doing  
discriminating routing.
 
Anyone being familiar with OSPF will admit that you may advertise  individual 
links and individual nodes to "be not usable for transit". If this  were too 
general, then of course it may take some more effort to advertise  them "to be 
not usable (for transit) by well-specified packet flows".
Will say: it is not a fundamental question whether this kind of  economic 
model can be supported or not.
 
However, multipath routes via  more remote neighbors, are,  fundamentally !!, 
disabled, if such a neighbor has at first received  an UPDATE message from 
the current router, and has no reason to propagate a  worse path to this current 
router. Here the economic model excludes a  significant portion of multipath 
alternatives, which cannot be enabled without  an enormous churn increase.
 
Heiner

_______________________________________________
rrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/rrg

---

From: "William Herrin" <[email-masked]>
Date: Fri, 19 Dec 2008 13:09:02 -0500

On Fri, Dec 19, 2008 at 12:58 PM,  <[email-masked]> wrote:
> general, then of course it may take some more effort to advertise them "to
> be not usable (for transit) by well-specified packet flows".

Heiner,

OSPF is an intra-domain routing protocol. A single entity owns all of
the nodes and links. Since you really can't steal from yourself, no
theft of service anomalies are possible.

OSPF is not used as an interdomain routing protocol and does not make
an appropriate solution in the interdomain space.

Regards,
Bill Herrin

-- 
William D. Herrin ................ [email-masked]  [email-masked]
3005 Crane Dr. ...................... Web: <http://bill.herrin.us/>
Falls Church, VA 22042-3004
_______________________________________________
rrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/rrg