Subject: Re: [rrg] Two new I-Ds on Routing Architecture for the Next Generation Intern...

From: [email-masked]
Date: Fri, 13 Mar 2009 06:37:36 EDT

Xiaohu,
Your RANGI makes me think about further improvements of TARA:
What is addressed by the IP-address might better be addressed by the host  
identifier of HIP. Whereas adressing the destination DFZ-router can be done  
better by means of its geographical location id, derived from its  longitude / 
latitude position, which is a) non-political/more  stable and b) summarizable 
(each point can be the center point of circles  of any radius around). (= a main 
difference to RANGI's countrycode / reagion  code ...).
 
Then you don't need neither IPv4 nor IPv6 addresses. Is it a sacrileg  to 
have thoughts like this?  

BTW, can anyone of the LISP supporters tell me and all the others how many  
ALT routers will be needed as to cope with today's (tomorrow's) internet ?
 
Heiner

 
In einer eMail vom 13.03.2009 10:49:58 Westeuropäische Normalzeit schreibt  
[email-masked]:

In fact,  the RANGI proxy borrows some idea from the map&encap approach  to
support communication between RANGI-aware hosts and legacy IPv4/v6  hosts. To
some extent, the map&encap can be considered as transition  strategy for a
host-based id/locator split approach.That's to say, the  Strategy A and B
(Herrin's Taxonomy)can be complementary.

Any  comment  welcomed.

Xiaohu

> -----邮件原件-----
> 发件人:  Raj Jain [mailto:[email-masked]] 
> 发送时间: 2009年3月6日 15:15
>  收件人: [email-masked]
> 主题: Two new I-Ds on Routing Architecture for the  Next 
> Generation Internet (RANGI)
> 重要性: 高
> 
>  Earlier this week, we submitted two new drafts: 
> draft-xu-rangi-00.txt  and draft-xu-rangi-proxy-00.txt
> 
>  http://tools.ietf.org/html/draft-xu-rangi and 
>  http://tools.ietf.org/html/draft-xu-rangi-proxy
> 
> Both these  drafts build on and explain the details of the 
> RANGI presentation I  had given at the last RRG meeting in Minneapolis.
>  
> We  would appreciate receiving your comments and suggestions 
> for  improvements.
> 
> Abstracts of the drafts are as follows:
>  
> draft-xu-rangi-00.txt
> Routing Architecture for the Next  Generation Internet (RANGI) 
> 
>    IRTF Routing  Research Group (RRG) is exploring a new 
> routing and  addressing
>    architecture to meet the challenges that  current Internet 
> is facing, especially in
>    terms  of routing scalability. This internet draft 
> describes a new routing  and
>    addressing architecture, called Routing Architecture  for 
> the Next Generation
>    Internet (RANGI) as a  solution to the problems of 
> scalability, mobility,
>   multihoming, and traffic engineering. RANGI is a hybrid 
>  proposal that combines and
>    enhances the ideas from  several proposals particularly 
> those based on
>     identifier/locator split approach. It introduces a 
> hierarchical and  cryptographic
>    host identifier and adopts a hierarchical  routing 
> mechanism to support routing
>    across  multiple independent address spaces. To allow 
> smooth transition from  IPv4
>    to IPv6, it adopts an IPv6 address with an IPv4  embedded 
> in the last four bytes as
>    locator. This  also simplifies renumbering in case of 
> change of service  providers.
>    RANGI allows traffic engineering by allowing  border 
> routers to overwrite the
>    source  addresses. It allows policy control on ID to 
> address translation by  having
>    a hierarchical resolution mechanism.
>  
> draft-xu-rangi-proxy-00.txt
> A Transition Mechanism for   
> Routing Architecture for the Next Generation Internet  (RANGI)
> 
>    The Routing Architecture for the Next  Generation Internet 
> (RANGI) is
>    a proposal for  solving routing scalability, mobility, multihoming,
>     traffic engineering and other issues facing the current  Internet.
>    RANGI is described in a separate document  [RANGI]. This document
>    describes a transition mechanism  for RANGI. With this mechanism,
>    legacy IPv4 or IPv6 hosts  can communicate with RANGI 
> hosts, and vice
>     versa. This allows RANGI to be deployed incrementally in 
> the  current
>    Internet.
> 
> Thanks.
> -Raj  Jain and Xiaohu Xu
>  -----------------------------------------------------
> Raj Jain   
>  Professor of Computer Science and Engineering         
> Washington University in St.  Louis
> Campus Box 1045, One Brookings Drive
> St. Louis, MO  63130
> Phone: +1 314 935 4963
> Email: [email-masked]
>  URL: http://www.cse.wustl.edu/~jain
>  ------------------------------------------------------
> 
>  

_______________________________________________
rrg mailing  list
[email-masked]
http://www.irtf.org/mailman/listinfo/rrg

---

From: Xu Xiaohu <[email-masked]>
Date: Mon, 16 Mar 2009 11:38:50 +0800

Heiner,
 
In RANGI, the locator is still provider-assigned IPv6 address with the exception that this IPv6 address is a IPv4-embeded IPv6 address. In fact, the country/region code is an example of the Administrative Domain ID which is a part of the hiearchical host ID.
 
BTW, do you believe that the flat label is a good option for identifier (e.g. the HIT in HIP)?
 
Xiaohu

  _____  

发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2009年3月13日 18:38
收件人: [email-masked]; [email-masked]
抄送: [email-masked]
主题: Re: [rrg] Two new I-Ds on Routing Architecture for the Next Generation Intern...

Xiaohu,
Your RANGI makes me think about further improvements of TARA:
What is addressed by the IP-address might better be addressed by the host identifier of HIP. Whereas adressing the destination DFZ-router can be done better by means of its geographical location id, derived from its longitude / latitude position, which is a) non-political/more stable and b) summarizable (each point can be the center point of circles of any radius around). (= a main difference to RANGI's countrycode / reagion code ...).
 
Then you don't need neither IPv4 nor IPv6 addresses. Is it a sacrileg to have thoughts like this?  

BTW, can anyone of the LISP supporters tell me and all the others how many ALT routers will be needed as to cope with today's (tomorrow's) internet ?
 
Heiner

 
In einer eMail vom 13.03.2009 10:49:58 Westeuropäische Normalzeit schreibt [email-masked]:

Any comment  welcomed.

Xiaohu