Subject: Re: [rrg] question about the Identifier/Locator separation

From: "张国强" <[email-masked]>
Date: Sat, 28 Mar 2009 07:39:47 +0800

�����������������ᵽ:
>From: "Jun Bi" <[email-masked]>
>Reply-To: 
>To: 张国�?<[email-masked]>,
<[email-masked]>
>Subject: Re: [rrg] question about the Identifier/Locator separation
>Date:Fri, 27 Mar 2009 16:28:48 -0700
>
>
> 
>> I'm a newcommer to this working group.
>> To my understanding, the new architecture contains identifiers, 
>> locator/routing,
>> mapping systems. So when a user moves, his identifier will not change, but 
>> he will
>> get a new locator, and he has to publish the new locator in the mapping 
>> system, or
>> there is some automotic mechanisms to do that.
>>
>> My problem is that in traditional routing systems, the IPv4 address serves 
>> both
>> the identifier and locator, and the routing table growth and routing 
>> dynamics
>> happens to the routing system. When identifier and locator separates, the 
>> routing
>> system will have much less pressure, but what about the mapping system. It 
>> seems
>> that the pressure has been transfered from the routing system to the 
>> mapping
>> system. Can the mapping system handle the large number of mappings and 
>> dynamics?
>
>I think, the major benifits of ID/Location mapping are not only for routing 
>scaliablity.
>Please see the slides in RRG meeting today.

I don't doubt the benefits of ID/locator separation. My concern is what if the
mapping system cannot accompolish the strong dynamics or other burdens that are
shifted from the routing system?

>thanks,
>Jun Bi
>
>
>
>
>>
>>
>> _______________________________________________
>> rrg mailing list
>> [email-masked]
>> http://www.irtf.org/mailman/listinfo/rrg
>>
>> 
>
>

---

From: "Jun Bi" <[email-masked]>
Date: Fri, 27 Mar 2009 16:46:38 -0700

Yes, I agree, that's a issue need to be investigated.
Multiple IDs could share the single Locator (ip address), and one ID may use 
multiple locators.
So there will be 1:n and n:1 mapping (rather than 1:1 mapping). So the 
mapping need to be stuided.

For ID/Loc separation, it's just at the staring point, defining the term.

thanks,
Jun

----- Original Message ----- >>