Subject: [rrg] Locators

From: Toni Stoev <[email-masked]>
Date: Sat, 15 Aug 2009 23:23:53 +0300

"Why should it be simple when it can be complex?" -- Folklore

You are reading your email off your portable computer and you have a constantly updated weather map on your desktop. You may be chatting through an instant messaging service and may be listening to live-streamed audio, and may start talking on the computer videophone.
You move to a different room, so you unplug your network cable, and you know a wireless link will keep those communications running.
Your local router has to realize the situation and stop transmitting communications packets to the cable interface and start transmitting them to the computer's wireless interface, and any broken sessions have to be re-established with remote servers.
You are the same person using the same network services on your same computer through your same router, but you experience service slowdown or even need to reinitiate some of the communications. Why?

(Re)searcher Toni

---

From: Scott Brim <[email-masked]>
Date: Sat, 15 Aug 2009 19:12:28 -0400

> You are the same person using the same network services on your same computer through your same router, but you experience service slowdown or even need to reinitiate some of the communications. Wh…

Your local router doesn't have to solve this problem.  It's
end-to-end, and each of those flows may have a different solution.
Some like the weather map may be solved in the application.  You might
find this interesting:

http://www.ietf.org/mail-archive/web/multipathtcp/current/maillist.html

(for multipath SCTP see the TSVarea list)

---

From: Toni Stoev <[email-masked]>
Date: Mon, 24 Aug 2009 08:37:34 +0300

Noel, Scott, Heiner, thank you for engaging.

Scott Brim wrote:
> end-to-end,

So should an end be engaged with remote end's local link interfaces, like sending packets with destination an interface locator, and why?

> and each of those flows may have a different solution. 
> Some like the weather map may be solved in the application. 

If a problem is left intact in the routing, multiple working groups are needed to solve its effects.

> You might 

> You move to a different room, so you unplug your network cable, and you know a wireless link will keep those communications running.

That is the easy case. What if you are in a public place and get public globally routable locators, should the locators be bound to interfaces and should the remote servers take care therefor of your local connectivity?

> You are the same person using the same network services on your same computer through your same router, but you experience service slowdown or even need to reinitiate some of the communications. Wh…

The same