Subject: Re: [rrg] 答复: 答复: Some misunderstanding about ILNP

From: Tony Li <[email-masked]>
Date: Thu, 06 Aug 2009 00:27:14 -0700

Xu Xiaohu wrote:
> So I wonder whether this choice of using locally
> unique identifiers is much worthwhile.

Certain people are very much in favor of locally unique identifiers.
This is because traffic analysis of globally unique identifiers raises
privacy concerns.

Tony

---

From: RJ Atkinson <[email-masked]>
Date: Thu, 06 Aug 2009 05:18:56 -0400

On  5 Aug 2009, at 23:31, Xu Xiaohu wrote:
> For the purpose of identifier switchover in ILNP, the
> communicating nodes should also exchange their bundle
> of identifiers in advance.

ILNP-capable nodes keep their set of I records in the DNS,
just as IP addresses are kept in A/AAAA records.  This is
described in the Internet-Drafts, especially in the DNS I-D.

> ( e.g., using the combination of identifier and nonce to distinguish
> two nodes which use the same identifier but are located within  
> different
> subnets,

Hmm.  I would not have worded that in the way that you did.

Different subnets always have different Locators.  Locators are
just names for subnets, for example see the ILNP Intro I-D.  So
anytime there is a different subnet, there will also by definition
be a different Locator value.

> and using the above pre-exchange of identifier bundle

It seems curious to describe "using the DNS to retrieve I Records
associated with a Domain Name" as "pre-exchange of identifier bundle".

Yours,

Ran