Subject: Re: [rrg] Another concern about using FQDNs as host idenfieirs//re: A concern with ILNP//re: critique of RANGI

From: Xu Xiaohu <[email-masked]>
Date: Wed, 03 Feb 2010 09:13:52 +0800

> -----邮件原件-----
> 发件人: Xu Xiaohu [mailto:[email-masked]]
> 发送时间: 2010年2月2日 17:02
> 收件人: 'Tony Li'; [email-masked]'
> 主题: re: [rrg] Another concern about using FQDNs as host idenfieirs//re:
A
> concern with ILNP//re: critique of RANGI
> 
> 
> 
> > -----邮件原件-----
> > 发件人: [email-masked] [mailto:[email-masked]] 代表 Tony Li
> > 发送时间: 2010年2月2日 14:24
> > 收件人: [email-masked]
> > 主题: Re: [rrg] Another concern about using FQDNs as host
idenfieirs//re:
> A
> > concern with ILNP//re: critique of RANGI
> >
> >
> >
> > > If I understood ILNP correctly, each ILNP host needs a globally unique
FQDN.
> > > That’s to say, the FQDN can not be used as a service ID to represent
a
> set
> > > of ILNP servers which are scattered in the Internet. As a result, the
above
> > > load-balancing service through DNS is not available anymore in the
ILNP
> > > architecture. Maybe another indirection from one FQDN (representing a
> > > Service ID) to another one (representing a Host ID) should be
developed
> in
> > > order to support the above service.
> >
> >
> > Hi,
> >
> > That's an interesting interpretation.
> >
> > ILNP uses an explicit numeric token as the identifier.  The FQDN is not
> > the identifier.  The identifier can be found in the I record.
> >
> > On a forward reference, a FQDN is resolved into an I record and one or
> > more L records.  In the case of a service name, it is not unreasonable
> > for DNS to return multiple I records, each with an associated set of L
> > records.  This is not explicitly called out in the current ILNP
> > documentation, but is a reasonable extrapolation from current usage,
> > plus the existing documents.
> 
> Interesting, is there any association between the I record and the L
record?

By the way, as stated in the ILNP draft, "...the Locally unique Identifiers
are unique within the context of their associated Locators...". Therefore,
there SHOULD be some association between I records and L records of a given
host. Unfortunately, there seems NO such association in the current ILNP
specification.

Xiaohu
 
> Best wishes,
> Xiaohu
> 
> > Regards,
> > Tony
> >
> >
> > _______________________________________________
> > rrg mailing list
> > [email-masked]
> > http://www.irtf.org/mailman/listinfo/rrg

---

From: Xu Xiaohu <[email-masked]>
Date: Wed, 03 Feb 2010 11:02:02 +0800

> -----邮件原件-----
> 发件人: [email-masked] [mailto:[email-masked]] 代表 Xu Xiaohu
> 发送时间: 2010年2月3日 9:14
> 收件人: 'Tony Li'; [email-masked]
> 主题: Re: [rrg] Another concern about using FQDNs as host idenfieirs//re:
A
> there SHOULD be some association between I records and L records of a
given

Otherwise, using mismatched L and I pair will cause a packet intended for
host A (e.g., a multi-homed host with two L+I pairs, Lx+Ix, Ly+Iy) to be
forwarded mistakenly to host B (Lx+Iy). Note that the I records mentioned
here are filled with Locally unique Identifiers. 

Xiaohu

---

From: Tony Li <[email-masked]>
Date: Wed, 03 Feb 2010 09:30:33 -0800

Hi Xiaohu,

> here are filled with Locally unique Identifiers.

There's more misunderstanding here.

A multihomed host has only one identifier.  The problem comes about, as
you've previously observed, when a FQDN resolves to multiple hosts.

Tony

---

From: Xu Xiaohu <[email-masked]>
Date: Thu, 04 Feb 2010 11:16:01 +0800

Hi Tony,

> -----邮件原件-----
> 发件人: Tony Li [mailto:[email-masked]]
> 发送时间: 2010年2月4日 1:31
> 收件人: Xu Xiaohu; [email-masked]
A
> A multihomed host has only one identifier.  

It seems that Ran doesn't agree to your point :). Please see Ran's response
to your opinion in another discussion thread " Sundry ILNP confusions...":
************************************************
Much earlier, Tony Li wrote:
> ILNP uses an explicit numeric token as the identifier.  The FQDN is 
> not the identifier.  The identifier can be found in the I record.
> 
> more L records.

Yes, with one edit:
	...into one or more I records and one or more L records...

One does not expect a node to be using multiple IDs in the common case, but
it is permitted -- for example to enable folks who wish to use "privacy"
(sic) Identifiers generated (as per RFC-4941) or use
cryptographically-generated Identifiers (as per RFC-3972).
************************************************

> The problem comes about, as

I guess you wanted to say "... when a FQDN resolves to multiple _I records_
(no matter whether they belong to a single host or not)". But your above
statement seems also right since your assumption is a host has only one I
record.

Xiaohu