Subject: [rrg] More abbreviation expansions

From: Tony Li <[email-masked]>
Date: Fri, 26 Feb 2010 17:41:51 -0800

Hi all,

I've received the following proposed text:

PA - Provider Assigned: Addresses which cannot be 'taken with you' when a
site moves to a different location on the network connectivity
structure; usually assigned by a service provider (hence the name).

PI - Provider Independent: Addresses associated with a site and which move
with it when it moves to a different location on the network connectivity
structure; independent of any service provider (hence the name).

Any objections?

Tony

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 28 Feb 2010 13:33:59 +1300

I have always understood PA to mean Provider Aggregatable
or Provider Aggregated (which is of course only possible
because they are assigned by the provider who will perform
the aggregation).

In terms of history, I have in my archive a note drafted
in 1995 by Daniel Karrenberg at RIPE, entitled
"Provider Independent vs Provider Aggregatable Address Space"
(sent to [email-masked], [email-masked], [email-masked] and
[email-masked] on 17 May 1995).

"provider assign[ed]" also pops up in my archive from the same
era, but "aggregatable" seems to be the more common usage
(46 vs 18 hits in my archive).

Regards
   Brian Carpenter

On 2010-02-27 14:41, Tony Li wrote:
> _______________________________________________
> rrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/rrg
>

---

From: Christopher Morrow <[email-masked]>
Date: Sun, 28 Feb 2010 13:19:11 -0500

I think either set works, but pick one and stick to it, that's the
important bit.

-chris

---

From: Ruediger Volk <[email-masked]>
Date: Sun, 28 Feb 2010 22:37:12 +0100

> (46 vs 18 hits in my archive).
I'm also used to expand the "A" to "Aggregatable" (thanks for the supporting
stats:-)

I'd prefer sticking with that interpretation:
- "aggregation" seems to be much more the core concept that is of interest
  while "assigned" seems more coincidental
- also note that it happens all the time that by (change of) policy
  provider assigned address space is turned into PI - unfortunately :-(

It does not look like a good idea to dilute the "routing semantics" of PA
this way and creating the need for another term that precisely captures
the ability to aggregrate.

  > > structure; usually assigned by a service provider (hence the name).
s/\(.*\)//
add (or something similar):
Global routing of a PA block usually can be supported by a route for just
the aggregate prefix (hence the name).

  > > structure; independent of any service provider (hence the name).

Ruediger Volk