Subject: Re: [rrg] FW: I-D Action:draft-irtf-rrg-recommendation-05.txt

From: Patrick Frejborg <[email-masked]>
Date: Mon, 1 Mar 2010 17:06:04 +0200

Tony,

my apologizes for being late with an update for hIPv4.

Since the IP option isn't doable I had to move the extensions to a
shim header, thus the text needs be updated. I also had to remove the
text mentioning that hIPv4 might be integrated to a map&encap solution
- I think it is still possible but haven't explained how - my day work
has and is taking all time.

-- patte

On Sat, Feb 27, 2010 at 5:59 AM, Tony Li <[email-masked]> wrote:
>
> FYI...
>
> This is just a working draft.
>
> Please recall that our deadline for a 'counterpoint' contribution is Mar. 2,
> next Tues.  And our final deadline for document submission prior to IETF is
> Mar. 8.  I can make no promises for anything to be included that is received
> after Mar. 2.
>
> Regards,
> Tony
>
>
>
> ------ Forwarded Message
> From: <[email-masked]>
> Reply-To: <[email-masked]>
> Date: Fri, 26 Feb 2010 18:30:02 -0800 (PST)
> To: <[email-masked]>
> Subject: I-D Action:draft-irtf-rrg-recommendation-05.txt
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>
>  Title           : Recommendation for a Routing Architecture
>  Author(s)       : T. Li
>  Filename        : draft-irtf-rrg-recommendation-05.txt
>  Pages           : 62
>  Date            : 2010-02-26
>
> It is commonly recognized that the Internet routing and addressing
> architecture is facing challenges in scalability, multi-homing, and
> inter-domain traffic engineering.  This document surveys many of the
> proposals that were brought forward for discussion in this activity,
> as well as some of the subsequent analysis.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-irtf-rrg-recommendation-05.txt
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
> ------ End of Forwarded Message
>
>
> _______________________________________________
> rrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/rrg
>
>

---

From: Matthias Hartmann <[email-masked]>
Date: Tue, 02 Mar 2010 15:24:40 +0100

Hi Tony,

here comes the rebuttal for our GLI-Split proposal.

Best regards,
   Matthias Hartmann

The arguments in the GLI-Split critique are correct. There are only two points that 
should be clarified here. (1) First, it is not a drawback that hosts perform the 
mapping lookups. (2) Second, the critique proposed an improvement to the mobility 
mechanism, which is of general nature and not specific to GLI-Split.

(1)	The additional burden on the hosts is actually a benefit, compared to having the 
same burden on the gateways. If the gateway would perform the lookups and packets 
addressed to not yet cached EIDs arrive, a lookup in the mapping system must be 
initiated. Until the mapping reply returns, packets must be either dropped, cached, 
or the packets must be sent over the mapping system to the destination. All these 
options are not optimal and have their drawbacks. To avoid these problems in 
GLI-Split, the hosts perform the lookup. The short additional delay is not a big 
issue in the hosts because it happens before the first packets are sent. So no 
packets are lost or have to be cached. GLI-Split could also easily be adapted to 
special GLI-hosts (e.g., low power sensor nodes) that do not have to do any lookup 
and simply let the gateway do all the work. This functionality is included anyway for 
backward compatibility with regular IPv6-hosts inside the GLI-domain.
(2)	The critique proposes a DNS-based mobility mechanism as an improvement to 
GLI-Split. However, this improvement is an alternative mobility approach which can be 
applied to any routing architecture including GLI-Split and raises also some 
concerns, e.g., the update speed of DNS. Therefore, we prefer to keep this issue out 
of the discussion.

-- 
Dipl.-Inform. Matthias Hartmann
University of Wuerzburg, Institute of Computer Science
Chair of Distributed Systems (Informatik III)

Am Hubland, 97074 Wuerzburg, Germany

http://www3.informatik.uni-wuerzburg.de/staff/hartmann/
[email-masked]
phone: +49-931-31-83381

---

From: Tony Li <[email-masked]>
Date: Sat, 06 Mar 2010 15:09:44 -0800

> has and is taking all time.

Received and incorporated.

Thanks,
Tony

---

From: Tony Li <[email-masked]>
Date: Sat, 06 Mar 2010 15:12:01 -0800

Tony