Subject: Re: [rrg] LISP does not implement Locator / Identity Separation

From: [email-masked] (Noel Chiappa)
Date: Thu, 11 Mar 2010 22:38:19 -0500 (EST)

> From: "Templin, Fred L" <[email-masked]>

    > routable within a certain scope; even if that scope is only node-local.
    > Conversely, a true identifier ... is not routable within any scope.

I guess the difference between a name with is 'routable' only within the
confines of a single machine, and another name which is "not routable within
any scope" is a finer hair than I apprehend how to split.

	Noel

---

From: "Templin, Fred L" <[email-masked]>
Date: Fri, 12 Mar 2010 08:40:55 -0800

Noel,

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Noel Chiappa
> Sent: Thursday, March 11, 2010 7:38 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [rrg] LISP does not implement Locator / Identity Separation
> 

Consider an end system which from outward appearance looks
like a "router-on-a-stick" with a single physical interface,
but inwardly is really a "host with embedded gateway function"
per RFC1122. Now, consider that there may be an arbitrarily
complex network of virtual hosts, routers and links within
the physical host; perhaps using something like vmware or the
Boeing CORE (http://cs.itd.nrl.navy.mil/work/core/index.php).
Each of these virtual hosts can configure an EID address on
an interface attached to a virtual link, and each virtual
router can route between EID addresses and prefixes without
ever pushing a single packet outside of the physical confines
of the end system. That is what I mean by "node-local".

Fred
[email-masked]

> 	Noel
> _______________________________________________
> rrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/rrg