Subject: Re: [rrg] Recommendation and what happens next

From: [email-masked] (Noel Chiappa)
Date: Mon, 8 Mar 2010 00:08:02 -0500 (EST)

> From: Tony Li <[email-masked]>

    > IPv4 is done. Over. Cooked. Fully toast. It will either enter a black
    > market where we deaggregate and no proposal will help, or we shift to
    > v6 and v4 is irrelevant. In either case, we're not in time to do
    > anything significant for v4. 

Probably needless to say, I do not agree with this. There are _definitely_
more options than DeathI and DeathII.

     Noel

---

From: Tom Vest <[email-masked]>
Date: Mon, 8 Mar 2010 06:21:46 -0500

> more options than DeathI and DeathII.

There is also DeathIII, i.e., we shift to v6 (or something else), but through some series of steps that preserves IPv4 in place as a critical, non-substitutable input for provisioning routing services. If that happens, black market-driven deaggregation would not be inevitable. However, any other outcome would likely arise from and/or push IPv4 and incumbent IPv4-based operators into assuming the same sort of (economic) roles that have been traditionally associated with physical "last mile" facilities and their owner-operators... which would ultimately drive every other aspiring new routing service provider thereafter into the same sort of (basically, adversarial) position with the same sort of bypass-centric goals that were/are commonly attributed to non-incumbent Internet service providers, esp. back in the 1980-1990s. 

What other potential options do you envision which might provide some reasonable probability of avoiding this Catch-22?

TV

---

From: Tony Li <[email-masked]>
Date: Mon, 08 Mar 2010 09:28:17 -0800

> What other potential options do you envision which might provide some
> reasonable probability of avoiding this Catch-22?

A shift in the carriers away from anything IP based.

Tony

---

From: Tom Vest <[email-masked]>
Date: Mon, 8 Mar 2010 13:18:25 -0500

> A shift in the carriers away from anything IP based.

Unless I'm missing something, I think that we're agreeing with each other.
Or rather, the shift that you suggest here sounds to me like a path that tilts in the direction of the "adversarial" outcome that I tried to describe -- i.e., a future in which open innovation becomes rare, improbable, and/or very expensive unless/until someone comes up with an entirely new way to route around whatever that new not-IP thing is.

I guess it could go the other way, assuming that the post-IP thing is once again an open standard, albeit one that does not create or depend on any scarce protocol element(s), and that could be freely adopted and implemented on an ad hoc basis by anyone... Is that the sort of post-IP thing that you had in mind, or think is likely to emerge?

TV

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 09 Mar 2010 10:54:43 +1300

On 2010-03-09 00:21, Tom Vest wrote:
>>> From: Tony Li <[email-masked]> IPv4 is done. Over.
>>> Cooked. Fully toast. It will either enter a black market
>>> where we deaggregate and no proposal will help, or we
>>> shift to v6 and v4 is irrelevant. In either case, we're
>>> not in time to do anything significant for v4.
>> Probably needless to say, I do not agree with this. There
>> are _definitely_ more options than DeathI and DeathII.
>> 
>> Noel
> 
> There is also DeathIII, i.e., we shift to v6 (or something
> else), but through some series of steps that preserves IPv4
> in place as a critical, non-substitutable input for
> provisioning routing services. If that happens, black
> market-driven deaggregation would not be inevitable. 

I think you're neglecting what is actually happening now, which
is a (semi) permanent shift to a dual stack routing network
with various forms of multiprotocol interworking, including
but by no means limited to v6/v4 packet level translation.

That will allow the v4 network to survive for a long time,
but my personal guess is that it won't deaggregate beyond
about a million prefixes, because it will just be easier to
grow IPv6 after a certain point. Yes, there will be a fairly
messy grey or black IPv4 market and a lot of users suffering
from gangrene (double or triple NAT, or living on the wrong
side of NAT64).

IPv4-only providers will indeed end up as dinosaurs. Funny,
really, that it's the incumbent carriers who seem to be
at the lowest risk of this.

   Brian

However,
> any other outcome would likely arise from and/or push IPv4
> and incumbent IPv4-based operators into assuming the same
> sort of (economic) roles that have been traditionally
> associated with physical "last mile" facilities and their
> owner-operators... which would ultimately drive every other
> aspiring new routing service provider thereafter into the
> same sort of (basically, adversarial) position with the same
> sort of bypass-centric goals that were/are commonly
> attributed to non-incumbent Internet service providers, esp.
> back in the 1980-1990s.
> 
> What other potential options do you envision which might
> provide some reasonable probability of avoiding this
> Catch-22?
> 
> TV _______________________________________________ rrg
> mailing list [email-masked] 
> http://www.irtf.org/mailman/listinfo/rrg
>

---

From: Patrick Frejborg <[email-masked]>
Date: Tue, 9 Mar 2010 11:40:40 +0200

> at the lowest risk of this.

Yes, IPv4 address is becoming an asset which is worth money - either
directly (renting it on the grey market - oh, shouldn't have used that
- "outsourcing the public IPv4 address management to a third party to
optimize the usage of the addresses") or indirectly (by keeping
competitors away from the market). So the users and service providers
do not have much reason to give up the asset for free - until the
network becomes more or less useless, or too expensive to run - close
to a complete chaos.
And the IPv4 community is today too large that the content providers
would release a new service only for the IPv6 community....you
probably wouldn't get much funding from the VCs if you state in your
plans that this service is intended only for IPv6, would you?

-- patte

---

From: Tom Vest <[email-masked]>
Date: Tue, 9 Mar 2010 07:06:17 -0500

> at the lowest risk of this.

Far from neglecting, I've been closely following & actively encouraging IPv6 deployment, at least as much as my own circumstances permit. 
But while some recent movements in that direction are fairly encouraging, I personally think that it's premature to assume that they represent a "(semi) permanent shift" to anything, much less to the sort of dual stack routing environment that would enable IPv6-only networks to operate at anything less than a crippling/fatal disadvantage.

In another, very closely related context, the correlates of transition that you identify  -- messy, opaque, unpredictable input exchange markets, interworking mechanisms that impose various local and transitive disadvantages on some parties, while advantaging others  -- have been identified with an historically recurring adaptation pattern called "Gresham's Law," which in this context would would translate to "bad interworking mechanisms drive out the good/better interworking alternatives." The mechanisms that have been historically associated with Gresham's Law are the exact same developments that we're anticipating today, e.g., 

1. "Strategic rationing" of the more favorable interworking tokens by those who have them, for use only in their most critical interactions and exchanges, i.e., with (economic) peers and/or parties with superior bargaining power. As a result, whatever distinct advantages were provided under the previous interworking regime become increasingly rare and inaccessible, esp. to new entrants.

2. Deep aversion to using the less favorable interworking tokens by the majority of system participants, driven in part by a persistent, widespread, and very durable (b/c it's not strong informed by empirical counter/evidence) perception both that the other kind interworking token is not reliable now, and that it's future utility is even more uncertain.

3. On balance, the technical decomposability of key interworking inputs (in this case short < > long IPv4 prefixes, individual IPv4 addresses < > TCP ports) actually encourages as much or more aggregation/consolidation than it does de-aggregation/diffusion, ultimately resulting in (4).

4. Initial natural/technical barriers to interworking create private incentives among enough well-placed market participants so that over time the barriers become fixed in place regardless of their original causes, creating an ossified, class-based economy with greatly reduced vertical mobility. 

5. Everyone gradually gets used to the new, diminished, less reliable interworking environment, and to the less efficient, less innovative, more risk averse, more stratified, more brittle -- i.e., broadly inferior -- economy that it permits. 

Bottom line: It's too soon to tell whether TCP/IP will succumb to Gresham's Law, but IMO it's way too soon to conclude that the modest uptick in IPv6 deployment that we're seeing now, finally, means that the risks associated with a Gresham's Law-like adaptation have been eliminated. 

That said, I heartily encourage my friends and colleagues who are still operators to prove me wrong!

TV

---

From: "Fleischman, Eric" <[email-masked]>
Date: Tue, 9 Mar 2010 09:07:42 -0800

>From: [email-masked] [mailto:[email-masked]] On Behalf Of Tom Vest
>To: Brian E Carpenter
>Cc: RRG; Noel Chiappa
> 
>> IPv4-only providers will indeed end up as dinosaurs. Funny, really, 
>> that it's the incumbent carriers who seem to be at the lowest risk of 
>> this.
>> 
>>   Brian

<snip>

>1. "Strategic rationing" of the more favorable interworking tokens by those 
>who have them, for use only in their most critical interactions and exchanges, 
>i.e., with (economic) peers and/or parties with superior bargaining power. As 
>a result, whatever distinct advantages were provided under the previous interworking 
>regime become increasingly rare and inaccessible, esp. to new entrants.

<snip>

>Bottom line: It's too soon to tell whether TCP/IP will succumb to Gresham's Law, 
>but IMO it's way too soon to conclude that the modest uptick in IPv6 deployment 
>that we're seeing now, finally, means that the risks associated with a Gresham's 
>Law-like adaptation have been eliminated. 
<snip>

I think that we are all talking about variations of a similar future vision, which differs very much (in my own mind, at least) from Tony's DeathI and DeathII. 

The one addition that I would like to add is that because strong market pressures motivate large end users to not migrate from IPv4, it is probable that these users will preserve their IPv4-only infrastructures for the indefinite future, unless a business case to do otherwise eventually appears. For large IPv4 communities, it is easier to use private addresses in the manner permitted by RANGER to meet future growth needs. (RANGER also supports mixed deployments as well as IPv6-only deployments.)

I presume that IPv4 will remain the dominate networking protocol for many years (decades?) after the IPv4 address space has been consumed. However, as IPv4 addresses become harder to obtain, entities requiring new public addresses may have a business case to deploy IPv6. 

At this current time there is a very high financial penalty to deploy IPv6 due to the comparative immaturity of the products and lack of economies of scale. As the IPv6 deployment grows, the financial penalty to deploy it will diminish. Once the IPv6 deployments achieve critical mass then economics will no longer punish IPv6. It is conceivable that IPv6 will someday become the more economical alternative. The big question is how long in the future will it be until this occurs?

However, since the RRG is oriented to ISPs, then I concur with Brian's vision that ISPs will face increasing pressure to deploy dual stacks. They may eventually move to a single IPv6 stack by encapsulating IPv4 into IPv6, but that is unlikely to occur until the IPv6 deployment has achieved a larger market presence. If this is accurate, then ISPs can expect to continue to support an IPv4 majority for a long time. This means a continued growth of inter-domain traffic containing both IPv4 and IPv6.