Subject: Re: [rrg] Recommendation

From: [email-masked] (Noel Chiappa)
Date: Fri, 26 Mar 2010 15:38:07 -0400 (EDT)

> From: Tony Li <[email-masked]>

    > the recommendation of the [chairs of the] RRG

IFYP.

	Noel

---

From: Scott Brim <[email-masked]>
Date: Fri, 26 Mar 2010 13:18:23 -0700

>     > the recommendation of the [chairs of the] RRG

?

---

From: Tony Li <[email-masked]>
Date: Fri, 26 Mar 2010 14:13:02 -0700

>>> the recommendation of the [chairs of the] RRG

I grep'ed for that and came up with things that didn't make sense.  I
suspect that Noel meant "IF You Please".

While there is no argument that this is not a consensus based
recommendation, IRTF outcomes are not required to be consensus based.  So
while Noel's amended version is correct, the original is also correct.

Just so we're all clear, I'm very disappointed that we were unable to make
further progress in reaching consensus.

Tony

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 26 Mar 2010 17:21:48 -0400

I would have to disagree slightly.
I do not believe that you can represent this as the recommendation of 
the Research Group.
The document can be published as an RRG RFC with a recommendation from 
the chairs of the RRG.  But the conclusion (whether I agree or disagree 
with it) is not the recommendation of the RRG.

Yours,
Joel

Tony Li wrote:
> _______________________________________________
> rrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/rrg
>

---

From: xuxiaohu 41208 <[email-masked]>
Date: Fri, 26 Mar 2010 14:35:05 -0700

Hi Tony,

Is there a so strict deadline for submitting a RRG recommendation that makes the RRG (co-chairs) to make such a hurried recommedation for a scalable routing and addressing architecture which is deemed to be useful in a long period of time?

Is it reasonable to give us some time (e.g., three or four months) to argue against these candidate solutions so that we can realize whether or not all of them deserve the recommendation?

Best regards,
Xiaohu

---

From: Christopher LILJENSTOLPE <[email-masked]>
Date: Sat, 27 Mar 2010 10:51:05 +1100

Greetings Xiaohu,

	That discussion has been going on for a long time already.  I won't speak for the chairs, but the intent may be to focus the group on driving to a rough consensus on the most likely path(s) forward, rather than continuing along in a debating society.  Then again, I may be completely wrong here....  

	However, if I am not, please remember, that from the time that something gets done in the IRTF, it has to go to the IETF, get standardized, rolled into code, regressed, bug stomped, and then the hard work starts.  My (as an operator) engineers have to understand it to design a network using it, my planners have to understand it to account for whatever we are doing in their planning formula, I have to train the NOC guys to use it, I have to train my testing guys to test it, I have to find a non-sucky implementation of it, then buy it, kick off a deployment program, rack it, stack it, commission it, and then start using it in production.  I completely left any OSS/BSS  impacts out of the litany because, if I thought about that, I'd just fall gibbering into a dark abyss and never come out.....  And then there are the impacts on my peering agreements, interconnection contracts, etc (that means lawyers - oh my, time to start drinking....)

	Some of those pain points go away if it is an implementation approach, with no new standards/protocols work required.  However, by no means to all (or even most) of those go away.  I get to take the IETF delay inducing factor out, but the rest are all still there.

	In short, the IRTF producing a recommendation 1 year before I need it would not only be not helpful, it would actually be ignored or at worse, harmful.

	Chris

>> further progress in reaching consensus.

- - ---
李柯睿
Check my PGP key here:
https://www.asgaard.org/~cdl/cdl.asc

- ---
李柯睿
Check my PGP key here:
https://www.asgaard.org/~cdl/cdl.asc

---

From: William Herrin <[email-masked]>
Date: Fri, 26 Mar 2010 20:38:32 -0400

2010/3/26 xuxiaohu 41208 <[email-masked]>:
> Is there a so strict deadline for submitting a RRG
> recommendation that makes the RRG (co-chairs
> to make such a hurried recommedation for a
> scalable routing and addressing architecture
> which is deemed to be useful in a long period of time?

DARPA is handing out multiyear research grants for a next generation
Internet architecture. Proposals are due next month.

Regards,
Bill Herrin

-- 
William D. Herrin ................ [email-masked]  [email-masked]
3005 Crane Dr. ...................... Web: <http://bill.herrin.us/>
Falls Church, VA 22042-3004

---

From: Tony Li <[email-masked]>
Date: Fri, 26 Mar 2010 19:29:52 -0700

Hi Xiaohu,

In fact, the situation is even more straightforward than that.  When we
started work on this topic, we gave ourselves a two year schedule.  When we
had not reached rough consensus within that time, we gave ourselves another
whole year to converge.  So, this has hardly been a rush.

Regards,
Tony

On 3/26/10 4:51 PM, "Christopher LILJENSTOLPE" <[email-masked]> wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> 
> Greetings Xiaohu,
> 
> That discussion has been going on for a long time already.  I won't speak for
> the chairs, but the intent may be to focus the group on driving to a rough
> consensus on the most likely path(s) forward, rather than continuing along in
> a debating society.  Then again, I may be completely wrong here....
> 
> However, if I am not, please remember, that from the time that something gets
> done in the IRTF, it has to go to the IETF, get standardized, rolled into
> code, regressed, bug stomped, and then the hard work starts.  My (as an
> operator) engineers have to understand it to design a network using it, my
> planners have to understand it to account for whatever we are doing in their
> planning formula, I have to train the NOC guys to use it, I have to train my
> testing guys to test it, I have to find a non-sucky implementation of it, then
> buy it, kick off a deployment program, rack it, stack it, commission it, and
> then start using it in production.  I completely left any OSS/BSS  impacts out
> of the litany because, if I thought about that, I'd just fall gibbering into a
> dark abyss and never come out.....  And then there are the impacts on my
> peering agreements, interconnection contracts, etc (that means lawyers - oh
> my, time to start drinking....)
> 
> Some of those pain points go away if it is an implementation approach, with no
> new standards/protocols work required.  However, by no means to all (or even
> most) of those go away.  I get to take the IETF delay inducing factor out, but
> the rest are all still there.
> 
> In short, the IRTF producing a recommendation 1 year before I need it would
> not only be not helpful, it would actually be ignored or at worse, harmful.
> 
> Chris
> 
>> Is there a so strict deadline for submitting a RRG recommendation that makes
>> the RRG (co-chairs) to make such a hurried recommedation for a scalable
>> routing and addressing architecture which is deemed to be useful in a long
>> period of time?
>> 
>> Is it reasonable to give us some time (e.g., three or four months) to argue
>> against these candidate solutions so that we can realize whether or not all
>> of them deserve the recommendation?
>> 
>> Best regards,
>> Xiaohu
>> 
>> ----- 原邮件 -----
> -----BEGIN PGP SIGNATURE-----
> 
> iQEcBAEBAgAGBQJLrUhqAAoJEGmx2Mt/+Iw/swcH/3fNV6Pi6+E9e3fNJy5UwwvA
> J+t0bWhfLqRxEun7p+7y5LGlwygiUZNgytrrdTfQ4IwUY3dzJUT989lsKHEYjDJj
> F2DaRnxDsMol54HKYzjckk2zZLe9+j9af03GDHjkMGPV3rcxI3wVQ6j8L8UE8c0N
> ihcXP9guF/eTN2ZQcPK2rhc1IgBb6qXxA5o2Q5AQgD+78+aysc6xx8aHln6Ttsxd
> 9+wafT0HTiqiQZLo97n5QvI3XvUGbePOKZJSTJLYNLrv958F0G7M7zcJF2PFiw3W
> fD3exou6w/DubM1qSHGXgmNFwy8DZsSncxpzRPGVr26VyL09wxpZsUw77QAN7hA=
> =Fc5M
> -----END PGP SIGNATURE-----

---

From: Luigi Iannone <[email-masked]>
Date: Mon, 29 Mar 2010 10:08:33 +0200

I agree with Joel.

The current recommendation is RRG's Chairs recommendation and not RRG's recommendation.

This should be clearly said in the final document.

Luigi

On Mar 26, 2010, at 22:21 , Joel M. Halpern wrote:

> I do not believe that you can represent this as the recommendation of the Research Group.
> The document can be published as an RRG RFC with a recommendation from the chairs of the RRG.  But the conclusion (whether I agree or disagree with it) is not the recommendation of the RRG.
> 
> Yours,
> Joel
> 
> 
> Tony Li wrote:

---

From: Luigi Iannone <[email-masked]>
Date: Mon, 29 Mar 2010 14:29:39 +0200

By the way I would also change the title of the document.

Now it is "Recommendation for a Routing Architecture", but the document does not contain any "architectural" recommendation.
AIS and renumbering are not an "architecture". 
ILNP  is a protocol (based on the Loc/ID split paradigm/architecture, but still a protocol).

Luigi