Subject: Re: [rrg] Next pass

From: [email-masked] (Noel Chiappa)
Date: Sun, 25 Apr 2010 13:02:18 -0400 (EDT)

> From: Ross Callon <[email-masked]>

    > Suppose hypothetically that we do all agree that it is desirable to
    > separate location and identity, and that it is feasible to do so. It
    > seems highly likely that we don't agree on the feasibility of any one
    > specific scheme .. Thus what does it mean if we say that each person
    > who has participated in the RRG discussions separately feels that
    > there is *some* feasible way to do so?

Well, it does establish two things.

First (and most importantly from my point of view), it does put into the
formal record the desirability of separating location and identity. This is a
concept that did not fly in the IETF some decades ago (much to the chagrin of
me and others), and so I would view a formal endorsement of the desirability
(nay, necessity) of doing so as a significant milestone in making progress.

Second, the second clause ("also technically feasible to do so") indicates
that the considered engineering opinion of the group is that it is, well,
technically feasible - something else which has been questioned in the past.

    > Thus to me the statement:

    >> 'The RRG did reach a rough consensus that it is both desirable to
    >> separate location and identity, and also technically feasible to do
    >> so.'

    > seems to be somewhere on the boundary between meaningless and
    > misleading. Perhaps a better sentence might be:

    >> 'The RRG did reach a rough consensus that it would be desirable to
    >> separate location and identity, should we agree on a way to do so.'

The problem with that, from my perspective, is that you're putting the
engineering cart (the details of how to do it) before the architecture horse
(the high-level goal of separating location and identity). To put it another
way, you're holding progress on the architectural front hostage to agreement
on the engineering front.

As I previously discussed with Wes George, I think that people can
_reasonably_ disagree about the optimal engineering path (based on things
like how necessary one thinks it is to provide benfits to early adopters),
which means disagreement on choice of a particular engineering path is
somewhat inevitable.

However, having agreement on an architectual goal does increase, I think, the
urgency of exploring the various engineering paths that lead to that overall
agreed-upen goal. For that, and other reasons, I think there is value to
recording agreement on an overall _goal_, even if we have yet to reach agreement
on the _means_ to get there.

	Noel

---

From: Ross Callon <[email-masked]>
Date: Mon, 26 Apr 2010 00:23:25 -0400

> ...Second, the second clause ("also technically feasible to do so")
> indicates that the considered engineering opinion of the group
> is that it is, well, technically feasible - something else which
> has been questioned in the past.

I feel that it is misleading to suggest that "It is technically feasible to separate location and identity" unless there is at least one proposal that does this that we agree is feasible. In fact personally I think that it *is* feasible, but it is not yet clear whether it is worth the cost (which I suppose is not the point of "feasibility"), and I am not sure whether I would agree on the feasibility of any approach to which you would also agree on the feasibility. 

> The problem with that, from my perspective, is that you're
> putting the engineering cart (the details of how to do it)
> before the architecture horse (the high-level goal of
> separating location and identity). To put it another way, 
> you're holding progress on the architectural front hostage
> to agreement on the engineering front.

If we ignore technical feasibility, then there are a *lot* of things which are desirable goals. Progress on the architectural front needs to be hostage to the feasibility of defining, agreeing on, implementing and deploying the result, and to an evaluation of whether it will be worth people's effort to deploy the result. Of course, in some cases in the past "agreement" has come after a solution was first defined in an IETF or other group, and implemented, and deployed. 

Ross

---

From: Eliot Lear <[email-masked]>
Date: Mon, 26 Apr 2010 06:42:19 +0200

On 4/26/10 6:23 AM, Ross Callon wrote:
> I feel that it is misleading to suggest that "It is technically feasible to separate location and identity" unless there is at least one proposal that does this that we agree is feasible.

Misleading to what end?  To lead people to believe that there exists at 
least one approach for locator/identity split that is technically 
feasible?  Has anyone claimed such an approach is infeasible?  It seems 
to me the debate within this group (at least amongst active 
participants) hasn't been that, but rather which approach of the several 
that have survived is MOST feasible.

>   In fact personally I think that it *is* feasible, but it is not yet clear whether it is worth the cost (which I suppose is not the point of "feasibility") [...]

Looking at incentives for deployment to me seems like a very reasonable 
approach, but I don't know if it should be mandatory in this group, 
given the type of expertise that requires.  Either we're getting into 
the MBA-level discussion of whether it's good for business, which seems 
entirely inappropriate, or we're getting into a formal economic modeling 
approach, which seems better handled elsewhere in the academic realm, 
where real economists participate.

> If we ignore technical feasibility, then there are a *lot* of things which are desirable goals.

Yes, but this is the one WE are considering whether it is important for 
US articulate.

Eliot

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 26 Apr 2010 00:50:22 -0400

I would disagree somewhat.
While we are not MBAs, nor economists, and we are not (I hope) going to 
do detailed business case analysis of deployment, nonetheless, 
deployment is arguably the key question.

If there is not sufficient incentive to deploy the solution we suggest, 
then it will not get deployed.  And an undeployed solution is not a 
solution.

(Many years ago Noel ran into this with Nimrod, where the difficulty in 
articulating a benefit for anyone deploying as long as only a few folks 
had deployed created an almost insuperable barrier to adoption.)

There are actually similar issues with several of the solutions.  If the 
interoperability depends upon certain kinds of deployment, then there 
better be reasonable reasons for those deployments to take place.

Put differently, we know that flag days no longer happen.
Hence there has to be an incremental deployment story, with reasonable 
benefits / incentives for that incremental deployment to take place. 
(How big the incentives have to be obviously depends upon multiple 
factors, including how big the costs are.)

Yours,
Joel

Eliot Lear wrote:
>> I feel that it is misleading to suggest that "It is technically 
>> feasible to separate location and identity" unless there is at least 
>> one proposal that does this that we agree is feasible.
> 
>>   In fact personally I think that it *is* feasible, but it is not yet 
>> clear whether it is worth the cost (which I suppose is not the point 
>> of "feasibility") [...]
> 
> _______________________________________________
> rrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/rrg
>

---

From: Eliot Lear <[email-masked]>
Date: Mon, 26 Apr 2010 07:08:40 +0200

Joel,

I agree with much of what you wrote, even though you disagreed with what 
I wrote ;-)  Absent properly aligned incentives lots of pretty technical 
work doesn't get out the door, and Silicon Valley is littered with 
examples, as is the IETF.

My concern is that the active participants have very limited experience 
in the field that is necessary to answer the question Ross asked.  To my 
knowledge in the last year there has been a single paper presented in 
this forum that has even approached one side of the question, and that 
was Luigi's work on a cost comparison of LISP mapping approaches.

Work on this sort of analysis HAS occurred, just elsewhere.  For 
instance, I think I've previously mentioned a paper done by Richard 
Clayton at WEIS 2009 on an economic analysis of SHIM6, and why it is 
unlikely to ever see wide deployment.  I was thrilled that he did that, 
because I'm hoping others will catch on and do that for other works in 
this arena, but note that he didn't present the paper at the IRTF, nor 
did he even participate in the IETF SHIIM6 working group.  The work was 
presented elsewhere.

And so the question we turn to is whether we should wait for others to 
perform that work, and there I answer a definitive NO because we might 
be gating for work that might never happen.  Rather, as we have been 
discussing, we caveat the recommendation by saying it is TECHNICALLY 
feasible, and leave it to others to decide if it is ECONOMICALLY feasible.

Or is anyone here offering an economist a job?

Eliot
> While we are not MBAs, nor economists, and we are not (I hope) going 
> to do detailed business case analysis of deployment, nonetheless, 
> If there is not sufficient incentive to deploy the solution we 
> suggest, then it will not get deployed.  And an undeployed solution is 
> not a solution.
>
> (Many years ago Noel ran into this with Nimrod, where the difficulty 
> in articulating a benefit for anyone deploying as long as only a few 
> folks had deployed created an almost insuperable barrier to adoption.)
>
> There are actually similar issues with several of the solutions.  If 
> the interoperability depends upon certain kinds of deployment, then 
> there better be reasonable reasons for those deployments to take place.
>
>> Misleading to what end?  To lead people to believe that there exists 
>> at least one approach for locator/identity split that is technically 
>> feasible?  Has anyone claimed such an approach is infeasible?  It 
>> seems to me the debate within this group (at least amongst active 
>> participants) hasn't been that, but rather which approach of the 
>> several that have survived is MOST feasible.
>>
>>
>>>   In fact personally I think that it *is* feasible, but it is not 
>>> yet clear whether it is worth the cost (which I suppose is not the 
>>> point of "feasibility") [...]
>>
>> Looking at incentives for deployment to me seems like a very 
>> reasonable approach, but I don't know if it should be mandatory in 
>> this group, given the type of expertise that requires.  Either we're 
>> getting into the MBA-level discussion of whether it's good for 
>> business, which seems entirely inappropriate, or we're getting into a 
>> formal economic modeling approach, which seems better handled 
>> elsewhere in the academic realm, where real economists participate.
>>
>> Yes, but this is the one WE are considering whether it is important 
>> for US articulate.
>>
>> Eliot

---

From: Robin Whittle <[email-masked]>
Date: Mon, 26 Apr 2010 15:46:16 +1000

Hi Eliot,

In the "Re: [rrg] Next pass" thread, regarding incentives to

> was Luigi's work on a cost comparison of LISP mapping approaches.

A month ago I wrote about Ivip's new Distributed Real Time Mapping
(DRTM) system - which is also applicable to LISP:

  http://www.firstpr.com.au/ip/ivip/drtm/Ivip-DRTM.pdf

This is 3,300 words - about the same amount of text as the last 9
messages in the "Next pass" thread.  There are three diagrams too.

  http://www.firstpr.com.au/ip/ivip/drtm/Ivip-DRTM-Fig-1.pdf
  http://www.firstpr.com.au/ip/ivip/drtm/Ivip-DRTM-Fig-2.pdf
  http://www.firstpr.com.au/ip/ivip/drtm/Ivip-DRTM-Fig-3.pdf

DRTM shows initial, substantial, deployment without any investment by
ISPs, other than accepting packets from their SPI (Scalable PI) using
end-user networks where the source address is from the "edge" subset
of the address space.  (In LISP, this would be an "EID" address in
the source field.)

There is no need for ISPs to install ITRs or ETRs.  They can do this,
and after a while, there are motivations for them to do so - at least
with ITRs.

It doesn't take an economist to quantify the initial investment by
ISPs, because there is none.  The investment comes from those who
benefit directly and immediately: the companies which lease out SPI
space from the Mapped Address Blocks (MABs) they run, and by the
end-user networks who lease this space and pay other fees to use it.

These organisations have an immediate incentive to deploy the new
system, since they get immediate substantial benefits.

The adopting networks get full use of their new SPI space - all
incoming traffic is handled by ITRs (initially the DITRs run by the
companies which run the MABs).  This is full benefits right from the
start for all adoptors - not in proportion to how many other networks
adopt it, as with Core-Edge Elimination (ILNP etc.) architectures.

  - Robin

---

From: Ross Callon <[email-masked]>
Date: Mon, 26 Apr 2010 17:06:09 -0400

Regarding:

> My concern is that the active participants have very limited experience in the field that is
> necessary to answer the question Ross asked.

To be fair, I think that in the IETF/RRG/related groups we have more experience in this field
(deploying technology related to TCP/IP) than any other standards group in the world. Also,
some of us *have* at least put some thought into the deployability and economics of
deployment of possible solutions.

Thinking about this more, "technically possible to design, implement, and deploy" I would agree
with. Whether it is economically feasible or whether the tradeoffs make sense is something that
we (for some definition of "we") can figure out over time.

Ross

________________________________
From: Eliot Lear [mailto:[email-masked]]
Sent: 26 April 2010 01:09
To: Joel M. Halpern
Cc: Ross Callon; [email-masked]; Noel Chiappa
Subject: Re: [rrg] Next pass

Joel,

I agree with much of what you wrote, even though you disagreed with what I wrote ;-)  Absent properly aligned incentives lots of pretty technical work doesn't get out the door, and Silicon Valley is littered with examples, as is the IETF.

My concern is that the active participants have very limited experience in the field that is necessary to answer the question Ross asked.  To my knowledge in the last year there has been a single paper presented in this forum that has even approached one side of the question, and that was Luigi's work on a cost comparison of LISP mapping approaches.

Work on this sort of analysis HAS occurred, just elsewhere.  For instance, I think I've previously mentioned a paper done by Richard Clayton at WEIS 2009 on an economic analysis of SHIM6, and why it is unlikely to ever see wide deployment.  I was thrilled that he did that, because I'm hoping others will catch on and do that for other works in this arena, but note that he didn't present the paper at the IRTF, nor did he even participate in the IETF SHIIM6 working group.  The work was presented elsewhere.

And so the question we turn to is whether we should wait for others to perform that work, and there I answer a definitive NO because we might be gating for work that might never happen.  Rather, as we have been discussing, we caveat the recommendation by saying it is TECHNICALLY feasible, and leave it to others to decide if it is ECONOMICALLY feasible.

Eliot

I would disagree somewhat.
While we are not MBAs, nor economists, and we are not (I hope) going to do detailed business case analysis of deployment, nonetheless, deployment is arguably the key question.

If there is not sufficient incentive to deploy the solution we suggest, then it will not get deployed.  And an undeployed solution is not a solution.

(Many years ago Noel ran into this with Nimrod, where the difficulty in articulating a benefit for anyone deploying as long as only a few folks had deployed created an almost insuperable barrier to adoption.)

There are actually similar issues with several of the solutions.  If the interoperability depends upon certain kinds of deployment, then there better be reasonable reasons for those deployments to take place.

Put differently, we know that flag days no longer happen.
Hence there has to be an incremental deployment story, with reasonable benefits / incentives for that incremental deployment to take place. (How big the incentives have to be obviously depends upon multiple factors, including how big the costs are.)

Yours,
Joel

Eliot Lear wrote:

Misleading to what end?  To lead people to believe that there exists at least one approach for locator/identity split that is technically feasible?  Has anyone claimed such an approach is infeasible?  It seems to me the debate within this group (at least amongst active participants) hasn't been that, but rather which approach of the several that have survived is MOST feasible.

Looking at incentives for deployment to me seems like a very reasonable approach, but I don't know if it should be mandatory in this group, given the type of expertise that requires.  Either we're getting into the MBA-level discussion of whether it's good for business, which seems entirely inappropriate, or we're getting into a formal economic modeling approach, which seems better handled elsewhere in the academic realm, where real economists participate.

Yes, but this is the one WE are considering whether it is important for US articulate.

Eliot
_______________________________________________
rrg mailing list
[email-masked]<mailto:[email-masked]>
http://www.irtf.org/mailman/listinfo/rrg

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 27 Apr 2010 09:27:30 +1200

On 2010-04-26 17:08, Eliot Lear wrote:
...
> did he even participate in the IETF SHIIM6 working group.  The work was

Having read Richard's paper carefully before it was even presented,
I'd like to observe that not everybody agrees with it. Nor with Luigi's
work for that matter. And with all due respect, neither Richard nor Luigi
are economists. Neither is Geoff Huston, despite his very interesting
economic analysis of IPv6 deployment incentives presented at APRICOT
this March.
(http://www.potaroo.net/presentations/2010-03-02-ipv6-transition.pdf)
Nevertheless, I'd be interested to see Geoff's approach applied to
the RRG space.

However, to get anything really trustworthy, we'd need to get a few real
economists interested.

    Brian

---

From: Eliot Lear <[email-masked]>
Date: Tue, 27 Apr 2010 07:43:59 +0200

Brian,

While Richard himself isn't an economist he has been a key leader of a 
unique interdiscplinary conference on economics and security.  You may 
not agree with his results (or Luigi's).  So write a paper of your own, 
but I suggest collaborating with some of the folks Richard has worked 
with.  They're an extremely bright group (the WEIS conference folk)!

Eliot