Subject: [rrg] The Proper Granularity

From: Toni Stoev <[email-masked]>
Date: Mon, 24 May 2010 01:49:57 +0300

Dae Young, fellow researchers,

Let me formulate two basic statements out of the recent discussion:

1. "Node" is the proper granularity unit for an intra-domain routing point.

Presuming that inter-domain routing is based on routing domains as inter-domain routing points:

2. Inter-domain routing shall be based on intra-domain routing as a service.

This allows for inter-domainly transparent intra-domain routing as well as for intra-domain traffic engineering.

Do you agree with the statements?

http://www.doodle.com/8g5857qvudsnwquf

Regards
Toni

---

From: Dae Young KIM <[email-masked]>
Date: Mon, 24 May 2010 10:04:11 +0900

Toni,

(Call me DY, which should be easier for you.)

Before indulging into voting, let me give a question about Statement
2. I don't fully get what you'd mean by that:

Would you elaborate on it more, please?

On Mon, May 24, 2010 at 7:49 AM, Toni Stoev <[email-masked]> wrote:
> _______________________________________________
> rrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/rrg
>

-- 

Regards,
DY

---

From: Dae Young KIM <[email-masked]>
Date: Mon, 24 May 2010 10:36:05 +0900

Perhaps, you mean two routings (intra- and inter-) are decoupled or orthogonal?

-- 
DY

---

From: Toni Stoev <[email-masked]>
Date: Mon, 24 May 2010 10:29:30 +0300

> Would you elaborate on it more, please?

"Intra-domain routing as a service" means that a packet is able to traverse a routing domain as an inter-domain hop. The packet is so able by containing the destination routing domain ID and/or the next-hop routing domain ID. The routers in the current domain forward the packet to the next-hop domain serving collectively as an inter-domain router/forwarder.
Then inter-domain routing utilizes routing domain hopping with a graph routing technique.

> > This allows for inter-domainly transparent intra-domain routing as well as for intra-domain traffic engineering.

Poll URL: http://www.doodle.com/8g5857qvudsnwquf

Cheers, today is the day of science and culture in my country Bulgaria.

---

From: [email-masked]
Date: Mon, 24 May 2010 03:50:20 -0400

Toni,
Generally, sophisticated terminology does not replace a solution.

Specifically, I don't know what statement 1 is going after or what relevance it has at all.

Statement 2: I am inclined to agree in view of TARA. But I am sure you mean something else, hence have to disagree.

Therefore I obstain from voting.
Heiner

-----Ursprüngliche Mitteilung----- 
Von: Toni Stoev <[email-masked]>
An: IRTF RRG <[email-masked]>
Verschickt: Mo., 24. Mai. 2010, 0:49
Thema: [rrg] The Proper Granularity

Presuming that inter-domain routing is based on routing domains as inter-domain 
routing points:

This allows for inter-domainly transparent intra-domain routing as well as for 
intra-domain traffic engineering.

Regards
Toni

---

From: Toni Stoev <[email-masked]>
Date: Mon, 24 May 2010 12:18:06 +0300

Dear Heiner,

> Generally, sophisticated terminology does not replace a solution.

But is a step that way.

> Specifically, I don't know what statement 1 is going after or what relevance it has at all.

Choosing node as routing point in packet exchange is going after defining locator meaning and utilization.
This relates to distinction in asset naming for location reaching and identity recognition.

> Statement 2: I am inclined to agree in view of TARA. But I am sure you mean something else, hence have to disagree.

If I would travel from Austria to Netherlands, should I traverse Germany and how?

> Therefore I obstain from voting.

I would go to RIPE NCC.
Toni

---

From: Dae Young KIM <[email-masked]>
Date: Mon, 24 May 2010 18:50:35 +0900

> Then inter-domain routing utilizes routing domain hopping with a graph routing technique.

Exactly the same idea as mine.

Now, the question might be what gain there would be for our scheme in
comparison to use of global-scope Locators for domains as in ILNP. At
least, curious to you and me.

However, I'm not sure whether we can keep torturing people in this RRG
with our discussion since apparently most regard our idea as a
non-sense. Also, this thread was about polling not about any other
wild ideas.

As long as this is RRG, not ILNP WG, however, I think there still
should be room for other discussions on routing by starting a separate
thread.

Or, now that the objectives of the RRG have been apparently achieved,
we might wait until a new group would be formed to continue our
discussion.

Or just keep private any further discussions.

-- 
DY

---

From: Toni Stoev <[email-masked]>
Date: Mon, 24 May 2010 13:43:39 +0300

> Exactly the same idea as mine.

So vote, please.

> least, curious to you and me.

Reasonable question. Answer: Purposeful inter-domain and intra-domain routing. Therefore scalability.

> non-sense.

No one said this. Maybe no one thinks so. And there are potential supporters. We have evolved this idea from common understandings.

> Also, this thread was about polling not about any other 
> wild ideas.
> 

I remember what Scott Brim said: The RRG is still a research group. You can propose anything you want and see what flies.

> Or, now that the objectives of the RRG have been apparently achieved,

How about a poll on RRG goal achievement...

> Or just keep private any further discussions.

Sure we'll talk in private. But we also have differences in certain directions, and the gain of group discussion is that viable ideas get support from third parties.

Best regards, DY, all.

---

From: Tony Li <[email-masked]>
Date: Sun, 30 May 2010 22:07:45 -0700

> http://www.doodle.com/8g5857qvudsnwquf

This poll has now run a week.  There are four respondents.  Both statements
got 2 agreements, so this does not appear to be rough consensus.

Tony

---

From: Toni Stoev <[email-masked]>
Date: Mon, 31 May 2010 10:42:26 +0300

> got 2 agreements, so this does not appear to be rough consensus.

Smooth parity withstands.
I am deducing to ask research folks whether routing point granualrity matters to routing scalability.

> Tony

Thanks
Toni