Subject: [rrg] Scalable routing architecture

From: Toni Stoev <[email-masked]>
Date: Sun, 9 May 2010 12:32:47 +0300

Dae Young,

> In essence, we are reaching at a recursive network like Joe Touch or
> Jon Day asserted:
> 
>   o Within a domain, local addressing (for nodes) and LS routing (more
> specifically IS-IS since nodes are addressed, not the interfaces) are
> used.
> 
>   o At a higher recursion level formerly known as DFZ, also local
> addressing (for domains) and IS-IS are used.
> 
>   o Repetition of exactly the same routing infra in two adjacent layers.

Inside routing domains consisting of nodes we need to follow topology with node location names in order to keep routing simple.
On inter-domain level, we are naming autonomous systems with numbers, which are just IDs. Then we can apply any routing mechanism based on domain ID cognition.
We have two types of abstraction: intra-domain with structural unit naming and inter-domain with ordinal unit naming.

Let's keep up the good work.
I have set up a page on the wiki to write things collaboratively:

http://trac.tools.ietf.org/group/irtf/trac/wiki/RRGdashboard

You need to log in, in order to be able to edit. The server supports TLS/SSL.

Best regards all.

---

From: Dae Young KIM <[email-masked]>
Date: Sun, 9 May 2010 18:51:58 +0900

OK, I will. Thanks.

On Sun, May 9, 2010 at 6:32 PM, Toni Stoev <[email-masked]> wrote:
> _______________________________________________
> rrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/rrg
>

-- 

Regards,
DY

---

From: Toni Stoev <[email-masked]>
Date: Wed, 12 May 2010 09:07:30 +0300

Dae Young, all interested,

> > You need to log in, in order to be able to edit. The server supports TLS/SSL.

An autonomous system should act collectively as a router on inter-domain level. It should forward packets to its neighbor domains and may resolve AS numbers to a next-hop domain.

Salute,
Toni

---

From: [email-masked]
Date: Wed, 12 May 2010 13:21:29 -0400

An autonomous system should act collectively as a router on inter-domain level. 
It should forward packets to its neighbor domains and may resolve AS numbers to 
a next-hop domain.

Are you hereby describing what is state of the art ? If not, I am sure you can be more specific.
Heiner

-----Ursprüngliche Mitteilung----- 
Von: Toni Stoev <[email-masked]>
An: IRTF RRG <[email-masked]>
Verschickt: Mi., 12. Mai. 2010, 8:07
Thema: Re: [rrg] Scalable routing architecture

> > You need to log in, in order to be able to edit. The server supports 
TLS/SSL.

An autonomous system should act collectively as a router on inter-domain level. 
It should forward packets to its neighbor domains and may resolve AS numbers to 
a next-hop domain.

Salute,
Toni

---

From: Toni Stoev <[email-masked]>
Date: Thu, 13 May 2010 10:13:33 +0300

> Are you hereby describing what is state of the art ? If not, I am sure you can be more specific.

I am proposing ideas to agree upon and write to the common wiki page.

New version: An autonomous system may act collectively as a router on inter-domain level. As a router, it should forward packets to its neighbor domains and may resolve AS numbers to a next-hop domain.

Surely, we can elaborate the specific way this is realized within AS's routing infrastructure.

Toni

---

From: Dae Young KIM <[email-masked]>
Date: Thu, 13 May 2010 20:39:35 +0900

Agreed... perhaps only between you and me...

-- 

Regards,
DY

---

From: Toni Stoev <[email-masked]>
Date: Thu, 13 May 2010 17:21:00 +0300

> Agreed... perhaps only between you and me...

It's a good start.

https://trac.tools.ietf.org/group/irtf/trac/wiki/RRGdashboard