Subject: [rrg] Inter-domain routing

From: Toni Stoev <[email-masked]>
Date: Sat, 8 May 2010 12:09:56 +0300

Dae Young,

Nice to hear from you.

>   o Packets would be appended by an AS number of the destination at
> exiting its own AS.

Packets would need to be globally destined at sending. Destination "AS number + intra-domain locator" is just fine. So destination AS number should be set initially in the packet. This is quite end-to-end, right?

>   o DFZ routers sees only AS numbers in determining the next hop router.

OK.

>   o The destination IP address would be examined only after the packet
> has entered the destination AS.

Let's say "locator" instead of "IP address".

> RFC1955 by Bob Hinden back in 1996...
> Curious to know why this was rejected in IPNG?

I'm not curious about past rejections, but if you know there's any good essence for our creativity, say it please.

Heiner,

> What value is provided by the orthogonality between intra- and inter-domain routing?

Independent inter-/intra-domain routing scalability.

Are you a proponent?

Best regards to you both.
Cheers listeners.

---

From: Dae Young KIM <[email-masked]>
Date: Sat, 8 May 2010 19:04:49 +0900

Toni,

See below.

Regards,
DY

> Packets would need to be globally destined at sending. Destination "AS number + intra-domain locator" is just fine. So destination AS number should be set initially in the packet. This is quite end…

Yes, DNS query would return 'AS number + intra-domain locator'.

> Let's say "locator" instead of "IP address".

OK, no problem.

> I'm not curious about past rejections, but if you know there's any good essence for our creativity, say it please.

Yes, this is the simplest scenario I can think of. Almost nothing
changes except:

      o Packets would be appended by AS numbers from outset.
      o Inter-domain routing works on AS numbers.

> _______________________________________________
> rrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/rrg
>

---

From: Dae Young KIM <[email-masked]>
Date: Sat, 8 May 2010 20:42:22 +0900

>> Let's say "locator" instead of "IP address".

I think I have a problem here. As you know, ILNP also uses the
terminology 'locator', but there it rather means something more like
(domain) network prefix or even like domain ID.

You know, the problem is people seem to use the same
wording/terminology for different meaning.

As long as we're not going to be so extreme to get rid of the IP
addresses also, calling it 'IP address', be it IPv4 or IPv6, would be
less confusing than using 'locator' in our discussion. This is also
what Bob Hinden used in his description.

-- 

Regards,
DY

---

From: [email-masked]
Date: Sat, 08 May 2010 10:53:59 -0400

Note, the current FIB is the combined table for intra- and interdomain  next hop forwarding. That's ecaxtly what I have in mind too:
Enable next hop lookup by either one table-offset (dest. is in a different geo-patch) or by three table-offsets (dest. is in the same geopatch) 
- in the end, of course, - no matter whether it is an intra-domain destination or an external destination.

Dae,
Even if you want to apply Dijkstra, you could do this based on BGP (in this case BGP has just to advertise links/tunnels/LSPs) rather than on  a link-state protocol like OSPF.
My TARA-topology would be the combination of differently filtered topologies that where disseminated by BGP. E.g. of five topologies (of different zooming levels).
The reason is again the too large size of one flat topology. Imagine the number of ASes times the average number of bordering with neighboring ASes.
That is too much information which btw isn't needed. 
As I pointed out before: Given I want to travel from Munich, Karlsplatz, to San Francisco, Golden Gate Bridge, and while I haven't yet entered the plane(link) to San Francisco,international airport, I don't need to see the city map of S.F. nor of any other city I would fly over. That's more than 99,9 % of topology information that I don't need to know.
And yet I can find a stretch-1 route to my destination.

Heiner

-----Ursprüngliche Mitteilung----- 
Von: Toni Stoev <[email-masked]>
An: IRTF RRG <[email-masked]>
Verschickt: Sa., 8. Mai. 2010, 11:09
Thema: [rrg] Inter-domain routing

Dae Young,

Nice to hear from you.

>   o Packets would be appended by an AS number of the destination at

Packets would need to be globally destined at sending. Destination "AS number + 
intra-domain locator" is just fine. So destination AS number should be set 
initially in the packet. This is quite end-to-end, right?

OK.

> Curious to know why this was rejected in IPNG?

I'm not curious about past rejections, but if you know there's any good essence 
for our creativity, say it please.

Heiner,

Are you a proponent?

---

From: Dae Young KIM <[email-masked]>
Date: Sun, 9 May 2010 08:29:47 +0900

Never been to Karlsplatz yet, though to many places in Germany.

Geo is indeed a very useful information. I'm not at all against
utilizing it as far as possible.

I'm just trying to climb up the mountain along a different track:

   - Orthogonal (right term?) routing bw intra- and inter-
   - Preferably no need for extra mapping infra other than DNS(-extended)
   - Local intra-domain addressing
   - ...

We'll meet around at the summit to complement each other, I'd hope.

On Sat, May 8, 2010 at 11:53 PM,  <[email-masked]> wrote:
>
>> What value is provided by the orthogonality between intra- and
>> inter-domain
> routing?
>
> Note, the current FIB is the combined table for intra- and interdomain  next
> hop forwarding. That's ecaxtly what I have in mind too:
> Enable next hop lookup by either one table-offset (dest. is in a different
> geo-patch) or by three table-offsets (dest. is in the same geopatch)
> Even if you want to apply Dijkstra, you could do this based on BGP (in this
> case BGP has just to advertise links/tunnels/LSPs) rather than on  a
> link-state protocol like OSPF.
> My TARA-topology would be the combination of differently filtered topologies
> that where disseminated by BGP. E.g. of five topologies (of different
> zooming levels).
> The reason is again the too large size of one flat topology. Imagine the
> number of ASes times the average number of bordering with neighboring ASes.
> As I pointed out before: Given I want to travel from Munich, Karlsplatz, to
> San Francisco, Golden Gate Bridge, and while I haven't yet entered the
> plane(link) to San Francisco,international airport, I don't need to see the
> city map of S.F. nor of any other city I would fly over. That's more than
> 99,9 % of topology information that I don't need to know.
>> What value is provided by the orthogonality between intra- and
>> inter-domain
> routing?
>

-- 

Regards,
DY

---

From: Dae Young KIM <[email-masked]>
Date: Sun, 9 May 2010 08:54:07 +0900

> link-state protocol like OSPF.

Indeed.

-- 

Regards,
DY

---

From: [email-masked]
Date: Sun, 09 May 2010 03:23:57 -0400

H: Are you sure? Maybe you have been to Stachus (which is the more popular name for Karlsplatz)? It has always been the center of Munich and is situated between
central station and Marienplatz. Google for it ! Find the picture with the Karlstor! The building to the left, fourth floor, I would live when I was a student:-)

Heiner

-----Ursprüngliche Mitteilung----- 
Von: Dae Young KIM <[email-masked]>
An: [email-masked]
Cc: [email-masked]; [email-masked]
Verschickt: So., 9. Mai. 2010, 1:29
Thema: Re: [rrg] Inter-domain routing

-- 

Regards,
DY

---

From: [email-masked]
Date: Sun, 09 May 2010 03:57:31 -0400

...with many additional advantages like
- no administration needed as to assign someone some particular geo. coordinates
- non-political (as opposed to E164) and forever stable

besides its powerful contribution for better routing technology.

Heiner

---

From: [email-masked]
Date: Sun, 09 May 2010 12:38:45 -0400

One more remark (just for avoiding any misunderstanding) about geo-routing:

I am not in favor of  shortest geo-distance routing. That would disable/hamper any reasonable QoS/Policy routing.
I would only exploit it to ensure that every router can view a (sliding) hierarchy of topological zooms. The weight is still the number of hops.

Heiner

ps: maybe we can meet in Maastricht (rather than on the summit of the mountain:-)

-----Ursprüngliche Mitteilung----- 
Von: Dae Young KIM <[email-masked]>
An: [email-masked]
Cc: [email-masked]; [email-masked]
Verschickt: So., 9. Mai. 2010, 1:29
Thema: Re: [rrg] Inter-domain routing

-- 

Regards,
DY

=

---

From: [email-masked]
Date: Sun, 16 May 2010 18:17:47 -0400

What is the namespace for the ILNP locator ? Is it AS? or E164? or both? or something else?

Heiner

---

From: Tony Li <[email-masked]>
Date: Sun, 16 May 2010 16:39:27 -0700

>  What is the namespace for the ILNP locator ? Is it AS? or E164? or both? or

None of the above.  It is an independent, 64 bit, hierarchically assigned,
topologically sensitive space.

Tony

---

From: [email-masked]
Date: Mon, 17 May 2010 04:16:36 -0400

Can you give detailed examples, what  this topologically sensitive locator information is all about: from what derived, by whom assigned, how composed ?

Heiner

-----Ursprüngliche Mitteilung----- 
Von: Tony Li <[email-masked]>
An: [email-masked]; [email-masked]
Verschickt: Mo., 17. Mai. 2010, 1:39
Thema: Re: [rrg] ILNP question

Tony