Subject: Re: [rrg] ILNP step-by-step criticism

From: Tony Li <[email-masked]>
Date: Sat, 12 Jun 2010 19:37:18 -0700

Hi Xiaohu,

> Is there a final solution for this identifier collision issue now? if so,
> what is it? If the answer is to use the globally unique identifier for
> mobility, my next question is how to guarantee the global uniqueness of
> identifiers and how to prevent the malicious attackers from using your legal
> identifier to interfere your normal mobility service.

Nothing has changed, as there is no problem.

If you want mobility, you need to use a globally unique identifier, derived
from EUI-64, as has been mentioned many times before.

And, once again, attempted theft of an identifier will have no effect unless
the attacker can compromise DNS as well.

Asked and answered, many times now.

Tony

---

From: Toni Stoev <[email-masked]>
Date: Sun, 13 Jun 2010 22:12:10 +0300

На Sunday 13 June 2010 05:22:25 Xu Xiaohu написа:
> > -----邮件原件-----
> > 发件人: [email-masked] [mailto:[email-masked]] 代表 Tony Li
> > 发送时间: 2010年6月13日 5:30
> > 收件人: Toni Stoev; IRTF RRG
> > 主题: Re: [rrg] ILNP step-by-step criticism
> > 
> > 
> > Hi Toni,
> > 
> > >> There is no name for the location of a node in ILNP.  There is no need
> > >> for one as long as there is some subnetwork point of attachment
> > >> resolution (i.e., ND, ARP) based on the L3 locator and identifier.
> > >
> > >
> > > Tony, are you quite sure about the lack of need for a name of the
> > > location of a node?  What happens when a node with a locally
> > > unique identifier in a subnetwork moves to another subnetwork
> > > where there is another node with exactly the same (locally
> > > unique) identifier? How are the two nodes distinguished, and how
> > > are their ongoing sessions preserved?
> > 
> > 
> > Yes, I'm quite sure.  Locally unique identifiers are there
> > precisely for the set of people who have privacy concerns about
> > globally unique identifiers.
> > 
> > You are correct, locally unique identifiers will have mobility issues and
> > hosts should not use their locally unique identifier outside if its scope.
> 
> It seems an old question which had been discussed before. See:
> http://www.ietf.org/mail-archive/web/rrg/current/msg05117.html
> http://www.ietf.org/mail-archive/web/rrg/current/msg05114.html
> 
> identifiers

In terms of guarantees for high uniqueness, the current most successful global identifiers are IP addresses and FQDNs. Each of these has structure that denotes distributed hierarchy.
In the case of IP addresses, distributed hierarchy represents location. In the case of FQDNs, non-network characteristics are represented.

> and how to prevent the malicious attackers from using your legal 
> Best wishes,
> Xiaohu

Mine too.
Toni