Subject: Re: [rrg] ILNP q1: Scalability

From: [email-masked] (Noel Chiappa)
Date: Mon, 7 Jun 2010 18:58:40 -0400 (EDT)

> From: Toni Stoev <[email-masked]>

    > I am describing a locator.

You can call an elephant an eagle, but the animal which is so named still
cannot fly.

A locator names a place, not a path. In the system you are advocating, a
place is 'identified' (or perhaps 'functionally defined' would be a more
accurate way to put it) by a path which ends at that place - but the place is
not the path.

Have you read IEN-19? (If nothing else, there other paths which can also get
to that place.) 

    > It is a locator formed as strict route from a certain node within a
    > domain. This node is common for all locators within the domain.

Well, whether the start node for the partial source route is common or not,
what you have is still just a partial source route, starting from the
'certain node'.

So what happens when you make a change to the connectivity inside the site
(i.e. get rid of a node, or a node-node link) - all source routes which
traverse that deleted element no longer function, and you need to propogate
new source routes, for all such destinations, to everyplace in the Internet
which wants to talk to those destinations.

    > Actually the domain is formed based on locators span.

That part I did not get.

    > The next-hop selection is comparison of destination and current nodes'
    > locators for longest match.

I gather you mean 'to find the next hop, compare the source route to the
current (intermediate) node, and the source route to the destination; where
they diverge, the next entry in the source route to the destination is the
next hop'.

But by definition, a source route to a destination which leads through a node
must contain, as the first part of the total partial source route, a source
route to that node. So the point at which they diverge should also be the end
of the source route to the intermediate node?

So unless you want to do consistency/error checking, all you need to do to
find the 'next hop' entry in a partial source route, at an intermediate node,
is i) calculate (once) the length of the partial source route to the
intermediate node; then, ii) for each destination partial source route you
look at, just look that far into the partial source route, and that's where
the 'next hop' is.

	Noel

---

From: Toni Stoev <[email-masked]>
Date: Tue, 8 Jun 2010 10:41:42 +0300

On Tuesday 08 June 2010 at 01:58:40 Noel Chiappa sent:
> A locator names a place, not a path.

But the locator may actually be a path.

> In the system you are advocating, a 

The place is named with a locator. The locator is formed as path.
The purpose of naming a place with a locator is to facilitate location of the place.
A locator being path simplifies hop-by-hop (default) path selection.

In the approach I am advocating, each hop of the locator path is a neighbor ID among the neighbors of the previous hop. 

> Have you read IEN-19? (If nothing else, there other paths which can also get

Still advocating, a locator is a node ID sequence that is the default path to the named node.

> what you have is still just a partial source route, starting from the

The locator is the full route from the starting node of the domain to the named one.
But a packet does not need to go to the starting node if there is a shorter/preferred route.

> (i.e. get rid of a node,

Nodes after that node regain their locators.
Intermediate nodes are merely infrastructure routers – not oftenly get rid from a connectivity chain.

> or a node-node link)

If there is another link between the two nodes, nothing special happens.
If not – the nodes from the branch that has lost connectivity to the world may keep their locators at least until the branch gets connected again.

The two nodes may have been peers and just knowing each other's locator. Again – nothing special about locators.

> - all source routes which  

Locators are intra-domain names. Inter-domain routing takes care of reaching the domain.
No propagation is needed about a lost branch of the domain.

>     > Actually the domain is formed based on locators span.

Imagine a spanning tree with nodes named with locators, which originate from the common root.
The set of locators defines the domain.

> they diverge, the next entry in the source route to the destination is the

Locator of the destiantion contains locator of the current node, from its start.

> of the source route to the intermediate node?

Yes.

> intermediate node;

The intermediate node knows its locator. It gets it from an upstream node.

> then, ii) for each destination partial source route you 

Simple. Hop-by-hop path selection. Location.
 
> 	Noel

Regards,
Toni