Subject: [rrg] ILNP step-by-step criticism

From: Toni Stoev <[email-masked]>
Date: Sat, 12 Jun 2010 09:05:08 +0300

Series of micro-analyses of ILNP

Introduction

1. "have different names for the
   identity of a node and the location of a node"
– OK, but:

What is the name for the location of a node in ILNP?

"Locator" is the name for the location of a "subnetwork".
"Identifier" is the name for the identity of a node.

2. "with ILNP the Identifier names a node,
   not a specific interface on a node"
– OK.

3. "the Locator names a subnetwork"
– A "subnetwork" is:
 the set of nodes attached to a link, or
 the set of links attached to a node, or
 the set of neighbors of a node?

4. "Identifiers are bound to nodes, not to interfaces"
– OK.

5. "Identifiers can be either globally unique or locally unique.
   Locally unique Identifiers are unique within the context of their
   associated Locators."
– So "locally unique identifiers" are committed to location!

Toni Stoev

---

From: Tony Li <[email-masked]>
Date: Sat, 12 Jun 2010 00:34:52 -0700

Hi Toni, 1. "have different names for
>>> > the   identity of a node and the location of a node"  OK, but: What is
>>> the 
>>> > name for the location of a node in ILNP? "Locator" is the name for the
>>> > location of a "subnetwork". "Identifier" is the name for the identity of a
>>> > node.
>> 

There is no name for the location of a node in ILNP.  There is no need
for one as long as there is some subnetwork point of attachment
resolution (i.e., ND, ARP) based on the L3 locator and identifier. 3. "the
Locator names a subnetwork"  A "subnetwork" is:
>>> > the set of nodes attached to a link, or the set of links attached to a
>>> node, 
>>> > or the set of neighbors of a node?
A subnetwork is a lower layer interconnect (think cloud) where a set of
nodes is attached to the cloud, and reachability between nodes does
not require traversing another L3 node.
Tony

---

From: Toni Stoev <[email-masked]>
Date: Sat, 12 Jun 2010 14:14:22 +0300

On Saturday 12 June 2010 at 10:34:52 Tony Li sent:
> resolution (i.e., ND, ARP) based on the L3 locator and identifier.

Tony, are you quite sure about the lack of need for a name of the location of a node?
What happens when a node with a locally unique identifier in a subnetwork moves to another subnetwork where there is another node with exactly the same (locally unique) identifier? How are the two nodes distinguished, and how are their ongoing sessions preserved?

> 3. "the 

I am using this definition in the preceding comment.

I think role-based: http://isi.edu/newarch/DOCUMENTS/hotrba.paper.pdf

> Tony

Toni

---

From: Tony Li <[email-masked]>
Date: Sat, 12 Jun 2010 14:30:00 -0700

Hi Toni,

> Tony, are you quite sure about the lack of need for a name of the
> location of a node?  What happens when a node with a locally
> unique identifier in a subnetwork moves to another subnetwork
> where there is another node with exactly the same (locally
> unique) identifier? How are the two nodes distinguished, and how
> are their ongoing sessions preserved?

Yes, I'm quite sure.  Locally unique identifiers are there
precisely for the set of people who have privacy concerns about
globally unique identifiers.

You are correct, locally unique identifiers will have mobility issues and
hosts should not use their locally unique identifier outside if its scope.

Tony

---

From: Dae Young KIM <[email-masked]>
Date: Sun, 13 Jun 2010 06:49:00 +0900

>   Locally unique Identifiers are unique within the context of their

Toni,

Isn't it that in ILNP?:

    Locally unique Identifiers are unique within a given site.

-- 
DY

---

From: Toni Stoev <[email-masked]>
Date: Sun, 13 Jun 2010 22:33:51 +0300

>     Locally unique Identifiers are unique within a given site.

So far I have not found out.

---

From: Dae Young KIM <[email-masked]>
Date: Mon, 14 Jun 2010 08:54:10 +0900

Toni,

It was me who was wrong. Your quote above is exactly the same in the draft.

I was naive to take it as 'site'.

Uniqueness of identifiers only within a locator or a subnet... No
practical meaning/use...

Globally unique identifiers... far from what I personally would prefer.

> _______________________________________________
> rrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/rrg
>

-- 
DY

---

From: Toni Stoev <[email-masked]>
Date: Mon, 14 Jun 2010 09:41:58 +0300

> Globally unique identifiers... far from what I personally would prefer.

But, DY, since a node is free to roam everywhere in the common network and needs to maintain its continuous sessions independently of roaming, global/universal uniqueness of identifier is therefore natural.

---

From: Dae Young KIM <[email-masked]>
Date: Mon, 14 Jun 2010 15:45:17 +0900

Yes, of course in a usual way.

I'm personally yet striving to find a path through toward 'local
addressing/identifier' scenario, with which I don't have an intention
to bother the rest of the group anymore.

-- 
DY

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 14 Jun 2010 02:48:35 -0400

And, as Tony Li said, for nodes which will be roaming outside of their 
environment, and administrators who wish to enable that, globally unique 
IDs will be used.  The proposal does not require that local IDs be used, 
but rather allows them, in a way that never collides with globally 
unique IDs.

Yours,
Joel M. Halpern