Subject: Re: [rrg] Terminology straw poll

From: [email-masked] (Noel Chiappa)
Date: Sat, 12 Jun 2010 07:36:56 -0400 (EDT)

> From: [email-masked]

    > I am worried that the pretty new term "Locator" is going to be
    > bent, too 

It already has been.

The original definition of 'locator' (RFC-1992) was of a structured
location-sensitive name for an interface which _did not necessarily appear
in packets_ (since people kept assuming an 'address' had to appear in all
packets, which was not true in that design).

No big deal... "The street finds its own uses for things."

	Noel

---

From: [email-masked]
Date: Sat, 12 Jun 2010 17:08:52 -0400

It already has been.

    Noel
________________

Though I would really hope that people obstain from abusing this term.

Promoting the TARA-locator I am not afraid that any other type of locator would  surpass its aggregatability.
Indeed:  Each geopatch can clearly recognize the 8 surrounding geopatches, and each such cluster of geopatches can clearly recognize an even larger geopatch cluster with itself in the middle thereof. This is a different league compared with country-code based aggregation for instance.
But:
The primary objective is not aggregatability. Instead the primary goal must be that a locator is ROUTABLE !!!
This is why I insist that a locator of a node must denote the location of that node. If this is not acceptable, then I suggest to find another name instead of "locator" that is more suitable for the intended use.

Heiner