Subject: [rrg] ILNP Issue #2 from Toni Stoev

From: Ran Atkinson <[email-masked]>
Date: Wed, 16 Jun 2010 13:41:10 -0400

Earlier, Toni Stoev wrote:
> Issue #2, technical: Identity/location separation with locally unique identifiers
> 
> On Sunday 13 June 2010 at 00:30:00 Tony Li sent:
> > > What happens when a node with a locally
> > > unique identifier in a subnetwork moves to another subnetwork
> > > where there is another node with exactly the same (locally
> > > unique) identifier? How are the two nodes distinguished, and how
> > > are their ongoing sessions preserved?
> > 
> > You are correct, locally unique identifiers will have mobility issues and
> > hosts should not use their locally unique identifier outside if its scope.
> 
> There is no identity/location separation with locally unique identifiers.

I think we disagree.  

Even with local-scope Identifier values, the Identifier
does not name a location && the Locator does not identify
a node.  So the concepts of identity and location are 
crisply separated, with clear semantics for each.

Another way of examining this might be to consider that 
with ILNP, routing only uses Locators, while upper-layer 
protocols (e.g. TCP/UDP pseudo-header checksum; IPsec 
Security Association) bind only to the Identifiers, 
never to the Locators.  Again, this shows clear separation 
of location from identity, and this is also true with
local-scope Identifier values.

Again, this is a major architectural change from IPv4/IPv6, 
where the upper-layer protocols (e.g. TCP/UDP pseudo-header 
checksum, IPsec Security Association) bind to the entire 
IP address and misuse it as a node identifier.  The issues
the deployed world has with things like NAT or various 
Mobile IP approaches or even (indirectly) site multi-homing
are because location was incorrectly bound up in the 
upper-layer protocols when those protocols only really
cared about node identity.

Yours,

Ran Atkinson

---

From: Toni Stoev <[email-masked]>
Date: Fri, 18 Jun 2010 23:42:43 +0300

> crisply separated, with clear semantics for each.

Does a locally unique identifier provide unique identity outside of its subnetwork?

---

From: Tony Li <[email-masked]>
Date: Fri, 18 Jun 2010 16:41:23 -0700

> Does a locally unique identifier provide unique identity outside of its subnetwork?

A locally unique identifier is unique only within its administrative scope.  That scope is NOT necessarily confined to a single subnetwork.  In many cases, that might be a site and may span many subnetworks.  However, it is also not global.

Tony

---

From: Toni Stoev <[email-masked]>
Date: Wed, 23 Jun 2010 11:07:06 +0300

> A locally unique identifier is unique only within its administrative scope.  That scope is NOT necessarily confined to a single subnetwork.  In many cases, that might be a site and may span many su…

So the locally unique identifier is actually a privately unique identifier. Its uniqueness is not confined by a location scope, but by an administrative one.
And being not global means it is not public.

Identity divides into public and private. Placement – to global/universal and local.

Toni

---

From: Tony Li <[email-masked]>
Date: Wed, 23 Jun 2010 02:05:01 -0700

> Identity divides into public and private. Placement – to global/universal and local.

Disagree.  Normally, privacy implies that others cannot observe.  In this case, a locally administered identifier is readily apparent to all correspondents.

Tony

---

From: Toni Stoev <[email-masked]>
Date: Wed, 23 Jun 2010 12:35:39 +0300

> Disagree.  Normally, privacy implies that others cannot observe.  In this case, a locally administered identifier is readily apparent to all correspondents.

"All correspondents" are only possible within the same administrative scope, because others cannot recognize the identifier.

Toni

---

From: Tony Li <[email-masked]>
Date: Wed, 23 Jun 2010 09:30:34 -0700

Hi Toni,

> "All correspondents" are only possible within the same administrative scope, because others cannot recognize the identifier.

A locally administered identifier is perfectly adequate for global communications and other ILNP hosts can easily recognize it.  The only difference is that the host cannot roam outside of its administrative scope.

Similarly, the identifier 'Toni' is not globally unique, but is perfectly adequate for correspondence without the least confusion.  ;-)

Tony

---

From: Toni Stoev <[email-masked]>
Date: Thu, 24 Jun 2010 14:39:55 +0300

On Wednesday 23 June 2010 at 19:30:34 Tony Li sent:
> 
> A locally administered identifier is perfectly adequate for global communications and other ILNP hosts can easily recognize it. 

Not without the assurance of the pursuing locator. Both the locator and the identifier make the uniqueness. 

> The only difference is that the host cannot roam outside of its administrative scope.  

So "locally administered" identifier is bound to its location: subnetwork, site. Where is the identity/location separation then?

---

From: Tony Li <[email-masked]>
Date: Fri, 25 Jun 2010 10:23:54 -0700

> Not without the assurance of the pursuing locator. Both the locator and the identifier make the uniqueness. 

Again, the locally administered identifier is bound to a site.  Typically, a site will have a number of locators.  

> So "locally administered" identifier is bound to its location: subnetwork, site. Where is the identity/location separation then?

A locally administered identifier still provides seamless mobility within the site, which is not without value.  Hosts wanting seamless mobility across sites will need to use a global identifier. We suspect that the vast majority of hosts to make use of a global identifier as a result, however, the local identifier is part of the architecture so that those that have strong privacy requirements can also participate.

Tony

---

From: Toni Stoev <[email-masked]>
Date: Sat, 26 Jun 2010 01:36:19 +0300

The correct expression for "locally-unique identifier" is "privately-unique identifier".
This privately-unique identifier, administered to be unique within a location scope, provides for identity/location separation in communications within that scope.
The privately-unique identifier, administered to be unique within a location scope, does not provide for identity/location separation in communications beyond that scope.

---

From: Dae Young KIM <[email-masked]>
Date: Sat, 26 Jun 2010 10:21:19 +0900

>> (Toni said) So "locally administered" identifier is bound to its location: subnetwork, site.

ILNP-05 <draft-rja-ilnp-intro-05#section-2> says:

    "Locally-unique Identifiers MUST be unique within the context
   of their Locators."

So, my understanding might be, locality of Identifiers are about
subnets, not sites.

-- 
DY