Subject: [rrg] Intra-domain location naming and hop-by-hop path selection

From: Toni Stoev <[email-masked]>
Date: Wed, 9 Jun 2010 01:08:16 +0300

This is intra-domain location naming that follows topology explicitly.

The location is of nodes. Locations are named with locators.
A locator is not just identifier of a node, but a representation of its place within a routing domain.
The locator represents the default sequence of hops from a starting node to the located node.
Hops are named with neighbor IDs. Each ID is of a node among the neighbors of the node with the preceding ID.
Obviously, being defined as representations of variable sequences of nodes, locators may differ in length.
All locators within a domain start from a common node – root. Thus the domain is defined as a spanning tree.

This location naming is made with "source routes" as locators, but those are just names of the locations of nodes.
No packet is obligated to go through the entire "source route" that its destination locator represents.

Hop-by-hop path selection within the destination routing domain:

When a packet enters a node of the tree, its destination locator is matched to the locator of the node.
The two locators by definition start with the same sequence. If there is any remaining difference, forwarding decision is made: Either forwarding upstream in the tree, or forwarding to one of the downstream branches.
This is the default behavior. Traffic engineering is still possible.

Again, this is destination intra-domain hop-by-hop path selection.
This path selection is not "source routing", but performs matching of "source routes" for making forwarding decisions.

---

From: Tony Li <[email-masked]>
Date: Tue, 08 Jun 2010 15:20:21 -0700

Hi,

This conversation doesn't seem to be making significant forward progress.
Can we please take it offline until it generates a bit more enlightenment?

Endless reiteration is not persuasive in the least.

Thanks,
Tony

> This is intra-domain location naming that follows topology explicitly.

The
> location is of nodes. Locations are named with locators.
A locator is not just
> identifier of a node, but a representation of its place within a routing
> domain.
The locator represents the default sequence of hops from a starting
> node to the located node.
Hops are named with neighbor IDs. Each ID is of a
> node among the neighbors of the node with the preceding ID.
Obviously, being
> defined as representations of variable sequences of nodes, locators may differ
> in length.
All locators within a domain start from a common node  root. Thus
> the domain is defined as a spanning tree.

This location naming is made with
> "source routes" as locators, but those are just names of the locations of
> nodes.
No packet is obligated to go through the entire "source route" that its
> destination locator represents.

Hop-by-hop path selection within the
> destination routing domain:

When a packet enters a node of the tree, its
> destination locator is matched to the locator of the node.
The two locators by
> definition start with the same sequence. If there is any remaining difference,
> forwarding decision is made: Either forwarding upstream in the tree, or
> forwarding to one of the downstream branches.
This is the default behavior.
> Traffic engineering is still possible.

Again, this is destination
> intra-domain hop-by-hop path selection.
This path selection is not "source
> routing", but performs matching of "source routes" for making forwarding
> decisions.
_______________________________________________
rrg mailing
> list
[email-masked]
http://www.irtf.org/mailman/listinfo/rrg