Subject: Re: [rrg] ILNP Identfiers

From: RJ Atkinson <[email-masked]>
Date: Tue, 15 Jun 2010 13:15:01 -0400

Earlier, Toni Stoev wrote:
> ILNP obviously has unresloved issues.

Please describe the issues, either technical issues 
or documentation issues, precisely.  Vague assertions
like "obviously has unresolved issues" are not helpful.

The best way to get any issues resolved in the next set 
of ILNP I-Ds, which I am working on today, is to cite 
a specific ILNP I-D, Section, Page, and Paragraph 
where one thinks an issue exists-- and then to clearly 
describe the issue.  Direct email to me works fine, 
or one may post to the RG list.

I totally accept that there might be places where the
documents aren't clear.  So I am keen to get feedback
on where the I-Ds need to be edited.  So far, I haven't
seen a whole lot of constructive or actionable feedback.

(Credit where due, some folks have given excellent feedback.
For example, tli pointed out an issue with the ICMP 
Locator Update document. I now am working to fix that.)

> So why not just answer questions, instead of making people
> read additional non-routing related documentation.

I'm not in any way clear what you might mean by 
"additional non-routing related documentation".

One can debate whether ILNP is more about naming
(which I think it is) than routing (which remains LPM), 
but that debate would not in any way be useful.  

It is a waste of many people's time (the poster's,
mine, and many other people on the list) when someone
asks questions that are already answered in the existing
ILNP documentation.

ILNP is not part of my day job, so I have very little
time available for list discussions.  That also means,
sadly, that I am not able to run a tutorial on the
RRG mailing list.  There have been presentations to the
RG in the past, which I imagine are available online in
the Proceedings of the meetings.  I am happy to respond 
to questions where someone has *read the documents* and 
has some specific point of confusion or correction.

Other RG members also have answered various ILNP 
questions from time to time, for which I am very
grateful.  This demonstrates that a fair number of 
RG members already understand ILNP.

Yesterday's question was about the fact that ILNP uses 
EUI-64 syntax for Identifier values.  This has long been 
clearly documented.  It is mentioned in virtually every 
research paper on ILNP.  It is also mentioned in the most 
basic of the ILNP documents (draft-rja-ilnp-intro-*.txt).  
Further, reference to the use of EUI-64 syntax has been 
in that I-D for many versions of that document, so it 
isn't a recent addition of some sort.

So asking what form an ILNP Identifier takes demonstrates 
purely laziness -- someone who can't be bothered to make 
a reasonable effort to read existing readily available
documentation.

Yours,

Ran Atkinson

---

From: Dae Young KIM <[email-masked]>
Date: Wed, 16 Jun 2010 03:40:59 +0900

> a reasonable effort to read existing readily available

Ran, for one thing, I must have read your ILNP document
(draft-rja-ilnp-intro-*.txt) already three times over a different time
period.

But, dumb as I am, I haven't got an unambiguous message like 'EUI-64
is the ILNP ID syntax.' All I got was that it is just one of many
possible address form for ILNP ID. (Now, as I have another look, you
have said that in that way. Only that I was not attentive enough.) I
mistakenly thought you were describing, with EUI-64, the case of
generating local ID's.

The effect might be as good as I haven't read it at all, but that's not true.

To those who've developed this work for long, everything might be so
obvious. But for some naive ones like me, I'm still struggling to
exactly understand exact implications of ILNP.

If you're not ready to answer questions so obvious to you, one option
might be close this ML.

All things are done and perhaps all objectives of the RRG have been
achieved. ILNP is stable to be finalized/freezed, not any further
explanations are needed.

Why keep this ML still open to let some people expect to get more
explanation to reconfirm the picture developing in their head or to
give some comments?

And not all comments have been any hostile to your document. Most only
to get a clear picture or to reconfirmation.

As one said, sorry for not being so professional, but I'd thought
giving silly questions would be better than indifference or in
remaining obscurity.

In a way, I don't understand why you're so sensitive and even hostile
to questions and comments on your document. It's a rather contrast to
some other authors of other proposals who don't bother to repeat the
same arguments/explanations over and over to bring bring people to
understanding.

Please have some patience to invite people to your side. Your document
is excellent but I don't think it's a good idea to close this RG with
just a handful of passionate advocators.

Don't worry. There'll be any more questions/comments from me, at least.

Good luck.

-- 
DY

---

From: Dae Young KIM <[email-masked]>
Date: Wed, 16 Jun 2010 03:43:46 +0900

Not any more.. no more.

-- 
DY

---

From: [email-masked]
Date: Tue, 15 Jun 2010 16:57:34 -0400

Ran,
can you tell me where you describe the value space of your locators?
I have no idea at all what routable and allegeably also hierarchically structured value space ILNP is using.

Heiner

-----Ursprüngliche Mitteilung----- 
Von: RJ Atkinson <[email-masked]>
An: IRTF Routing RG <[email-masked]>
Verschickt: Di., 15. Jun. 2010, 19:15
Thema: Re: [rrg] ILNP Identfiers

Yours,

Ran Atkinson

_______________________________________________
rrg mailing list
[email-masked]
http://www.irtf.org/mailman/listinfo/rrg

---

From: Tony Li <[email-masked]>
Date: Tue, 15 Jun 2010 14:26:10 -0700

Heiner,

> I have no idea at all what routable and allegeably also hierarchically structured value space ILNP is using.

Locators are simply IPv6 prefixes.

Tony

---

From: RJ Atkinson <[email-masked]>
Date: Tue, 15 Jun 2010 17:28:15 -0400

> I have no idea at all what routable and allegeably also hierarchically structured value space ILNP is using.

I don't understand what you mean by a "value space".

So I'm not sure exactly what is being asked.
Since I don't understand the question, I am not sure 
whether I am pointing at the right place, but here is 
an attempt:

draft-rja-ilnp-intro-03, Section 1, Page 4, says in part:
% The high-order 64-bits of the IPv6 address become the Locator.
% The Locator indicates the subnetwork point of attachment for
% a node.  In essence, the Locator names a subnetwork.  Locators
% are also known as Routing Prefixes.

Yours,

Ran

---

From: [email-masked]
Date: Tue, 15 Jun 2010 17:59:47 -0400

Yes, this was all that I had found before asking my question. Now Tony tells me, it is simply the IPv6 address space.

What is here any better/different from LISP-2 ?

I am confused. This sounds like Karl Valentin. Though the left spotlight (IPv4) on a stage was down, he tried to repair the right one (IPv6).

Heiner

-----Ursprüngliche Mitteilung----- 
Von: RJ Atkinson <[email-masked]>
An: [email-masked]
Cc: [email-masked]
Verschickt: Di., 15. Jun. 2010, 23:28
Thema: Re: [rrg] ILNP Identfiers

Yours,

Ran

---

From: Toni Stoev <[email-masked]>
Date: Wed, 16 Jun 2010 12:06:14 +0300

> like "obviously has unresolved issues" are not helpful.

Issue #1, documentation: Name for the location of a node

ILNP Concept of Operations says:
   The crux of this proposal is to have different names for the
   identity of a node and the location of a node, with crisp
   semantics for each.

On Saturday 12 June 2010 at 10:34:52 Tony Li sent:
> There is no name for the location of a node in ILNP.  There is no need
> for one as long as there is some subnetwork point of attachment
> resolution (i.e., ND, ARP) based on the L3 locator and identifier.

The statement of having different node identity/location names is misleading.

Issue #2, technical: Identity/location separation with locally unique identifiers

On Sunday 13 June 2010 at 00:30:00 Tony Li sent:
> > What happens when a node with a locally
> > unique identifier in a subnetwork moves to another subnetwork
> > where there is another node with exactly the same (locally
> > unique) identifier? How are the two nodes distinguished, and how
> > are their ongoing sessions preserved?
> 
> You are correct, locally unique identifiers will have mobility issues and
> hosts should not use their locally unique identifier outside if its scope.

There is no identity/location separation with locally unique identifiers.

Issue #3, technical documentation: "Subnetwork" term

ILNP Concept of Operations says:
   In essence, the Locator names a subnetwork.

On Saturday 12 June 2010 at 10:34:52 Tony Li sent:
> A subnetwork is a lower layer interconnect (think cloud) where a set of
> nodes is attached to the cloud, and reachability between nodes does
> not require traversing another L3 node.

There is no definition of "subnetwork" in ILNP.
"Interconnect" and "cloud" need definition too.

---

From: Toni Stoev <[email-masked]>
Date: Fri, 18 Jun 2010 23:44:10 +0300

Issue #4, technical documentation: "Site" term

ILNP Concept of Operations contains the term "site".

There is no definition of "site" in the ILNP documentation.

What does a "site" mean in ILNP?

---

From: Tony Li <[email-masked]>
Date: Fri, 18 Jun 2010 16:44:02 -0700

> What does a "site" mean in ILNP?

A 'site', throughout all of routing, is a set of networks that are under a single administration.

Tony