Subject: Re: [rrg] ILNP q1: Scalability

From: [email-masked] (Noel Chiappa)
Date: Thu, 3 Jun 2010 09:48:02 -0400 (EDT)

On 3 June 2010 at 10:29:42 Lixia Zhang sent:

    >> Who's a routing expert in this group?

    > there are many routing experts on this list, people who wrote the
    > routing code that forwards your and my email messages.

Umm, can we please be careful and distinguish between 'routing', in the sense
of 'path selection', i.e. the (distributed, in the current architecture)
computations which select source->destination paths; and 'forwarding', the
process (necessarily in a single switch) of getting a packet in, selecting
its next hop (based on the output of the path selection), and sending it
out?

I know 'routing' is somewhat ambiguous, because one would think it's what
'routers' do - which also includes 'forwarding' - which is why I use the
term 'path selection' or 'path computation' a lot, to make it explicit
that it's that kind of 'routing' I am thinking of.

I reallly don't care what terminology gets used, as long as i) it is precise,
and ii) people agree on it. So if people want to use some other, less
ambiguous term, for what I have called 'path selection', that would be fine
with me.

	Noel

PS: The 'routing' in RRG is of course the 'path selection' meaning.

---

From: Toni Stoev <[email-masked]>
Date: Fri, 4 Jun 2010 10:48:11 +0300

> its next hop (based on the output of the path selection), and sending it

Yes. I am taking up this wording.

> PS: The 'routing' in RRG is of course the 'path selection' meaning.

But RRG's charter includes exploration of "addressing" problems.
An "address" is used to determine forwarding operation.
So it's natural to discuss forwarding issues here. Right?

Toni
Regards

---

From: Tony Li <[email-masked]>
Date: Fri, 04 Jun 2010 21:41:15 +0800

> So it's natural to discuss forwarding issues here. Right?

Ummm...  No, not in the full generality of how some people use that term.

Again, we were chartered to discuss routing and addressing architecture.
Forwarding issues typically involve interesting questions about how you can
structure your FIB to minimize painful memory accesses, what type of memory
to use, how it should be interconnected to your processing element, how to
deal with ECMP, dealing with indirect next hops and the like.  All of those
are out of scope.

Regards,
Tony

---

From: Toni Stoev <[email-masked]>
Date: Fri, 4 Jun 2010 20:31:20 +0300

> deal with ECMP, dealing with indirect next hops and the like.  All of those

OK, I agree.
But there is one certain point of intersection of addressing, forwarding and path selection:
As clear an address shows a node's topological location, that much it facilitates hop by hop path selection to that node, says: decision making for forwarding, sequentially.

So why not just embed next hops in an address: locator?

---

From: Tony Li <[email-masked]>
Date: Sat, 05 Jun 2010 07:32:03 +0800

> As clear an address shows a node's topological location, that much it
> facilitates hop by hop path selection to that node, says: decision making for
> forwarding, sequentially.
> 

So then the locator is basically a detailed path that has to change anytime
there's a topology change along the path.

Tony

---

From: Ruediger Volk <[email-masked]>
Date: Thu, 03 Jun 2010 19:24:16 +0200

Hi Noel,

  > PS: The 'routing' in RRG is of course the 'path selection' meaning.
I guess this is in fact too restrictive a view:
concerns about FIB scaling have been included - and I would think (use of)
the FIB being very much part of forwarding (while feeding the FIB of course
is path selection).

Regards,
  Ruediger

Ruediger Volk

Deutsche Telekom AG -- Internet Backbone Engineering

E-Mail:  [email-masked]

---

From: Lixia Zhang <[email-masked]>
Date: Fri, 4 Jun 2010 18:10:01 -0700

Hi Noel,

Regards,
 Ruediger

Ruediger Volk

E-Mail:  [email-masked]
_______________________________________________
rrg mailing list
[email-masked]
http://www.irtf.org/mailman/listinfo/rrg

---

From: "Flinck, Hannu (NSN - FI/Espoo)" <[email-masked]>
Date: Sun, 6 Jun 2010 19:30:47 +0300

Hello

This starts to sound a lot like pathlet routing: 

http://www.cs.berkeley.edu/~pbg/pathlet_routing-sigcomm09.pdf

There the path address is represented by a forwarding identifierthat is
locally assigned by the domains through which the path passes.

- Hannu 

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On 
>Behalf Of ext Tony Li
>Sent: Saturday, June 05, 2010 02:32
>To: Toni Stoev; IRTF RRG
>Subject: Re: [rrg] ILNP q1: Scalability
>
>
>
>
>> facilitates hop by hop path selection to that node, says: decision 
>> making for forwarding, sequentially.
>> 
>So then the locator is basically a detailed path that has to 
>change anytime there's a topology change along the path.
>
>Tony
>
>

---

From: "Templin, Fred L" <[email-masked]>
Date: Mon, 7 Jun 2010 09:19:13 -0700

Apologies if I missed the announcement, but will this group
be meeting at IETF78?

Thanks - Fred
[email-masked]

---

From: Tony Li <[email-masked]>
Date: Mon, 07 Jun 2010 10:38:10 -0700

> Apologies if I missed the announcement, but will this group

Sorry, no.

Tony