Subject: Re: [rrg] (no subject)

From: Ran Atkinson <[email-masked]>
Date: Tue, 8 Jun 2010 10:10:55 -0400

Earlier today, Toni Stoev wrote:
% But the locator may actually be a path.

Toni,

No, a locator cannot name a specific path.  

By the basic definition of a Locator, 
it names a place, not a path.

That definition of the term "Locator" is broadly 
accepted within this RG, across multiple proposals 
(e.g. LISP, ILNP, and several others).  I second Noel's 
suggestion to re-read IEN-19.  For that matter, 
it would be helpful to re-read IEN-23 and IEN-1.

Yours,

Ran

PS:  IEN-1 is only available in PDF, not in text/plain.
     Please see this URL:
	http://postel.org/ien/pdf/ien001.pdf

---

From: Toni Stoev <[email-masked]>
Date: Tue, 8 Jun 2010 18:14:45 +0300

> it would be helpful to re-read IEN-23 and IEN-1.

OK, locator names a place. The place is a node.
The locator is formed as sequence of neighor IDs, each among the neighbors of the node with the preceding ID.
This locator resembles a path but each component of it is a node-local ID, not a universal location name.
So, the locator is to be used as hop-by-hop location pointer.

---

From: Scott Brim <[email-masked]>
Date: Tue, 08 Jun 2010 17:50:22 +0200

> OK, locator names a place. The place is a node.

No, a place is a _location_ of a node.

This is called "locator/identifier separation".

> The locator is formed as sequence of neighor IDs, each among the
> neighbors of the node with the preceding ID. This locator resembles a
> path but each component of it is a node-local ID, not a universal
> location name. So, the locator is to be used as hop-by-hop location
> pointer.

Each of those would be a limited-scope location name.

---

From: [email-masked]
Date: Tue, 08 Jun 2010 13:44:04 -0400

> No, a locator cannot name a specific path.  

Toni,
all who responded are right: A locator identifies a node and not a path. What you have in mind is source routing, which is used in  MPLS.
We should not fall back to that. But what makes sense is having directives which support hop-by-hop routing in order to pursue consistently some particular (among multiple ones)
path towards the destination. The internet is spanning  the globe. You can really get to India while going West !!! But confusion about which direction is to be taken must be avoided during forwarding.
Furthermore I would also be much in favor of enabling the conveyance of via-nodes, particularly in case of detours.
A lot of interesting work is still waiting to be done as to build a future-prone network layer, where -wrt a given destination- all adjacent links of any transit router are potential next hops (except those which lead into dead end).

Heiner

-----Ursprüngliche Mitteilung----- 
Von: Toni Stoev <[email-masked]>
An: IRTF RRG <[email-masked]>
Verschickt: Di., 8. Jun. 2010, 17:14
Thema: Re: [rrg] (no subject)

OK, locator names a place. The place is a node.
The locator is formed as sequence of neighor IDs, each among the neighbors of 
the node with the preceding ID.
This locator resembles a path but each component of it is a node-local ID, not a 
universal location name.
So, the locator is to be used as hop-by-hop location pointer.

>   http://postel.org/ien/pdf/ien001.pdf
_______________________________________________
rrg mailing list
[email-masked]
http://www.irtf.org/mailman/listinfo/rrg