Subject: [rrg] ILNP Issue #3 from Toni Stoev

From: Ran Atkinson <[email-masked]>
Date: Wed, 16 Jun 2010 13:51:26 -0400

Earlier, Toni Stoev wrote:
> Issue #3, technical documentation: "Subnetwork" term
> 
> ILNP Concept of Operations says:
>    In essence, the Locator names a subnetwork.
> 
> On Saturday 12 June 2010 at 10:34:52 Tony Li sent:
> > A subnetwork is a lower layer interconnect (think cloud) where a set of
> > nodes is attached to the cloud, and reachability between nodes does
> > not require traversing another L3 node.
> 
> There is no definition of "subnetwork" in ILNP.
> "Interconnect" and "cloud" need definition too.

The term "subnetwork" has been around for decades now
and is a basic term used in computer networking.

A quick grep(1) indicates that the first use of the term
"subnetwork" within the RFC document series was in RFC-410, 
published on 10 November 1972.  The term apparently was 
already in common use by then, as no formal definition 
of the term is provided in RFC-410.  

It has had numerous uses in numerous RFCs since then.  
If I've run the right grep, there were 350 lines using 
the term within the first 999 RFCs, and over 1900 lines 
using the term within all RFCs currently on my disk.
So there is strong evidence that this is a widely
used term, and that the term has been widely used in
this field for over 30 years now.

ILNP does not change the definition of "subnetwork".
So the ILNP documents don't need to provide a formal 
dictionary definition for subnetwork.

While I happen to find Tony Li's quoted text above
quite clear, that isn't text from the ILNP documents.
A quick grep indicates that none of the ILNP I-Ds
contains either "cloud" or "interconnect".
So I don't see a need to create formal definitions
for either "cloud" or "interconnect" within the
ILNP documents.

Yours,

Ran Atkinson

---

From: Toni Stoev <[email-masked]>
Date: Fri, 18 Jun 2010 23:43:10 +0300

> >    In essence, the Locator names a subnetwork.

What does a Locator name?
1. the set of nodes attached to a link
2. the set of links attached to a node
3. the set of neighbors of a node

---

From: Tony Li <[email-masked]>
Date: Fri, 18 Jun 2010 16:42:07 -0700

> 3. the set of neighbors of a node

The locator names a subnetwork.

Asked and answered.  Please move on.

Tony