Subject: [rrg] ILNP Issue #1 from Toni Stoev

From: RJ Atkinson <[email-masked]>
Date: Wed, 16 Jun 2010 13:34:48 -0400

First, MANY thanks for re-focusing your notes around
separate numbered issues and for being specific in 
quoting previous text that you are concerned about.

(I really think this will be a much more productive
conversation for everyone. :-)

I am splitting your 3 comments into separate threads,
so topics don't get confused accidentally.

Earlier, Toni Stoev wrote:
> Issue #1, documentation: Name for the location of a node
> 
> ILNP Concept of Operations says:
>    The crux of this proposal is to have different names for the
>    identity of a node and the location of a node, with crisp
>    semantics for each.
> 
> On Saturday 12 June 2010 at 10:34:52 Tony Li sent:
> > There is no name for the location of a node in ILNP.  There is no need
> > for one as long as there is some subnetwork point of attachment
> > resolution (i.e., ND, ARP) based on the L3 locator and identifier.
> 
> The statement of having different node identity/location names is misleading.

The Identifier names a node, but does not name its location.
The Locator names a subnetwork, but does not name a node.

A node that is connected to the Internet using ILNP has
one or more Locators.  A node not connected to the Internet
(e.g. because of some temporary outage) still has identity,
but does not have a Locator because it has no Internet location.

This all is pretty clearly described in draft-rja-ilnp-intro,
and it is consistent with and supportive of the claim that
the name for a node is different from the name for a subnetwork
location.

I'm not clear on what edit you would like made, nor am I 
clear where (e.g. document & section/page) you would like 
an edit made.

Thanks,

Ran Atkinson

---

From: Toni Stoev <[email-masked]>
Date: Fri, 18 Jun 2010 23:42:25 +0300

> >    identity of a node and the location of a node, with crisp

You don't have a name for the location of a node, crisply in ILNP.

> clear where (e.g. document & section/page) you would like 

In the last paragraph on page 3 of ILNP Concept of Operations say:
   The crux of this proposal is to have different names for the
   identity of a node and the location of a subnetwork, with crisp
   semantics for each.