Subject: Re: [rrg] ILNPv6 Mobility problem

From: [email-masked] (Noel Chiappa)
Date: Sat, 24 Jul 2010 08:49:45 -0400 (EDT)

> From: Tony Li <[email-masked]>

    > Not much. The device needs a new locally unique ID. 

"Not much"? What about on-going connections? And how does the node tell
entities which have cached its EID (from a DNS->EID binding) that that
EID value has changed? And I assume it also has to update the DNS->EID
binding, for entities which are trying to communcate with it now?

Please forgive my being too lazy to check, but is there any protocol support
in ILNP for a node changing its EID?

	Noel

---

From: Tony Li <[email-masked]>
Date: Sat, 24 Jul 2010 14:41:18 -0700

> in ILNP for a node changing its EID?

Let me say it for the umpteenth time: ILNP does not provide mobility support for locally unique IDs.  If you want mobility, use a globally unique ID.  Locally unique IDs are for those that want privacy.  

You can have privacy or mobility, but not both.

If you do use a local ID and change locators, then a) on-going connections are going to be dropped, b) there is no way to quickly inform correspondents of the identifier change, c) if the host wants to update its DNS->ID binding, it may do so, but given that it implicitly wants privacy (otherwise why use the local ID), that's probably contra-indicated.  More likely, the host should obtain a new FQDN along with its new ID.

No, there is no explicit support for changing global or local IDs.  Global IDs don't need changing, and local IDs can't use mechanisms for doing so.

Tony