Subject: Re: [rrg] ILNPv6 Mobility problem

From: Toni Stoev <[email-masked]>
Date: Sat, 10 Jul 2010 10:54:30 +0300

On Friday 9.7.2010 at 19:40:18 Tony Li posted:
> 
> In the real world, there are no perfect solutions.  Why is everyone insistent on an architecture that solves all problems, even in the face of equipment that clearly does NOT follow existing architectures?  

An architecture is worth adopting if it solves more problems than it creates.

The architecture needed is one that provides identifier uniqueness and that provides reliable identifiability to compliant equipment. This is why people insist on rectification of the globally unique identifier model.

Regards

---

From: [email-masked]
Date: Sun, 25 Jul 2010 02:31:25 EDT

Short comments are inserted.
Heiner

In einer eMail vom 25.07.2010 01:49:57 Westeuropäische Sommerzeit schreibt  
[email-masked]:

>>  You can have privacy or mobility, but not both.
Wrong.

>  
> Many people will be unhappy with having to choose between those  two....

True.

Many people want a pony, too.
I am inclined to disagree.

If you want mobility, then you must signal to your  correspondents.  
However, when you signal, you lose  privacy. 
Wrong.

The two  are fundamentally incompatible
Wrong.

, much  like optimal routing and abstraction.
Wrong.

Tony

---

From: [email-masked]
Date: Sun, 25 Jul 2010 08:31:53 EDT

Having been inspired see my expanded comments inserted
Heiner

 
In einer eMail vom 25.07.2010 12:32:57 Westeuropäische Sommerzeit schreibt  
[email-masked]:

Hi  Heiner,

This is crossing over the line from professional discourse into  the 
unprofessional.  

Regards,
Tony

On Jul 24,  2010, at 11:31 PM, [email-masked] wrote:

> In einer eMail  vom 25.07.2010 01:49:57 Westeuropäische Sommerzeit 
> >> You can have privacy or mobility, but not  both.
IMHO, this statement is wrong while assuming that in the current discussion 
 we do not understand by privacy the objective of hiding the user's current 
 (eventually compromising) location .

> > Many people will be unhappy with having to choose between  those two....
Surely true, but - see above - such a choice isn't to be made. 

> The two are fundamentally incompatible
Again, surely wrong given the made assumption, see above.
 
I think the discussion has gone far off the network layer's turf. 
Wrt globally uniqueness of the identifier:
Globally unique identifiers are fine, but don't have to be free of any  
single overlappings.
IMHO, the chance of overlaps should be kept small, but eventual clashes  
should be envisioned and be handled by appropriate procedures.

>  , much like optimal routing and abstraction.
Deeply wrong: 
As it looks like, this is once more with view to the allegeablely  bad 
stretch-behavior of hierarchical routing.
But there is an alternative as all do know.