Subject: Re: [rrg] Fwd: I-D Action:draft-irtf-rrg-recommendation-09.txt - ILNP problems

From: Robin Whittle <[email-masked]>
Date: Sun, 01 Aug 2010 17:27:32 +1000

Hi Tony,

You wrote:

> Did you have any editorial comments?

No.

> All I'm finding are (continued) disputes about content.

The problems I mentioned seem more important than "editorial" matters.

  - Robin

---

From: Toni Stoev <[email-masked]>
Date: Sun, 1 Aug 2010 12:44:09 +0300

> The problems I mentioned seem more important than "editorial" matters.

They are.

>   - Robin
> _______________________________________________
> rrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/rrg
>

---

From: "Stephen D. Strowes" <[email-masked]>
Date: Mon, 02 Aug 2010 15:29:23 +0100

Hi,

On Fri, 2010-07-30 at 09:05 +0100, Tony Li wrote:
> Comments to me or the list, as you see fit, please.

Without looking in too much detail at -09 yet, I think it would be
useful for each proposal to have

> 
> Thanks,
> Tony
> 
> 
> Begin forwarded message:
> 
> > From: [email-masked]
> > Date: July 30, 2010 12:45:02 AM PDT
> > To: [email-masked]
> > Subject: I-D Action:draft-irtf-rrg-recommendation-09.txt 
> > Reply-To: [email-masked]
> > 
> > A New Internet-Draft is available from the on-line Internet-Drafts directories.
> > 
> > 	Title           : Recommendation for a Routing Architecture
> > 	Author(s)       : T. Li
> > 	Filename        : draft-irtf-rrg-recommendation-09.txt
> > 	Pages           : 72
> > 	Date            : 2010-07-30
> > 
> > It is commonly recognized that the Internet routing and addressing
> > architecture is facing challenges in scalability, multihoming, and
> > inter-domain traffic engineering.  This document surveys many of the
> > proposals that were brought forward for discussion in this activity,
> > as well as some of the subsequent analysis.
> > 
> > A URL for this Internet-Draft is:
> > http://www.ietf.org/internet-drafts/draft-irtf-rrg-recommendation-09.txt
> > 
> > Internet-Drafts are also available by anonymous FTP at:
> > ftp://ftp.ietf.org/internet-drafts/
> > 
> > Below is the data which will enable a MIME compliant mail reader
> > implementation to automatically retrieve the ASCII version of the
> > Internet-Draft.

---

From: "Stephen D. Strowes" <[email-masked]>
Date: Mon, 02 Aug 2010 15:34:53 +0100

Hi,

[Bit heavy on the ENTER key. Oops.]

> Comments to me or the list, as you see fit, please.

Without looking in too much detail at -09 yet, I think a useful
editorial tweak would be for each proposal to cite the relevant
documents its own Summary section, or at least forward reference the
appropriate subsection in section 21.

I think the summary descriptions of some proposals are (necessarily)
terse, but this can be offset by immediately pointing the reader at more
information.

For example: Section 2.2 starts abruptly with LISP-ALT, without even an
expansion of the abbreviation.

-S.

---

From: Tony Li <[email-masked]>
Date: Tue, 17 Aug 2010 13:33:54 -0700

> terse, but this can be offset by immediately pointing the reader at more

Hi Stephen,

Thank you for your comment.  This turns out to also be necessary, as the IETF's idnits tool, which must run cleanly prior to final publication, is not prepared to accept the many different references subsections that we were using.  Thus, I've added the forward references in the summary sections and collapsed all of the references into one larger section.

This will appear in version 10 of the draft, which I've just submitted.

Regards,
Tony

---

From: Tony Li <[email-masked]>
Date: Tue, 17 Aug 2010 13:46:13 -0700

Hi all,

This concludes this final review cycle.  One comment was received during this review cycle.  This comment was editorial and was addressed, and a new version of the draft has been issued as draft-irtf-rrg-recommendation-10.txt.  

We will now start a final consensus check on the publication of this document.  The poll for consensus can be found here:

http://www.doodle.com/3s9kihwbhbkxbnf2

This consensus check will close one week from this note.

Regards,
Tony

On Jul 30, 2010, at 1:05 AM, Tony Li wrote:

> 
> Hi all,
> 
> After much delay, I've finally finished my editorial pass over the recommendation.  Please see the link below.
> 
> Please note that this pass was purely editorial.  I've tried to retain the same intent as the original text, but have tried to clean up the language and in some cases wordsmith things just a bit.  
> 
> I would ask that we start a two week (hopefully) final review cycle.  Could all contributors please review the text proper one last time, as well as my changes?  Other reviewers are also welcome at this point.
> 
> Diffs can be found here:
> 
> http://tools.ietf.org/rfcdiff?difftype=--hwdiff&url2=draft-irtf-rrg-recommendation-09.txt
> 
> and here:
> 
> http://tools.ietf.org/rfcdiff?url2=draft-irtf-rrg-recommendation-09.txt
> 
> <Mail Attachment>
>> I-D-Announce mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/i-d-announce
>> Internet-Draft directories: http://www.ietf.org/shadow.html
>> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: Tony Li <[email-masked]>
Date: Fri, 20 Aug 2010 10:21:05 -0700

Hi all,

So far, only 6 people have responded to this consensus check.  I could have sworn that there are more of you out there.  ;-)

Tony

Begin forwarded message:

> From: Tony Li <[email-masked]>
> Date: August 17, 2010 1:46:13 PM PDT
> To: Tony Li <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [rrg] Fwd: I-D Action:draft-irtf-rrg-recommendation-09.txt
> 
> 
> Hi all,
>

---

From: Robin Whittle <[email-masked]>
Date: Mon, 23 Aug 2010 20:57:59 +1000

Hi Tony,

Regarding your msg07247, I voted Yes at:

because I believe this is the best single document to give an overview
of the work done by RRG participants since April 2007.

However, I believe the description of ILNP and the co-chairs'
recommendation of ILNP has a number of deficiencies which I listed on
1 August:

  Re: [rrg] Fwd: I-D Action:draft-irtf-rrg-recommendation-09.txt -
ILNP problems
  http://www.ietf.org/mail-archive/web/rrg/current/msg07185.html

Neither Ran nor the co-chairs seem to be interested in these matters,
but I understand from Toni Stoev's msg07188 that I am not alone in
these concerns.

You wrote:

> One comment was received during this review cycle.  This comment
> was editorial and was addressed, and a new version of the draft
> has been issued as draft-irtf-rrg-recommendation-10.txt.

I guess you are referring to Stephen D. Strowes' msg07190.

Your statement "One comment was received during this review cycle."
appears to be incorrect, since this ignores my msg07185.  Toni Stoev
also commented on -09 in msg07182, though I think this is not a
request for you to change the draft.

  - Robin

---

From: Shane Amante <[email-masked]>
Date: Mon, 23 Aug 2010 21:02:49 -0600

Tony,

I tried to respond to the poll, before the deadline, but it appears that doodle.com is dead:
---snip---
traceroute to www.doodle.com (188.92.145.71), 64 hops max, 52 byte packets
[--snip--]
 5  te8-4-10g.ar3.dal2.gblx.net (64.208.110.201)  65.761 ms  67.475 ms  69.001 ms
 6  146.82.32.154 (146.82.32.154)  194.726 ms  189.273 ms  194.325 ms
 7  r1gva1.core.init7.net (77.109.128.54)  198.038 ms  197.302 ms  197.259 ms
 8  r1zur2.core.init7.net (77.109.128.217)  216.180 ms  215.156 ms  221.403 ms
 9  r1zba1.core.init7.net (77.109.128.206)  204.841 ms  212.814 ms  208.787 ms
10  r1zlz1.core.init7.net (77.109.128.229)  207.197 ms  214.455 ms  221.869 ms
11  gw-nine.init7.net (77.109.135.6)  209.592 ms  206.866 ms  212.612 ms
12  ge0.br5.cz.nine.ch (217.150.240.5)  214.979 ms  215.681 ms  219.093 ms
13  94.230.208.155 (94.230.208.155)  205.844 ms  207.158 ms  203.243 ms
14  * * *
15  * * *
16  * * *
17  * *^C
shane$ telnet www.doodle.com. 80
Trying 188.92.145.71...
^C
shane$ 
---snip---

FWIW, you can record my vote as "Yes, publish it".  I'll check and see if doodle.com is back on the air tomorrow morning and, if so, record my vote on there.

-shane

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 24 Aug 2010 15:46:21 +1200

> I tried to respond to the poll, before the deadline, but it appears that doodle.com is dead:

We have consensus on that.

> FWIW, you can record my vote as "Yes, publish it".  I'll check and see if doodle.com is back on the air tomorrow morning and, if so, record my vote on there.

Ditto. I think the draft is a fair representation of the discussions, and
I presume that the chairs agree with their own recommendations.

    Brian

---

From: Tony Li <[email-masked]>
Date: Tue, 24 Aug 2010 01:29:45 -0700

FYI: doodle.com seems to be back...

Tony

---

From: Tony Li <[email-masked]>
Date: Tue, 24 Aug 2010 14:31:01 -0700

Hi all,

This consensus check is now closed.  As of this moment, we have 16 participants in favor via the web site, and I'm also including Brian Carpenter as he had difficulty accessing the web site.

This gives us a unanimous result of 17 in favor, zero against.

Thanks to everyone in the RG for participating in this multi-year effort.  This has been interesting and contentious at times, and I think most of us have learned substantially from one another.  The result is not ideal, but is the best that we could have reasonably achieved.

There are some small editorial issues that need to get cleaned up.  These should become part of a -11 version that I hope to get to the IRSG in the next day or so.

Our next step is reach consensus on the publication of the requirements document.  The current version is here: http://tools.ietf.org/html/draft-irtf-rrg-design-goals-01.  I realize that this is also a contentious document, but I'm hopeful that we can, in fact, polish this and reach a real consensus on this document.  If not, we should still publish this with the 'consensus on publication, but not on content' disclaimer.  The window for discussing this is now open.  I'd like to set a goal of closing the discussion by Sept. 15th.  Please speak up now.

Comments?  Questions?

Regards,
Tony

---

From: Eliot Lear <[email-masked]>
Date: Wed, 25 Aug 2010 18:07:11 +0200

Tony,

Thanks for the opportunity to comment.  The biggest issues I've ever had
with this document was that it doesn't really explain what a first class
element is in this context, and the Wikipedia definition is, well,
wanting.  If you could provide a more detailed example of what you mean,
perhaps it would be clearer.  Yes, you mention tunneling, but I would
suggest more detail would be helpful.

Eliot

---

From: Tony Li <[email-masked]>
Date: Wed, 25 Aug 2010 10:18:15 -0700

Hi Eliot,

> suggest more detail would be helpful.

Thanks for the suggestion, I'll give it a shot.  If you care to contribute text, that would also be most welcome.

Regards,
Tony