Subject: Re: [rrg] rrg-design-goals-04 - we should write something much better

From: [email-masked] (Noel Chiappa)
Date: Mon, 22 Nov 2010 21:07:37 -0500 (EST)

> From: "George, Wes E [NTK]" <[email-masked]>

    > we happen to be very much interested in scalable routing... RIGHT
    > ZARKING NOW, so that some thing might be implemented before we have to
    > spend another XX million USD in a few years to buy $router_vendor 's
    > next generation linecard and memory to hold the routing table. This is
    > especially true if we do that upgrad e once or twice more

I'm curious about how this strong desire on your part interacts with your
prior comments about IPv6. Isn't widespread IPv6 deployment on an end-end
basis likely to dramatically increase (aka immediately come close to
doubling) the size of the routing table you have to support - and then some,
with the PI policy for IPv6 addreses?

(Yes, something like ILNP might eventually help, but it will take time to get
it implemented, and rolled out to hosts, by which time the routing table size
increase will have left the barn...)

Wouldn't some sort of 'mixed' architecture (something like Comcast) be better,
from that combined perspective?

	Noel

---

From: "George, Wes E [NTK]" <[email-masked]>
Date: Tue, 23 Nov 2010 14:22:20 +0000

> -----Original Message-----
> From: Noel Chiappa [mailto:[email-masked]]
> Sent: Monday, November 22, 2010 9:08 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [rrg] rrg-design-goals-04 - we should write something much
> better

> with the PI policy for IPv6 addreses?
[WES] yes it will increase it. Probably not exactly double owing to efficiencies gained by larger block sizes that should allow most networks to only need one, but your point is still accurate especially since we don't have a good solution for TE or multihoming that doesn't involve deaggregation yet. However, I view this IPv6-driven routing table growth as a foregone conclusion, and my view is that it's going to be easier to make changes to an IPv6 stack than it is the IPv4. This is especially true when you consider that the same widgets in the network today that will never support IPv6 are equally unlikely to get any updates to support something like ILNP. Then, as IPv6 gains critical mass and it becomes more obvious that the IPv4 game is largely over, you will start to get more and more people saying, "why should I change IPv4? It basically works (as well as it's going to) and I can't grow my network on IPv4, so why should I invest any more money in it?" Therefore, I'd rather concentrate where we get the biggest long-term advantage. We telco people have a buzzword bingo phrase for it - cap and grow.

> increase will have left the barn...)

[WES] Yes. Hence my sense of urgency on forward progress. Ideally we should have solved this problem in, oh, 2006 when the original concerns were raised, and had it ready so that as everyone was madly updating things in the last couple of years to support IPv6, we got this in the same update. Oh, and while we're asking for impossible things, I'd also like a Ferrari and a supermodel mechanic to keep it running. ;-)
The best I can hope for is that ILNP's (or something else's) benefits start to show up in parallel with the routing table growth, but I'm under no illusion that this will be easy or fast.

> from that combined perspective?
[WES] Please clarify what you mean by this.

Wes George

________________________________

This e-mail may contain Sprint Nextel proprietary information intended for the sole use of the recipient(s). Any use by others is prohibited. If you are not the intended recipient, please contact the sender and delete all copies of the message.