Subject: [rrg] Fwd: Comments about draft-irtf-rrg-design-goals-03

From: Tony Li <[email-masked]>
Date: Sat, 6 Nov 2010 09:35:03 +0800

This message appears not to have made it to the mailing list archives.  Retransmitting.

Tony

Begin forwarded message:

> From: Tony Li <[email-masked]>
> Date: November 5, 2010 3:15:50 PM GMT+08:00
> To: <[email-masked]> <[email-masked]>
> Cc: [email-masked]
> Subject: Re: Comments about draft-irtf-rrg-design-goals-03
> 
> 	
> Hi all,
> 
> In looking at the changes that Mohamed has proposed, I wanted to run some of them past the group.
> 
> Proposed text:
> 
> 	It is commonly recognized that the Internet routing and addressing 
> 	architecture is facing challenges which may question the sustainability of 
> 	the Internet. Examples of these challenges are scalability, mobility, 
> 	multi-homing, and inbound inter-domain traffic engineering.
> 
> Are folks comfortable with this language?  I'm concerned that it may be seen as inflammatory. 
> 
> MB: What about reducing the message churn ?
> 
> The churn is much more of a BGP protocol issue, not a routing architecture issue.
> 
> MB: Not only inter-domain. In some deployment, intra domains routes are bigger than the inter-domain one. Yes, it is the case!
> 
> Perhaps, but if it's intra-domain it's definitely not an architectural problem.
> 
> MB: Precise inbound TE is more problematic that outbound one.
> 
> What are folks doing to address outbound TE?  I assume there are fun and games with local pref.
> 
> MB: I don’t think any solution can claim it can be scalable if PI are assigned.  This is not an achievable goal IMHO without concrete actions from registries.
> 
> I tend to agree until demonstrated otherwise.  ;-)  I agree that registries will have to be involved, but we also have to put an architecture in place so that they can offer a reasonable alternative to PI.
> 
> MB: What means « scalable » in the context of mobility?  This is not elaborated in the text.
> 
> I consider scalability to be a constant, regardless of the context.  This is simply a restriction.  It implies that the mobility solution can't do something as drastic as creating inter-domain host routes.
> 
> MB: I don’t get the point of this section.
> 
> Actually, we're rewritten this because others didn't get it either.  Please review the most recent draft.
> 
> Tony
>

---

From: Eliot Lear <[email-masked]>
Date: Sun, 14 Nov 2010 11:13:55 +0100

Tony:

>> Are folks comfortable with this language?  I'm concerned that it may be seen as inflammatory. 

I would agree with you, and not to the change.  It is best to stick to
factual quantifiable statements, where possible.

>> MB: I don’t think any solution can claim it can be scalable if PI are assigned.  This is not an achievable goal IMHO without concrete actions from registries.

"TCP will never go faster than 1 mb/s."

Let's not make such statements for two reasons:
1.  Several groups of smart people believe they have a solution at hand
(ILNP / LISP); and
2.  Even if they don't, there is no law holding the above to be true. 
We just have the existing system, which can be changed.

>> I consider scalability to be a constant, regardless of the context.  This is simply a restriction.  It implies that the mobility solution can't do something as drastic as creating inter-domain hos…

Or that such routes carry no cost beyond the participants in the
communication (MN, CN, FA, HA).

Eliot

---

From: "Templin, Fred L" <[email-masked]>
Date: Mon, 15 Nov 2010 07:49:49 -0800

Eliot,

> (ILNP / LISP);

Please keep IRON on your list.

Thanks - Fred
[email-masked]

---

From: Eliot Lear <[email-masked]>
Date: Mon, 15 Nov 2010 16:54:01 +0100

More proves the point!