Subject: [rrg] Fwd: I-D Action:draft-irtf-rrg-design-goals-04.txt

From: Tony Li <[email-masked]>
Date: Tue, 9 Nov 2010 14:18:06 +0800

I've updated the design goals draft based on the many comments that I've received.  Please review the changes.

As the draft still seems to be in significant flux, and many of us are still busy with IETF, I'm extending the last call until 12 noon, Nov. 12, 2010, PST.

Comments anyone?

Thanks,
Tony

Begin forwarded message:

> From: [email-masked]
> Date: November 9, 2010 10:15:26 AM GMT+08:00
> To: [email-masked]
> Subject: I-D Action:draft-irtf-rrg-design-goals-04.txt
> Reply-To: [email-masked]
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 	Title           : Design Goals for Scalable Internet Routing
> 	Author(s)       : T. Li
> 	Filename        : draft-irtf-rrg-design-goals-04.txt
> 	Pages           : 9
> 	Date            : 2010-11-07
> 
> It is commonly recognized that the Internet routing and addressing
> architecture is facing challenges in scalability, mobility, multi-
> homing, and inter-domain traffic engineering.  The Routing Research
> Group is investigating an alternate architecture to meet these
> challenges.  This document consists of a prioritized list of design
> goals for the target architecture.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-irtf-rrg-design-goals-04.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Tony Li <[email-masked]>
Date: Mon, 15 Nov 2010 09:51:17 +0900

Hi all,

The last call has now expired, so I'd like to start the consensus check on the design goals.  The design goals document can be found here:

The consensus check can be found here:

http://doodle.com/idw28gc26vezipv9

The consensus check will close one week from this note.

Regards,
Tony

Begin forwarded message:

> From: Tony Li <[email-masked]>
> Date: November 9, 2010 3:18:06 PM GMT+09:00
> To: [email-masked]
> Subject: [rrg] Fwd: I-D Action:draft-irtf-rrg-design-goals-04.txt
> 
> 
> rrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/rrg

---

From: Toni Stoev <[email-masked]>
Date: Mon, 15 Nov 2010 10:36:32 +0200

The consensus check is on the publication (?!?) of the RRG design goals, which have already been published.

> Poll: Consensus check on publication of design goals
> "This is a consensus check on the publication of the RRG design goals (http://www.ietf.org/internet-drafts/draft-irtf-rrg-design-goals-04.txt)." 

I am actually in favor of almost all of the design goals in this document.

---

From: Tony Li <[email-masked]>
Date: Mon, 15 Nov 2010 17:45:56 +0900

Hi Toni,

> The consensus check is on the publication (?!?) of the RRG design goals, which have already been published.

Sorry, I should have said "published as an RFC".  Internet drafts aren't strictly a publication as they evaporate after 6 months.

> I am actually in favor of almost all of the design goals in this document.

Yet your entry to the consensus check is neither for or against.  I'm not sure how to interpret that.  Vocal abstention?

Tony

---

From: Toni Stoev <[email-masked]>
Date: Mon, 15 Nov 2010 11:36:42 +0200

> Yet your entry to the consensus check is neither for or against.  I'm not sure how to interpret that.  Vocal abstention?

Tony, if you change the title and description of the poll, delete my entry and I will vote again.

I am in favor of the publication of the RRG design goals as RFC document.

---

From: Tony Li <[email-masked]>
Date: Mon, 15 Nov 2010 21:24:23 +0900

> I am in favor of the publication of the RRG design goals as RFC document.

I have updated the detailed description of the poll.

<MontyPython>
I wasn't expecting the Spanish Inquisition.
</MontyPython>

Tony

---

From: Toni Stoev <[email-masked]>
Date: Fri, 19 Nov 2010 19:31:56 +0200

> > http://doodle.com/idw28gc26vezipv9

I like the Big Brother's style, but I also want to see the IEEE & ITU's solution.

---

From: Tony Li <[email-masked]>
Date: Mon, 22 Nov 2010 10:42:42 -0800

Hi all,

This consensus check is now closed.  The results are:

In favor: 12
Against: 1
Vocally abstain: 1
Spam: 1

Tony

On Nov 14, 2010, at 4:51 PM, Tony Li wrote:

> <Mail Attachment>

---

From: "Templin, Fred L" <[email-masked]>
Date: Mon, 22 Nov 2010 10:49:38 -0800

Does that mean that the wool has been pulled over
my eyes fair-and-square?

Fred
[email-masked] 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Tony Li
> Sent: Monday, November 22, 2010 10:43 AM
> To: Tony Li
> Cc: [email-masked]
> Subject: Re: [rrg] Consensus check on design goals
> 
> 
> Hi all,
> 
> > The last call has now expired, so I'd like to start the 
> consensus check on the design goals.  The design goals 
> document can be found here:
> > 
> > 
> >> I've updated the design goals draft based on the many 
> comments that I've received.  Please review the changes.
> >> 
> >> As the draft still seems to be in significant flux, and 
> many of us are still busy with IETF, I'm extending the last 
> call until 12 noon, Nov. 12, 2010, PST.
> >> 
> >> Comments anyone?
> >> 
> >> Thanks,
> >> Tony
> >> 
> >> 
> >> Begin forwarded message:
> >>

---

From: Tony Li <[email-masked]>
Date: Mon, 22 Nov 2010 10:57:51 -0800

Fred,

> Does that mean that the wool has been pulled over

As far as I can tell, the process has been completely open and straightforward.  There has been ample opportunity to review the draft, with extensions to the last call period, plus a week for a consensus check.

Unless you're wearing a sweater, no wool has been used.  ;-)

Tony

---

From: Robin Whittle <[email-masked]>
Date: Tue, 23 Nov 2010 06:30:35 +1100

Hi Fred,

> Does that mean that the wool has been pulled over

Yes - fair-and-square.

You mistakenly voted for a document which contained something you are
really opposed to.  Its not surprising you didn't see this - who would
expect such a flat-out requirement ("desired" and "required", but
later summarized as "desired) for one approach (Loc/ID Separation)
with any other approach "required" to be compatible with it.

This requirement of compatibility - for instance of a CES architecture
such as IRON, Ivip or LISP with Loc/ID Separation - is not mentioned
in the summary of priorities, 3.11.

Here is the problematic section:

  http://tools.ietf.org/html/draft-irtf-rrg-design-goals-04

      3.4.  Decoupling location and identification

              Numerous sources have noted that an IPv4 address
              embodies both host attachment point information and
              identification information.  [IEN1]  This overloading
              has caused numerous semantic collisions that have
              limited the flexibility of the Internet architecture.
              Therefore, it is desired that a solution separate the
              host location information namespace from the
              identification namespace.

              Caution must be taken here to clearly distinguish the
              decoupling of host location and identification
              information, and the decoupling of end-site addresses
              from globally routable prefixes; the latter has
              been proposed as one of the approaches to a scalable
              routing architecture.  Solutions to both problems, i.e.
              (1) the decoupling of host location and identification
              information and (2) a scalable global routing system
              (whose solution may, or may not, depend on the second
              decoupling) are required and it is required that their
              solutions are compatible with each other.

This text hasn't been altered since Tony's draft 00 of 2007-04-11.  He
took no interest in my 2007-07-14 critique of draft 01:

  http://www.ietf.org/mail-archive/web/rrg/current/msg00203.html

He took no interest in my most recent critique:

  http://www.ietf.org/mail-archive/web/rrg/current/msg07560.html

He discouraged or attempted to ban discussion of *proposals*
(candidate architectures) for much of 2007, 2008 and 2009 - in favor
of an "architectural" discussion.  Yet I don't recall him leading by
example in terms of what that discussion should be.

I think the list of things which Tony has exhibited, on the list,
genuine interest in is very small - considering the importance of our
task, the number of people who have attempted to contribute, and the
variety of ideas which have been proposed.  I think his blank response
to your recent concern that you voted mistakenly is part of that
pattern.

You are duly recorded as one of the 12 people in favour of the current
draft being published as an official RRG RFC.

For the record, here are the votes:

     Tony Li has created this poll.

     "This is a consensus check on the publication of the RRG
     design goals (http://www.ietf.org/internet-drafts/draft-irtf-
     rrg-design-goals-04.txt) as an RFC."

     In favor of         Against          Neither
     publication         publication

     Tony Li
     Hongbin Luo
                                          Toni Stoev
     Patrick Frejborg
     Hannu Flinck
     Stephen Strowes
     Marshall Eubanks
     Paul Jakma
     rja (Ran Atkinson)
     Wes George
                                          (Toni Stoev, I think):
                                          IEEE & ITU have this solved
     Heiner Hummel
     Fred Templin
     Dae Young KIM
                         Robin Whittle

Officially:   "In favor: 12
               Against: 1
               Vocally abstain: 1
               Spam: 1"

He got your vote fair-and-square and is unapologetic about counting
it, despite you expressing your concern before the final count that
you made it in error.

 - Robin

---

From: "George, Wes E [NTK]" <[email-masked]>
Date: Mon, 22 Nov 2010 20:36:06 +0000

> it, despite you expressing your concern before the final count that

[WES] Spare me the righteous indignation, Robin.
I don't know about anywhere else, but in the US, ignorance of the platform/views of the candidate you voted for doesn't give you license to rescind or change your vote, so let's stop demonizing the process or trying to champion the cause of the supposedly disenfranchised just because it didn't go the way you wanted. You want this to be fair, open, and independent, but yet you also seem to want to be able to change the results. It's a binary choice. Pick one.

Either way, allow me to update the above numbers to reflect Fred's confusion:

UNOfficially:   "In favor: 11
                Against: 2
                Vocally abstain: 1
                Spam: 1"
This changes the situation exactly...how?

Wes

________________________________

This e-mail may contain Sprint Nextel proprietary information intended for the sole use of the recipient(s). Any use by others is prohibited. If you are not the intended recipient, please contact the sender and delete all copies of the message.

---

From: "Templin, Fred L" <[email-masked]>
Date: Mon, 22 Nov 2010 12:51:48 -0800

Wes,

My maybe not-so-professional last few posts aside, is
this really called for? I mean, when something is *wrong*,
just because a few people who may or may not have noticed
voted in favor does not make it *right*.

We have the opportunity to get things right here; let's
not snatch defeat from the jaws of victory.

Fred

> Behalf Of George, Wes E [NTK]
> Sent: Monday, November 22, 2010 12:36 PM
> To: Robin Whittle; [email-masked]
> Subject: Re: [rrg] Consensus check on design goals - Fred's 
> mistaken votecounted as valid
> 
> I don't know about anywhere else, but in the US, ignorance of 
> the platform/views of the candidate you voted for doesn't 
> give you license to rescind or change your vote, so let's 
> stop demonizing the process or trying to champion the cause 
> of the supposedly disenfranchised just because it didn't go 
> the way you wanted. You want this to be fair, open, and 
> independent, but yet you also seem to want to be able to 
> change the results. It's a binary choice. Pick one.
> 
> This e-mail may contain Sprint Nextel proprietary information 
> intended for the sole use of the recipient(s). Any use by 
> others is prohibited. If you are not the intended recipient, 
> please contact the sender and delete all copies of the message.
>

---

From: "George, Wes E [NTK]" <[email-masked]>
Date: Mon, 22 Nov 2010 21:14:34 +0000

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Templin, Fred L
> Sent: Monday, November 22, 2010 3:52 PM
> To: George, Wes E [NTK]; Robin Whittle; [email-masked]
> Subject: Re: [rrg] Consensus check on design goals - Fred's mistaken
> votecounted as valid
>
> Wes,
>

[WES] Fred, I'm not sure I follow you. What would you like to see different here? What is *wrong* that you'd like to see be made *right*? And how do you propose that we do it? Is this just about your vote, or am I missing something larger?

Wes George

---

From: "Templin, Fred L" <[email-masked]>
Date: Mon, 22 Nov 2010 14:09:03 -0800

Wes,
 
> [WES] Fred, I'm not sure I follow you. What would you like to 
> see different here? What is *wrong* that you'd like to see be 
> made *right*? And how do you propose that we do it? Is this 
> just about your vote, or am I missing something larger?

See below for what I think is right, and no it is not
just about my vote but about something larger. This should
satisfy a number of concerns that IRON was going too far
out on a limb for strict provider independence. For
example, although I did not prepare this for your benefit
it should satisfy your concerns raised at the mike in
Beijing regarding over-emphasis on PI.

Thanks - Fred

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, November 22, 2010 2:00 PM
To: [email-masked]
Subject: I-D Action:draft-templin-iron-pm-00.txt

	Title           : Provider-Managed IRON
	Author(s)       : F. Templin
	Filename        : draft-templin-iron-pm-00.txt
	Pages           : 11
	Date            : 2010-11-22

The Internet Routing Overlay Network (IRON) is a new internetworking
architecture based on encapsulation of inner network layer packets
within outer network layer headers using a non-broadcast, multiple
access (NBMA) virtual interface model.  IRON suggests a third-party
global deployment of servers and relays to achieve a Provider-
Independent (PI) routing and addressing framework, but there may be
instances in which an Internet Service Provider (ISP) wishes to
manage its own IRON deployment.  This document presents a Provider-
Managed IRON framework that offers a fast path alternative for
deployment of a long term solution.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-templin-iron-pm-00.txt

---

From: Dae Young KIM <[email-masked]>
Date: Tue, 23 Nov 2010 12:33:18 +0900

Hi, Robin,

The RRG might have had rechartered as LIS RRG.

I tried to change my vote, but I couldn't figure out how to do that.

Do you know how? Or Once cast votes cannot be change?

-- 
DY

---

From: Robin Whittle <[email-masked]>
Date: Tue, 23 Nov 2010 16:09:12 +1100

Hi Wes,

> This changes the situation exactly...how?

It is for Tony to decide what happens officially.  I support the chair
having wide discretion in how IRTF groups are run.  I disagree
strongly with how Tony has run the group.  I have expressed my views
about this on the list and anyone in the future who is interested in
the background behind the final RRG RFCs will be able to make their
own well-informed judgements by looking into the archives.

At least we have a more accurate count in the archives.

Hi Dae Young Kim,

> Do you know how? Or Once cast votes cannot be change?

I don't think it is possible to change a Doodle vote, but I guess you
could have voted again, with a name such as "Dae Young Kim's more
considered and final position".

Fred wrote to the list about his mistaken vote before the close of
counting, and you wrote after.  Tony did not appear to be interested
in Fred's final, more informed, choice - but rather in counting the
vote he cast based on a mistaken understanding of the design goals I-D.

I am not sure what you mean by "LIS RRG".

To update Wes' count:

> UNOfficially:   "In favor: 10
>                 Against: 3
>                 Vocally abstain: 1
>                 Spam: 1"

  - Robin

---

From: Tony Li <[email-masked]>
Date: Mon, 22 Nov 2010 21:10:32 -0800

> Do you know how? Or Once cast votes cannot be change?

Once the poll is closed, the votes cannot be changed.

Tony

---

From: Dae Young KIM <[email-masked]>
Date: Tue, 23 Nov 2010 15:30:44 +0900

OK, all my fault if any, not yours.

-- 
DY

---

From: Dae Young KIM <[email-masked]>
Date: Tue, 23 Nov 2010 15:58:05 +0900

On Tue, Nov 23, 2010 at 2:09 PM, Robin Whittle <[email-masked]> wrote:

Loc/ID Separation Routing RG.

-- 
DY

---

From: Robin Whittle <[email-masked]>
Date: Tue, 23 Nov 2010 18:16:33 +1100

Hello DY,

> Loc/ID Separation Routing RG.

Ahh . . .  Yes indeed!

  - Robin

---

From: Toni Stoev <[email-masked]>
Date: Tue, 23 Nov 2010 09:22:12 +0200

> I am in favor of the publication of the RRG design goals as RFC document.

Who's abstained?

---

From: Toni Stoev <[email-masked]>
Date: Tue, 23 Nov 2010 09:22:38 +0200

>      Tony Li has created this poll.

The poll has been modified since.

>      rrg-design-goals-04.txt) as an RFC."

When I voted, "as an RFC" was not there.

>      In favor of         Against          Neither

My vote "neither" is on the publication of the document already published!!!

>                                           IEEE & ITU have this solved

Think again.

---

From: Tony Li <[email-masked]>
Date: Tue, 23 Nov 2010 00:09:12 -0800

> When I voted, "as an RFC" was not there.

I added that clarification on your request.

Tony

---

From: Tony Li <[email-masked]>
Date: Tue, 23 Nov 2010 00:09:48 -0800

>> I am in favor of the publication of the RRG design goals as RFC document.

You did, as you never changed your vote.

Tony

---

From: Toni Stoev <[email-masked]>
Date: Tue, 23 Nov 2010 11:15:11 +0200

> You did, as you never changed your vote.

Mr. Li, count my opinion "In Favor".

And please tell people how to change their votes on Doodle.

---

From: "Stephen D. Strowes" <[email-masked]>
Date: Tue, 23 Nov 2010 09:27:14 +0000

> And please tell people how to change their votes on Doodle.

You cannot. A voting system is little use if votes can be altered.

However, you could have voted a second time. And to avoid allegations of
ballot stuffing or spoiled votes, politely request of the chair that
your first vote be disregarded.

-S.

---

From: Toni Stoev <[email-masked]>
Date: Tue, 23 Nov 2010 11:33:00 +0200

---

From: Dae Young KIM <[email-masked]>
Date: Tue, 23 Nov 2010 18:38:35 +0900

Please don't bother. I'm OK.

-- 
DY

---

From: Tony Li <[email-masked]>
Date: Tue, 23 Nov 2010 08:31:28 -0800

> your first vote be disregarded.

Exactly.  Doodle (correctly) does not allow votes to be changed.  If you want to change how your vote is to be counted, you can enter a corrected ballot before the close of the poll.

Tony

---

From: Tony Li <[email-masked]>
Date: Tue, 23 Nov 2010 08:32:47 -0800

> _

And Doodle does not allow changing the title of the poll, nor does it allow the administrator to delete a ballot.

I did clarify the description...

Tony

---

From: Toni Stoev <[email-masked]>
Date: Wed, 24 Nov 2010 08:50:51 +0200

I dug into the Doodle system and tested it. It does allow votes to be changed, the poll being not closed. It allows tiltle to be changed. Even an anoymous user can change or delete other people's votes, except the poll creator's.
Furthermore, the Doodle site does not allow for TLS/SSL.

Reading this list, I consider the results as follows:

In favor: 11
Against: 1
Mistaken: 2 (may be explicitly specified)
Vocally abstain, anonymous: 1 (the guy does vote only once)

---

From: Dae Young KIM <[email-masked]>
Date: Thu, 25 Nov 2010 12:53:03 +0900

No problem for me. Please don't bother.

On Wed, Nov 24, 2010 at 1:31 AM, Tony Li <[email-masked]> wrote:

> Exactly.  Doodle (correctly) does not allow votes to be changed.  If you
> want to change how your vote is to be counted, you can enter a corrected
> ballot before the close of the poll.
>
> Tony
>

-- 
DY