Subject: Re: [rrg] RRG to hibernation

From: [email-masked] (Noel Chiappa)
Date: Mon, 12 Nov 2012 13:01:12 -0500 (EST)

> From: Tony Li <[email-masked]>

    >> a design which requires changes to all hosts is, IMO, a non-starter.

    > Why?

Practise shows that it doesn't work.

We can speculate as to why: my theory is that it increases the cost (in a
broader sense than just $/Euros/etc), and I think you need to have a pretty
low cost threshold to get new stuff out.

YMMV.

	Noel

---

From: Tony Li <[email-masked]>
Date: Mon, 12 Nov 2012 10:48:40 -0800

> low cost threshold to get new stuff out.

Past experiences need not be a predictor of future failure.  ;-)

The cost of software changes to the end user are now pretty much lost in the churn of maintenance releases and new devices.

Thus, the real hurdle that has to be accomplished is to woo the OS providers.  Convince them to implement and distribute and that solves the deployment problem.  And to convince the OS providers, you have to show them the killer app.  Without a value add, it's not in their interest.

But once you do have that value add, it would seem to be all downhill.

Tony

---

From: Mark Townsley <[email-masked]>
Date: Mon, 12 Nov 2012 23:15:57 +0100

> But once you do have that value add, it would seem to be all downhill.

As a data point - we squashed 6to4 mostly by actively rooting it out in the hosts. We started talking about how it should go away in 2008-9. Modifications came out in 2010. It was essentially dead by the end of 2011. 3 years. But, only a subset of hosts and apps were causing the bulk of the problem to begin with - a subset that happened to already respond well to updates. 

The real question is whether "some hosts" is good enough or not. If you really need "all hosts" to participate, you have to ask if and when you are willing to throw the previous generation of non-self-updating webcams, TVs, Windows XP, etc. under the bus. 

- Mark

> 
> Tony
> 
> _______________________________________________
> rrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/rrg